Clean up spec file a bit and move EFI to a subpackage.
Still not completely ready...
This commit is contained in:
parent
95e479dce1
commit
41a54de8fa
46
grub-1.99-just-say-linux.patch
Normal file
46
grub-1.99-just-say-linux.patch
Normal file
@ -0,0 +1,46 @@
|
||||
From d4bd41f972c6e22b86c773cbba2a1e14f400a8be Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Mon, 14 Mar 2011 14:27:42 -0400
|
||||
Subject: [PATCH] Don't say "GNU/Linux" in generated menus.
|
||||
|
||||
In Fedora and RHEL we just call it Linux.
|
||||
---
|
||||
util/grub.d/10_linux.in | 4 ++--
|
||||
util/grub.d/20_linux_xen.in | 4 ++--
|
||||
2 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
|
||||
index a09c3e6..0b0df78 100644
|
||||
--- a/util/grub.d/10_linux.in
|
||||
+++ b/util/grub.d/10_linux.in
|
||||
@@ -29,9 +29,9 @@ export TEXTDOMAINDIR=@localedir@
|
||||
CLASS="--class gnu-linux --class gnu --class os"
|
||||
|
||||
if [ "x${GRUB_DISTRIBUTOR}" = "x" ] ; then
|
||||
- OS=GNU/Linux
|
||||
+ OS=Linux
|
||||
else
|
||||
- OS="${GRUB_DISTRIBUTOR} GNU/Linux"
|
||||
+ OS="${GRUB_DISTRIBUTOR} Linux"
|
||||
CLASS="--class $(echo ${GRUB_DISTRIBUTOR} | tr '[A-Z]' '[a-z]' | cut -d' ' -f1) ${CLASS}"
|
||||
fi
|
||||
|
||||
diff --git a/util/grub.d/20_linux_xen.in b/util/grub.d/20_linux_xen.in
|
||||
index ee49cd9..10422b0 100644
|
||||
--- a/util/grub.d/20_linux_xen.in
|
||||
+++ b/util/grub.d/20_linux_xen.in
|
||||
@@ -29,9 +29,9 @@ export TEXTDOMAINDIR=@localedir@
|
||||
CLASS="--class gnu-linux --class gnu --class os --class xen"
|
||||
|
||||
if [ "x${GRUB_DISTRIBUTOR}" = "x" ] ; then
|
||||
- OS=GNU/Linux
|
||||
+ OS=Linux
|
||||
else
|
||||
- OS="${GRUB_DISTRIBUTOR} GNU/Linux"
|
||||
+ OS="${GRUB_DISTRIBUTOR} Linux"
|
||||
CLASS="--class $(echo ${GRUB_DISTRIBUTOR} | tr '[A-Z]' '[a-z]' | cut -d' ' -f1) ${CLASS}"
|
||||
fi
|
||||
|
||||
--
|
||||
1.7.4
|
||||
|
12
grub2.spec
12
grub2.spec
@ -32,6 +32,7 @@ Source3: README.Fedora
|
||||
Patch0: grub-1.99-handle-fwrite-return.patch
|
||||
Patch1: grub-1.99-unused-variable.patch
|
||||
Patch2: grub-1.99-grub_test_assert_printf.patch
|
||||
Patch3: grub-1.99-just-say-linux.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -110,6 +111,14 @@ cd grub-efi-%{filever}
|
||||
--with-platform=efi \
|
||||
--program-transform-name=s,grub,%{name}-efi,
|
||||
make %{?_smp_mflags}
|
||||
%ifarch %{ix86}
|
||||
%define grubefiarch i386-efi
|
||||
%else
|
||||
%define grubefiarch %{_arch}-efi
|
||||
%endif
|
||||
./grub-mkimage -O %{grubefiarch} -o grub.efi -d grub-core part_gpt hfsplus fat \
|
||||
ext2 btrfs normal chain boot configfile linux appleldr minicmd \
|
||||
loadbios reboot halt search font gfxterm
|
||||
cd ..
|
||||
%endif
|
||||
|
||||
@ -160,6 +169,8 @@ do
|
||||
TGT=$(echo $MODULE |sed "s,$RPM_BUILD_ROOT,.debugroot,")
|
||||
# install -m 755 -D $BASE$EXT $TGT
|
||||
done
|
||||
install -m 755 -d $RPM_BUILD_ROOT/boot/efi/EFI/redhat/
|
||||
install -m 755 grub.efi $RPM_BUILD_ROOT/boot/efi/EFI/redhat/grub.efi
|
||||
cd ..
|
||||
%endif
|
||||
|
||||
@ -277,6 +288,7 @@ rm -f /boot/%{name}/device.map
|
||||
%ifarch %{efi}
|
||||
%files efi
|
||||
%defattr(-,root,root,-)
|
||||
%attr(0755,root,root)/boot/efi/EFI/redhat
|
||||
/etc/bash_completion.d/grub
|
||||
%{_libdir}/grub2-efi
|
||||
%{_libdir}/grub/
|
||||
|
Loading…
Reference in New Issue
Block a user