parent
a0ce68fd71
commit
d39cbb3926
@ -1,7 +1,7 @@
|
|||||||
From 103f1f6b4e4cfd007375cd127b8e69cd102d4097 Mon Sep 17 00:00:00 2001
|
From 2f311bd175e78f889df099d5fcd945f357d6f037 Mon Sep 17 00:00:00 2001
|
||||||
From: Jan Vcelak <jvcelak@redhat.com>
|
From: Jan Vcelak <jvcelak@redhat.com>
|
||||||
Date: Tue, 1 Jan 2013 15:32:01 +0100
|
Date: Tue, 1 Jan 2013 15:32:01 +0100
|
||||||
Subject: [PATCH] missing groff-x11 info message when gxditview not found
|
Subject: [PATCH 1/4] missing groff-x11 info message when gxditview not found
|
||||||
|
|
||||||
Adds info message that 'groff-x11' package might be missing when
|
Adds info message that 'groff-x11' package might be missing when
|
||||||
executing 'groff -X' and 'gxditview' is not found.
|
executing 'groff -X' and 'gxditview' is not found.
|
||||||
@ -13,10 +13,10 @@ Signed-off-by: Jan Vcelak <jvcelak@redhat.com>
|
|||||||
1 file changed, 2 insertions(+)
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
diff --git a/src/roff/groff/pipeline.c b/src/roff/groff/pipeline.c
|
diff --git a/src/roff/groff/pipeline.c b/src/roff/groff/pipeline.c
|
||||||
index cea7593..fce0abc 100644
|
index 2e3236f..75268c2 100644
|
||||||
--- a/src/roff/groff/pipeline.c
|
--- a/src/roff/groff/pipeline.c
|
||||||
+++ b/src/roff/groff/pipeline.c
|
+++ b/src/roff/groff/pipeline.c
|
||||||
@@ -486,6 +486,8 @@ int run_pipeline(int ncommands, char ***commands, int no_pipe)
|
@@ -487,6 +487,8 @@ int run_pipeline(int ncommands, char ***commands, int no_pipe)
|
||||||
execvp(commands[i][0], commands[i]);
|
execvp(commands[i][0], commands[i]);
|
||||||
error("couldn't exec %1: %2",
|
error("couldn't exec %1: %2",
|
||||||
commands[i][0], strerror(errno), (char *)0);
|
commands[i][0], strerror(errno), (char *)0);
|
||||||
@ -26,5 +26,5 @@ index cea7593..fce0abc 100644
|
|||||||
_exit(EXEC_FAILED_EXIT_STATUS);
|
_exit(EXEC_FAILED_EXIT_STATUS);
|
||||||
}
|
}
|
||||||
--
|
--
|
||||||
1.8.0.2
|
2.21.1
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
From c6d8bb3e0ebc03274564d7b2c768e9932cc5f79d Mon Sep 17 00:00:00 2001
|
From f83e0b188bb7bf4f38536ff8d08c2ca7384ac161 Mon Sep 17 00:00:00 2001
|
||||||
From: Jan Vcelak <jvcelak@redhat.com>
|
From: Jan Vcelak <jvcelak@redhat.com>
|
||||||
Date: Tue, 1 Jan 2013 15:33:45 +0100
|
Date: Tue, 1 Jan 2013 15:33:45 +0100
|
||||||
Subject: [PATCH] load site-font and site-tmac from /etc/groff
|
Subject: [PATCH 2/4] load site-font and site-tmac from /etc/groff
|
||||||
|
|
||||||
Move site-font and site-tmac configuration from /usr/share/groff to
|
Move site-font and site-tmac configuration from /usr/share/groff to
|
||||||
/etc/groff. That allows permanent custom changes. (Symlinking brought
|
/etc/groff. That allows permanent custom changes. (Symlinking brought
|
||||||
@ -13,10 +13,10 @@ Signed-off-by: Jan Vcelak <jvcelak@redhat.com>
|
|||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile.in b/Makefile.in
|
diff --git a/Makefile.in b/Makefile.in
|
||||||
index 7534e56..d97d1b9 100644
|
index 505e9c3..5331dd3 100644
|
||||||
--- a/Makefile.in
|
--- a/Makefile.in
|
||||||
+++ b/Makefile.in
|
+++ b/Makefile.in
|
||||||
@@ -167,7 +167,7 @@ fontdir=$(datasubdir)/font
|
@@ -3573,7 +3573,7 @@ fontdir = $(datasubdir)/font
|
||||||
oldfontdir = $(datasubdir)/oldfont
|
oldfontdir = $(datasubdir)/oldfont
|
||||||
|
|
||||||
# `localfontdir' says where local fonts will be installed (as dev*/*).
|
# `localfontdir' says where local fonts will be installed (as dev*/*).
|
||||||
@ -25,7 +25,7 @@ index 7534e56..d97d1b9 100644
|
|||||||
|
|
||||||
# `legacyfontdir' is for compatibility with non-GNU troff.
|
# `legacyfontdir' is for compatibility with non-GNU troff.
|
||||||
legacyfontdir = /usr/lib/font
|
legacyfontdir = /usr/lib/font
|
||||||
@@ -179,10 +179,10 @@ fontpath=$(localfontdir)$(RT_SEP)$(fontdir)$(RT_SEP)$(legacyfontdir)
|
@@ -3585,10 +3585,10 @@ fontpath = $(localfontdir)$(RT_SEP)$(fontdir)$(RT_SEP)$(legacyfontdir)
|
||||||
tmacdir = $(datasubdir)/tmac
|
tmacdir = $(datasubdir)/tmac
|
||||||
|
|
||||||
# `systemtmacdir' says where to install platform-dependent macros.
|
# `systemtmacdir' says where to install platform-dependent macros.
|
||||||
@ -36,8 +36,8 @@ index 7534e56..d97d1b9 100644
|
|||||||
-localtmacdir = $(dataprogramdir)/site-tmac
|
-localtmacdir = $(dataprogramdir)/site-tmac
|
||||||
+localtmacdir = @sysconfdir@/groff/site-tmac
|
+localtmacdir = @sysconfdir@/groff/site-tmac
|
||||||
|
|
||||||
|
# appresdir
|
||||||
# `appresdir' says where to install the application resource file for
|
# `appresdir' says where to install the application resource file for
|
||||||
# gxditview.
|
|
||||||
--
|
--
|
||||||
1.8.0.2
|
2.21.1
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
From 36115e102859badb08cb5b2398de6b0ba45421d3 Mon Sep 17 00:00:00 2001
|
From f95bed4ad636f286ef9ff3f5b4330a10938fd064 Mon Sep 17 00:00:00 2001
|
||||||
From: Jan Vcelak <jvcelak@redhat.com>
|
From: Jan Vcelak <jvcelak@redhat.com>
|
||||||
Date: Tue, 4 Nov 2014 14:36:47 +0100
|
Date: Tue, 4 Nov 2014 14:36:47 +0100
|
||||||
Subject: [PATCH] various security fixes
|
Subject: [PATCH 3/4] various security fixes
|
||||||
|
|
||||||
CVE-2009-5044 (#709413)
|
CVE-2009-5044 (#709413)
|
||||||
CVE-2009-5080 (#720058)
|
CVE-2009-5080 (#720058)
|
||||||
@ -12,36 +12,35 @@ Resolves: #709415, #720060
|
|||||||
Signed-off-by: Jan Vcelak <jvcelak@redhat.com>
|
Signed-off-by: Jan Vcelak <jvcelak@redhat.com>
|
||||||
---
|
---
|
||||||
contrib/eqn2graph/eqn2graph.sh | 2 ++
|
contrib/eqn2graph/eqn2graph.sh | 2 ++
|
||||||
contrib/gdiffmk/tests/runtests.in | 5 +++--
|
contrib/gdiffmk/tests/runtests.sh | 5 +++--
|
||||||
contrib/grap2graph/grap2graph.sh | 2 ++
|
contrib/grap2graph/grap2graph.sh | 2 ++
|
||||||
contrib/groffer/main_subs.pl | 10 +++++-----
|
contrib/groffer/main_subs.pl | 10 +++++-----
|
||||||
contrib/groffer/roff2.pl | 2 +-
|
contrib/groffer/roff2.pl | 2 +-
|
||||||
contrib/pdfmark/pdfroff.man | 5 +++--
|
contrib/pdfmark/pdfroff.1.man | 5 +++--
|
||||||
contrib/pic2graph/pic2graph.sh | 2 ++
|
contrib/pic2graph/pic2graph.sh | 2 ++
|
||||||
doc/fixinfo.sh | 5 +++--
|
doc/fixinfo.sh | 5 +++--
|
||||||
doc/groff.info-2 | 6 +++---
|
doc/groff.texi | 6 +++---
|
||||||
doc/groff.texinfo | 6 +++---
|
|
||||||
gendef.sh | 10 +++-------
|
gendef.sh | 10 +++-------
|
||||||
11 files changed, 30 insertions(+), 25 deletions(-)
|
10 files changed, 27 insertions(+), 22 deletions(-)
|
||||||
|
|
||||||
diff --git a/contrib/eqn2graph/eqn2graph.sh b/contrib/eqn2graph/eqn2graph.sh
|
diff --git a/contrib/eqn2graph/eqn2graph.sh b/contrib/eqn2graph/eqn2graph.sh
|
||||||
index ee7cc5f..13edf78 100644
|
index 3e9c374..4e4f11e 100644
|
||||||
--- a/contrib/eqn2graph/eqn2graph.sh
|
--- a/contrib/eqn2graph/eqn2graph.sh
|
||||||
+++ b/contrib/eqn2graph/eqn2graph.sh
|
+++ b/contrib/eqn2graph/eqn2graph.sh
|
||||||
@@ -67,6 +67,8 @@ for d in "$GROFF_TMPDIR" "$TMPDIR" "$TMP" "$TEMP" /tmp; do
|
@@ -74,6 +74,8 @@ then
|
||||||
|
# but is supported by the stripped-down dash shell, for instance.
|
||||||
tmp=$d/eqn2graph$$-$RANDOM
|
tmp="$d/eqn2graph$$-${RANDOM:-$PPID}"
|
||||||
(umask 077 && mkdir $tmp) 2> /dev/null && break
|
(umask 077 && mkdir "$tmp") 2> /dev/null
|
||||||
+
|
+
|
||||||
+ tmp=
|
+ tmp=
|
||||||
done;
|
fi
|
||||||
if test -z "$tmp"; then
|
|
||||||
echo "$0: cannot create temporary directory" >&2
|
if ! test -d "$tmp"
|
||||||
diff --git a/contrib/gdiffmk/tests/runtests.in b/contrib/gdiffmk/tests/runtests.in
|
diff --git a/contrib/gdiffmk/tests/runtests.sh b/contrib/gdiffmk/tests/runtests.sh
|
||||||
index 714ce48..40a35c4 100644
|
index 0f7c3b6..f8aa874 100755
|
||||||
--- a/contrib/gdiffmk/tests/runtests.in
|
--- a/contrib/gdiffmk/tests/runtests.sh
|
||||||
+++ b/contrib/gdiffmk/tests/runtests.in
|
+++ b/contrib/gdiffmk/tests/runtests.sh
|
||||||
@@ -56,8 +56,9 @@ function TestResult {
|
@@ -63,8 +63,9 @@ TestResult () {
|
||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -54,23 +53,23 @@ index 714ce48..40a35c4 100644
|
|||||||
# Run tests.
|
# Run tests.
|
||||||
|
|
||||||
diff --git a/contrib/grap2graph/grap2graph.sh b/contrib/grap2graph/grap2graph.sh
|
diff --git a/contrib/grap2graph/grap2graph.sh b/contrib/grap2graph/grap2graph.sh
|
||||||
index 58544e1..aeab832 100644
|
index 29df25b..94c436b 100644
|
||||||
--- a/contrib/grap2graph/grap2graph.sh
|
--- a/contrib/grap2graph/grap2graph.sh
|
||||||
+++ b/contrib/grap2graph/grap2graph.sh
|
+++ b/contrib/grap2graph/grap2graph.sh
|
||||||
@@ -63,6 +63,8 @@ for d in "$GROFF_TMPDIR" "$TMPDIR" "$TMP" "$TEMP" /tmp; do
|
@@ -76,6 +76,8 @@ then
|
||||||
|
# but is supported by the stripped-down dash shell, for instance.
|
||||||
tmp=$d/grap2graph$$-$RANDOM
|
tmp="$d/grap2graph$$-${RANDOM:-$PPID}"
|
||||||
(umask 077 && mkdir $tmp) 2> /dev/null && break
|
(umask 077 && mkdir "$tmp") 2> /dev/null
|
||||||
+
|
+
|
||||||
+ tmp=
|
+ tmp=
|
||||||
done;
|
fi
|
||||||
if test -z "$tmp"; then
|
|
||||||
echo "$0: cannot create temporary directory" >&2
|
if ! test -d "$tmp"
|
||||||
diff --git a/contrib/groffer/main_subs.pl b/contrib/groffer/main_subs.pl
|
diff --git a/contrib/groffer/main_subs.pl b/contrib/groffer/main_subs.pl
|
||||||
index 90627cc..76896cd 100644
|
index a40e356..c8c4e53 100644
|
||||||
--- a/contrib/groffer/main_subs.pl
|
--- a/contrib/groffer/main_subs.pl
|
||||||
+++ b/contrib/groffer/main_subs.pl
|
+++ b/contrib/groffer/main_subs.pl
|
||||||
@@ -1239,7 +1239,7 @@ sub main_temp {
|
@@ -1244,7 +1244,7 @@ sub main_temp {
|
||||||
our $fh_stdin;
|
our $fh_stdin;
|
||||||
our $tmp_cat;
|
our $tmp_cat;
|
||||||
our $tmp_stdin;
|
our $tmp_stdin;
|
||||||
@ -79,7 +78,7 @@ index 90627cc..76896cd 100644
|
|||||||
foreach ($ENV{'GROFF_TMPDIR'}, $ENV{'TMPDIR'}, $ENV{'TMP'}, $ENV{'TEMP'},
|
foreach ($ENV{'GROFF_TMPDIR'}, $ENV{'TMPDIR'}, $ENV{'TMP'}, $ENV{'TEMP'},
|
||||||
$ENV{'TEMPDIR'}, File::Spec->catfile($ENV{'HOME'}, 'tmp')) {
|
$ENV{'TEMPDIR'}, File::Spec->catfile($ENV{'HOME'}, 'tmp')) {
|
||||||
if ($_ && -d $_ && -w $_) {
|
if ($_ && -d $_ && -w $_) {
|
||||||
@@ -1271,12 +1271,12 @@ sub main_temp {
|
@@ -1276,12 +1276,12 @@ sub main_temp {
|
||||||
|
|
||||||
# further argument: SUFFIX => '.sh'
|
# further argument: SUFFIX => '.sh'
|
||||||
if ($Debug{'KEEP'}) {
|
if ($Debug{'KEEP'}) {
|
||||||
@ -97,7 +96,7 @@ index 90627cc..76896cd 100644
|
|||||||
}
|
}
|
||||||
} # main_temp()
|
} # main_temp()
|
||||||
diff --git a/contrib/groffer/roff2.pl b/contrib/groffer/roff2.pl
|
diff --git a/contrib/groffer/roff2.pl b/contrib/groffer/roff2.pl
|
||||||
index d8dad3f..f0ca9f2 100755
|
index cf5c583..24af006 100755
|
||||||
--- a/contrib/groffer/roff2.pl
|
--- a/contrib/groffer/roff2.pl
|
||||||
+++ b/contrib/groffer/roff2.pl
|
+++ b/contrib/groffer/roff2.pl
|
||||||
@@ -123,7 +123,7 @@ if ($Has_Groffer) {
|
@@ -123,7 +123,7 @@ if ($Has_Groffer) {
|
||||||
@ -109,21 +108,21 @@ index d8dad3f..f0ca9f2 100755
|
|||||||
my ($fh, $stdin);
|
my ($fh, $stdin);
|
||||||
if ($tempdir) {
|
if ($tempdir) {
|
||||||
($fh, $stdin) = tempfile($template, UNLINK => 1, DIR => $tempdir) ||
|
($fh, $stdin) = tempfile($template, UNLINK => 1, DIR => $tempdir) ||
|
||||||
diff --git a/contrib/pdfmark/pdfroff.man b/contrib/pdfmark/pdfroff.man
|
diff --git a/contrib/pdfmark/pdfroff.1.man b/contrib/pdfmark/pdfroff.1.man
|
||||||
index ec412bb..faf2898 100644
|
index 95d7807..aa6f079 100644
|
||||||
--- a/contrib/pdfmark/pdfroff.man
|
--- a/contrib/pdfmark/pdfroff.1.man
|
||||||
+++ b/contrib/pdfmark/pdfroff.man
|
+++ b/contrib/pdfmark/pdfroff.1.man
|
||||||
@@ -555,7 +555,7 @@ defaults to
|
@@ -540,7 +540,7 @@ gs \-dBATCH \-dQUIET \-dNOPAUSE \-dSAFER \-sDEVICE=pdfwrite \e
|
||||||
.B GROFF_TMPDIR
|
.I GROFF_TMPDIR
|
||||||
Identifies the directory in which
|
Identifies the directory in which
|
||||||
.B pdfroff
|
.B pdfroff
|
||||||
-should create temporary files.
|
-should create temporary files.
|
||||||
+should create a subdirectory for its temporary files.
|
+should create a subdirectory for its temporary files.
|
||||||
.
|
.
|
||||||
If
|
If
|
||||||
.B \%GROFF_TMPDIR
|
.I \%GROFF_TMPDIR
|
||||||
@@ -568,7 +568,8 @@ and
|
@@ -553,7 +553,8 @@ and
|
||||||
.B TEMP
|
.I TEMP
|
||||||
are considered in turn, as possible temporary file repositories.
|
are considered in turn, as possible temporary file repositories.
|
||||||
If none of these are set, then temporary files are created
|
If none of these are set, then temporary files are created
|
||||||
-in the current directory.
|
-in the current directory.
|
||||||
@ -131,28 +130,28 @@ index ec412bb..faf2898 100644
|
|||||||
+.BR /tmp .
|
+.BR /tmp .
|
||||||
.
|
.
|
||||||
.TP
|
.TP
|
||||||
.B GROFF_GHOSTSCRIPT_INTERPRETER
|
.I GROFF_GHOSTSCRIPT_INTERPRETER
|
||||||
diff --git a/contrib/pic2graph/pic2graph.sh b/contrib/pic2graph/pic2graph.sh
|
diff --git a/contrib/pic2graph/pic2graph.sh b/contrib/pic2graph/pic2graph.sh
|
||||||
index 72c5477..6b3360d 100644
|
index b229914..2d6e77c 100644
|
||||||
--- a/contrib/pic2graph/pic2graph.sh
|
--- a/contrib/pic2graph/pic2graph.sh
|
||||||
+++ b/contrib/pic2graph/pic2graph.sh
|
+++ b/contrib/pic2graph/pic2graph.sh
|
||||||
@@ -78,6 +78,8 @@ for d in "$GROFF_TMPDIR" "$TMPDIR" "$TMP" "$TEMP" /tmp; do
|
@@ -89,6 +89,8 @@ then
|
||||||
tmp=$d/pic2graph$$-$RANDOM
|
# but is supported by the stripped-down dash shell, for instance.
|
||||||
(umask 077 && mkdir $tmp) 2> /dev/null \
|
tmp="$d/pic2graph$$-${RANDOM:-$PPID}"
|
||||||
&& break
|
(umask 077 && mkdir "$tmp") 2> /dev/null
|
||||||
+
|
+
|
||||||
+ tmp=
|
+ tmp=
|
||||||
done;
|
fi
|
||||||
if test -z "$tmp"; then
|
|
||||||
echo "$0: cannot create temporary directory" >&2
|
if ! test -d "$tmp"
|
||||||
diff --git a/doc/fixinfo.sh b/doc/fixinfo.sh
|
diff --git a/doc/fixinfo.sh b/doc/fixinfo.sh
|
||||||
index 2c853f8..6954e6a 100644
|
index 47127f8..69bb74d 100644
|
||||||
--- a/doc/fixinfo.sh
|
--- a/doc/fixinfo.sh
|
||||||
+++ b/doc/fixinfo.sh
|
+++ b/doc/fixinfo.sh
|
||||||
@@ -22,8 +22,9 @@
|
@@ -24,8 +24,9 @@
|
||||||
# groff.texinfo macro code. Hopefully, a new texinfo version makes it
|
#
|
||||||
# unnecessary.
|
# 09-2014: no more problem with texinfo 5.0 or higher
|
||||||
|
#
|
||||||
-t=${TMPDIR-.}/gro$$.tmp
|
-t=${TMPDIR-.}/gro$$.tmp
|
||||||
-
|
-
|
||||||
+t="`mktemp -t groff-fixinfo.XXXXXXXXXX`" || exit
|
+t="`mktemp -t groff-fixinfo.XXXXXXXXXX`" || exit
|
||||||
@ -161,13 +160,13 @@ index 2c853f8..6954e6a 100644
|
|||||||
cat $1 | sed '
|
cat $1 | sed '
|
||||||
1 {
|
1 {
|
||||||
N
|
N
|
||||||
diff --git a/doc/groff.info-2 b/doc/groff.info-2
|
diff --git a/doc/groff.texi b/doc/groff.texi
|
||||||
index 7eaae86..e7dab72 100644
|
index e7fe4aa..b4d01ed 100644
|
||||||
--- a/doc/groff.info-2
|
--- a/doc/groff.texi
|
||||||
+++ b/doc/groff.info-2
|
+++ b/doc/groff.texi
|
||||||
@@ -1697,9 +1697,9 @@ not there, 'groff' would not know when to stop.
|
@@ -13857,9 +13857,9 @@ into a document:
|
||||||
time into a document:
|
@pindex perl
|
||||||
|
@Example
|
||||||
.sy perl -e 'printf ".nr H %d\\n.nr M %d\\n.nr S %d\\n",\
|
.sy perl -e 'printf ".nr H %d\\n.nr M %d\\n.nr S %d\\n",\
|
||||||
- (localtime(time))[2,1,0]' > /tmp/x\n[$$]
|
- (localtime(time))[2,1,0]' > /tmp/x\n[$$]
|
||||||
-.so /tmp/x\n[$$]
|
-.so /tmp/x\n[$$]
|
||||||
@ -176,27 +175,10 @@ index 7eaae86..e7dab72 100644
|
|||||||
+.so timefile\n[$$]
|
+.so timefile\n[$$]
|
||||||
+.sy rm timefile\n[$$]
|
+.sy rm timefile\n[$$]
|
||||||
\nH:\nM:\nS
|
\nH:\nM:\nS
|
||||||
|
|
||||||
Note that this works by having the 'perl' script (run by 'sy')
|
|
||||||
diff --git a/doc/groff.texinfo b/doc/groff.texinfo
|
|
||||||
index 066b527..83684da 100644
|
|
||||||
--- a/doc/groff.texinfo
|
|
||||||
+++ b/doc/groff.texinfo
|
|
||||||
@@ -13736,9 +13736,9 @@ into a document:
|
|
||||||
@pindex perl
|
|
||||||
@Example
|
|
||||||
.sy perl -e 'printf ".nr H %d\\n.nr M %d\\n.nr S %d\\n",\
|
|
||||||
- (localtime(time))[2,1,0]' > /tmp/x\n[$$]
|
|
||||||
-.so /tmp/x\n[$$]
|
|
||||||
-.sy rm /tmp/x\n[$$]
|
|
||||||
+ (localtime(time))[2,1,0]' > timefile\n[$$]
|
|
||||||
++.so timefile\n[$$]
|
|
||||||
++.sy rm timefile\n[$$]
|
|
||||||
\nH:\nM:\nS
|
|
||||||
@endExample
|
@endExample
|
||||||
|
|
||||||
diff --git a/gendef.sh b/gendef.sh
|
diff --git a/gendef.sh b/gendef.sh
|
||||||
index 41a511b..050bcbe 100644
|
index be41dbe..4770bae 100644
|
||||||
--- a/gendef.sh
|
--- a/gendef.sh
|
||||||
+++ b/gendef.sh
|
+++ b/gendef.sh
|
||||||
@@ -33,11 +33,9 @@ do
|
@@ -33,11 +33,9 @@ do
|
||||||
@ -224,5 +206,5 @@ index 41a511b..050bcbe 100644
|
|||||||
|
|
||||||
# eof
|
# eof
|
||||||
--
|
--
|
||||||
1.9.3
|
2.21.1
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
From e263e19aa1c63dbcbe710e8aae79c8e298606e4c Mon Sep 17 00:00:00 2001
|
From 6c997078a8f74429f58e4679b7630de7962e18b0 Mon Sep 17 00:00:00 2001
|
||||||
From: Peter Schiffer <pschiffe@redhat.com>
|
From: Peter Schiffer <pschiffe@redhat.com>
|
||||||
Date: Tue, 4 Nov 2014 14:49:57 +0100
|
Date: Tue, 4 Nov 2014 14:49:57 +0100
|
||||||
Subject: [PATCH] don't use /usr/bin/env in shebang
|
Subject: [PATCH 4/4] don't use /usr/bin/env in shebang
|
||||||
|
|
||||||
There might be an issue that the script is executed with unwanted version of
|
There might be an issue that the script is executed with unwanted version of
|
||||||
<lang> if that language is provided by enabled dynamic software collection.
|
<lang> if that language is provided by enabled dynamic software collection.
|
||||||
@ -15,7 +15,7 @@ Resolves: #987069
|
|||||||
4 files changed, 4 insertions(+), 4 deletions(-)
|
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
diff --git a/contrib/chem/chem.pl b/contrib/chem/chem.pl
|
diff --git a/contrib/chem/chem.pl b/contrib/chem/chem.pl
|
||||||
index 1a8b3cc..15eda5f 100755
|
index 883907b..57e0216 100755
|
||||||
--- a/contrib/chem/chem.pl
|
--- a/contrib/chem/chem.pl
|
||||||
+++ b/contrib/chem/chem.pl
|
+++ b/contrib/chem/chem.pl
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
@ -25,7 +25,7 @@ index 1a8b3cc..15eda5f 100755
|
|||||||
# chem - a groff preprocessor for producing chemical structure diagrams
|
# chem - a groff preprocessor for producing chemical structure diagrams
|
||||||
|
|
||||||
diff --git a/contrib/groffer/groffer.pl b/contrib/groffer/groffer.pl
|
diff --git a/contrib/groffer/groffer.pl b/contrib/groffer/groffer.pl
|
||||||
index 4e2e575..913e8eb 100755
|
index 697dacb..654f18e 100755
|
||||||
--- a/contrib/groffer/groffer.pl
|
--- a/contrib/groffer/groffer.pl
|
||||||
+++ b/contrib/groffer/groffer.pl
|
+++ b/contrib/groffer/groffer.pl
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
@ -35,7 +35,7 @@ index 4e2e575..913e8eb 100755
|
|||||||
# groffer - display groff files
|
# groffer - display groff files
|
||||||
|
|
||||||
diff --git a/contrib/groffer/roff2.pl b/contrib/groffer/roff2.pl
|
diff --git a/contrib/groffer/roff2.pl b/contrib/groffer/roff2.pl
|
||||||
index f0ca9f2..1b8577f 100755
|
index 24af006..35a560c 100755
|
||||||
--- a/contrib/groffer/roff2.pl
|
--- a/contrib/groffer/roff2.pl
|
||||||
+++ b/contrib/groffer/roff2.pl
|
+++ b/contrib/groffer/roff2.pl
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
@ -45,7 +45,7 @@ index f0ca9f2..1b8577f 100755
|
|||||||
# roff2* - transform roff files into other formats
|
# roff2* - transform roff files into other formats
|
||||||
|
|
||||||
diff --git a/src/roff/grog/grog.pl b/src/roff/grog/grog.pl
|
diff --git a/src/roff/grog/grog.pl b/src/roff/grog/grog.pl
|
||||||
index fb7b54c..9baa869 100644
|
index f7fb8e4..1d5c3d8 100644
|
||||||
--- a/src/roff/grog/grog.pl
|
--- a/src/roff/grog/grog.pl
|
||||||
+++ b/src/roff/grog/grog.pl
|
+++ b/src/roff/grog/grog.pl
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
@ -55,5 +55,5 @@ index fb7b54c..9baa869 100644
|
|||||||
# Inspired by doctype script in Kernighan & Pike, Unix Programming
|
# Inspired by doctype script in Kernighan & Pike, Unix Programming
|
||||||
# Environment, pp 306-8.
|
# Environment, pp 306-8.
|
||||||
--
|
--
|
||||||
1.9.3
|
2.21.1
|
||||||
|
|
||||||
|
@ -1,25 +0,0 @@
|
|||||||
From 65c9f2f5152b3eebba8494cbead00d79d1dcbb1c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jan Chaloupka <jchaloup@redhat.com>
|
|
||||||
Date: Wed, 12 Nov 2014 08:23:00 +0100
|
|
||||||
Subject: [PATCH] Add missing rule for gropdf
|
|
||||||
|
|
||||||
---
|
|
||||||
Makefile.in | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/Makefile.in b/Makefile.in
|
|
||||||
index 4b5a5c6..7ae9ac2 100644
|
|
||||||
--- a/Makefile.in
|
|
||||||
+++ b/Makefile.in
|
|
||||||
@@ -896,6 +896,8 @@ $(GNULIBDIRS): FORCE
|
|
||||||
$(MAKE) ACLOCAL=: AUTOCONF=: AUTOHEADER=: AUTOMAKE=: $(do) ;; \
|
|
||||||
esac
|
|
||||||
|
|
||||||
+$(SHPROGDIRS): $(PROGDEPDIRS)
|
|
||||||
+
|
|
||||||
$(OTHERDIRS): $(PROGDEPDIRS) $(CCPROGDIRS) $(CPROGDIRS) $(SHPROGDIRS)
|
|
||||||
|
|
||||||
$(INCDIRS) $(PROGDEPDIRS) $(SHPROGDIRS) $(OTHERDIRS): FORCE
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
28
0005-do-not-overwrite-docdir.patch
Normal file
28
0005-do-not-overwrite-docdir.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From ad194a6cadbb4718d238c85925ab8c646a3afdf7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
|
||||||
|
Date: Fri, 6 Mar 2020 10:40:09 +0100
|
||||||
|
Subject: [PATCH 5/5] do not overwrite docdir
|
||||||
|
|
||||||
|
---
|
||||||
|
Makefile.in | 5 ++---
|
||||||
|
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile.in b/Makefile.in
|
||||||
|
index 5331dd3..21522e3 100644
|
||||||
|
--- a/Makefile.in
|
||||||
|
+++ b/Makefile.in
|
||||||
|
@@ -3378,9 +3378,8 @@ doc_dist_target_ok = @doc_dist_target_ok@
|
||||||
|
# `infodir' says where to install info files.
|
||||||
|
|
||||||
|
# docdir
|
||||||
|
-# `docdir' says where to install documentation files. The default
|
||||||
|
-# location is ${datarootdir}/doc/${PACKAGE}, but we add the version
|
||||||
|
-docdir = $(datarootdir)/doc/${PACKAGE}-$(SHORT_VERSION)
|
||||||
|
+# `docdir' says where to install documentation files.
|
||||||
|
+docdir = @docdir@
|
||||||
|
dvidir = @dvidir@
|
||||||
|
exec_prefix = @exec_prefix@
|
||||||
|
g = @g@
|
||||||
|
--
|
||||||
|
2.21.1
|
||||||
|
|
19
groff.spec
19
groff.spec
@ -2,8 +2,8 @@
|
|||||||
|
|
||||||
Summary: A document formatting system
|
Summary: A document formatting system
|
||||||
Name: groff
|
Name: groff
|
||||||
Version: 1.22.3
|
Version: 1.22.4
|
||||||
Release: 24%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+ and GFDL and BSD and MIT
|
License: GPLv3+ and GFDL and BSD and MIT
|
||||||
URL: http://www.gnu.org/software/groff/
|
URL: http://www.gnu.org/software/groff/
|
||||||
Source: ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
|
Source: ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
|
||||||
@ -15,8 +15,8 @@ Patch1: 0002-load-site-font-and-site-tmac-from-etc-groff.patch
|
|||||||
Patch2: 0003-various-security-fixes.patch
|
Patch2: 0003-various-security-fixes.patch
|
||||||
# resolves: #987069
|
# resolves: #987069
|
||||||
Patch3: 0004-don-t-use-usr-bin-env-in-shebang.patch
|
Patch3: 0004-don-t-use-usr-bin-env-in-shebang.patch
|
||||||
# SSIA
|
# allow to specify custom docdir
|
||||||
Patch4: 0005-Add-missing-rule-for-gropdf.patch
|
Patch4: 0005-do-not-overwrite-docdir.patch
|
||||||
|
|
||||||
Requires: coreutils, groff-base = %{version}-%{release}
|
Requires: coreutils, groff-base = %{version}-%{release}
|
||||||
|
|
||||||
@ -25,6 +25,7 @@ Requires(postun): %{_sbindir}/update-alternatives
|
|||||||
Requires(preun): %{_sbindir}/update-alternatives
|
Requires(preun): %{_sbindir}/update-alternatives
|
||||||
|
|
||||||
BuildRequires: gcc, gcc-c++
|
BuildRequires: gcc, gcc-c++
|
||||||
|
BuildRequires: bison, texinfo
|
||||||
BuildRequires: git, netpbm-progs, perl-generators, psutils, ghostscript
|
BuildRequires: git, netpbm-progs, perl-generators, psutils, ghostscript
|
||||||
|
|
||||||
Provides: nroff-i18n = %{version}-%{release}
|
Provides: nroff-i18n = %{version}-%{release}
|
||||||
@ -99,7 +100,7 @@ git add .
|
|||||||
git commit -n -m "release %{version}"
|
git commit -n -m "release %{version}"
|
||||||
git am %{patches}
|
git am %{patches}
|
||||||
|
|
||||||
for file in NEWS src/devices/grolbp/grolbp.man doc/{groff.info*,webpage.ms} \
|
for file in NEWS src/devices/grolbp/grolbp.1.man doc/webpage.ms \
|
||||||
contrib/mm/*.man contrib/mom/examples/{README.txt,*.mom,mom.vim}; do
|
contrib/mm/*.man contrib/mom/examples/{README.txt,*.mom,mom.vim}; do
|
||||||
iconv -f iso-8859-1 -t utf-8 < "$file" > "${file}_"
|
iconv -f iso-8859-1 -t utf-8 < "$file" > "${file}_"
|
||||||
mv "${file}_" "$file"
|
mv "${file}_" "$file"
|
||||||
@ -202,6 +203,7 @@ fi
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
# data
|
# data
|
||||||
|
%{_datadir}/%{name}/%{version}/font/devcp1047/
|
||||||
%{_datadir}/%{name}/%{version}/font/devdvi/
|
%{_datadir}/%{name}/%{version}/font/devdvi/
|
||||||
%{_datadir}/%{name}/%{version}/font/devlbp/
|
%{_datadir}/%{name}/%{version}/font/devlbp/
|
||||||
%{_datadir}/%{name}/%{version}/font/devlj4/
|
%{_datadir}/%{name}/%{version}/font/devlj4/
|
||||||
@ -225,6 +227,7 @@ fi
|
|||||||
%{_datadir}/%{name}/%{version}/tmac/ms.tmac
|
%{_datadir}/%{name}/%{version}/tmac/ms.tmac
|
||||||
%{_datadir}/%{name}/%{version}/tmac/mse.tmac
|
%{_datadir}/%{name}/%{version}/tmac/mse.tmac
|
||||||
%{_datadir}/%{name}/%{version}/tmac/om.tmac
|
%{_datadir}/%{name}/%{version}/tmac/om.tmac
|
||||||
|
%{_datadir}/%{name}/%{version}/tmac/pdfpic.tmac
|
||||||
%{_datadir}/%{name}/%{version}/tmac/pdfmark.tmac
|
%{_datadir}/%{name}/%{version}/tmac/pdfmark.tmac
|
||||||
%{_datadir}/%{name}/%{version}/tmac/refer-me.tmac
|
%{_datadir}/%{name}/%{version}/tmac/refer-me.tmac
|
||||||
%{_datadir}/%{name}/%{version}/tmac/refer-mm.tmac
|
%{_datadir}/%{name}/%{version}/tmac/refer-mm.tmac
|
||||||
@ -233,6 +236,7 @@ fi
|
|||||||
%{_datadir}/%{name}/%{version}/tmac/s.tmac
|
%{_datadir}/%{name}/%{version}/tmac/s.tmac
|
||||||
%{_datadir}/%{name}/%{version}/tmac/spdf.tmac
|
%{_datadir}/%{name}/%{version}/tmac/spdf.tmac
|
||||||
%{_datadir}/%{name}/%{version}/tmac/trace.tmac
|
%{_datadir}/%{name}/%{version}/tmac/trace.tmac
|
||||||
|
%{_datadir}/%{name}/%{version}/tmac/zh.tmac
|
||||||
# programs
|
# programs
|
||||||
%{_bindir}/addftinfo
|
%{_bindir}/addftinfo
|
||||||
%{_bindir}/eqn2graph
|
%{_bindir}/eqn2graph
|
||||||
@ -328,7 +332,6 @@ fi
|
|||||||
%{_datadir}/%{name}/%{version}/tmac/hyphen.sv
|
%{_datadir}/%{name}/%{version}/tmac/hyphen.sv
|
||||||
%{_datadir}/%{name}/%{version}/tmac/hyphen.us
|
%{_datadir}/%{name}/%{version}/tmac/hyphen.us
|
||||||
%{_datadir}/%{name}/%{version}/tmac/hyphenex.cs
|
%{_datadir}/%{name}/%{version}/tmac/hyphenex.cs
|
||||||
%{_datadir}/%{name}/%{version}/tmac/hyphenex.det
|
|
||||||
%{_datadir}/%{name}/%{version}/tmac/hyphenex.us
|
%{_datadir}/%{name}/%{version}/tmac/hyphenex.us
|
||||||
%{_datadir}/%{name}/%{version}/tmac/ja.tmac
|
%{_datadir}/%{name}/%{version}/tmac/ja.tmac
|
||||||
%{_datadir}/%{name}/%{version}/tmac/latin1.tmac
|
%{_datadir}/%{name}/%{version}/tmac/latin1.tmac
|
||||||
@ -471,6 +474,10 @@ fi
|
|||||||
%doc %{_pkgdocdir}/pdf/
|
%doc %{_pkgdocdir}/pdf/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 05 2020 Nikola Forró <nforro@redhat.com> - 1.22.4-1
|
||||||
|
- Update to version 1.22.4
|
||||||
|
resolves: #1808072
|
||||||
|
|
||||||
* Sun Mar 01 2020 Nikola Forró <nforro@redhat.com> - 1.22.3-24
|
* Sun Mar 01 2020 Nikola Forró <nforro@redhat.com> - 1.22.3-24
|
||||||
- Fix %pre scriptlets
|
- Fix %pre scriptlets
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user