[tw] - fixed DoCharacter calls in xditview (#110812)
- fixed fclose called once too often (#132690): thanks to Ulrich Drepper for the bug hunting
This commit is contained in:
parent
404b62698c
commit
99d8df5dc8
27
groff-1.18.1.1-do_char.patch
Normal file
27
groff-1.18.1.1-do_char.patch
Normal file
@ -0,0 +1,27 @@
|
||||
--- groff-1.18.1.1/src/xditview/draw.c.do_char 2004-09-15 17:42:34.221596494 +0200
|
||||
+++ groff-1.18.1.1/src/xditview/draw.c 2004-09-15 17:42:35.880369335 +0200
|
||||
@@ -418,7 +418,11 @@
|
||||
dw->dvi.state->font_size, c, &wid))
|
||||
return;
|
||||
if (dw->dvi.native) {
|
||||
+#ifdef ENABLE_MULTIBYTE
|
||||
+ DoCharacter (dw, c, wid, map->char2XChar2b);
|
||||
+#else
|
||||
DoCharacter (dw, c, wid);
|
||||
+#endif
|
||||
return;
|
||||
}
|
||||
map = QueryFontMap (dw, dw->dvi.state->font_number);
|
||||
@@ -429,7 +433,11 @@
|
||||
name = device_name_for_code ((DeviceFont *)0, c)) {
|
||||
int code = DviCharIndex (map, name);
|
||||
if (code >= 0) {
|
||||
- DoCharacter (dw, code, wid);
|
||||
+#ifdef ENABLE_MULTIBYTE
|
||||
+ DoCharacter (dw, code, wid, map->char2XChar2b);
|
||||
+#else
|
||||
+ DoCharacter (dw, code, wid);
|
||||
+#endif
|
||||
break;
|
||||
}
|
||||
if (FakeCharacter (dw, name, wid))
|
10
groff-1.18.1.1-grn.patch
Normal file
10
groff-1.18.1.1-grn.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- groff-1.18.1.1/src/preproc/grn/hdb.cc.grn 2002-10-07 06:42:55.000000000 +0200
|
||||
+++ groff-1.18.1.1/src/preproc/grn/hdb.cc 2004-09-16 10:23:42.394486378 +0200
|
||||
@@ -115,7 +115,6 @@
|
||||
type = DBGetType(string); /* interpret element type */
|
||||
if (type < 0) { /* no more data */
|
||||
done = TRUE;
|
||||
- (void) fclose(file);
|
||||
} else {
|
||||
#ifdef UW_FASTSCAN
|
||||
(void) xscanf(file, &x, &y); /* always one point */
|
12
groff.spec
12
groff.spec
@ -3,7 +3,7 @@
|
||||
Summary: A document formatting system.
|
||||
Name: groff
|
||||
Version: 1.18.1.1
|
||||
Release: 1
|
||||
Release: 2
|
||||
License: GPL
|
||||
Group: Applications/Publishing
|
||||
Source0: ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
|
||||
@ -25,6 +25,9 @@ Patch14: groff-xlibs.patch
|
||||
Patch15: groff-1.18.1-fix15.patch
|
||||
Patch16: groff-1.18.1-devutf8.patch
|
||||
Patch17: groff-1.18.1.1-revision.patch
|
||||
Patch18: groff-1.18.1.1-do_char.patch
|
||||
Patch19: groff-1.18.1.1-grn.patch
|
||||
|
||||
URL: ftp://ftp.gnu.org/gnu/groff/
|
||||
Requires: mktemp
|
||||
Prereq: /sbin/install-info
|
||||
@ -86,6 +89,8 @@ System display.
|
||||
%patch15 -p1 -b .fix9
|
||||
%patch16 -p1 -b .devutf8
|
||||
%patch17 -p1 -b .revision
|
||||
%patch18 -p1 -b .do_char
|
||||
%patch19 -p1 -b .grn
|
||||
|
||||
%build
|
||||
PATH=$PATH:%{_prefix}/X11R6/bin
|
||||
@ -191,6 +196,11 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Sep 16 2004 Thomas Woerner <twoerner@redhat.com> 1.18.1.1-2
|
||||
- fixed DoCharacter calls in xditview (#110812)
|
||||
- fixed fclose called once too often (#132690): thanks to Ulrich Drepper for
|
||||
the bug hunting
|
||||
|
||||
* Tue Jun 29 2004 Thomas Woerner <twoerner@redhat.com> 1.18.1.1-1
|
||||
- new version 1.18.1.1 (fixed groffer script)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user