Rebase to version 1.23.0

Upstream has changed the ftp:// to https:// in Source
This commit is contained in:
Lukas Javorsky 2023-07-10 13:35:50 +00:00
parent f9410d48a3
commit 97ed6a6130
6 changed files with 55 additions and 168 deletions

View File

@ -1,30 +1,30 @@
From 2f311bd175e78f889df099d5fcd945f357d6f037 Mon Sep 17 00:00:00 2001 From 20f199d608d7aa4c8eb21067480dc3a682f6188c Mon Sep 17 00:00:00 2001
From: Jan Vcelak <jvcelak@redhat.com> From: groff owner <groff-owner@fedoraproject.org>
Date: Tue, 1 Jan 2013 15:32:01 +0100 Date: Mon, 10 Jul 2023 10:54:23 +0000
Subject: [PATCH 1/4] missing groff-x11 info message when gxditview not found Subject: [PATCH] missing groff-x11 info message when gxditview not found
Adds info message that 'groff-x11' package might be missing when Adds info message that 'groff-x11' package might be missing when
executing 'groff -X' and 'gxditview' is not found. executing 'groff -X' and 'gxditview' is not found.
Resolves: #530788 Resolves: #530788
Signed-off-by: Jan Vcelak <jvcelak@redhat.com>
--- ---
src/roff/groff/pipeline.c | 2 ++ src/roff/groff/pipeline.c | 2 ++
1 file changed, 2 insertions(+) 1 file changed, 2 insertions(+)
diff --git a/src/roff/groff/pipeline.c b/src/roff/groff/pipeline.c diff --git a/src/roff/groff/pipeline.c b/src/roff/groff/pipeline.c
index 2e3236f..75268c2 100644 index defafc2..188b98e 100644
--- a/src/roff/groff/pipeline.c --- a/src/roff/groff/pipeline.c
+++ b/src/roff/groff/pipeline.c +++ b/src/roff/groff/pipeline.c
@@ -487,6 +487,8 @@ int run_pipeline(int ncommands, char ***commands, int no_pipe) @@ -485,6 +485,8 @@ int run_pipeline(int ncommands, char ***commands, int no_pipe)
execvp(commands[i][0], commands[i]); execvp(commands[i][0], commands[i]);
error("couldn't exec %1: %2", c_error("couldn't exec %1: %2",
commands[i][0], strerror(errno), (char *)0); commands[i][0], strerror(errno), (char *)0);
+ if (strcmp(commands[i][0], "gxditview") == 0) + if (strcmp(commands[i][0], "gxditview") == 0)
+ fprintf(stderr, "You might be missing 'groff-x11' package.\n"); + fprintf(stderr, "You might be missing 'groff-x11' package.\n");
fflush(stderr); /* just in case error() doesn't */
_exit(EXEC_FAILED_EXIT_STATUS); _exit(EXEC_FAILED_EXIT_STATUS);
} }
/* in the parent */
-- --
2.21.1 2.41.0

View File

@ -1,31 +1,30 @@
From f83e0b188bb7bf4f38536ff8d08c2ca7384ac161 Mon Sep 17 00:00:00 2001 From c59b56642d10997a35553ae08e6b341b565794f7 Mon Sep 17 00:00:00 2001
From: Jan Vcelak <jvcelak@redhat.com> From: groff owner <groff-owner@fedoraproject.org>
Date: Tue, 1 Jan 2013 15:33:45 +0100 Date: Mon, 10 Jul 2023 11:51:30 +0000
Subject: [PATCH 2/4] load site-font and site-tmac from /etc/groff Subject: [PATCH] load site-font and site-tmac from /etc/groff
Move site-font and site-tmac configuration from /usr/share/groff to Move site-font and site-tmac configuration from /usr/share/groff to
/etc/groff. That allows permanent custom changes. (Symlinking brought /etc/groff. That allows permanent custom changes. (Symlinking brought
a lot of problems with RPM. This is safer and cleaner.) a lot of problems with RPM. This is safer and cleaner.)
Signed-off-by: Jan Vcelak <jvcelak@redhat.com>
--- ---
Makefile.in | 6 +++--- Makefile.in | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-) 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/Makefile.in b/Makefile.in diff --git a/Makefile.in b/Makefile.in
index 505e9c3..5331dd3 100644 index a47df30..e9618d1 100644
--- a/Makefile.in --- a/Makefile.in
+++ b/Makefile.in +++ b/Makefile.in
@@ -3573,7 +3573,7 @@ fontdir = $(datasubdir)/font @@ -3857,7 +3857,7 @@ fontdir = $(datasubdir)/font
oldfontdir = $(datasubdir)/oldfont oldfontdir = $(datasubdir)/oldfont
# `localfontdir' says where local fonts will be installed (as dev*/*). # `localfontdir' says where local fonts will be installed (as dev*/*).
-localfontdir = $(dataprogramdir)/site-font -localfontdir = $(dataprogramdir)/site-font
+localfontdir = @sysconfdir@/groff/site-font +localfontdir = @sysconfdir@/groff/site-font
# `legacyfontdir' is for compatibility with non-GNU troff. # `legacyfontdir' is for compatibility with AT&T/DWB troff.
legacyfontdir = /usr/lib/font legacyfontdir = /usr/lib/font
@@ -3585,10 +3585,10 @@ fontpath = $(localfontdir)$(RT_SEP)$(fontdir)$(RT_SEP)$(legacyfontdir) @@ -3869,10 +3869,10 @@ fontpath = $(localfontdir)$(RT_SEP)$(fontdir)$(RT_SEP)$(legacyfontdir)
tmacdir = $(datasubdir)/tmac tmacdir = $(datasubdir)/tmac
# `systemtmacdir' says where to install platform-dependent macros. # `systemtmacdir' says where to install platform-dependent macros.
@ -36,8 +35,8 @@ index 505e9c3..5331dd3 100644
-localtmacdir = $(dataprogramdir)/site-tmac -localtmacdir = $(dataprogramdir)/site-tmac
+localtmacdir = @sysconfdir@/groff/site-tmac +localtmacdir = @sysconfdir@/groff/site-tmac
# appresdir # appdefdir
# `appresdir' says where to install the application resource file for # `appdefdir' says where to install the application defaults file for
-- --
2.21.1 2.41.0

View File

@ -1,27 +1,20 @@
From f95bed4ad636f286ef9ff3f5b4330a10938fd064 Mon Sep 17 00:00:00 2001 From 2e14a9f44b79fe6a13cd1ecec3f8c50d44be2188 Mon Sep 17 00:00:00 2001
From: Jan Vcelak <jvcelak@redhat.com> From: groff owner <groff-owner@fedoraproject.org>
Date: Tue, 4 Nov 2014 14:36:47 +0100 Date: Mon, 10 Jul 2023 13:15:36 +0000
Subject: [PATCH 3/4] various security fixes Subject: [PATCH] various security fixes
CVE-2009-5044 (#709413) CVE-2009-5044 (#709413)
CVE-2009-5080 (#720058) CVE-2009-5080 (#720058)
CVE-2009-5081 (#720057) CVE-2009-5081 (#720057)
Based on: http://cvsweb.openwall.com/cgi/cvsweb.cgi/Owl/packages/groff/groff-1.20.1-owl-tmp.diff?rev=1.2;content- type=text%2Fplain
Resolves: #709415, #720060
Signed-off-by: Jan Vcelak <jvcelak@redhat.com>
--- ---
contrib/eqn2graph/eqn2graph.sh | 2 ++ contrib/eqn2graph/eqn2graph.sh | 2 ++
contrib/gdiffmk/tests/runtests.sh | 5 +++-- contrib/grap2graph/grap2graph.sh | 2 ++
contrib/grap2graph/grap2graph.sh | 2 ++ contrib/pdfmark/pdfroff.1.man | 5 +++--
contrib/groffer/main_subs.pl | 10 +++++----- contrib/pic2graph/pic2graph.sh | 2 ++
contrib/groffer/roff2.pl | 2 +- doc/groff.texi | 6 +++---
contrib/pdfmark/pdfroff.1.man | 5 +++-- gendef.sh | 10 +++-------
contrib/pic2graph/pic2graph.sh | 2 ++ 6 files changed, 15 insertions(+), 12 deletions(-)
doc/fixinfo.sh | 5 +++--
doc/groff.texi | 6 +++---
gendef.sh | 10 +++-------
10 files changed, 27 insertions(+), 22 deletions(-)
diff --git a/contrib/eqn2graph/eqn2graph.sh b/contrib/eqn2graph/eqn2graph.sh diff --git a/contrib/eqn2graph/eqn2graph.sh b/contrib/eqn2graph/eqn2graph.sh
index 3e9c374..4e4f11e 100644 index 3e9c374..4e4f11e 100644
@ -36,22 +29,6 @@ index 3e9c374..4e4f11e 100644
fi fi
if ! test -d "$tmp" if ! test -d "$tmp"
diff --git a/contrib/gdiffmk/tests/runtests.sh b/contrib/gdiffmk/tests/runtests.sh
index 0f7c3b6..f8aa874 100755
--- a/contrib/gdiffmk/tests/runtests.sh
+++ b/contrib/gdiffmk/tests/runtests.sh
@@ -63,8 +63,9 @@ TestResult () {
fi
}
-tmpfile=/tmp/$$
-trap 'rm -f ${tmpfile}' 0 1 2 3 15
+tmpfile="`mktemp -t gdiffmk-runtests.XXXXXXXXXX`" || exit
+trap 'rm -f -- "$tmpfile"' EXIT
+trap 'trap - EXIT; rm -f -- "$tmpfile"; exit 1' HUP INT QUIT TERM
# Run tests.
diff --git a/contrib/grap2graph/grap2graph.sh b/contrib/grap2graph/grap2graph.sh diff --git a/contrib/grap2graph/grap2graph.sh b/contrib/grap2graph/grap2graph.sh
index 29df25b..94c436b 100644 index 29df25b..94c436b 100644
--- a/contrib/grap2graph/grap2graph.sh --- a/contrib/grap2graph/grap2graph.sh
@ -65,72 +42,29 @@ index 29df25b..94c436b 100644
fi fi
if ! test -d "$tmp" if ! test -d "$tmp"
diff --git a/contrib/groffer/main_subs.pl b/contrib/groffer/main_subs.pl
index a40e356..c8c4e53 100644
--- a/contrib/groffer/main_subs.pl
+++ b/contrib/groffer/main_subs.pl
@@ -1244,7 +1244,7 @@ sub main_temp {
our $fh_stdin;
our $tmp_cat;
our $tmp_stdin;
- my $template = 'groffer_' . "$$" . '_XXXX';
+ my $template = 'groffer_' . "$$" . '_XXXXXXXXXX';
foreach ($ENV{'GROFF_TMPDIR'}, $ENV{'TMPDIR'}, $ENV{'TMP'}, $ENV{'TEMP'},
$ENV{'TEMPDIR'}, File::Spec->catfile($ENV{'HOME'}, 'tmp')) {
if ($_ && -d $_ && -w $_) {
@@ -1276,12 +1276,12 @@ sub main_temp {
# further argument: SUFFIX => '.sh'
if ($Debug{'KEEP'}) {
- ($fh_cat, $tmp_cat) = tempfile(',cat_XXXX', DIR => $tmpdir);
- ($fh_stdin, $tmp_stdin) = tempfile(',stdin_XXXX', DIR => $tmpdir);
+ ($fh_cat, $tmp_cat) = tempfile(',cat_XXXXXXXXXX', DIR => $tmpdir);
+ ($fh_stdin, $tmp_stdin) = tempfile(',stdin_XXXXXXXXXX', DIR => $tmpdir);
} else {
- ($fh_cat, $tmp_cat) = tempfile(',cat_XXXX', UNLINK => 1,
+ ($fh_cat, $tmp_cat) = tempfile(',cat_XXXXXXXXXX', UNLINK => 1,
DIR => $tmpdir);
- ($fh_stdin, $tmp_stdin) = tempfile(',stdin_XXXX', UNLINK => 1,
+ ($fh_stdin, $tmp_stdin) = tempfile(',stdin_XXXXXXXXXX', UNLINK => 1,
DIR => $tmpdir);
}
} # main_temp()
diff --git a/contrib/groffer/roff2.pl b/contrib/groffer/roff2.pl
index cf5c583..24af006 100755
--- a/contrib/groffer/roff2.pl
+++ b/contrib/groffer/roff2.pl
@@ -123,7 +123,7 @@ if ($Has_Groffer) {
last;
}
}
- my $template = $Name . '_XXXX';
+ my $template = $Name . '_XXXXXXXXXX';
my ($fh, $stdin);
if ($tempdir) {
($fh, $stdin) = tempfile($template, UNLINK => 1, DIR => $tempdir) ||
diff --git a/contrib/pdfmark/pdfroff.1.man b/contrib/pdfmark/pdfroff.1.man diff --git a/contrib/pdfmark/pdfroff.1.man b/contrib/pdfmark/pdfroff.1.man
index 95d7807..aa6f079 100644 index 029a1f4..ee7ac13 100644
--- a/contrib/pdfmark/pdfroff.1.man --- a/contrib/pdfmark/pdfroff.1.man
+++ b/contrib/pdfmark/pdfroff.1.man +++ b/contrib/pdfmark/pdfroff.1.man
@@ -540,7 +540,7 @@ gs \-dBATCH \-dQUIET \-dNOPAUSE \-dSAFER \-sDEVICE=pdfwrite \e @@ -619,7 +619,7 @@ gs \-dBATCH \-dQUIET \-dNOPAUSE \-dSAFER \-sDEVICE=pdfwrite \e
.I GROFF_TMPDIR .I GROFF_TMPDIR
Identifies the directory in which Identifies the directory in which
.B pdfroff .I pdfroff
-should create temporary files. -should create temporary files.
+should create a subdirectory for its temporary files. +should create a subdirectory for its temporary files.
. .
If If
.I \%GROFF_TMPDIR .I \%GROFF_TMPDIR
@@ -553,7 +553,8 @@ and @@ -635,7 +635,8 @@ are considered in turn as possible temporary file repositories.
.I TEMP .
are considered in turn, as possible temporary file repositories. If none of these are set,
If none of these are set, then temporary files are created then temporary files are created
-in the current directory. -in the current directory.
+in a subdirectory of +in a subdirectory of
+.BR /tmp . +.BR /tmp .
.
. .
.TP .TP
.I GROFF_GHOSTSCRIPT_INTERPRETER
diff --git a/contrib/pic2graph/pic2graph.sh b/contrib/pic2graph/pic2graph.sh diff --git a/contrib/pic2graph/pic2graph.sh b/contrib/pic2graph/pic2graph.sh
index b229914..2d6e77c 100644 index b229914..2d6e77c 100644
--- a/contrib/pic2graph/pic2graph.sh --- a/contrib/pic2graph/pic2graph.sh
@ -144,27 +78,11 @@ index b229914..2d6e77c 100644
fi fi
if ! test -d "$tmp" if ! test -d "$tmp"
diff --git a/doc/fixinfo.sh b/doc/fixinfo.sh
index 47127f8..69bb74d 100644
--- a/doc/fixinfo.sh
+++ b/doc/fixinfo.sh
@@ -24,8 +24,9 @@
#
# 09-2014: no more problem with texinfo 5.0 or higher
#
-t=${TMPDIR-.}/gro$$.tmp
-
+t="`mktemp -t groff-fixinfo.XXXXXXXXXX`" || exit
+trap 'rm -f -- "$t"' EXIT
+trap 'trap - EXIT; rm -f -- "$t"; exit 1' HUP INT QUIT TERM
cat $1 | sed '
1 {
N
diff --git a/doc/groff.texi b/doc/groff.texi diff --git a/doc/groff.texi b/doc/groff.texi
index e7fe4aa..b4d01ed 100644 index 2a6635e..1fdf632 100644
--- a/doc/groff.texi --- a/doc/groff.texi
+++ b/doc/groff.texi +++ b/doc/groff.texi
@@ -13857,9 +13857,9 @@ into a document: @@ -16005,9 +16005,9 @@ The following code fragment introduces the current time into a document.
@pindex perl @pindex perl
@Example @Example
.sy perl -e 'printf ".nr H %d\\n.nr M %d\\n.nr S %d\\n",\ .sy perl -e 'printf ".nr H %d\\n.nr M %d\\n.nr S %d\\n",\
@ -178,7 +96,7 @@ index e7fe4aa..b4d01ed 100644
@endExample @endExample
diff --git a/gendef.sh b/gendef.sh diff --git a/gendef.sh b/gendef.sh
index be41dbe..4770bae 100644 index bb30a4f..eb2e31c 100644
--- a/gendef.sh --- a/gendef.sh
+++ b/gendef.sh +++ b/gendef.sh
@@ -33,11 +33,9 @@ do @@ -33,11 +33,9 @@ do
@ -206,5 +124,5 @@ index be41dbe..4770bae 100644
# eof # eof
-- --
2.21.1 2.41.0

View File

@ -9,10 +9,7 @@ There might be an issue that the script is executed with unwanted version of
Resolves: #987069 Resolves: #987069
--- ---
contrib/chem/chem.pl | 2 +- contrib/chem/chem.pl | 2 +-
contrib/groffer/groffer.pl | 2 +- 1 files changed, 1 insertions(+), 1 deletions(-)
contrib/groffer/roff2.pl | 2 +-
src/roff/grog/grog.pl | 2 +-
4 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/contrib/chem/chem.pl b/contrib/chem/chem.pl diff --git a/contrib/chem/chem.pl b/contrib/chem/chem.pl
index 883907b..57e0216 100755 index 883907b..57e0216 100755
@ -24,36 +21,6 @@ index 883907b..57e0216 100755
# chem - a groff preprocessor for producing chemical structure diagrams # chem - a groff preprocessor for producing chemical structure diagrams
diff --git a/contrib/groffer/groffer.pl b/contrib/groffer/groffer.pl
index 697dacb..654f18e 100755
--- a/contrib/groffer/groffer.pl
+++ b/contrib/groffer/groffer.pl
@@ -1,4 +1,4 @@
-#! /usr/bin/env perl
+#! /usr/bin/perl
# groffer - display groff files
diff --git a/contrib/groffer/roff2.pl b/contrib/groffer/roff2.pl
index 24af006..35a560c 100755
--- a/contrib/groffer/roff2.pl
+++ b/contrib/groffer/roff2.pl
@@ -1,4 +1,4 @@
-#! /usr/bin/env perl
+#! /usr/bin/perl
# roff2* - transform roff files into other formats
diff --git a/src/roff/grog/grog.pl b/src/roff/grog/grog.pl
index f7fb8e4..1d5c3d8 100644
--- a/src/roff/grog/grog.pl
+++ b/src/roff/grog/grog.pl
@@ -1,4 +1,4 @@
-#! /usr/bin/env perl
+#! /usr/bin/perl
# grog - guess options for groff command
# Inspired by doctype script in Kernighan & Pike, Unix Programming
# Environment, pp 306-8.
-- --
2.21.1 2.21.1

View File

@ -2,8 +2,8 @@
Summary: A document formatting system Summary: A document formatting system
Name: groff Name: groff
Version: 1.22.4 Version: 1.23.0
Release: 11%{?dist} Release: 1%{?dist}
# Everything is under GPL-3.0-or-later, except for the following files: # Everything is under GPL-3.0-or-later, except for the following files:
# MIT license # MIT license
# -- tmac/hyphen.den # -- tmac/hyphen.den
@ -46,7 +46,7 @@ Release: 11%{?dist}
# contrib/eqn2graph/eqn2graph.sh # contrib/eqn2graph/eqn2graph.sh
License: GPL-3.0-or-later AND GFDL-1.3-or-later AND BSD-4-Clause-UC AND MIT AND X11 AND LicenseRef-Fedora-Public-Domain License: GPL-3.0-or-later AND GFDL-1.3-or-later AND BSD-4-Clause-UC AND MIT AND X11 AND LicenseRef-Fedora-Public-Domain
URL: http://www.gnu.org/software/groff/ URL: http://www.gnu.org/software/groff/
Source: ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz Source: https://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
# resolves: #530788 # resolves: #530788
Patch0: 0001-missing-groff-x11-info-message-when-gxditview-not-fo.patch Patch0: 0001-missing-groff-x11-info-message-when-gxditview-not-fo.patch
@ -517,6 +517,9 @@ fi
%doc %{_pkgdocdir}/pdf/ %doc %{_pkgdocdir}/pdf/
%changelog %changelog
* Mon Jul 10 2023 Lukas Javorsky <ljavorsk@redhat.com> - 1.23.0-1
- Rebase to version 1.23.0
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.22.4-11 * Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.22.4-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (groff-1.22.4.tar.gz) = 1c42d3cd71efaf067b5850945d9097fa1f0fadd5e2b6ba7446bd9d4f439fe1ad058e4ddb0d4e0f503682137dfc7c822944ce1e3e5cf981673f8ba197ea77126d SHA512 (groff-1.23.0.tar.gz) = eff473fd1d0e6b27527318452ef2b7c6c7aba0b1c27fc529036496eccba5717f3639df0b81a297a57f700e27543196d7086b15e43d7e3c7bf075f95feb7f4089