- add BuildRequires imake and update dependencies for modular X

- spec cleanup
This commit is contained in:
Jindrich Novy 2006-01-05 14:49:14 +00:00
parent 15f798d785
commit 8556acb4fe
14 changed files with 218 additions and 165 deletions

View File

@ -1,21 +1,18 @@
--- groff-1.19.1/src/roff/troff/input.cpp.safer 2004-05-05 18:41:58.000000000 +0200
+++ groff-1.19.1/src/roff/troff/input.cpp 2005-01-12 13:27:33.947740912 +0100
@@ -5444,20 +5444,35 @@ void source()
if (nm.is_null())
skip_line();
--- groff-1.16/src/roff/troff/input.cc.safer Wed Jun 7 21:47:48 2000
+++ groff-1.16/src/roff/troff/input.cc Wed Jun 7 21:50:37 2000
@@ -4404,12 +4406,28 @@
else {
+ char cbuf[PATH_MAX], * cwd;
+ char pbuf[PATH_MAX], * path;
+ struct stat st;
+
while (!tok.newline() && !tok.eof())
tok.next();
- errno = 0;
- FILE *fp = include_search_path.open_file_cautious(nm.contents());
- FILE *fp = fopen(nm.contents(), "r");
- if (fp)
- input_stack::push(new file_iterator(fp, nm.contents()));
- else
- error("can't open `%1': %2", nm.contents(), strerror(errno));
+ char cbuf[PATH_MAX], * cwd;
+ char pbuf[PATH_MAX], * path;
+ struct stat st;
+
+ if ((cwd = realpath(".", cbuf)) == NULL)
+ error("realpath on `%1' failed: %2", ".", strerror(errno));
@ -38,9 +35,3 @@
tok.next();
}
}
-// like .so but use popen()
-
void pipe_source()
{
if (safer_flag) {

View File

@ -1,5 +1,5 @@
--- groff-1.19.1/src/roff/troff/Makefile.sub.gzip 2004-01-06 23:49:05.000000000 +0100
+++ groff-1.19.1/src/roff/troff/Makefile.sub 2005-01-12 13:49:11.542476528 +0100
--- groff-1.18/src/roff/troff/Makefile.sub.hugo 2002-05-03 00:33:21.000000000 +0200
+++ groff-1.18/src/roff/troff/Makefile.sub 2002-11-04 21:30:09.000000000 +0100
@@ -1,6 +1,6 @@
PROG=troff$(EXEEXT)
MAN1=troff.n
@ -7,10 +7,10 @@
+XLIBS=-lz $(LIBGROFF)
MLIB=$(LIBM)
OBJS=\
dictionary.$(OBJEXT) \
--- groff-1.19.1/src/roff/troff/input.cpp.gzip 2005-01-12 13:49:11.516480480 +0100
+++ groff-1.19.1/src/roff/troff/input.cpp 2005-01-12 13:57:40.615085728 +0100
@@ -41,6 +41,8 @@ Foundation, 59 Temple Place - Suite 330,
env.o \
--- groff-1.18/src/roff/troff/input.cc.hugo 2002-11-04 21:30:09.000000000 +0100
+++ groff-1.18/src/roff/troff/input.cc 2002-11-04 21:36:13.000000000 +0100
@@ -42,6 +42,8 @@
#include "nonposix.h"
@ -19,7 +19,7 @@
#ifdef NEED_DECLARATION_PUTENV
extern "C" {
int putenv(const char *);
@@ -190,6 +192,130 @@ void restore_escape_char()
@@ -217,6 +219,130 @@
skip_line();
}
@ -150,7 +150,7 @@
class input_iterator {
public:
input_iterator();
@@ -209,7 +335,7 @@ private:
@@ -236,7 +362,7 @@
virtual int get_location(int, const char **, int *) { return 0; }
virtual void backtrace() {}
virtual int set_location(const char *, int) { return 0; }
@ -159,7 +159,7 @@
virtual void shift(int) {}
virtual int is_boundary() {return 0; }
virtual int internal_level() { return 0; }
@@ -250,7 +376,7 @@ public:
@@ -277,7 +403,7 @@
};
class file_iterator : public input_iterator {
@ -168,7 +168,7 @@
int lineno;
const char *filename;
int popened;
@@ -259,7 +385,9 @@ class file_iterator : public input_itera
@@ -286,7 +412,9 @@
enum { BUF_SIZE = 512 };
unsigned char buf[BUF_SIZE];
void close();
@ -178,7 +178,7 @@
file_iterator(FILE *, const char *, int = 0);
~file_iterator();
int fill(node **);
@@ -267,18 +395,30 @@ public:
@@ -294,18 +422,30 @@
int get_location(int, const char **, int *);
void backtrace();
int set_location(const char *, int);
@ -213,7 +213,7 @@
}
}
@@ -289,6 +429,8 @@ file_iterator::~file_iterator()
@@ -316,6 +456,8 @@
void file_iterator::close()
{
@ -222,7 +222,7 @@
if (fp == stdin)
clearerr(stdin);
#ifndef POPEN_MISSING
@@ -297,6 +439,7 @@ void file_iterator::close()
@@ -324,6 +466,7 @@
#endif /* not POPEN_MISSING */
else
fclose(fp);
@ -230,7 +230,7 @@
}
int file_iterator::is_file()
@@ -304,7 +447,7 @@ int file_iterator::is_file()
@@ -331,7 +474,7 @@
return 1;
}
@ -239,7 +239,7 @@
{
close();
filename = s;
@@ -327,7 +470,7 @@ int file_iterator::fill(node **)
@@ -354,7 +497,7 @@
ptr = p;
unsigned char *e = p + BUF_SIZE;
while (p < e) {
@ -248,7 +248,7 @@
if (c == EOF)
break;
if (invalid_input_char(c))
@@ -354,13 +497,13 @@ int file_iterator::fill(node **)
@@ -381,13 +524,13 @@
int file_iterator::peek()
{
@ -265,7 +265,7 @@
return c;
}
@@ -406,7 +549,7 @@ public:
@@ -433,7 +576,7 @@
static int set_location(const char *, int);
static void backtrace();
static void backtrace_all();
@ -274,7 +274,7 @@
static void end_file();
static void shift(int n);
static void add_boundary();
@@ -583,7 +726,7 @@ int input_stack::set_location(const char
@@ -605,7 +748,7 @@
return 0;
}
@ -283,22 +283,22 @@
{
input_iterator **pp;
for (pp = &top; *pp != &nil_iterator; pp = &(*pp)->next)
@@ -669,10 +812,11 @@ void next_file()
@@ -691,10 +834,11 @@
input_stack::end_file();
else {
errno = 0;
- FILE *fp = include_search_path.open_file_cautious(nm.contents());
- FILE *fp = fopen(nm.contents(), "r");
- if (!fp)
+ opaque_fp *fp = new opaque_fp(nm.contents(), "r");
+ if (!fp->active()) {
+ delete fp;
+ delete fp;
error("can't open `%1': %2", nm.contents(), strerror(errno));
- else
+ } else
input_stack::next_file(fp, nm.contents());
}
tok.next();
@@ -5463,11 +5607,12 @@ void source()
@@ -5372,11 +5516,12 @@
error("won't source non-file `%1' without -U flag", path);
else {
errno = 0;
@ -315,7 +315,7 @@
}
tok.next();
}
@@ -6856,16 +7001,18 @@ void macro_source()
@@ -6822,16 +6967,18 @@
static void process_input_file(const char *name)
{
@ -328,11 +328,11 @@
}
else {
errno = 0;
- fp = include_search_path.open_file_cautious(name);
- fp = fopen(name, "r");
- if (!fp)
+ fp = new opaque_fp(name, "r", OPQ_FP_GUESS);
+ if (!fp->active()) {
+ delete fp;
+ delete fp;
fatal("can't open `%1': %2", name, strerror(errno));
+ }
}

View File

@ -1,6 +1,6 @@
--- groff-1.19.1/doc/Makefile.sub.nohtml 2004-03-05 10:52:57.000000000 +0100
+++ groff-1.19.1/doc/Makefile.sub 2005-01-12 13:39:54.345183392 +0100
@@ -59,14 +59,11 @@
--- groff-1.18/doc/Makefile.sub.nohtml 2002-06-14 17:18:34.000000000 +0200
+++ groff-1.18/doc/Makefile.sub 2002-08-06 13:46:19.000000000 +0200
@@ -54,11 +54,9 @@
meintro.ps \
pic.ps
@ -8,18 +8,14 @@
- pic.html
+HTMLDOCFILES=
-HTMLDOCFILESALL=\
- pic*.html
+HTMLDOCFILESALL=
-HTMLDOCIMAGEFILES=\
- pic*
+HTMLDOCIMAGEFILES=
EXAMPLEFILES=\
webpage.ms \
@@ -77,11 +74,9 @@
webpage.ps \
@@ -71,11 +69,9 @@
gnu.png \
grnexmpl.ps
-HTMLEXAMPLEFILES=\
@ -32,7 +28,7 @@
imagedir=img
htmldocimagedir=$(htmldocdir)/$(imagedir)
@@ -120,7 +115,7 @@
@@ -109,7 +105,7 @@
all: groff $(PROCESSEDDOCFILES) prepare_examples \
@ -41,9 +37,9 @@
html: $(HTMLDOCFILES) $(HTMLEXAMPLEFILES)
@@ -148,7 +143,7 @@
@@ -131,7 +127,7 @@
distfiles: groff gnu.eps gnu.png
distfiles: groff
-install_data: groff $(DOCFILES) $(PROCESSEDDOCFILES) $(make_install_html) \
+install_data: groff $(DOCFILES) $(PROCESSEDDOCFILES) \

View File

@ -1,6 +1,6 @@
--- groff-1.19.1/Makefile.in.pfbtops_cpp 2004-04-07 17:33:39.000000000 +0200
+++ groff-1.19.1/Makefile.in 2005-01-12 13:46:40.242477624 +0100
@@ -464,8 +464,9 @@
--- groff-1.18/Makefile.in.sopwith 2002-10-04 17:10:56.000000000 -0400
+++ groff-1.18/Makefile.in 2002-10-04 17:11:09.000000000 -0400
@@ -422,8 +422,9 @@
src/utils/lookbib \
src/utils/indxbib \
src/utils/lkbib \
@ -9,6 +9,6 @@
+ src/utils/addftinfo \
+ src/utils/pfbtops
+CPROGDIRS=
PROGDEPDIRS=arch/misc
PROGDIRS=$(PROGDEPDIRS) $(CCPROGDIRS) $(CPROGDIRS)
PROGDIRS=$(CCPROGDIRS) $(CPROGDIRS)
DEVDIRS=\
font/devps \

17
groff-1.18.1-8bit.patch Normal file
View File

@ -0,0 +1,17 @@
2002-10-11 Ruslan Ermilov <ru@FreeBSD.org>
* src/roff/troff/env.cc (hyphen_trie::read_patterns_file): Add
cast to `unsigned char' to properly read patterns with 8bit
characters.
--- groff-1.18.1/src/roff/troff/env.cc
+++ groff-1.18.1/src/roff/troff/env.cc
@@ -3924,7 +3924,7 @@
if (i > 0) {
if (have_patterns || final_pattern || traditional) {
for (int j = 0; j < i; j++)
- buf[j] = hpf_code_table[buf[j]];
+ buf[j] = hpf_code_table[(unsigned char)buf[j]];
insert_pattern(buf, i, num);
final_pattern = 0;
}

View File

@ -1,3 +1,15 @@
--- groff-1.18.1/font/devutf8/M.proto.devutf8 2004-03-08 16:25:52.000000000 +0100
+++ groff-1.18.1/font/devutf8/M.proto 2004-03-08 17:02:40.265336984 +0100
@@ -1,6 +1,6 @@
name M
internalname 4
-spacewidth 48
+spacewidth 24
charset
-u2E00..u9FFF 48 0
-uFF00..uFFEF 48 0
+u0100..u07FF 24 0
+u0800..uFFFF 48 0
--- groff-1.18.1/font/devutf8/DESC.proto.devutf8 2004-03-08 16:25:52.000000000 +0100
+++ groff-1.18.1/font/devutf8/DESC.proto 2004-03-08 16:25:53.000000000 +0100
@@ -3,10 +3,7 @@

27
groff-1.18.1-fix15.patch Normal file
View File

@ -0,0 +1,27 @@
--- groff-1.18.1/src/libs/libgroff/encoding.cc.fix15 2004-03-08 16:13:15.825000416 +0100
+++ groff-1.18.1/src/libs/libgroff/encoding.cc 2004-03-08 16:14:41.451983136 +0100
@@ -384,21 +384,10 @@
}
/* otherwise */
#if HAVE_LANGINFO_CODESET
- charset = nl_langinfo(CODESET);
-#else
- charset = strchr(locale, '.');
- if (charset)
- ++charset;
- else
- charset = "";
+ locale = nl_langinfo(CODESET);
#endif
- if (strncmp(locale, "ja", 2) == 0) {
- select_input_encoding_handler(charset);
- select_output_encoding_handler(charset);
- } else if ((!device || strcmp(device, "ascii8") == 0)) {
- select_input_encoding_handler(NULL);
- select_output_encoding_handler(NULL);
- }
+ select_input_encoding_handler(locale);
+ select_output_encoding_handler(locale);
#endif
return;
}

View File

@ -1,9 +1,9 @@
--- groff-1.19.1/font/devutf8/R.proto.fixminus 2003-12-28 09:42:31.000000000 +0100
+++ groff-1.19.1/font/devutf8/R.proto 2005-01-12 14:00:15.628520104 +0100
@@ -405,7 +405,7 @@
*f 24 0 0x03D5
--- groff-1.18.1/font/devutf8/R.proto.fixminus 2003-02-03 14:19:47.000000000 +0100
+++ groff-1.18.1/font/devutf8/R.proto 2003-02-03 14:20:06.000000000 +0100
@@ -285,7 +285,7 @@
+h 24 0 0x03D1
+f 24 0 0x03D5
+p 24 0 0x03D6
+e 24 0 0x03F5
-- 24 0 0x2010
+- 24 0 0x002D
hy "

View File

@ -1,16 +1,11 @@
--- groff-1.19.1/src/roff/troff/input.cpp.gzext 2005-01-12 14:17:15.469480712 +0100
+++ groff-1.19.1/src/roff/troff/input.cpp 2005-01-12 14:22:57.666458864 +0100
@@ -5590,16 +5590,20 @@ void source()
else {
--- groff-1.18.1/src/roff/troff/input.cc.gzext 2003-02-10 18:32:00.000000000 +0100
+++ groff-1.18.1/src/roff/troff/input.cc 2003-02-10 18:33:18.000000000 +0100
@@ -5487,12 +5487,16 @@
char cbuf[PATH_MAX], * cwd;
char pbuf[PATH_MAX], * path;
+ char tmp[PATH_MAX];
struct stat st;
+ char tmp[PATH_MAX];
+ snprintf(tmp, PATH_MAX, "%s.gz", nm.contents());
+
while (!tok.newline() && !tok.eof())
tok.next();
if ((cwd = realpath(".", cbuf)) == NULL)
error("realpath on `%1' failed: %2", ".", strerror(errno));
@ -18,8 +13,9 @@
- error("realpath on `%1' failed: %2", nm.contents(), strerror(errno));
- else if (safer_flag && strncmp(cwd, path, strlen(cwd)))
+ else if ((path = realpath(nm.contents(), pbuf)) == NULL &&
+ (path = realpath(tmp, pbuf)) == NULL) {
+ error("realpath on `%1' failed: %3", nm.contents(), strerror(errno));
+ (path = realpath(tmp, pbuf)) == NULL)
+ {
+ error("realpath on `%1' failed: %3", nm.contents(), strerror(errno));
+ } else if (safer_flag && strncmp(cwd, path, strlen(cwd)))
error("won't source `%1' outside of `%2' without -U flag", path, cwd);
else if (stat(path, &st) < 0)

View File

@ -1,44 +1,38 @@
--- groff-1.19.1/src/roff/nroff/nroff.sh.korean 2004-04-06 16:10:32.000000000 +0200
+++ groff-1.19.1/src/roff/nroff/nroff.sh 2005-01-12 14:15:39.714037752 +0100
@@ -12,6 +12,10 @@
T=-Tlatin1 ;;
IBM-1047)
--- groff-1.18.1/src/roff/nroff/nroff.sh.orig 2003-02-06 19:37:17.000000000 +0900
+++ groff-1.18.1/src/roff/nroff/nroff.sh 2003-02-06 19:38:34.000000000 +0900
@@ -14,6 +14,8 @@
T=-Tcp1047 ;;
+ EUC-JP)
+ T=-Tnippon ;;
EUC-JP)
T=-Tnippon ;;
+ EUC-KR)
+ T=-Tkorean ;;
*)
case "${LC_ALL-${LC_CTYPE-${LANG}}}" in
*.UTF-8)
@@ -20,6 +24,10 @@
T=-Tlatin1 ;;
*.IBM-1047)
@@ -24,6 +26,8 @@
T=-Tcp1047 ;;
+ ja_JP.ujis | ja_JP.eucJP)
+ T=-Tnippon ;;
ja_JP.ujis | ja_JP.eucJP)
T=-Tnippon ;;
+ ko_KR.eucKR)
+ T=-Tkorean ;;
*)
case "$LESSCHARSET" in
utf-8)
@@ -28,6 +36,10 @@
T=-Tlatin1 ;;
cp1047)
@@ -34,6 +38,8 @@
T=-Tcp1047 ;;
+ japanese)
+ T=-Tnippon ;;
+ ko)
+ T=-Tkorean ;;
japanese)
T=-Tnippon ;;
+ ko)
+ T=-Tkorean ;;
*)
T=-Tascii ;;
T=-Tascii8 ;;
esac ;;
@@ -52,7 +64,7 @@
@@ -58,7 +64,7 @@
exit 1 ;;
-[iptSUC] | -[dmrno]*)
-[iptSUC] | -[mrno]*)
opts="$opts $1" ;;
- -Tascii | -Tlatin1 | -Tutf8 | -Tcp1047)
+ -Tascii | -Tlatin1 | -Tutf8 | -Tcp1047 | -Tnippon | -Tkorean)
- -Tascii | -Tlatin1 | -Tutf8 | -Tcp1047 | -Tascii8 | -Tnippon)
+ -Tascii | -Tlatin1 | -Tutf8 | -Tcp1047 | -Tascii8 | -Tnippon | -Tkorean)
T=$1 ;;
-T*)
# ignore other devices

10
groff-1.18.1.1-grn.patch Normal file
View File

@ -0,0 +1,10 @@
--- groff-1.18.1.1/src/preproc/grn/hdb.cc.grn 2002-10-07 06:42:55.000000000 +0200
+++ groff-1.18.1.1/src/preproc/grn/hdb.cc 2004-09-16 10:23:42.394486378 +0200
@@ -115,7 +115,6 @@
type = DBGetType(string); /* interpret element type */
if (type < 0) { /* no more data */
done = TRUE;
- (void) fclose(file);
} else {
#ifdef UW_FASTSCAN
(void) xscanf(file, &x, &y); /* always one point */

View File

@ -1,12 +1,12 @@
--- groff-1.19.1/Makefile.ccpg.xlibs 2003-04-12 16:07:05.000000000 +0200
+++ groff-1.19.1/Makefile.ccpg 2005-01-12 14:24:58.349112312 +0100
--- groff-1.18.1/Makefile.ccpg.sopwith Mon Feb 10 08:33:21 2003
+++ groff-1.18.1/Makefile.ccpg Mon Feb 10 08:54:00 2003
@@ -8,7 +8,7 @@
all: $(PROG) $(MANPAGES)
-$(PROG): $(OBJS) $(XLIBS)
+$(PROG): $(OBJS)
$(LINK.cpp) -o $@ $(OBJS) $(XLIBS) $(LIBS) $(MLIB)
$(LINK.cc) -o $@ $(OBJS) $(XLIBS) $(LIBS) $(MLIB)
install_bin: install_prog
@@ -28,6 +28,6 @@
@ -16,4 +16,4 @@
-$(PROG).pure: $(OBJS) $(XLIBS)
+$(PROG).pure: $(OBJS)
$(PURIFY) $(PURIFYCCFLAGS) \
$(LINK.cpp) -o $@ $(OBJS) $(XLIBS) $(LIBS) $(MLIB)
$(LINK.cc) -o $@ $(OBJS) $(XLIBS) $(LIBS) $(MLIB)

View File

@ -2,27 +2,32 @@
Summary: A document formatting system.
Name: groff
Version: 1.19.1
Release: 1
Version: 1.18.1.1
Release: 6
License: GPL
Group: Applications/Publishing
Source0: ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.bz2
Source0: ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
Source3: mandocj.tar.gz
Source4: man-pages-ja-GNU_groff-20000115.tar.gz
Source6: hyphen.cs
Source7: nroff
Patch1: groff-1.16-safer.patch
Patch2: groff-1.18-info.patch
Patch3: groff-1.18-nohtml.patch
Patch4: groff-1.18-pfbtops_cpp.patch
Patch5: groff-1.18-gzip.patch
Patch6: groff-1.18.1-fixminus.patch
Patch7: groff-1.18.1-korean.patch
Patch8: groff-1.18.1-gzext.patch
Patch9: groff-xlibs.patch
Patch10: groff-1.18.1.1-revision.patch
Patch11: groff-1.18.1.1-do_char.patch
Patch12: groff-1.18.1.1-tempfile.patch
Patch3: groff_1.18.1-15.diff
Patch4: groff-1.18-info.patch
Patch5: groff-1.18-nohtml.patch
Patch6: groff-1.18-pfbtops_cpp.patch
Patch7: groff-1.18-gzip.patch
Patch9: groff-1.18.1-fixminus.patch
Patch11: groff-1.18.1-8bit.patch
Patch12: groff-1.18.1-korean.patch
Patch13: groff-1.18.1-gzext.patch
Patch14: groff-xlibs.patch
Patch15: groff-1.18.1-fix15.patch
Patch16: groff-1.18.1-devutf8.patch
Patch17: groff-1.18.1.1-revision.patch
Patch18: groff-1.18.1.1-do_char.patch
Patch19: groff-1.18.1.1-grn.patch
Patch20: groff-1.18.1.1-tempfile.patch
URL: ftp://ftp.gnu.org/gnu/groff/
Requires: mktemp
@ -30,10 +35,12 @@ Prereq: /sbin/install-info
Buildroot: %{_tmppath}/%{name}-root
Obsoletes: groff-tools
Provides: nroff-i18n
BuildRequires: netpbm-progs zlib-devel texinfo
BuildRequires: netpbm-progs zlib-devel texinfo imake
BuildRequires: xorg-x11-proto-devel libX11-devel libXaw-devel
BuildRequires: libXt-devel libXpm-devel libXp-devel libXext-devel
BuildPrereq: byacc
%if %{with_x}
BuildRequires: xorg-x11-devel
#BuildRequires: xorg-x11-devel
%endif
%description
@ -71,18 +78,23 @@ System display.
%prep
%setup -q -a 4
%patch1 -p1 -b .safer
%patch2 -p1 -b .infopatch
%patch3 -p1 -b .nohtml
%patch4 -p1 -b .pfbtops_cpp
%patch5 -p1 -b .gzip
%patch6 -p1 -b .fixminus
%patch7 -p1 -b .korean
%patch8 -p1 -b .gzext
%patch9 -p1 -b .xlibs
%patch10 -p1 -b .revision
%patch11 -p1 -b .do_char
%patch12 -p1 -b .tempfile
%patch1 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch9 -p1
%patch11 -p1
%patch12 -p1
%patch13 -p1 -b .gzext
%patch14 -p1
%patch15 -p1 -b .fix9
%patch16 -p1 -b .devutf8
%patch17 -p1 -b .revision
%patch18 -p1 -b .do_char
%patch19 -p1 -b .grn
%patch20 -p1 -b .tempfile
for i in contrib/mm/{groff_mm,groff_mmse,mmroff}.man \
src/devices/grolbp/grolbp.man; do
@ -91,7 +103,8 @@ for i in contrib/mm/{groff_mm,groff_mmse,mmroff}.man \
done
%build
PATH=$PATH:%{_prefix}/X11R6/bin
#PATH=$PATH:%{_prefix}/X11R6/bin
#autoconf
%configure --enable-japanese --enable-multibyte
make
(cd doc && makeinfo groff.texinfo)
@ -102,7 +115,7 @@ xmkmf && make
%install
rm -rf ${RPM_BUILD_ROOT}
PATH=$PATH:%{_prefix}/X11R6/bin
#PATH=$PATH:%{_prefix}/X11R6/bin
mkdir -p ${RPM_BUILD_ROOT}%{_prefix} ${RPM_BUILD_ROOT}%{_infodir}
%makeinstall manroot=${RPM_BUILD_ROOT}/%{_mandir}
#install -m 644 doc/groff.info* ${RPM_BUILD_ROOT}/%{_infodir}
@ -112,20 +125,20 @@ cd src/xditview
cd ../..
%endif
#mv $RPM_BUILD_ROOT%{_prefix}/man $RPM_BUILD_ROOT%{_prefix}/share
ln -s s.tmac ${RPM_BUILD_ROOT}%{_prefix}/share/groff/%version/tmac/gs.tmac
ln -s mse.tmac ${RPM_BUILD_ROOT}%{_prefix}/share/groff/%version/tmac/gmse.tmac
ln -s m.tmac ${RPM_BUILD_ROOT}%{_prefix}/share/groff/%version/tmac/gm.tmac
ln -s troff ${RPM_BUILD_ROOT}%{_prefix}/bin/gtroff
ln -s tbl ${RPM_BUILD_ROOT}%{_prefix}/bin/gtbl
ln -s pic ${RPM_BUILD_ROOT}%{_prefix}/bin/gpic
ln -s eqn ${RPM_BUILD_ROOT}%{_prefix}/bin/geqn
ln -s neqn ${RPM_BUILD_ROOT}%{_prefix}/bin/gneqn
ln -s refer ${RPM_BUILD_ROOT}%{_prefix}/bin/grefer
ln -s lookbib ${RPM_BUILD_ROOT}%{_prefix}/bin/glookbib
ln -s indxbib ${RPM_BUILD_ROOT}%{_prefix}/bin/gindxbib
ln -s soelim ${RPM_BUILD_ROOT}%{_prefix}/bin/gsoelim
ln -s soelim ${RPM_BUILD_ROOT}%{_prefix}/bin/zsoelim
ln -s nroff ${RPM_BUILD_ROOT}%{_prefix}/bin/gnroff
ln -s s.tmac ${RPM_BUILD_ROOT}%{_datadir}/groff/%version/tmac/gs.tmac
ln -s mse.tmac ${RPM_BUILD_ROOT}%{_datadir}/groff/%version/tmac/gmse.tmac
ln -s m.tmac ${RPM_BUILD_ROOT}%{_datadir}/groff/%version/tmac/gm.tmac
ln -s troff ${RPM_BUILD_ROOT}%{_bindir}/gtroff
ln -s tbl ${RPM_BUILD_ROOT}%{_bindir}/gtbl
ln -s pic ${RPM_BUILD_ROOT}%{_bindir}/gpic
ln -s eqn ${RPM_BUILD_ROOT}%{_bindir}/geqn
ln -s neqn ${RPM_BUILD_ROOT}%{_bindir}/gneqn
ln -s refer ${RPM_BUILD_ROOT}%{_bindir}/grefer
ln -s lookbib ${RPM_BUILD_ROOT}%{_bindir}/glookbib
ln -s indxbib ${RPM_BUILD_ROOT}%{_bindir}/gindxbib
ln -s soelim ${RPM_BUILD_ROOT}%{_bindir}/gsoelim
ln -s soelim ${RPM_BUILD_ROOT}%{_bindir}/zsoelim
ln -s nroff ${RPM_BUILD_ROOT}%{_bindir}/gnroff
# Build system is compressing man-pages
ln -s eqn.1.gz ${RPM_BUILD_ROOT}%{_mandir}/man1/geqn.1.gz
@ -139,23 +152,23 @@ ln -s soelim.1.gz ${RPM_BUILD_ROOT}%{_mandir}/man1/zsoelim.1.gz
ln -s tbl.1.gz ${RPM_BUILD_ROOT}%{_mandir}/man1/gtbl.1.gz
ln -s troff.1.gz ${RPM_BUILD_ROOT}%{_mandir}/man1/gtroff.1.gz
ln -s devnippon ${RPM_BUILD_ROOT}/usr/share/groff/%{version}/font/devkorean
ln -s devnippon ${RPM_BUILD_ROOT}%{_datadir}/groff/%{version}/font/devkorean
cat debian/mandoc.local >> ${RPM_BUILD_ROOT}/usr/share/groff/site-tmac/mdoc.local
cat debian/mandoc.local >> ${RPM_BUILD_ROOT}/usr/share/groff/site-tmac/man.local
cat debian/mandoc.local >> ${RPM_BUILD_ROOT}%{_datadir}/groff/site-tmac/mdoc.local
cat debian/mandoc.local >> ${RPM_BUILD_ROOT}%{_datadir}/groff/site-tmac/man.local
find ${RPM_BUILD_ROOT}%{_prefix}/bin ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l | \
find ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l | \
grep -v afmtodit | grep -v grog | grep -v mdoc.samples |\
grep -v mmroff |\
sed "s|${RPM_BUILD_ROOT}||g" | sed "s|\.[0-9]|\.*|g" > groff-files
install -m 644 %SOURCE6 $RPM_BUILD_ROOT/usr/share/groff/%version/tmac/hyphen.cs
install -m 644 %SOURCE6 $RPM_BUILD_ROOT%{_datadir}/groff/%version/tmac/hyphen.cs
install -m 755 %SOURCE7 $RPM_BUILD_ROOT/usr/bin/nroff
install -m 755 %SOURCE7 $RPM_BUILD_ROOT%{_bindir}/nroff
ln -sf doc.tmac $RPM_BUILD_ROOT/usr/share/groff/%version/tmac/docj.tmac
ln -sf doc.tmac $RPM_BUILD_ROOT%{_datadir}/groff/%version/tmac/docj.tmac
# installed, but not packaged in rpm
rm -fr $RPM_BUILD_ROOT/usr/share/doc/groff $RPM_BUILD_ROOT%{_infodir}/dir
rm -fr $RPM_BUILD_ROOT%{_datadir}/doc/groff $RPM_BUILD_ROOT%{_infodir}/dir $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
%clean
rm -rf ${RPM_BUILD_ROOT}
@ -173,14 +186,14 @@ fi
%defattr(-,root,root)
%doc BUG-REPORT NEWS PROBLEMS README TODO VERSION
%doc doc/meintro.me doc/meref.me doc/pic.ms
%{_prefix}/share/groff
%{_datadir}/groff
%{_infodir}/groff*
%files perl
%defattr(-,root,root)
%{_prefix}/bin/grog
%{_prefix}/bin/mmroff
%{_prefix}/bin/afmtodit
%{_bindir}/grog
%{_bindir}/mmroff
%{_bindir}/afmtodit
%{_mandir}/man1/afmtodit.*
%{_mandir}/man1/grog.*
%{_mandir}/man1/mmroff*
@ -188,15 +201,13 @@ fi
%if %{with_x}
%files gxditview
%defattr(-,root,root)
%{_prefix}/X11R6/bin/gxditview
%{_prefix}/X11R6/lib/X11/app-defaults/GXditview
%{_bindir}/gxditview
%{_datadir}/X11/app-defaults/GXditview
%endif
%changelog
* Wed Jan 12 2005 Jindrich Novy <jnovy@redhat.com> 1.19.1-1
- update to groff 1.19.1
- drop 8bit, fix15, devutf8, grn patches
- sync the rest of patches with current release
* Thu Jan 05 2006 Jindrich Novy <jnovy@redhat.com> - 1.18.1.1-6
- add BuildRequires imake and update dependencies for modular X
- spec cleanup
* Wed Nov 24 2004 Miloslav Trmac <mitr@redhat.com> - 1.18.1.1-5

View File

@ -1,4 +1,3 @@
511dbd64b67548c99805f1521f82cc5e groff-1.18.1.1.tar.gz
9bbf9b74fd587d248e17543bda4ce5de man-pages-ja-GNU_groff-20000115.tar.gz
e5d7f3273b4d53033723fcd2654d980c mandocj.tar.gz
88239a9aa668235ac82c34bcdfc4e83a groff-1.19.1.tar.bz2