import groff-1.22.3-18.el8
This commit is contained in:
commit
753ef822a0
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/groff-1.22.3.tar.gz
|
1
.groff.metadata
Normal file
1
.groff.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
61a6808ea1ef715df9fa8e9b424e1f6b9fa8c091 SOURCES/groff-1.22.3.tar.gz
|
@ -0,0 +1,30 @@
|
|||||||
|
From 103f1f6b4e4cfd007375cd127b8e69cd102d4097 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jan Vcelak <jvcelak@redhat.com>
|
||||||
|
Date: Tue, 1 Jan 2013 15:32:01 +0100
|
||||||
|
Subject: [PATCH] missing groff-x11 info message when gxditview not found
|
||||||
|
|
||||||
|
Adds info message that 'groff-x11' package might be missing when
|
||||||
|
executing 'groff -X' and 'gxditview' is not found.
|
||||||
|
|
||||||
|
Resolves: #530788
|
||||||
|
Signed-off-by: Jan Vcelak <jvcelak@redhat.com>
|
||||||
|
---
|
||||||
|
src/roff/groff/pipeline.c | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/roff/groff/pipeline.c b/src/roff/groff/pipeline.c
|
||||||
|
index cea7593..fce0abc 100644
|
||||||
|
--- a/src/roff/groff/pipeline.c
|
||||||
|
+++ b/src/roff/groff/pipeline.c
|
||||||
|
@@ -486,6 +486,8 @@ int run_pipeline(int ncommands, char ***commands, int no_pipe)
|
||||||
|
execvp(commands[i][0], commands[i]);
|
||||||
|
error("couldn't exec %1: %2",
|
||||||
|
commands[i][0], strerror(errno), (char *)0);
|
||||||
|
+ if (strcmp(commands[i][0], "gxditview") == 0)
|
||||||
|
+ fprintf(stderr, "You might be missing 'groff-x11' package.\n");
|
||||||
|
fflush(stderr); /* just in case error() doesn't */
|
||||||
|
_exit(EXEC_FAILED_EXIT_STATUS);
|
||||||
|
}
|
||||||
|
--
|
||||||
|
1.8.0.2
|
||||||
|
|
@ -0,0 +1,43 @@
|
|||||||
|
From c6d8bb3e0ebc03274564d7b2c768e9932cc5f79d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jan Vcelak <jvcelak@redhat.com>
|
||||||
|
Date: Tue, 1 Jan 2013 15:33:45 +0100
|
||||||
|
Subject: [PATCH] load site-font and site-tmac from /etc/groff
|
||||||
|
|
||||||
|
Move site-font and site-tmac configuration from /usr/share/groff to
|
||||||
|
/etc/groff. That allows permanent custom changes. (Symlinking brought
|
||||||
|
a lot of problems with RPM. This is safer and cleaner.)
|
||||||
|
|
||||||
|
Signed-off-by: Jan Vcelak <jvcelak@redhat.com>
|
||||||
|
---
|
||||||
|
Makefile.in | 6 +++---
|
||||||
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile.in b/Makefile.in
|
||||||
|
index 7534e56..d97d1b9 100644
|
||||||
|
--- a/Makefile.in
|
||||||
|
+++ b/Makefile.in
|
||||||
|
@@ -167,7 +167,7 @@ fontdir=$(datasubdir)/font
|
||||||
|
oldfontdir=$(datasubdir)/oldfont
|
||||||
|
|
||||||
|
# `localfontdir' says where local fonts will be installed (as dev*/*).
|
||||||
|
-localfontdir=$(dataprogramdir)/site-font
|
||||||
|
+localfontdir=@sysconfdir@/groff/site-font
|
||||||
|
|
||||||
|
# `legacyfontdir' is for compatibility with non-GNU troff.
|
||||||
|
legacyfontdir=/usr/lib/font
|
||||||
|
@@ -179,10 +179,10 @@ fontpath=$(localfontdir)$(RT_SEP)$(fontdir)$(RT_SEP)$(legacyfontdir)
|
||||||
|
tmacdir=$(datasubdir)/tmac
|
||||||
|
|
||||||
|
# `systemtmacdir' says where to install platform-dependent macros.
|
||||||
|
-systemtmacdir=$(libprogramdir)/site-tmac
|
||||||
|
+systemtmacdir=@sysconfdir@/groff/site-tmac
|
||||||
|
|
||||||
|
# `localtmacdir' says where local files will be installed.
|
||||||
|
-localtmacdir=$(dataprogramdir)/site-tmac
|
||||||
|
+localtmacdir=@sysconfdir@/groff/site-tmac
|
||||||
|
|
||||||
|
# `appresdir' says where to install the application resource file for
|
||||||
|
# gxditview.
|
||||||
|
--
|
||||||
|
1.8.0.2
|
||||||
|
|
228
SOURCES/0003-various-security-fixes.patch
Normal file
228
SOURCES/0003-various-security-fixes.patch
Normal file
@ -0,0 +1,228 @@
|
|||||||
|
From 36115e102859badb08cb5b2398de6b0ba45421d3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jan Vcelak <jvcelak@redhat.com>
|
||||||
|
Date: Tue, 4 Nov 2014 14:36:47 +0100
|
||||||
|
Subject: [PATCH] various security fixes
|
||||||
|
|
||||||
|
CVE-2009-5044 (#709413)
|
||||||
|
CVE-2009-5080 (#720058)
|
||||||
|
CVE-2009-5081 (#720057)
|
||||||
|
|
||||||
|
Based on: http://cvsweb.openwall.com/cgi/cvsweb.cgi/Owl/packages/groff/groff-1.20.1-owl-tmp.diff?rev=1.2;content-type=text%2Fplain
|
||||||
|
Resolves: #709415, #720060
|
||||||
|
Signed-off-by: Jan Vcelak <jvcelak@redhat.com>
|
||||||
|
---
|
||||||
|
contrib/eqn2graph/eqn2graph.sh | 2 ++
|
||||||
|
contrib/gdiffmk/tests/runtests.in | 5 +++--
|
||||||
|
contrib/grap2graph/grap2graph.sh | 2 ++
|
||||||
|
contrib/groffer/main_subs.pl | 10 +++++-----
|
||||||
|
contrib/groffer/roff2.pl | 2 +-
|
||||||
|
contrib/pdfmark/pdfroff.man | 5 +++--
|
||||||
|
contrib/pic2graph/pic2graph.sh | 2 ++
|
||||||
|
doc/fixinfo.sh | 5 +++--
|
||||||
|
doc/groff.info-2 | 6 +++---
|
||||||
|
doc/groff.texinfo | 6 +++---
|
||||||
|
gendef.sh | 10 +++-------
|
||||||
|
11 files changed, 30 insertions(+), 25 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/contrib/eqn2graph/eqn2graph.sh b/contrib/eqn2graph/eqn2graph.sh
|
||||||
|
index ee7cc5f..13edf78 100644
|
||||||
|
--- a/contrib/eqn2graph/eqn2graph.sh
|
||||||
|
+++ b/contrib/eqn2graph/eqn2graph.sh
|
||||||
|
@@ -67,6 +67,8 @@ for d in "$GROFF_TMPDIR" "$TMPDIR" "$TMP" "$TEMP" /tmp; do
|
||||||
|
|
||||||
|
tmp=$d/eqn2graph$$-$RANDOM
|
||||||
|
(umask 077 && mkdir $tmp) 2> /dev/null && break
|
||||||
|
+
|
||||||
|
+ tmp=
|
||||||
|
done;
|
||||||
|
if test -z "$tmp"; then
|
||||||
|
echo "$0: cannot create temporary directory" >&2
|
||||||
|
diff --git a/contrib/gdiffmk/tests/runtests.in b/contrib/gdiffmk/tests/runtests.in
|
||||||
|
index 714ce48..40a35c4 100644
|
||||||
|
--- a/contrib/gdiffmk/tests/runtests.in
|
||||||
|
+++ b/contrib/gdiffmk/tests/runtests.in
|
||||||
|
@@ -56,8 +56,9 @@ function TestResult {
|
||||||
|
fi
|
||||||
|
}
|
||||||
|
|
||||||
|
-tmpfile=/tmp/$$
|
||||||
|
-trap 'rm -f ${tmpfile}' 0 1 2 3 15
|
||||||
|
+tmpfile="`mktemp -t gdiffmk-runtests.XXXXXXXXXX`" || exit
|
||||||
|
+trap 'rm -f -- "$tmpfile"' EXIT
|
||||||
|
+trap 'trap - EXIT; rm -f -- "$tmpfile"; exit 1' HUP INT QUIT TERM
|
||||||
|
|
||||||
|
# Run tests.
|
||||||
|
|
||||||
|
diff --git a/contrib/grap2graph/grap2graph.sh b/contrib/grap2graph/grap2graph.sh
|
||||||
|
index 58544e1..aeab832 100644
|
||||||
|
--- a/contrib/grap2graph/grap2graph.sh
|
||||||
|
+++ b/contrib/grap2graph/grap2graph.sh
|
||||||
|
@@ -63,6 +63,8 @@ for d in "$GROFF_TMPDIR" "$TMPDIR" "$TMP" "$TEMP" /tmp; do
|
||||||
|
|
||||||
|
tmp=$d/grap2graph$$-$RANDOM
|
||||||
|
(umask 077 && mkdir $tmp) 2> /dev/null && break
|
||||||
|
+
|
||||||
|
+ tmp=
|
||||||
|
done;
|
||||||
|
if test -z "$tmp"; then
|
||||||
|
echo "$0: cannot create temporary directory" >&2
|
||||||
|
diff --git a/contrib/groffer/main_subs.pl b/contrib/groffer/main_subs.pl
|
||||||
|
index 90627cc..76896cd 100644
|
||||||
|
--- a/contrib/groffer/main_subs.pl
|
||||||
|
+++ b/contrib/groffer/main_subs.pl
|
||||||
|
@@ -1239,7 +1239,7 @@ sub main_temp {
|
||||||
|
our $fh_stdin;
|
||||||
|
our $tmp_cat;
|
||||||
|
our $tmp_stdin;
|
||||||
|
- my $template = 'groffer_' . "$$" . '_XXXX';
|
||||||
|
+ my $template = 'groffer_' . "$$" . '_XXXXXXXXXX';
|
||||||
|
foreach ($ENV{'GROFF_TMPDIR'}, $ENV{'TMPDIR'}, $ENV{'TMP'}, $ENV{'TEMP'},
|
||||||
|
$ENV{'TEMPDIR'}, File::Spec->catfile($ENV{'HOME'}, 'tmp')) {
|
||||||
|
if ($_ && -d $_ && -w $_) {
|
||||||
|
@@ -1271,12 +1271,12 @@ sub main_temp {
|
||||||
|
|
||||||
|
# further argument: SUFFIX => '.sh'
|
||||||
|
if ($Debug{'KEEP'}) {
|
||||||
|
- ($fh_cat, $tmp_cat) = tempfile(',cat_XXXX', DIR => $tmpdir);
|
||||||
|
- ($fh_stdin, $tmp_stdin) = tempfile(',stdin_XXXX', DIR => $tmpdir);
|
||||||
|
+ ($fh_cat, $tmp_cat) = tempfile(',cat_XXXXXXXXXX', DIR => $tmpdir);
|
||||||
|
+ ($fh_stdin, $tmp_stdin) = tempfile(',stdin_XXXXXXXXXX', DIR => $tmpdir);
|
||||||
|
} else {
|
||||||
|
- ($fh_cat, $tmp_cat) = tempfile(',cat_XXXX', UNLINK => 1,
|
||||||
|
+ ($fh_cat, $tmp_cat) = tempfile(',cat_XXXXXXXXXX', UNLINK => 1,
|
||||||
|
DIR => $tmpdir);
|
||||||
|
- ($fh_stdin, $tmp_stdin) = tempfile(',stdin_XXXX', UNLINK => 1,
|
||||||
|
+ ($fh_stdin, $tmp_stdin) = tempfile(',stdin_XXXXXXXXXX', UNLINK => 1,
|
||||||
|
DIR => $tmpdir);
|
||||||
|
}
|
||||||
|
} # main_temp()
|
||||||
|
diff --git a/contrib/groffer/roff2.pl b/contrib/groffer/roff2.pl
|
||||||
|
index d8dad3f..f0ca9f2 100755
|
||||||
|
--- a/contrib/groffer/roff2.pl
|
||||||
|
+++ b/contrib/groffer/roff2.pl
|
||||||
|
@@ -123,7 +123,7 @@ if ($Has_Groffer) {
|
||||||
|
last;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
- my $template = $Name . '_XXXX';
|
||||||
|
+ my $template = $Name . '_XXXXXXXXXX';
|
||||||
|
my ($fh, $stdin);
|
||||||
|
if ($tempdir) {
|
||||||
|
($fh, $stdin) = tempfile($template, UNLINK => 1, DIR => $tempdir) ||
|
||||||
|
diff --git a/contrib/pdfmark/pdfroff.man b/contrib/pdfmark/pdfroff.man
|
||||||
|
index ec412bb..faf2898 100644
|
||||||
|
--- a/contrib/pdfmark/pdfroff.man
|
||||||
|
+++ b/contrib/pdfmark/pdfroff.man
|
||||||
|
@@ -555,7 +555,7 @@ defaults to
|
||||||
|
.B GROFF_TMPDIR
|
||||||
|
Identifies the directory in which
|
||||||
|
.B pdfroff
|
||||||
|
-should create temporary files.
|
||||||
|
+should create a subdirectory for its temporary files.
|
||||||
|
.
|
||||||
|
If
|
||||||
|
.B \%GROFF_TMPDIR
|
||||||
|
@@ -568,7 +568,8 @@ and
|
||||||
|
.B TEMP
|
||||||
|
are considered in turn, as possible temporary file repositories.
|
||||||
|
If none of these are set, then temporary files are created
|
||||||
|
-in the current directory.
|
||||||
|
+in a subdirectory of
|
||||||
|
+.BR /tmp .
|
||||||
|
.
|
||||||
|
.TP
|
||||||
|
.B GROFF_GHOSTSCRIPT_INTERPRETER
|
||||||
|
diff --git a/contrib/pic2graph/pic2graph.sh b/contrib/pic2graph/pic2graph.sh
|
||||||
|
index 72c5477..6b3360d 100644
|
||||||
|
--- a/contrib/pic2graph/pic2graph.sh
|
||||||
|
+++ b/contrib/pic2graph/pic2graph.sh
|
||||||
|
@@ -78,6 +78,8 @@ for d in "$GROFF_TMPDIR" "$TMPDIR" "$TMP" "$TEMP" /tmp; do
|
||||||
|
tmp=$d/pic2graph$$-$RANDOM
|
||||||
|
(umask 077 && mkdir $tmp) 2> /dev/null \
|
||||||
|
&& break
|
||||||
|
+
|
||||||
|
+ tmp=
|
||||||
|
done;
|
||||||
|
if test -z "$tmp"; then
|
||||||
|
echo "$0: cannot create temporary directory" >&2
|
||||||
|
diff --git a/doc/fixinfo.sh b/doc/fixinfo.sh
|
||||||
|
index 2c853f8..6954e6a 100644
|
||||||
|
--- a/doc/fixinfo.sh
|
||||||
|
+++ b/doc/fixinfo.sh
|
||||||
|
@@ -22,8 +22,9 @@
|
||||||
|
# groff.texinfo macro code. Hopefully, a new texinfo version makes it
|
||||||
|
# unnecessary.
|
||||||
|
|
||||||
|
-t=${TMPDIR-.}/gro$$.tmp
|
||||||
|
-
|
||||||
|
+t="`mktemp -t groff-fixinfo.XXXXXXXXXX`" || exit
|
||||||
|
+trap 'rm -f -- "$t"' EXIT
|
||||||
|
+trap 'trap - EXIT; rm -f -- "$t"; exit 1' HUP INT QUIT TERM
|
||||||
|
cat $1 | sed '
|
||||||
|
1 {
|
||||||
|
N
|
||||||
|
diff --git a/doc/groff.info-2 b/doc/groff.info-2
|
||||||
|
index 7eaae86..e7dab72 100644
|
||||||
|
--- a/doc/groff.info-2
|
||||||
|
+++ b/doc/groff.info-2
|
||||||
|
@@ -1697,9 +1697,9 @@ not there, 'groff' would not know when to stop.
|
||||||
|
time into a document:
|
||||||
|
|
||||||
|
.sy perl -e 'printf ".nr H %d\\n.nr M %d\\n.nr S %d\\n",\
|
||||||
|
- (localtime(time))[2,1,0]' > /tmp/x\n[$$]
|
||||||
|
- .so /tmp/x\n[$$]
|
||||||
|
- .sy rm /tmp/x\n[$$]
|
||||||
|
+ (localtime(time))[2,1,0]' > timefile\n[$$]
|
||||||
|
+ .so timefile\n[$$]
|
||||||
|
+ .sy rm timefile\n[$$]
|
||||||
|
\nH:\nM:\nS
|
||||||
|
|
||||||
|
Note that this works by having the 'perl' script (run by 'sy')
|
||||||
|
diff --git a/doc/groff.texinfo b/doc/groff.texinfo
|
||||||
|
index 066b527..83684da 100644
|
||||||
|
--- a/doc/groff.texinfo
|
||||||
|
+++ b/doc/groff.texinfo
|
||||||
|
@@ -13736,9 +13736,9 @@ into a document:
|
||||||
|
@pindex perl
|
||||||
|
@Example
|
||||||
|
.sy perl -e 'printf ".nr H %d\\n.nr M %d\\n.nr S %d\\n",\
|
||||||
|
- (localtime(time))[2,1,0]' > /tmp/x\n[$$]
|
||||||
|
-.so /tmp/x\n[$$]
|
||||||
|
-.sy rm /tmp/x\n[$$]
|
||||||
|
+ (localtime(time))[2,1,0]' > timefile\n[$$]
|
||||||
|
++.so timefile\n[$$]
|
||||||
|
++.sy rm timefile\n[$$]
|
||||||
|
\nH:\nM:\nS
|
||||||
|
@endExample
|
||||||
|
|
||||||
|
diff --git a/gendef.sh b/gendef.sh
|
||||||
|
index 41a511b..050bcbe 100644
|
||||||
|
--- a/gendef.sh
|
||||||
|
+++ b/gendef.sh
|
||||||
|
@@ -33,11 +33,9 @@ do
|
||||||
|
#define $def"
|
||||||
|
done
|
||||||
|
|
||||||
|
-# Use $TMPDIR if defined. Default to cwd, for non-Unix systems
|
||||||
|
-# which don't have /tmp on each drive (we are going to remove
|
||||||
|
-# the file before we exit anyway). Put the PID in the basename,
|
||||||
|
-# since the extension can only hold 3 characters on MS-DOS.
|
||||||
|
-t=${TMPDIR-.}/gro$$.tmp
|
||||||
|
+t="`mktemp -t groff-gendef.XXXXXXXXXX`" || exit
|
||||||
|
+trap 'rm -f -- "$t"' EXIT
|
||||||
|
+trap 'trap - EXIT; rm -f -- "$t"; exit 1' HUP INT QUIT TERM
|
||||||
|
|
||||||
|
sed -e 's/=/ /' >$t <<EOF
|
||||||
|
$defs
|
||||||
|
@@ -45,8 +43,6 @@ EOF
|
||||||
|
|
||||||
|
test -r $file && cmp -s $t $file || cp $t $file
|
||||||
|
|
||||||
|
-rm -f $t
|
||||||
|
-
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
# eof
|
||||||
|
--
|
||||||
|
1.9.3
|
||||||
|
|
59
SOURCES/0004-don-t-use-usr-bin-env-in-shebang.patch
Normal file
59
SOURCES/0004-don-t-use-usr-bin-env-in-shebang.patch
Normal file
@ -0,0 +1,59 @@
|
|||||||
|
From e263e19aa1c63dbcbe710e8aae79c8e298606e4c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Peter Schiffer <pschiffe@redhat.com>
|
||||||
|
Date: Tue, 4 Nov 2014 14:49:57 +0100
|
||||||
|
Subject: [PATCH] don't use /usr/bin/env in shebang
|
||||||
|
|
||||||
|
There might be an issue that the script is executed with unwanted version of
|
||||||
|
<lang> if that language is provided by enabled dynamic software collection.
|
||||||
|
|
||||||
|
Resolves: #987069
|
||||||
|
---
|
||||||
|
contrib/chem/chem.pl | 2 +-
|
||||||
|
contrib/groffer/groffer.pl | 2 +-
|
||||||
|
contrib/groffer/roff2.pl | 2 +-
|
||||||
|
src/roff/grog/grog.pl | 2 +-
|
||||||
|
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/contrib/chem/chem.pl b/contrib/chem/chem.pl
|
||||||
|
index 1a8b3cc..15eda5f 100755
|
||||||
|
--- a/contrib/chem/chem.pl
|
||||||
|
+++ b/contrib/chem/chem.pl
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#! /usr/bin/env perl
|
||||||
|
+#! /usr/bin/perl
|
||||||
|
|
||||||
|
# chem - a groff preprocessor for producing chemical structure diagrams
|
||||||
|
|
||||||
|
diff --git a/contrib/groffer/groffer.pl b/contrib/groffer/groffer.pl
|
||||||
|
index 4e2e575..913e8eb 100755
|
||||||
|
--- a/contrib/groffer/groffer.pl
|
||||||
|
+++ b/contrib/groffer/groffer.pl
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#! /usr/bin/env perl
|
||||||
|
+#! /usr/bin/perl
|
||||||
|
|
||||||
|
# groffer - display groff files
|
||||||
|
|
||||||
|
diff --git a/contrib/groffer/roff2.pl b/contrib/groffer/roff2.pl
|
||||||
|
index f0ca9f2..1b8577f 100755
|
||||||
|
--- a/contrib/groffer/roff2.pl
|
||||||
|
+++ b/contrib/groffer/roff2.pl
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#! /usr/bin/env perl
|
||||||
|
+#! /usr/bin/perl
|
||||||
|
|
||||||
|
# roff2* - transform roff files into other formats
|
||||||
|
|
||||||
|
diff --git a/src/roff/grog/grog.pl b/src/roff/grog/grog.pl
|
||||||
|
index fb7b54c..9baa869 100644
|
||||||
|
--- a/src/roff/grog/grog.pl
|
||||||
|
+++ b/src/roff/grog/grog.pl
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#! /usr/bin/env perl
|
||||||
|
+#! /usr/bin/perl
|
||||||
|
# grog - guess options for groff command
|
||||||
|
# Inspired by doctype script in Kernighan & Pike, Unix Programming
|
||||||
|
# Environment, pp 306-8.
|
||||||
|
--
|
||||||
|
1.9.3
|
||||||
|
|
25
SOURCES/0005-Add-missing-rule-for-gropdf.patch
Normal file
25
SOURCES/0005-Add-missing-rule-for-gropdf.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 65c9f2f5152b3eebba8494cbead00d79d1dcbb1c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jan Chaloupka <jchaloup@redhat.com>
|
||||||
|
Date: Wed, 12 Nov 2014 08:23:00 +0100
|
||||||
|
Subject: [PATCH] Add missing rule for gropdf
|
||||||
|
|
||||||
|
---
|
||||||
|
Makefile.in | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/Makefile.in b/Makefile.in
|
||||||
|
index 4b5a5c6..7ae9ac2 100644
|
||||||
|
--- a/Makefile.in
|
||||||
|
+++ b/Makefile.in
|
||||||
|
@@ -896,6 +896,8 @@ $(GNULIBDIRS): FORCE
|
||||||
|
$(MAKE) ACLOCAL=: AUTOCONF=: AUTOHEADER=: AUTOMAKE=: $(do) ;; \
|
||||||
|
esac
|
||||||
|
|
||||||
|
+$(SHPROGDIRS): $(PROGDEPDIRS)
|
||||||
|
+
|
||||||
|
$(OTHERDIRS): $(PROGDEPDIRS) $(CCPROGDIRS) $(CPROGDIRS) $(SHPROGDIRS)
|
||||||
|
|
||||||
|
$(INCDIRS) $(PROGDEPDIRS) $(SHPROGDIRS) $(OTHERDIRS): FORCE
|
||||||
|
--
|
||||||
|
1.9.3
|
||||||
|
|
10614
SOURCES/groff-1.22.3-coverity.patch
Normal file
10614
SOURCES/groff-1.22.3-coverity.patch
Normal file
File diff suppressed because it is too large
Load Diff
1007
SPECS/groff.spec
Normal file
1007
SPECS/groff.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user