new upstream release (1.22.1)

Resolves:   
This commit is contained in:
Jan Vcelak 2013-01-01 17:04:33 +01:00
parent 167204087b
commit 6aae928db3
11 changed files with 165 additions and 361 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/groff-1.21.tar.gz
/groff-*.tar.gz

View File

@ -0,0 +1,30 @@
From 103f1f6b4e4cfd007375cd127b8e69cd102d4097 Mon Sep 17 00:00:00 2001
From: Jan Vcelak <jvcelak@redhat.com>
Date: Tue, 1 Jan 2013 15:32:01 +0100
Subject: [PATCH] missing groff-x11 info message when gxditview not found
Adds info message that 'groff-x11' package might be missing when
executing 'groff -X' and 'gxditview' is not found.
Resolves: #530788
Signed-off-by: Jan Vcelak <jvcelak@redhat.com>
---
src/roff/groff/pipeline.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/roff/groff/pipeline.c b/src/roff/groff/pipeline.c
index cea7593..fce0abc 100644
--- a/src/roff/groff/pipeline.c
+++ b/src/roff/groff/pipeline.c
@@ -486,6 +486,8 @@ int run_pipeline(int ncommands, char ***commands, int no_pipe)
execvp(commands[i][0], commands[i]);
error("couldn't exec %1: %2",
commands[i][0], strerror(errno), (char *)0);
+ if (strcmp(commands[i][0], "gxditview") == 0)
+ fprintf(stderr, "You might be missing 'groff-x11' package.\n");
fflush(stderr); /* just in case error() doesn't */
_exit(EXEC_FAILED_EXIT_STATUS);
}
--
1.8.0.2

View File

@ -1,9 +1,19 @@
Move site-font and site-tmac configuration from /usr/share/groff to /etc/groff
(Symlinking brought a lot of problems with RPM. This is safer and cleaner.)
From c6d8bb3e0ebc03274564d7b2c768e9932cc5f79d Mon Sep 17 00:00:00 2001
From: Jan Vcelak <jvcelak@redhat.com>
Date: Tue, 1 Jan 2013 15:33:45 +0100
Subject: [PATCH] load site-font and site-tmac from /etc/groff
Author: Jan Vcelak <jvcelak@redhat.com>
Move site-font and site-tmac configuration from /usr/share/groff to
/etc/groff. That allows permanent custom changes. (Symlinking brought
a lot of problems with RPM. This is safer and cleaner.)
diff -uNPrp a/Makefile.in b/Makefile.in
Signed-off-by: Jan Vcelak <jvcelak@redhat.com>
---
Makefile.in | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/Makefile.in b/Makefile.in
index 7534e56..d97d1b9 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -167,7 +167,7 @@ fontdir=$(datasubdir)/font
@ -15,7 +25,7 @@ diff -uNPrp a/Makefile.in b/Makefile.in
# `legacyfontdir' is for compatibility with non-GNU troff.
legacyfontdir=/usr/lib/font
@@ -179,10 +179,10 @@ fontpath=$(localfontdir)$(RT_SEP)$(fontd
@@ -179,10 +179,10 @@ fontpath=$(localfontdir)$(RT_SEP)$(fontdir)$(RT_SEP)$(legacyfontdir)
tmacdir=$(datasubdir)/tmac
# `systemtmacdir' says where to install platform-dependent macros.
@ -28,3 +38,6 @@ diff -uNPrp a/Makefile.in b/Makefile.in
# `appresdir' says where to install the application resource file for
# gxditview.
--
1.8.0.2

View File

@ -1,11 +1,34 @@
From 8989e9e33080ed5a6e940bfbca3a4ef28b3264b5 Mon Sep 17 00:00:00 2001
From: Jan Vcelak <jvcelak@redhat.com>
Date: Tue, 1 Jan 2013 15:35:04 +0100
Subject: [PATCH] various security fixes
CVE-2009-5044 (#709413)
CVE-2009-5080 (#720058)
CVE-2009-5081 (#720057)
Based on: http://cvsweb.openwall.com/cgi/cvsweb.cgi/Owl/packages/groff/groff-1.20.1-owl-tmp.diff?rev=1.2;content-type=text%2Fplain
Resolves: #709415, #720060
Security: CVE-2009-5044 (#709413), CVE-2009-5080 (#720058), CVE-2009-5081 (#720057)
Signed-off-by: Jan Vcelak <jvcelak@redhat.com>
---
contrib/eqn2graph/eqn2graph.sh | 2 ++
contrib/gdiffmk/tests/runtests.in | 5 +++--
contrib/grap2graph/grap2graph.sh | 2 ++
contrib/groffer/perl/groffer.pl | 10 +++++-----
contrib/groffer/perl/roff2.pl | 2 +-
contrib/pdfmark/pdfroff.man | 5 +++--
contrib/pic2graph/pic2graph.sh | 2 ++
doc/fixinfo.sh | 4 +++-
doc/groff.info-2 | 6 +++---
doc/groff.texinfo | 6 +++---
gendef.sh | 10 +++-------
11 files changed, 30 insertions(+), 24 deletions(-)
diff -uNPrp groff-1.21/contrib/eqn2graph/eqn2graph.sh groff-1.21.fix/contrib/eqn2graph/eqn2graph.sh
--- groff-1.21/contrib/eqn2graph/eqn2graph.sh 2010-12-31 08:33:09.000000000 +0100
+++ groff-1.21.fix/contrib/eqn2graph/eqn2graph.sh 2012-05-29 12:19:38.594581148 +0200
@@ -69,6 +69,8 @@ for d in "$GROFF_TMPDIR" "$TMPDIR" "$TMP
diff --git a/contrib/eqn2graph/eqn2graph.sh b/contrib/eqn2graph/eqn2graph.sh
index 2f1fa56..c628423 100644
--- a/contrib/eqn2graph/eqn2graph.sh
+++ b/contrib/eqn2graph/eqn2graph.sh
@@ -69,6 +69,8 @@ for d in "$GROFF_TMPDIR" "$TMPDIR" "$TMP" "$TEMP" /tmp; do
tmp=$d/eqn2graph$$-$RANDOM
(umask 077 && mkdir $tmp) 2> /dev/null && break
@ -14,9 +37,10 @@ diff -uNPrp groff-1.21/contrib/eqn2graph/eqn2graph.sh groff-1.21.fix/contrib/eqn
done;
if test -z "$tmp"; then
echo "$0: cannot create temporary directory" >&2
diff -uNPrp groff-1.21/contrib/gdiffmk/tests/runtests.in groff-1.21.fix/contrib/gdiffmk/tests/runtests.in
--- groff-1.21/contrib/gdiffmk/tests/runtests.in 2010-12-31 08:33:09.000000000 +0100
+++ groff-1.21.fix/contrib/gdiffmk/tests/runtests.in 2012-05-29 12:19:38.594581148 +0200
diff --git a/contrib/gdiffmk/tests/runtests.in b/contrib/gdiffmk/tests/runtests.in
index 714ce48..40a35c4 100644
--- a/contrib/gdiffmk/tests/runtests.in
+++ b/contrib/gdiffmk/tests/runtests.in
@@ -56,8 +56,9 @@ function TestResult {
fi
}
@ -29,10 +53,11 @@ diff -uNPrp groff-1.21/contrib/gdiffmk/tests/runtests.in groff-1.21.fix/contrib/
# Run tests.
diff -uNPrp groff-1.21/contrib/grap2graph/grap2graph.sh groff-1.21.fix/contrib/grap2graph/grap2graph.sh
--- groff-1.21/contrib/grap2graph/grap2graph.sh 2010-12-31 08:33:09.000000000 +0100
+++ groff-1.21.fix/contrib/grap2graph/grap2graph.sh 2012-05-29 12:19:38.594581148 +0200
@@ -65,6 +65,8 @@ for d in "$GROFF_TMPDIR" "$TMPDIR" "$TMP
diff --git a/contrib/grap2graph/grap2graph.sh b/contrib/grap2graph/grap2graph.sh
index 580e340..fe38041 100644
--- a/contrib/grap2graph/grap2graph.sh
+++ b/contrib/grap2graph/grap2graph.sh
@@ -65,6 +65,8 @@ for d in "$GROFF_TMPDIR" "$TMPDIR" "$TMP" "$TEMP" /tmp; do
tmp=$d/grap2graph$$-$RANDOM
(umask 077 && mkdir $tmp) 2> /dev/null && break
@ -41,9 +66,10 @@ diff -uNPrp groff-1.21/contrib/grap2graph/grap2graph.sh groff-1.21.fix/contrib/g
done;
if test -z "$tmp"; then
echo "$0: cannot create temporary directory" >&2
diff -uNPrp groff-1.21/contrib/groffer/perl/groffer.pl groff-1.21.fix/contrib/groffer/perl/groffer.pl
--- groff-1.21/contrib/groffer/perl/groffer.pl 2012-05-29 12:19:21.425795787 +0200
+++ groff-1.21.fix/contrib/groffer/perl/groffer.pl 2012-05-29 12:19:38.595581136 +0200
diff --git a/contrib/groffer/perl/groffer.pl b/contrib/groffer/perl/groffer.pl
index 65d4cdb..fd11ab1 100755
--- a/contrib/groffer/perl/groffer.pl
+++ b/contrib/groffer/perl/groffer.pl
@@ -1379,7 +1379,7 @@ sub _check_prog_on_list {
########################################################################
@ -70,9 +96,10 @@ diff -uNPrp groff-1.21/contrib/groffer/perl/groffer.pl groff-1.21.fix/contrib/gr
DIR => $tmpdir);
}
} # main_temp()
diff -uNPrp groff-1.21/contrib/groffer/perl/roff2.pl groff-1.21.fix/contrib/groffer/perl/roff2.pl
--- groff-1.21/contrib/groffer/perl/roff2.pl 2010-12-31 08:33:09.000000000 +0100
+++ groff-1.21.fix/contrib/groffer/perl/roff2.pl 2012-05-29 12:19:38.595581136 +0200
diff --git a/contrib/groffer/perl/roff2.pl b/contrib/groffer/perl/roff2.pl
index 0e1f17a..b9eb67e 100755
--- a/contrib/groffer/perl/roff2.pl
+++ b/contrib/groffer/perl/roff2.pl
@@ -124,7 +124,7 @@ if ($Has_Groffer) {
last;
}
@ -82,9 +109,10 @@ diff -uNPrp groff-1.21/contrib/groffer/perl/roff2.pl groff-1.21.fix/contrib/grof
my ($fh, $stdin);
if ($tempdir) {
($fh, $stdin) = tempfile($template, UNLINK => 1, DIR => $tempdir) ||
diff -uNPrp groff-1.21/contrib/pdfmark/pdfroff.man groff-1.21.fix/contrib/pdfmark/pdfroff.man
--- groff-1.21/contrib/pdfmark/pdfroff.man 2010-12-31 08:33:09.000000000 +0100
+++ groff-1.21.fix/contrib/pdfmark/pdfroff.man 2012-05-29 12:19:38.595581136 +0200
diff --git a/contrib/pdfmark/pdfroff.man b/contrib/pdfmark/pdfroff.man
index 3a1d705..73650a8 100644
--- a/contrib/pdfmark/pdfroff.man
+++ b/contrib/pdfmark/pdfroff.man
@@ -529,7 +529,7 @@ defaults to
.B GROFF_TMPDIR
Identifies the directory in which
@ -104,10 +132,11 @@ diff -uNPrp groff-1.21/contrib/pdfmark/pdfroff.man groff-1.21.fix/contrib/pdfmar
.
.TP
.B GROFF_GHOSTSCRIPT_INTERPRETER
diff -uNPrp groff-1.21/contrib/pic2graph/pic2graph.sh groff-1.21.fix/contrib/pic2graph/pic2graph.sh
--- groff-1.21/contrib/pic2graph/pic2graph.sh 2010-12-31 08:33:09.000000000 +0100
+++ groff-1.21.fix/contrib/pic2graph/pic2graph.sh 2012-05-29 12:19:38.596581124 +0200
@@ -80,6 +80,8 @@ for d in "$GROFF_TMPDIR" "$TMPDIR" "$TMP
diff --git a/contrib/pic2graph/pic2graph.sh b/contrib/pic2graph/pic2graph.sh
index 0c45610..874aad0 100644
--- a/contrib/pic2graph/pic2graph.sh
+++ b/contrib/pic2graph/pic2graph.sh
@@ -80,6 +80,8 @@ for d in "$GROFF_TMPDIR" "$TMPDIR" "$TMP" "$TEMP" /tmp; do
tmp=$d/pic2graph$$-$RANDOM
(umask 077 && mkdir $tmp) 2> /dev/null \
&& break
@ -116,10 +145,11 @@ diff -uNPrp groff-1.21/contrib/pic2graph/pic2graph.sh groff-1.21.fix/contrib/pic
done;
if test -z "$tmp"; then
echo "$0: cannot create temporary directory" >&2
diff -uNPrp groff-1.21/doc/fixinfo.sh groff-1.21.fix/doc/fixinfo.sh
--- groff-1.21/doc/fixinfo.sh 2010-12-31 08:33:09.000000000 +0100
+++ groff-1.21.fix/doc/fixinfo.sh 2012-05-29 12:19:38.596581124 +0200
@@ -21,7 +21,9 @@
diff --git a/doc/fixinfo.sh b/doc/fixinfo.sh
index 2c853f8..a0e8295 100644
--- a/doc/fixinfo.sh
+++ b/doc/fixinfo.sh
@@ -22,7 +22,9 @@
# groff.texinfo macro code. Hopefully, a new texinfo version makes it
# unnecessary.
@ -130,10 +160,11 @@ diff -uNPrp groff-1.21/doc/fixinfo.sh groff-1.21.fix/doc/fixinfo.sh
cat $1 | sed '
1 {
diff -uNPrp groff-1.21/doc/groff.info-2 groff-1.21.fix/doc/groff.info-2
--- groff-1.21/doc/groff.info-2 2012-05-29 12:19:21.446795526 +0200
+++ groff-1.21.fix/doc/groff.info-2 2012-05-29 12:19:38.598581100 +0200
@@ -1918,9 +1918,9 @@ not there, `groff' would not know when t
diff --git a/doc/groff.info-2 b/doc/groff.info-2
index 3e169ec..e964dd6 100644
--- a/doc/groff.info-2
+++ b/doc/groff.info-2
@@ -1957,9 +1957,9 @@ not there, `groff' would not know when to stop.
.sy perl -e 'printf ".nr H %d\\n.nr M %d\\n.nr S %d\\n",\
@ -146,10 +177,11 @@ diff -uNPrp groff-1.21/doc/groff.info-2 groff-1.21.fix/doc/groff.info-2
\nH:\nM:\nS
Note that this works by having the `perl' script (run by `sy')
diff -uNPrp groff-1.21/doc/groff.texinfo groff-1.21.fix/doc/groff.texinfo
--- groff-1.21/doc/groff.texinfo 2010-12-31 08:33:09.000000000 +0100
+++ groff-1.21.fix/doc/groff.texinfo 2012-05-29 12:19:38.602581048 +0200
@@ -13568,9 +13568,9 @@ into a document:
diff --git a/doc/groff.texinfo b/doc/groff.texinfo
index bf77e95..914ba8b 100644
--- a/doc/groff.texinfo
+++ b/doc/groff.texinfo
@@ -13660,9 +13660,9 @@ into a document:
@pindex perl
@Example
.sy perl -e 'printf ".nr H %d\\n.nr M %d\\n.nr S %d\\n",\
@ -162,9 +194,10 @@ diff -uNPrp groff-1.21/doc/groff.texinfo groff-1.21.fix/doc/groff.texinfo
\nH:\nM:\nS
@endExample
diff -uNPrp groff-1.21/gendef.sh groff-1.21.fix/gendef.sh
--- groff-1.21/gendef.sh 2010-12-31 08:33:08.000000000 +0100
+++ groff-1.21.fix/gendef.sh 2012-05-29 12:19:38.604581023 +0200
diff --git a/gendef.sh b/gendef.sh
index ad4ccb2..c25e2d4 100644
--- a/gendef.sh
+++ b/gendef.sh
@@ -34,11 +34,9 @@ do
#define $def"
done
@ -189,3 +222,6 @@ diff -uNPrp groff-1.21/gendef.sh groff-1.21.fix/gendef.sh
exit 0
# eof
--
1.8.0.2

View File

@ -1,149 +0,0 @@
fix: groffer libdir is incorrect
adds --with-grofferdir= configure option
Resolves: #678572
Author: Jan Vcelak <jvcelak@redhat.com>
diff -uNPrp groff-1.21/configure groff-1.21.fixed/configure
--- groff-1.21/configure 2010-12-31 08:33:20.000000000 +0100
+++ groff-1.21.fixed/configure 2011-03-21 10:45:25.100074487 +0100
@@ -648,6 +648,7 @@ PSPRINT
LPQ
LP
LPR
+groffer_dir
appresdir
XLIBDIRS
XPROGDIRS
@@ -715,6 +716,7 @@ ac_user_opts='
enable_option_checking
with_x
with_appresdir
+with_grofferdir
with_gnu_ld
enable_rpath
with_libiconv_prefix
@@ -1362,6 +1363,7 @@ Optional Packages:
--without-PACKAGE do not use PACKAGE (same as --with-PACKAGE=no)
--with-x use the X Window System
--with-appresdir=DIR X11 application resource files
+ --with-grofferdir=DIR groffer files location
--with-gnu-ld assume the C compiler uses GNU ld default=no
--with-libiconv-prefix[=DIR] search for libiconv in DIR/include and DIR/lib
--without-libiconv-prefix don't search for libiconv in includedir and libdir
@@ -5446,6 +5448,18 @@ EOF
fi
fi
+
+# Check whether --with-grofferdir was given.
+if test "${with_grofferdir+set}" = set; then :
+ withval=$with_grofferdir;
+fi
+
+if test "x$with_grofferdir" = "x"; then
+ groffer_dir=$libdir/groff/groffer
+ else
+ groffer_dir=$with_grofferdir
+ fi
+
if test -z "$PSPRINT"; then
for ac_prog in lpr
do
diff -uNPrp groff-1.21/configure.ac groff-1.21.fixed/configure.ac
--- groff-1.21/configure.ac 2010-12-31 08:33:08.000000000 +0100
+++ groff-1.21.fixed/configure.ac 2011-03-21 10:43:32.249906873 +0100
@@ -59,6 +59,8 @@ GROFF_OS390
GROFF_X11
GROFF_APPRESDIR_OPTION
GROFF_APPRESDIR_DEFAULT
+GROFF_GROFFERDIR_OPTION
+GROFF_GROFFERDIR_DEFAULT
GROFF_PRINT
AC_PROG_EGREP
AC_PATH_PROG([PERLPATH], [perl], [/usr/bin/perl])
diff -uNPrp groff-1.21/contrib/groffer/Makefile.sub groff-1.21.fixed/contrib/groffer/Makefile.sub
--- groff-1.21/contrib/groffer/Makefile.sub 2010-12-31 08:33:09.000000000 +0100
+++ groff-1.21.fixed/contrib/groffer/Makefile.sub 2011-03-21 10:56:57.142842476 +0100
@@ -63,8 +63,6 @@ GROFFER_REST=$(srcdir)/roff2.man \
GROFFER_PERL_=`echo $(GROFFER_PERL) | sed 's|$(srcdir)/perl/||g'`
GROFFER_SHELL_=`echo $(GROFFER_SHELL) | sed 's|$(srcdir)/shell||g'`
-groffer_dir=$(libdir)/groff/groffer
-
# TODO: Add perl check to configure script.
groffer: $(GROFFER_PERL) $(GROFFER_SHELL) \
$(GROFFER_REST) $(SH_DEPS_SED_SCRIPT)
@@ -75,6 +73,7 @@ groffer: $(GROFFER_PERL) $(GROFFER_SHELL
-e "s|@g@|$(g)|g" \
-e "s|@BINDIR@|$(DESTDIR)$(bindir)|g" \
-e "s|@libdir@|$(DESTDIR)$(libdir)|g" \
+ -e "s|@groffer_dir@|$(DESTDIR)$(groffer_dir)|g" \
-e "s|@VERSION@|$(version)$(revision)|g" \
-e "$(SH_SCRIPT_SED_CMD)" \
$(srcdir)/perl/groffer.pl >$@; \
@@ -89,6 +88,7 @@ groffer: $(GROFFER_PERL) $(GROFFER_SHELL
-e "s|@g@|$(g)|g" \
-e "s|@BINDIR@|$(DESTDIR)$(bindir)|g" \
-e "s|@libdir@|$(DESTDIR)$(libdir)|g" \
+ -e "s|@groffer_dir@|$(DESTDIR)$(groffer_dir)|g" \
-e "s|@VERSION@|$(version)$(revision)|g" \
-e "$(SH_SCRIPT_SED_CMD)" \
$(srcdir)/shell/groffer.sh >$@; \
diff -uNPrp groff-1.21/contrib/groffer/perl/groffer.pl groff-1.21.fixed/contrib/groffer/perl/groffer.pl
--- groff-1.21/contrib/groffer/perl/groffer.pl 2010-12-31 08:33:09.000000000 +0100
+++ groff-1.21.fixed/contrib/groffer/perl/groffer.pl 2011-03-21 10:20:21.865418634 +0100
@@ -132,8 +132,7 @@ BEGIN {
$at_at{'BINDIR'} = '@BINDIR@';
$at_at{'G'} = '@g@';
$at_at{'LIBDIR'} = '@libdir@';
- $groffer_libdir =
- File::Spec->catdir($at_at{'LIBDIR'}, 'groff', 'groffer');
+ $groffer_libdir = '@groffer_dir@';
$file_perl_test_pl = File::Spec->catfile($groffer_libdir,
'perl_test.pl');
$File_version_sh = File::Spec->catfile($groffer_libdir, 'version.sh');
diff -uNPrp groff-1.21/Makefile.in groff-1.21.fixed/Makefile.in
--- groff-1.21/Makefile.in 2010-12-31 08:33:08.000000000 +0100
+++ groff-1.21.fixed/Makefile.in 2011-03-21 10:53:51.551854122 +0100
@@ -188,6 +188,8 @@ localtmacdir=$(dataprogramdir)/site-tmac
# gxditview.
appresdir=@appresdir@
+groffer_dir=@groffer_dir@
+
# `tmacpath' says where to look for macro files.
# The current directory will be prepended in unsafe mode only; the home
# directory will be always added.
@@ -493,6 +495,7 @@ MDEFINES= \
"YACC=$(YACC)" \
"YACCFLAGS=$(YACCFLAGS)" \
"appresdir=$(appresdir)" \
+ "groffer_dir=$(groffer_dir)" \
"bindir=$(bindir)" \
"common_words_file=$(common_words_file)" \
"datadir=$(datadir)" \
diff -uNPrp groff-1.21/m4/groff.m4 groff-1.21.fixed/m4/groff.m4
--- groff-1.21/m4/groff.m4 2010-12-31 08:33:09.000000000 +0100
+++ groff-1.21.fixed/m4/groff.m4 2011-03-21 10:54:17.716429483 +0100
@@ -1193,3 +1193,19 @@ AC_DEFUN([GROFF_APPRESDIR_CHECK],
])
fi
fi])
+
+
+# Set up the `--with-grofferdir' command line option.
+
+AC_DEFUN([GROFF_GROFFERDIR_OPTION],
+ [AC_ARG_WITH([grofferdir],
+ AS_HELP_STRING([--with-grofferdir=DIR],
+ [groffer files location]))])
+
+AC_DEFUN([GROFF_GROFFERDIR_DEFAULT],
+ [if test "x$with_grofferdir" = "x"; then
+ groffer_dir=$libdir/groff/groffer
+ else
+ groffer_dir=$with_grofferdir
+ fi
+ AC_SUBST([groffer_dir])])

View File

@ -1,58 +0,0 @@
Fix handling of wide characters in no-SGR mode.
Fixes: #712904 Japanese bold/underlined text not displayed correctly
Patch from upstream CVS:
2011-01-20 Colin Watson <cjwatson@debian.org>
Fix handling of wide characters in no-SGR mode.
* src/devices/grotty/tty.cpp (tty_printer::make_underline): Only
emit a single backspace in no-SGR mode. less (at least) backspaces
over a character at a time.
(tty_printer::make_bold): Likewise.
Index: src/devices/grotty/tty.cpp
===================================================================
RCS file: /sources/groff/groff/src/devices/grotty/tty.cpp,v
retrieving revision 1.23
retrieving revision 1.24
diff -u -r1.23 -r1.24
--- a/src/devices/grotty/tty.cpp 13 Dec 2010 17:42:28 -0000 1.23
+++ b/src/devices/grotty/tty.cpp 20 Jan 2011 07:13:57 -0000 1.24
@@ -1,6 +1,6 @@
// -*- C++ -*-
-/* Copyright (C) 1989-2000, 2001, 2002, 2003, 2004, 2005, 2006, 2009,
- 2010
+/* Copyright (C) 1989-2000, 2001, 2002, 2003, 2004, 2005, 2006,
+ 2009-2011
Free Software Foundation, Inc.
Written by James Clark (jjc@jclark.com)
@@ -311,11 +311,8 @@
if (!w)
warning("can't underline zero-width character");
else {
- int n = w / font::hor;
- for (int i = 0; i < n; i++)
- putchar('_');
- for (int j = 0; j < n; j++)
- putchar('\b');
+ putchar('_');
+ putchar('\b');
}
}
else {
@@ -337,10 +334,8 @@
if (!w)
warning("can't print zero-width character in bold");
else {
- int n = w / font::hor;
put_char(c);
- for (int i = 0; i < n; i++)
- putchar('\b');
+ putchar('\b');
}
}
else {

View File

@ -1,18 +0,0 @@
Adds info message that 'groff-x11' package might be missing when executing
'groff -X' and 'gxditview' is not found.
Author: Jan Vcelak <jvcelak@redhat.com>
Fixes: #530788 groff and groff-gxditview shouldn't be split
diff -ur groff-1.20.1.orig/src/roff/groff/pipeline.c groff-1.20.1/src/roff/groff/pipeline.c
--- groff-1.20.1.orig/src/roff/groff/pipeline.c 2010-03-19 11:06:37.437182240 +0100
+++ groff-1.20.1/src/roff/groff/pipeline.c 2010-03-19 11:42:14.820161806 +0100
@@ -486,6 +486,8 @@
execvp(commands[i][0], commands[i]);
error("couldn't exec %1: %2",
commands[i][0], strerror(errno), (char *)0);
+ if (strcmp(commands[i][0], "gxditview") == 0)
+ fprintf(stderr, "You might be missing 'groff-x11' package.\n");
fflush(stderr); /* just in case error() doesn't */
_exit(EXEC_FAILED_EXIT_STATUS);
}

View File

@ -1,17 +0,0 @@
Fixes a typo in Makefile.comm
Upstream fix:
http://lists.gnu.org/archive/html/bug-groff/2011-01/msg00002.html
diff -ur groff-1.21.old/Makefile.comm groff-1.21/Makefile.comm
--- groff-1.21.old/Makefile.comm 2010-12-31 08:33:08.000000000 +0100
+++ groff-1.21/Makefile.comm 2011-01-21 16:19:59.762069900 +0100
@@ -21,7 +21,7 @@
#
INCLUDES=-I. -I$(srcdir) \
-I$(top_builddir)/src/include -I$(top_srcdir)/src/include \
- -I$(tob_builddir)/src/libs/gnulib/lib
+ -I$(top_builddir)/src/libs/gnulib/lib
ALL_CCFLAGS=$(INCLUDES) $(CCDEFINES) $(CCFLAGS) $(CPPFLAGS)
COMPILE.cpp=$(CCC) $(ALL_CCFLAGS) -c
ALL_CFLAGS=$(INCLUDES) $(CDEFINES) $(CFLAGS) $(CPPFLAGS)

View File

@ -1,56 +0,0 @@
Various manual page fixes. Selected from #668524 and #668461.
Patch was sent upstream:
http://lists.gnu.org/archive/html/bug-groff/2011-01/msg00011.html
diff -uNPrp a/contrib/mm/groff_mm.man b/contrib/mm/groff_mm.man
--- a/contrib/mm/groff_mm.man 2011-01-21 14:52:52.302854667 +0100
+++ b/contrib/mm/groff_mm.man 2011-01-21 15:51:53.138775191 +0100
@@ -1158,7 +1158,7 @@ and also less than or equal to
.B Hb
or
.B Hs
-are centerered.
+are centered.
.RE
.
.IP
@@ -1229,7 +1229,7 @@ Fourteen number registers named
up to
.B H14
contain the counter for each heading level.
-The values are printed using arabic numerals;
+The values are printed using Arabic numerals;
this can be changed with the macro
.B HM
(see below).
@@ -1590,7 +1590,7 @@ is still controlled by
.IR text-indent .
.
.IP
-The mark is left-justified whitin the mark area if
+The mark is left-justified within the mark area if
.I pad
is\~0.
If
@@ -1664,7 +1664,7 @@ Default is\~0.
List-status clear.
Terminates all current active lists down to
.IR list-level ,
-or\~0 if no argmuent is given.
+or\~0 if no argument is given.
This is used by\~\c
.B H
to clear any active list.
diff -uNPrp groff-1.21.old/man/roff.man groff-1.21/man/roff.man
--- groff-1.21.old/man/roff.man 2010-12-31 08:33:09.000000000 +0100
+++ groff-1.21/man/roff.man 2011-01-21 15:26:24.061849971 +0100
@@ -252,7 +252,7 @@ Today, the name
.I roff
is used to refer to a
.I troff/\:nroff
-sytem as a whole.
+system as a whole.
.
.P
Ossanna's first version was written in the PDP-11 assembly language and

View File

@ -2,26 +2,22 @@
Summary: A document formatting system
Name: groff
Version: 1.21
Release: 10%{?dist}
Version: 1.22.1
Release: 1%{?dist}
License: GPLv3+ and GFDL and BSD and MIT
Group: Applications/Publishing
URL: http://groff.ffii.org
Source0: ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
Patch1: groff-info-missing-x11.patch
Patch2: groff-makefile-typo.patch
Patch3: groff-manpages-typos.patch
Patch4: groff-grofferdir-auto.patch
Patch5: groff-grotty-wc-no-sgr.patch
Patch6: groff-config-etc.patch
Patch7: groff-cve-2009-5044_5080_5081.patch
Patch1: 0001-missing-groff-x11-info-message-when-gxditview-not-fo.patch
Patch2: 0002-load-site-font-and-site-tmac-from-etc-groff.patch
Patch3: 0003-various-security-fixes.patch
Requires: coreutils
Requires: /sbin/install-info
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Provides: nroff-i18n = %{version}-%{release}
BuildRequires: git
BuildRequires: netpbm-progs psutils ghostscript
# when building from CVS add: BuildRequires: texinfo byacc
Requires: groff-base = %{version}-%{release}
@ -94,12 +90,15 @@ language and documentation for creating PDF files.
%prep
%setup -q
for patch in %patches ; do
%__patch %_default_patch_flags --fuzz=%_default_patch_fuzz -p1 -i $patch
done
git init
git config user.email groff-owner@fedoraproject.org
git config user.name "groff owner"
git add .
git commit -n -m "release %{version}"
git am %{patches}
for file in NEWS src/devices/grolbp/grolbp.man doc/{groff.info*,webpage.ms} \
contrib/mm/*.man contrib/mom/examples/{README.txt,*.mom} ; do
contrib/mm/*.man contrib/mom/examples/{README.txt,*.mom,mom.vim} ; do
iconv -f iso-8859-1 -t utf-8 < "$file" > "${file}_"
mv "${file}_" "$file"
done
@ -123,6 +122,11 @@ for file in g{nroff,troff,tbl,pic,eqn,neqn,refer,lookbib,indxbib,soelim} zsoelim
ln -s ${file#?}.1.gz %{buildroot}%{_mandir}/man1/${file}.1.gz
done
# fix absolute symlink to relative symlink
rm -f %{buildroot}%{_docdir}/%{name}-%{version}/pdf/mom-pdf.pdf
ln -s ../examples/mom/mom-pdf.pdf %{buildroot}%{_docdir}/%{name}-%{version}/pdf/mom-pdf.pdf
# another documentation files
cp BUG-REPORT COPYING FDL LICENSES MORE.STUFF NEWS PROBLEMS %{buildroot}%{_docdir}/%{name}-%{version}
@ -186,16 +190,20 @@ fi
%{_datadir}/%{name}/%{version}/tmac/m.tmac
%{_datadir}/%{name}/%{version}/tmac/me.tmac
%{_datadir}/%{name}/%{version}/tmac/mm.tmac
%{_datadir}/%{name}/%{version}/tmac/mm/
%{_datadir}/%{name}/%{version}/tmac/mmse.tmac
%{_datadir}/%{name}/%{version}/tmac/mom.tmac
%{_datadir}/%{name}/%{version}/tmac/ms.tmac
%{_datadir}/%{name}/%{version}/tmac/mse.tmac
%{_datadir}/%{name}/%{version}/tmac/om.tmac
%{_datadir}/%{name}/%{version}/tmac/pdfmark.tmac
%{_datadir}/%{name}/%{version}/tmac/refer-me.tmac
%{_datadir}/%{name}/%{version}/tmac/refer-mm.tmac
%{_datadir}/%{name}/%{version}/tmac/refer-ms.tmac
%{_datadir}/%{name}/%{version}/tmac/refer.tmac
%{_datadir}/%{name}/%{version}/tmac/s.tmac
%{_datadir}/%{name}/%{version}/tmac/spdf.tmac
%{_datadir}/%{name}/%{version}/tmac/trace.tmac
%{_datadir}/%{name}/%{version}/tmac/mm/
# programs
%{_bindir}/addftinfo
%{_bindir}/eqn2graph
@ -284,6 +292,7 @@ fi
%{_datadir}/%{name}/%{version}/tmac/doc.tmac
%{_datadir}/%{name}/%{version}/tmac/eqnrc
%{_datadir}/%{name}/%{version}/tmac/europs.tmac
%{_datadir}/%{name}/%{version}/tmac/fallbacks.tmac
%{_datadir}/%{name}/%{version}/tmac/fr.tmac
%{_datadir}/%{name}/%{version}/tmac/hyphen.cs
%{_datadir}/%{name}/%{version}/tmac/hyphen.den
@ -302,6 +311,7 @@ fi
%{_datadir}/%{name}/%{version}/tmac/man.tmac
%{_datadir}/%{name}/%{version}/tmac/mandoc.tmac
%{_datadir}/%{name}/%{version}/tmac/mdoc.tmac
%{_datadir}/%{name}/%{version}/tmac/mdoc/
%{_datadir}/%{name}/%{version}/tmac/papersize.tmac
%{_datadir}/%{name}/%{version}/tmac/pic.tmac
%{_datadir}/%{name}/%{version}/tmac/ps.tmac
@ -317,7 +327,6 @@ fi
%{_datadir}/%{name}/%{version}/tmac/tty.tmac
%{_datadir}/%{name}/%{version}/tmac/unicode.tmac
%{_datadir}/%{name}/%{version}/tmac/www.tmac
%{_datadir}/%{name}/%{version}/tmac/mdoc/
# programs
%{_bindir}/eqn
%{_bindir}/groff
@ -362,13 +371,17 @@ fi
%files perl
%defattr(-,root,root,-)
# data
%{_datadir}/%{name}/%{version}/font/devpdf/
%{_datadir}/%{name}/%{version}/groffer/
%{_datadir}/%{name}/%{version}/tmac/pdf.tmac
# programs
%{_bindir}/afmtodit
%{_bindir}/chem
%{_bindir}/groffer
%{_bindir}/grog
%{_bindir}/gropdf
%{_bindir}/mmroff
%{_bindir}/pdfmom
%{_bindir}/roff2dvi
%{_bindir}/roff2html
%{_bindir}/roff2pdf
@ -379,7 +392,9 @@ fi
%{_mandir}/man1/chem.*
%{_mandir}/man1/groffer.*
%{_mandir}/man1/grog.*
%{_mandir}/man1/gropdf.*
%{_mandir}/man1/mmroff.*
%{_mandir}/man1/pdfmom.*
%{_mandir}/man1/roff2dvi.*
%{_mandir}/man1/roff2html.*
%{_mandir}/man1/roff2pdf.*
@ -413,6 +428,14 @@ fi
%doc %{_docdir}/%{name}-%{version}/pdf/
%changelog
* Tue Jan 01 2013 Jan Vcelak <jvcelak@redhat.com> 1.22.1-1
- new upstream release (#890973)
+ various fixes in manual pages
+ various fixes and improvements in macros
+ new gropdf driver for generating PDF files
- fix: backslash-period escape does not work (#682857)
- fix: groff ftbfs - patch does not apply (#885225)
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.21-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild

View File

@ -1 +1 @@
8b8cd29385b97616a0f0d96d0951c5bf groff-1.21.tar.gz
875c9c628b8b78a0c325000a43ebb964 groff-1.22.1.tar.gz