auto-import groff-1.17.2-2 from groff-1.17.2-2.src.rpm
This commit is contained in:
parent
151b874768
commit
41b9d9f5a8
@ -1,3 +1,3 @@
|
||||
groff-1.16.1.tar.gz
|
||||
groff-1.17.2.tar.gz
|
||||
man-pages-ja-GNU_groff-20000115.tar.gz
|
||||
mandocj.tar.gz
|
||||
|
@ -1,14 +1,5 @@
|
||||
--- groff-1.16/src/roff/troff/input.cc.safer Wed Jun 7 21:47:48 2000
|
||||
+++ groff-1.16/src/roff/troff/input.cc Wed Jun 7 21:50:37 2000
|
||||
@@ -90,6 +90,8 @@
|
||||
static int inhibit_errors = 0;
|
||||
static int ignoring = 0;
|
||||
|
||||
+static int safer_flag = 1; // safer by default
|
||||
+
|
||||
static void enable_warning(const char *);
|
||||
static void disable_warning(const char *);
|
||||
|
||||
@@ -4404,12 +4406,28 @@
|
||||
else {
|
||||
while (!tok.newline() && !tok.eof())
|
||||
@ -44,11 +35,3 @@
|
||||
tok.next();
|
||||
}
|
||||
}
|
||||
@@ -5669,7 +5687,6 @@
|
||||
int tflag = 0;
|
||||
int fflag = 0;
|
||||
int nflag = 0;
|
||||
- int safer_flag = 1; // safer by default
|
||||
int no_rc = 0; // don't process troffrc and troffrc-end
|
||||
int next_page_number;
|
||||
opterr = 0;
|
||||
|
40
groff.spec
40
groff.spec
@ -1,7 +1,7 @@
|
||||
Summary: A document formatting system.
|
||||
Name: groff
|
||||
Version: 1.16.1
|
||||
Release: 8
|
||||
Version: 1.17.2
|
||||
Release: 2
|
||||
Copyright: GPL
|
||||
Group: Applications/Publishing
|
||||
Source0: ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
|
||||
@ -13,23 +13,23 @@ Source4: man-pages-ja-GNU_groff-20000115.tar.gz
|
||||
Source5: groff.test
|
||||
Source6: hyphen.cs
|
||||
Patch1: groff-1.16-safer.patch
|
||||
Patch2: groff-1.16-debian.patch
|
||||
Patch2: groff-1.17.2-6.patch
|
||||
Patch3: groff-1.17.2-6.diff
|
||||
Requires: mktemp
|
||||
Buildroot: %{_tmppath}/%{name}-root
|
||||
Obsoletes: groff-tools
|
||||
|
||||
%description
|
||||
Groff is a document formatting system. Groff takes standard text and
|
||||
formatting commands as input and produces formatted output. The
|
||||
Groff is a document formatting system. Groff takes standard text and
|
||||
formatting commands as input and produces formatted output. The
|
||||
created documents can be shown on a display or printed on a printer.
|
||||
Groff's formatting commands allow you to specify font type and size,
|
||||
bold type, italic type, the number and size of columns on a page, and
|
||||
more.
|
||||
|
||||
You should install groff if you want to use it as a document
|
||||
formatting system. Groff can also be used to format man pages. If you
|
||||
are going to use groff with the X Window System, you'll also need to
|
||||
install the groff-gxditview package.
|
||||
Groff can also be used to format man pages. If you are going to use
|
||||
groff with the X Window System, you will also need to install the
|
||||
groff-gxditview package.
|
||||
|
||||
%package perl
|
||||
Summary: Parts of the groff formatting system that require Perl.
|
||||
@ -50,10 +50,6 @@ Group: Applications/Publishing
|
||||
Gxditview displays the groff text processor's output on an X Window
|
||||
System display.
|
||||
|
||||
If you are going to use groff as a text processor, you should install
|
||||
gxditview so that you preview your processed text files in X. You'll
|
||||
also need to install the groff package and the X Window System.
|
||||
|
||||
%prep
|
||||
%setup -q -a 4
|
||||
%patch1 -p1 -b .safer
|
||||
@ -63,7 +59,7 @@ cp %{SOURCE2} .
|
||||
|
||||
%build
|
||||
PATH=$PATH:%{_prefix}/X11R6/bin
|
||||
autoconf
|
||||
#autoconf
|
||||
%configure --enable-japanese
|
||||
make
|
||||
cd src/xditview
|
||||
@ -78,9 +74,9 @@ cd src/xditview
|
||||
%makeinstall DESTDIR=$RPM_BUILD_ROOT
|
||||
cd ../..
|
||||
#mv $RPM_BUILD_ROOT%{_prefix}/man $RPM_BUILD_ROOT%{_prefix}/share
|
||||
ln -s tmac.s ${RPM_BUILD_ROOT}%{_prefix}/share/groff/tmac/tmac.gs
|
||||
ln -s tmac.mse ${RPM_BUILD_ROOT}%{_prefix}/share/groff/tmac/tmac.gmse
|
||||
ln -s tmac.m ${RPM_BUILD_ROOT}%{_prefix}/share/groff/tmac/tmac.gm
|
||||
ln -s s.tmac ${RPM_BUILD_ROOT}%{_prefix}/share/groff/%version/tmac/gs.tmac
|
||||
ln -s mse.tmac ${RPM_BUILD_ROOT}%{_prefix}/share/groff/%version/tmac/gmse.tmac
|
||||
ln -s m.tmac ${RPM_BUILD_ROOT}%{_prefix}/share/groff/%version/tmac/gm.tmac
|
||||
ln -s troff ${RPM_BUILD_ROOT}%{_prefix}/bin/gtroff
|
||||
ln -s tbl ${RPM_BUILD_ROOT}%{_prefix}/bin/gtbl
|
||||
ln -s pic ${RPM_BUILD_ROOT}%{_prefix}/bin/gpic
|
||||
@ -113,7 +109,7 @@ find ${RPM_BUILD_ROOT}%{_prefix}/bin ${RPM_BUILD_ROOT}%{_mandir} -type f -o -typ
|
||||
grep -v mmroff |\
|
||||
sed "s|${RPM_BUILD_ROOT}||g" | sed "s|\.[0-9]|\.*|g" > groff-files
|
||||
|
||||
install -m 644 %SOURCE6 $RPM_BUILD_ROOT/usr/share/groff/tmac/hyphen.cs
|
||||
install -m 644 %SOURCE6 $RPM_BUILD_ROOT/usr/share/groff/%version/tmac/hyphen.cs
|
||||
|
||||
%clean
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
@ -141,6 +137,14 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
#/etc/X11/app-defaults/GXditview
|
||||
|
||||
%changelog
|
||||
* Tue Aug 14 2001 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- fixes security bug #50494
|
||||
|
||||
* Sun Aug 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- update to 1.17.2
|
||||
- strerror patch is not needed anymore
|
||||
- apply newest debian patch
|
||||
|
||||
* Fri Apr 27 2001 Bill Nottingham <notting@redhat.com>
|
||||
- rebuild for C++ exception handling on ia64
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user