Update to 0.3.14
This commit is contained in:
parent
86cfb8bddd
commit
e1562654db
1
.gitignore
vendored
1
.gitignore
vendored
@ -31,3 +31,4 @@
|
||||
/grilo-0.3.11.tar.xz
|
||||
/grilo-0.3.12.tar.xz
|
||||
/grilo-0.3.13.tar.xz
|
||||
/grilo-0.3.14.tar.xz
|
||||
|
@ -1,59 +0,0 @@
|
||||
From 89537b8c4bae8857078de5d084f79ffe532a7ba8 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Mon, 21 Jun 2021 14:16:37 +0200
|
||||
Subject: [PATCH 1/2] build: Clarify LGPLv2.1 or later license
|
||||
|
||||
The COPYING file by itself isn't enough to know under which license the
|
||||
project is released, as a combined work.
|
||||
|
||||
Clarify this in the build system and the README.
|
||||
---
|
||||
README.md | 5 +++++
|
||||
doc/grilo/overview.xml | 3 ++-
|
||||
meson.build | 2 +-
|
||||
3 files changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/README.md b/README.md
|
||||
index c6fe38e..16f9453 100644
|
||||
--- a/README.md
|
||||
+++ b/README.md
|
||||
@@ -89,4 +89,9 @@ ninja -C build
|
||||
./build/tools/grilo-test-ui/grilo-test-ui-0.3
|
||||
```
|
||||
|
||||
+## License
|
||||
+
|
||||
+grilo is available under the [GNU Lesser General Public License v2.1 or later](https://spdx.org/licenses/LGPL-2.1-or-later.html).
|
||||
+Check the sources themselves for individual copyrights and licenses.
|
||||
+
|
||||
Enjoy!
|
||||
diff --git a/doc/grilo/overview.xml b/doc/grilo/overview.xml
|
||||
index aa169ae..52b8e41 100644
|
||||
--- a/doc/grilo/overview.xml
|
||||
+++ b/doc/grilo/overview.xml
|
||||
@@ -99,7 +99,8 @@ developers.
|
||||
</para>
|
||||
|
||||
<para>
|
||||
-Grilo is licensed under the GNU Lesser General Public License (LGPL).
|
||||
+Grilo is licensed under the GNU Lesser General Public License (LGPL)
|
||||
+version 2.1 or later.
|
||||
</para>
|
||||
|
||||
</section>
|
||||
diff --git a/meson.build b/meson.build
|
||||
index cf12454..f76d790 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -12,7 +12,7 @@ project('grilo', 'c',
|
||||
'c_std=gnu99',
|
||||
'warning_level=1'
|
||||
],
|
||||
- license: 'LGPL 2.1',
|
||||
+ license: 'LGPL-2.1-or-later',
|
||||
meson_version: '>= 0.46.0')
|
||||
|
||||
grilo_version = meson.project_version()
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,33 +0,0 @@
|
||||
From cd2472e506dafb1bb8ae510e34ad4797f63e263e Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Mon, 21 Jun 2021 15:00:14 +0200
|
||||
Subject: [PATCH 2/2] net: Fix TLS cert validation not being done for any
|
||||
network call
|
||||
|
||||
The default SoupSessionAsync behaviour does not perform any TLS certificate
|
||||
validation, unless the ssl-use-system-ca-file property is set to true.
|
||||
|
||||
See https://blogs.gnome.org/mcatanzaro/2021/05/25/reminder-soupsessionsync-and-soupsessionasync-default-to-no-tls-certificate-verification/
|
||||
|
||||
This mitigates CVE-2016-20011.
|
||||
|
||||
Closes: #146
|
||||
---
|
||||
libs/net/grl-net-wc.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/libs/net/grl-net-wc.c b/libs/net/grl-net-wc.c
|
||||
index 5a8e89f..5ff1d17 100644
|
||||
--- a/libs/net/grl-net-wc.c
|
||||
+++ b/libs/net/grl-net-wc.c
|
||||
@@ -314,6 +314,7 @@ grl_net_wc_init (GrlNetWc *wc)
|
||||
wc->priv = grl_net_wc_get_instance_private (wc);
|
||||
|
||||
wc->priv->session = soup_session_async_new ();
|
||||
+ g_object_set (G_OBJECT (wc->priv->session), "ssl-use-system-ca-file", TRUE, NULL);
|
||||
wc->priv->pending = g_queue_new ();
|
||||
|
||||
set_thread_context (wc);
|
||||
--
|
||||
2.31.1
|
||||
|
12
grilo.spec
12
grilo.spec
@ -2,8 +2,8 @@
|
||||
%define release_version %(echo %{version} | awk -F. '{print $1"."$2}')
|
||||
|
||||
Name: grilo
|
||||
Version: 0.3.13
|
||||
Release: 6%{?dist}
|
||||
Version: 0.3.14
|
||||
Release: 1%{?dist}
|
||||
Summary: Content discovery framework
|
||||
|
||||
License: LGPLv2+
|
||||
@ -28,11 +28,6 @@ BuildRequires: liboauth-devel
|
||||
%endif
|
||||
BuildRequires: totem-pl-parser-devel
|
||||
|
||||
# https://gitlab.gnome.org/GNOME/grilo/-/merge_requests/77
|
||||
Patch0: 0001-build-Clarify-LGPLv2.1-or-later-license.patch
|
||||
# https://gitlab.gnome.org/GNOME/grilo/-/merge_requests/78
|
||||
Patch1: 0002-net-Fix-TLS-cert-validation-not-being-done-for-any-n.patch
|
||||
|
||||
%description
|
||||
Grilo is a framework that provides access to different sources of
|
||||
multimedia content, using a pluggable system.
|
||||
@ -89,6 +84,9 @@ mkdir -p $RPM_BUILD_ROOT%{_datadir}/grilo-%{release_version}/plugins/
|
||||
%{_datadir}/vala/
|
||||
|
||||
%changelog
|
||||
* Tue Oct 5 2021 Victor Toso <victortoso@redhat.com> - 0.3.14-1
|
||||
- Update to 0.3.14
|
||||
|
||||
* Mon Aug 23 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.3.13-6
|
||||
- Drop the BuildRequires on liboauth from RHEL >= 9
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (grilo-0.3.13.tar.xz) = b229b9b7524c1be63ed8891a9438844ebb87013074b394330f25316feb015040b304cd98bf3c89dc3248e6898c587a5e51666776a5b4ba5026a80ee8ad3e6d01
|
||||
SHA512 (grilo-0.3.14.tar.xz) = 128464e51040ea121b19640c708fa996743a18e047ab11d4c3047db7d24732eac6da65393c16f987e834cb301385ef0c349eb0fabd7d67b2d10a230c8f03492a
|
||||
|
Loading…
Reference in New Issue
Block a user