Update to 0.3.11
This commit is contained in:
parent
8010433458
commit
ddb1064dec
1
.gitignore
vendored
1
.gitignore
vendored
@ -28,3 +28,4 @@
|
||||
/grilo-0.3.8.tar.xz
|
||||
/grilo-0.3.9.tar.xz
|
||||
/grilo-0.3.10.tar.xz
|
||||
/grilo-0.3.11.tar.xz
|
||||
|
@ -1,36 +0,0 @@
|
||||
From 60d135ef64f16671bb0ab4079ecbc59bdc32cbc7 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Tue, 12 Nov 2019 19:44:04 +0100
|
||||
Subject: [PATCH] pls: Support totem-pl-parser 3.26.4
|
||||
|
||||
---
|
||||
libs/pls/grl-pls.c | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libs/pls/grl-pls.c b/libs/pls/grl-pls.c
|
||||
index 62c578b..f6121cc 100644
|
||||
--- a/libs/pls/grl-pls.c
|
||||
+++ b/libs/pls/grl-pls.c
|
||||
@@ -47,6 +47,10 @@
|
||||
#include <totem-pl-parser.h>
|
||||
#include <totem-pl-parser-mini.h>
|
||||
|
||||
+#ifndef TOTEM_PL_IS_PARSER(x)
|
||||
+#define TOTEM_PL_IS_PARSER(x) TOTEM_IS_PL_PARSER(x)
|
||||
+#endif /* TOTEM_PL_IS_PARSER */
|
||||
+
|
||||
/* --------- Constants -------- */
|
||||
|
||||
#define GRL_DATA_PRIV_PLS_IS_PLAYLIST "priv:pls:is_playlist"
|
||||
@@ -465,7 +469,7 @@ grl_pls_playlist_entry_parsed_cb (TotemPlParser *parser,
|
||||
GRL_DEBUG ("%s (parser=%p, uri=\"%s\", metadata=%p, user_data=%p)",
|
||||
__FUNCTION__, parser, uri, metadata, user_data);
|
||||
|
||||
- g_return_if_fail (TOTEM_IS_PL_PARSER (parser));
|
||||
+ g_return_if_fail (TOTEM_PL_IS_PARSER (parser));
|
||||
g_return_if_fail (uri);
|
||||
g_return_if_fail (metadata);
|
||||
g_return_if_fail (user_data);
|
||||
--
|
||||
2.23.0
|
||||
|
10
grilo.spec
10
grilo.spec
@ -2,17 +2,14 @@
|
||||
%define release_version %(echo %{version} | awk -F. '{print $1"."$2}')
|
||||
|
||||
Name: grilo
|
||||
Version: 0.3.10
|
||||
Release: 2%{?dist}
|
||||
Version: 0.3.11
|
||||
Release: 1%{?dist}
|
||||
Summary: Content discovery framework
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://wiki.gnome.org/Projects/Grilo
|
||||
Source0: https://download.gnome.org/sources/grilo/%{release_version}/grilo-%{version}.tar.xz
|
||||
|
||||
# Backported from upstream
|
||||
Patch0: 0001-pls-Support-totem-pl-parser-3.26.4.patch
|
||||
|
||||
BuildRequires: meson
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: gettext
|
||||
@ -83,6 +80,9 @@ mkdir -p $RPM_BUILD_ROOT%{_datadir}/grilo-%{release_version}/plugins/
|
||||
%{_datadir}/vala/
|
||||
|
||||
%changelog
|
||||
* Fri Jan 10 2020 Kalev Lember <klember@redhat.com> - 0.3.11-1
|
||||
- Update to 0.3.11
|
||||
|
||||
* Thu Nov 28 2019 Kalev Lember <klember@redhat.com> - 0.3.10-2
|
||||
- Fix the build with totem-pl-parser 3.26.4
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (grilo-0.3.10.tar.xz) = c08780f1a8e778dcba0342fd924f6b573ce1e42162f25439c29a34a01bf2e24c3335317c10cc61301f3263b0a01ccfce74c80eb6c5cc02da58a1ec3eaf3a0a1a
|
||||
SHA512 (grilo-0.3.11.tar.xz) = fd46d035982b14ed19681acce3f4878cc678919babc031ce5eb577a21d14f97b905eb5094b344b7fc732bf317fb504dae940cffb7875de2d577bae431b7f9c36
|
||||
|
Loading…
Reference in New Issue
Block a user