Update to 0.3.3
This commit is contained in:
parent
11e200cec7
commit
73d84fdbe9
1
.gitignore
vendored
1
.gitignore
vendored
@ -20,3 +20,4 @@
|
|||||||
/grilo-0.3.0.tar.xz
|
/grilo-0.3.0.tar.xz
|
||||||
/grilo-0.3.1.tar.xz
|
/grilo-0.3.1.tar.xz
|
||||||
/grilo-0.3.2.tar.xz
|
/grilo-0.3.2.tar.xz
|
||||||
|
/grilo-0.3.3.tar.xz
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
From 3a6268f60712aafd2f007426e5d646c8ce237657 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Dominique Leuenberger <dimstar@opensuse.org>
|
|
||||||
Date: Sat, 10 Sep 2016 23:51:38 +0200
|
|
||||||
Subject: [PATCH] build: fix build due wrong format in debug
|
|
||||||
|
|
||||||
Introduced in commit f3ccf55
|
|
||||||
---
|
|
||||||
tests/lib-net.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/tests/lib-net.c b/tests/lib-net.c
|
|
||||||
index d1eb73e..0608083 100644
|
|
||||||
--- a/tests/lib-net.c
|
|
||||||
+++ b/tests/lib-net.c
|
|
||||||
@@ -86,7 +86,7 @@ soup_server_throttling_cb (SoupServer *server,
|
|
||||||
SoupClientContext *client,
|
|
||||||
gpointer user_data)
|
|
||||||
{
|
|
||||||
- gchar *response = g_strdup_printf ("%lu", g_get_monotonic_time());
|
|
||||||
+ gchar *response = g_strdup_printf ("%" G_GINT64_FORMAT, g_get_monotonic_time());
|
|
||||||
|
|
||||||
soup_message_set_response (message, "text/plain", SOUP_MEMORY_TAKE, response, strlen(response));
|
|
||||||
soup_message_set_status (message, SOUP_STATUS_OK);
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
11
grilo.spec
11
grilo.spec
@ -2,20 +2,17 @@
|
|||||||
%define release_version %(echo %{version} | awk -F. '{print $1"."$2}')
|
%define release_version %(echo %{version} | awk -F. '{print $1"."$2}')
|
||||||
|
|
||||||
Name: grilo
|
Name: grilo
|
||||||
Version: 0.3.2
|
Version: 0.3.3
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Content discovery framework
|
Summary: Content discovery framework
|
||||||
|
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://wiki.gnome.org/Projects/Grilo
|
URL: https://wiki.gnome.org/Projects/Grilo
|
||||||
Source0: https://download.gnome.org/sources/grilo/%{release_version}/grilo-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/grilo/%{release_version}/grilo-%{version}.tar.xz
|
||||||
# Backported from upstream
|
|
||||||
Patch0: 0001-build-fix-build-due-wrong-format-in-debug.patch
|
|
||||||
|
|
||||||
BuildRequires: chrpath
|
BuildRequires: chrpath
|
||||||
BuildRequires: gnome-common
|
BuildRequires: gnome-common
|
||||||
BuildRequires: intltool
|
BuildRequires: intltool
|
||||||
BuildRequires: vala-devel >= 0.27.1
|
|
||||||
BuildRequires: vala >= 0.27.1
|
BuildRequires: vala >= 0.27.1
|
||||||
BuildRequires: gtk-doc
|
BuildRequires: gtk-doc
|
||||||
BuildRequires: gobject-introspection-devel >= 0.9.0
|
BuildRequires: gobject-introspection-devel >= 0.9.0
|
||||||
@ -47,7 +44,6 @@ general and API documentation.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -106,6 +102,9 @@ rm -f $RPM_BUILD_ROOT%{_bindir}/grilo-simple-playlist
|
|||||||
%{_datadir}/vala/
|
%{_datadir}/vala/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 14 2017 Kalev Lember <klember@redhat.com> - 0.3.3-1
|
||||||
|
- Update to 0.3.3
|
||||||
|
|
||||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-5
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user