import grilo-plugins-0.3.13-6.el9

This commit is contained in:
CentOS Sources 2022-05-17 05:19:02 -04:00 committed by Stepan Oksanichenko
commit f9d3049896
7 changed files with 863 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/grilo-plugins-0.3.13.tar.xz

1
.grilo-plugins.metadata Normal file
View File

@ -0,0 +1 @@
3a72898ff7a2d9206daf302dc78ea68c2ece15aa SOURCES/grilo-plugins-0.3.13.tar.xz

View File

@ -0,0 +1,43 @@
From 0939ffda125bd89888a37759cdab1be99537b92b Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Mon, 21 Jun 2021 14:06:04 +0200
Subject: [PATCH 1/3] flickr: Add missing copyright/license header
---
src/flickr/flickr-oauth.c | 6 ++++++
src/flickr/gflickr.c | 8 ++++++++
2 files changed, 14 insertions(+)
diff --git a/src/flickr/flickr-oauth.c b/src/flickr/flickr-oauth.c
index 60f0f8b..de24dcc 100644
--- a/src/flickr/flickr-oauth.c
+++ b/src/flickr/flickr-oauth.c
@@ -1,3 +1,9 @@
+/*
+ * SPDX-FileCopyrightText: 2021 Marek Chalupa <mchalupa@redhat.com>
+ *
+ * SPDX-License-Identifier: LGPL-2.1-or-later
+ */
+
#include "flickr-oauth.h"
#include <glib.h>
diff --git a/src/flickr/gflickr.c b/src/flickr/gflickr.c
index d9aca42..204ff38 100644
--- a/src/flickr/gflickr.c
+++ b/src/flickr/gflickr.c
@@ -1,3 +1,11 @@
+/*
+ * SPDX-FileCopyrightText: 2011-2013 Juan A. Suarez Romero <jasuarez@igalia.com>
+ * SPDX-FileCopyrightText: 2013 Marek Chalupa <mchalupa@redhat.com>
+ * SPDX-FileCopyrightText: 2016 Rafael Fonseca <r4f4rfs@gmail.com>
+ *
+ * SPDX-License-Identifier: LGPL-2.1-or-later
+ */
+
#include "gflickr.h"
#include "flickr-oauth.h"
#include "grl-flickr.h" /* log domain */
--
2.31.1

View File

@ -0,0 +1,26 @@
From 1b0fae453daf32eda9d0267c1a13cfebe324f89f Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Sun, 4 Apr 2021 18:30:57 +0000
Subject: [PATCH] grl-lua-factory: Remove a bad pop
This was exposed by Lua 5.4.3, causing a crash.
---
src/lua-factory/grl-lua-factory.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/src/lua-factory/grl-lua-factory.c b/src/lua-factory/grl-lua-factory.c
index 4f37984..3a3b824 100644
--- a/src/lua-factory/grl-lua-factory.c
+++ b/src/lua-factory/grl-lua-factory.c
@@ -1255,8 +1255,6 @@ table_to_tags (lua_State *L)
lua_pop (L, 1);
}
- lua_pop (L, 1);
-
if (array->len == 0) {
g_ptr_array_free (array, TRUE);
return NULL;
--
2.31.1

View File

@ -0,0 +1,46 @@
From c0b6cab2ee83b153d450ecb306fcaa2a998ef370 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Mon, 21 Jun 2021 14:10:33 +0200
Subject: [PATCH 2/3] build: Clarify LGPLv2.1 or later license
The COPYING file by itself isn't enough to know under which license the
project is released, as a combined work.
Clarify this in the build system and the README.
---
README.md | 7 ++++++-
meson.build | 2 +-
2 files changed, 7 insertions(+), 2 deletions(-)
diff --git a/README.md b/README.md
index de5cfca..1cc8906 100644
--- a/README.md
+++ b/README.md
@@ -31,4 +31,9 @@ $ ninja -C build
$ sudo ninja -C build install
```
-Enjoy!
\ No newline at end of file
+## License
+
+grilo-plugins is available under the [GNU Lesser General Public License v2.1 or later](https://spdx.org/licenses/LGPL-2.1-or-later.html).
+Check the sources themselves for individual copyrights and licenses.
+
+Enjoy!
diff --git a/meson.build b/meson.build
index 5f8c7cd..41bef7b 100644
--- a/meson.build
+++ b/meson.build
@@ -12,7 +12,7 @@ project('grilo-plugins', 'c',
'c_std=gnu99',
'warning_level=1'
],
- license: 'LGPL 2.1',
+ license: 'LGPL-2.1-or-later',
meson_version: '>= 0.44.0')
plugin_version = meson.project_version()
--
2.31.1

View File

@ -0,0 +1,334 @@
From 50015c42e216fead3c45b82d22262bcd6b86bc0c Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Mon, 21 Jun 2021 14:31:58 +0200
Subject: [PATCH 3/3] plugins: Clarify plugins licenses
So that the licenses match that of the project as a whole.
---
src/bookmarks/grl-bookmarks.c | 2 +-
src/chromaprint/grl-chromaprint.c | 2 +-
src/dleyna/grl-dleyna.c | 2 +-
src/dmap/grl-daap.c | 2 +-
src/dmap/grl-dpap.c | 2 +-
src/filesystem/grl-filesystem.c | 2 +-
src/flickr/grl-flickr.c | 2 +-
src/freebox/grl-freebox.c | 2 +-
src/gravatar/grl-gravatar.c | 2 +-
src/local-metadata/grl-local-metadata.c | 2 +-
src/lua-factory/grl-lua-factory.c | 2 +-
src/magnatune/grl-magnatune.c | 2 +-
src/metadata-store/grl-metadata-store.c | 2 +-
src/opensubtitles/grl-opensubtitles.c | 2 +-
src/optical-media/grl-optical-media.c | 2 +-
src/podcasts/grl-podcasts.c | 2 +-
src/raitv/grl-raitv.c | 2 +-
src/shoutcast/grl-shoutcast.c | 2 +-
src/thetvdb/grl-thetvdb.c | 2 +-
src/tmdb/grl-tmdb.c | 2 +-
src/tracker/grl-tracker.c | 2 +-
src/tracker3/grl-tracker.c | 2 +-
src/youtube/grl-youtube.c | 2 +-
23 files changed, 23 insertions(+), 23 deletions(-)
diff --git a/src/bookmarks/grl-bookmarks.c b/src/bookmarks/grl-bookmarks.c
index 9e8db9b..208f5a9 100644
--- a/src/bookmarks/grl-bookmarks.c
+++ b/src/bookmarks/grl-bookmarks.c
@@ -168,7 +168,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for organizing media bookmarks",
"Igalia S.L.",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.igalia.com",
grl_bookmarks_plugin_init,
NULL,
diff --git a/src/chromaprint/grl-chromaprint.c b/src/chromaprint/grl-chromaprint.c
index 5a3598b..525e613 100644
--- a/src/chromaprint/grl-chromaprint.c
+++ b/src/chromaprint/grl-chromaprint.c
@@ -141,7 +141,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin to get metadata using chromaprint framework",
"Victor Toso",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://victortoso.com",
grl_chromaprint_plugin_init,
NULL,
diff --git a/src/dleyna/grl-dleyna.c b/src/dleyna/grl-dleyna.c
index ac38175..41a46df 100644
--- a/src/dleyna/grl-dleyna.c
+++ b/src/dleyna/grl-dleyna.c
@@ -137,7 +137,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for browsing DLNA servers",
"Intel Corp.",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"https://01.org/dleyna",
grl_dleyna_plugin_init,
grl_dleyna_plugin_deinit,
diff --git a/src/dmap/grl-daap.c b/src/dmap/grl-daap.c
index 962f2b8..59410fd 100644
--- a/src/dmap/grl-daap.c
+++ b/src/dmap/grl-daap.c
@@ -143,7 +143,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for browsing DAAP servers",
"W. Michael Petullo",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.flyn.org",
grl_daap_plugin_init,
NULL,
diff --git a/src/dmap/grl-dpap.c b/src/dmap/grl-dpap.c
index 6339654..f9ba136 100644
--- a/src/dmap/grl-dpap.c
+++ b/src/dmap/grl-dpap.c
@@ -148,7 +148,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for browsing DPAP servers",
"W. Michael Petullo",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.flyn.org",
grl_dpap_plugin_init,
NULL,
diff --git a/src/filesystem/grl-filesystem.c b/src/filesystem/grl-filesystem.c
index 7409c76..3006fac 100644
--- a/src/filesystem/grl-filesystem.c
+++ b/src/filesystem/grl-filesystem.c
@@ -199,7 +199,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for browsing the filesystem",
"Igalia S.L.",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.igalia.com",
grl_filesystem_plugin_init,
NULL,
diff --git a/src/flickr/grl-flickr.c b/src/flickr/grl-flickr.c
index a2a7407..a0b8699 100644
--- a/src/flickr/grl-flickr.c
+++ b/src/flickr/grl-flickr.c
@@ -250,7 +250,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for browsing and searching Flickr photos",
"Igalia S.L.",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.igalia.com",
grl_flickr_plugin_init,
NULL,
diff --git a/src/freebox/grl-freebox.c b/src/freebox/grl-freebox.c
index b07dc85..23a659a 100644
--- a/src/freebox/grl-freebox.c
+++ b/src/freebox/grl-freebox.c
@@ -169,7 +169,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for Freebox TV channels",
"GNOME",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.gnome.org",
grl_freebox_plugin_init,
NULL,
diff --git a/src/gravatar/grl-gravatar.c b/src/gravatar/grl-gravatar.c
index bf615f5..58c1109 100644
--- a/src/gravatar/grl-gravatar.c
+++ b/src/gravatar/grl-gravatar.c
@@ -126,7 +126,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin to get avatars for artist and author fields",
"Igalia S.L.",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.igalia.com",
grl_gravatar_source_plugin_init,
NULL,
diff --git a/src/local-metadata/grl-local-metadata.c b/src/local-metadata/grl-local-metadata.c
index 3fb1d19..d182938 100644
--- a/src/local-metadata/grl-local-metadata.c
+++ b/src/local-metadata/grl-local-metadata.c
@@ -110,7 +110,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin that gets simple-to-obtain metadata from the local filesystem",
"Igalia S.L.",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.igalia.com",
grl_local_metadata_source_plugin_init,
NULL,
diff --git a/src/lua-factory/grl-lua-factory.c b/src/lua-factory/grl-lua-factory.c
index 3a3b824..5c5206c 100644
--- a/src/lua-factory/grl-lua-factory.c
+++ b/src/lua-factory/grl-lua-factory.c
@@ -297,7 +297,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin that creates sources from Lua plugins",
"Victor Toso",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://victortoso.com",
grl_lua_factory_plugin_init,
grl_lua_factory_plugin_deinit,
diff --git a/src/magnatune/grl-magnatune.c b/src/magnatune/grl-magnatune.c
index c90d029..a023a01 100644
--- a/src/magnatune/grl-magnatune.c
+++ b/src/magnatune/grl-magnatune.c
@@ -214,7 +214,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for searching music",
"Victor Toso",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.igalia.com",
grl_magnatune_plugin_init,
NULL,
diff --git a/src/metadata-store/grl-metadata-store.c b/src/metadata-store/grl-metadata-store.c
index 9db39e5..199b0ec 100644
--- a/src/metadata-store/grl-metadata-store.c
+++ b/src/metadata-store/grl-metadata-store.c
@@ -177,7 +177,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for storing extra metadata information",
"Igalia S.L.",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.igalia.com",
grl_metadata_store_source_plugin_init,
NULL,
diff --git a/src/opensubtitles/grl-opensubtitles.c b/src/opensubtitles/grl-opensubtitles.c
index 19963ea..110d9be 100644
--- a/src/opensubtitles/grl-opensubtitles.c
+++ b/src/opensubtitles/grl-opensubtitles.c
@@ -158,7 +158,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin that gets a list of subtitles for a video",
"Bastien Nocera",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.hadess.net",
grl_opensubtitles_source_plugin_init,
NULL,
diff --git a/src/optical-media/grl-optical-media.c b/src/optical-media/grl-optical-media.c
index 54affe9..c937c40 100644
--- a/src/optical-media/grl-optical-media.c
+++ b/src/optical-media/grl-optical-media.c
@@ -169,7 +169,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for browsing optical media",
"GNOME",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.gnome.org",
grl_optical_media_plugin_init,
NULL,
diff --git a/src/podcasts/grl-podcasts.c b/src/podcasts/grl-podcasts.c
index 6c91e80..9eaed8e 100644
--- a/src/podcasts/grl-podcasts.c
+++ b/src/podcasts/grl-podcasts.c
@@ -317,7 +317,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for browsing podcasts",
"Igalia S.L.",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.igalia.com",
grl_podcasts_plugin_init,
NULL,
diff --git a/src/raitv/grl-raitv.c b/src/raitv/grl-raitv.c
index d7009b9..5aeacc3 100644
--- a/src/raitv/grl-raitv.c
+++ b/src/raitv/grl-raitv.c
@@ -246,7 +246,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for searching multimedia content using Rai.tv",
"Marco Piazza",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"https://wiki.gnome.org/Projects/Grilo",
grl_raitv_plugin_init,
NULL,
diff --git a/src/shoutcast/grl-shoutcast.c b/src/shoutcast/grl-shoutcast.c
index 272f5ce..879ce35 100644
--- a/src/shoutcast/grl-shoutcast.c
+++ b/src/shoutcast/grl-shoutcast.c
@@ -167,7 +167,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for browsing SHOUTcast radios",
"Igalia S.L.",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.igalia.com",
grl_shoutcast_plugin_init,
NULL,
diff --git a/src/thetvdb/grl-thetvdb.c b/src/thetvdb/grl-thetvdb.c
index a47f5e9..3f9acde 100644
--- a/src/thetvdb/grl-thetvdb.c
+++ b/src/thetvdb/grl-thetvdb.c
@@ -290,7 +290,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for fetching metadata of television shows",
"Victor Toso",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://victortoso.com",
grl_thetvdb_plugin_init,
NULL,
diff --git a/src/tmdb/grl-tmdb.c b/src/tmdb/grl-tmdb.c
index e195375..70a135e 100644
--- a/src/tmdb/grl-tmdb.c
+++ b/src/tmdb/grl-tmdb.c
@@ -201,7 +201,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin to retrieve movie metadata from themoviedb.org",
"Canonical Ltd.",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.canonical.com",
grl_tmdb_source_plugin_init,
NULL,
diff --git a/src/tracker/grl-tracker.c b/src/tracker/grl-tracker.c
index 96527d1..b69a648 100644
--- a/src/tracker/grl-tracker.c
+++ b/src/tracker/grl-tracker.c
@@ -301,7 +301,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for searching multimedia content using Tracker",
"Igalia S.L.",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.igalia.com",
grl_tracker_plugin_init,
grl_tracker_plugin_deinit,
diff --git a/src/tracker3/grl-tracker.c b/src/tracker3/grl-tracker.c
index 7a044e0..27fbdef 100644
--- a/src/tracker3/grl-tracker.c
+++ b/src/tracker3/grl-tracker.c
@@ -217,7 +217,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for searching multimedia content using Tracker Miners 3.x",
"Igalia S.L.",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.igalia.com",
grl_tracker3_plugin_init,
grl_tracker3_plugin_deinit,
diff --git a/src/youtube/grl-youtube.c b/src/youtube/grl-youtube.c
index c090565..b28ce1e 100644
--- a/src/youtube/grl-youtube.c
+++ b/src/youtube/grl-youtube.c
@@ -299,7 +299,7 @@ GRL_PLUGIN_DEFINE (GRL_MAJOR,
"A plugin for browsing and searching YouTube videos",
"Igalia",
VERSION,
- "LGPL",
+ "LGPL-2.1-or-later",
"http://www.igalia.com",
grl_youtube_plugin_init,
NULL,
--
2.31.1

412
SPECS/grilo-plugins.spec Normal file
View File

@ -0,0 +1,412 @@
# first two digits of version
%define release_version %(echo %{version} | awk -F. '{print $1"."$2}')
%global grilo_version 0.3.8
%global goa_version 3.17.91
Name: grilo-plugins
Version: 0.3.13
Release: 6%{?dist}
Summary: Plugins for the Grilo framework
License: LGPLv2+
URL: https://wiki.gnome.org/Projects/Grilo
Source0: https://download.gnome.org/sources/grilo-plugins/%{release_version}/grilo-plugins-%{version}.tar.xz
# https://gitlab.gnome.org/GNOME/grilo-plugins/-/merge_requests/108
Patch0: 0001-grl-lua-factory-Remove-a-bad-pop.patch
# https://gitlab.gnome.org/GNOME/grilo-plugins/-/merge_requests/114
Patch1: 0001-flickr-Add-missing-copyright-license-header.patch
Patch2: 0002-build-Clarify-LGPLv2.1-or-later-license.patch
Patch3: 0003-plugins-Clarify-plugins-licenses.patch
BuildRequires: gcc
BuildRequires: meson
BuildRequires: git
BuildRequires: avahi-gobject-devel
BuildRequires: gettext
BuildRequires: grilo-devel >= %{grilo_version}
BuildRequires: glib2-devel
BuildRequires: gom-devel
BuildRequires: gnome-online-accounts-devel >= %{goa_version}
BuildRequires: gperf
BuildRequires: libgcrypt-devel
BuildRequires: libxml2-devel
BuildRequires: itstool
BuildRequires: libarchive-devel
BuildRequires: libmediaart-devel
BuildRequires: libsoup-devel
BuildRequires: lua-devel
BuildRequires: rest-devel
BuildRequires: sqlite-devel
BuildRequires: libgdata-devel
BuildRequires: totem-pl-parser-devel
BuildRequires: tracker3-devel
BuildRequires: json-glib-devel
%if ! 0%{?rhel}
BuildRequires: libdmapsharing-devel
BuildRequires: pkgconfig(oauth)
%endif
%if ! 0%{?rhel}
Requires: dleyna-server
%endif
Requires: gnome-online-accounts%{_isa} >= %{goa_version}
Requires: grilo%{_isa} >= %{grilo_version}
%description
Grilo is a framework that provides access to different sources of
multimedia content, using a pluggable system.
This package contains plugins to get information from theses sources:
- Apple Trailers
- Bookmarks
- Euronews
- Filesystem
- Flickr
- Freebox
- Gravatar
- iTunes Music Sharing
- Last.fm (for album arts)
- Local metadata (album arts and thumbnails)
- Metadata Store
- Pocket
- Podcasts
- Radio France
- Shoutcast
- The Guardian Videos
- Tracker
- Youtube
%prep
%autosetup -p1 -S git
%build
%meson \
-Denable-static=no \
-Denable-shoutcast=no \
-Denable-bookmarks=yes \
%if 0%{?rhel}
-Denable-dleyna=no \
-Denable-dmap=no \
-Denable-flickr=no \
%else
-Denable-dleyna=yes \
-Denable-dmap=yes \
-Denable-flickr=yes \
%endif
-Denable-filesystem=yes \
-Denable-freebox=yes \
-Denable-gravatar=yes \
-Denable-lua-factory=yes \
-Denable-metadata-store=yes \
%if 0%{?fedora}
-Denable-podcasts=yes \
%endif
-Denable-tmdb=yes \
-Denable-youtube=yes \
-Denable-tracker=no \
-Denable-tracker3=yes
%meson_build
%install
%meson_install
%find_lang grilo-plugins --with-gnome
%files -f grilo-plugins.lang
%license COPYING
%doc AUTHORS NEWS README.md
%doc %{_datadir}/help/*/examples/example-tmdb.c
%{_datadir}/grilo-plugins/
%{_libdir}/pkgconfig/*.pc
%{_libdir}/grilo-%{release_version}/*.so*
%changelog
* Tue Aug 24 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.3.13-6
- Disable the Flickr plugin
Resolves: #1996896
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.3.13-5
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688
* Mon Jun 28 2021 Bastien Nocera <bnocera@redhat.com> - 0.3.13-4
+ grilo-plugins-0.3.13-4
- Clarify licenses
- Resolves: rhbz#1976718
* Wed May 12 2021 Bastien Nocera <bnocera@redhat.com> - 0.3.13-3
+ grilo-plugins-0.3.13-3
- Fix crash with newer lua
- Resolves: rhbz#1958772
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 0.3.13-2
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
* Wed Mar 31 2021 Victor Toso <victortoso@redhat.com> - 0.3.13-1
- Update to 0.3.13
- Vimeo e Jamendo were removed
- Tracker 2 is disabled
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.12-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Wed Sep 09 2020 Kalev Lember <klember@redhat.com> - 0.3.12-2
- Switch to tracker3
* Thu Sep 3 2020 Victor Toso <victortoso@redhat.com> - 0.3.12-1
- Update to 0.3.12
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.11-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Mon Jul 13 2020 Bastien Nocera <bnocera@redhat.com> - 0.3.11-3
+ grilo-plugins-0.3.11-3
- Disable DMAP plugins on RHEL
* Mon Mar 16 2020 Yaroslav Fedevych <yaroslav@fedevych.name> - 0.3.11-2
- Added pkgconfig(oauth) as an explicit build dependency
* Fri Feb 14 2020 Victor Toso <victortoso@redhat.com> - 0.3.11-1
- Update to 0.3.11
* Fri Feb 14 2020 Bastien Nocera <bnocera@redhat.com> - 0.3.10-4
+ grilo-plugins-0.3.10-4
- Fix dleyna disable conditions
* Fri Feb 14 2020 Bastien Nocera <bnocera@redhat.com> - 0.3.10-3
+ grilo-plugins-0.3.10-3
- Disable dleyna plugin on RHEL
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.10-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Sep 12 2019 Victor Toso <victortoso@redhat.com> - 0.3.10-1
- Update to 0.3.10
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Mon Jul 15 2019 Kalev Lember <klember@redhat.com> - 0.3.9-1
- Update to 0.3.9
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Mon Sep 24 2018 Victor Toso <victortoso@redhat.com> - 0.3.8-1
- Update to 0.3.8
* Tue Jul 31 2018 Florian Weimer <fweimer@redhat.com> - 0.3.7-4
- Rebuild with fixed binutils
* Sat Jul 28 2018 Victor Toso <victortoso@redhat.com> - 0.3.7-3
- Switch build to meson
- Drop gmime requirement
* Fri Jul 27 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.7-2
- Rebuild for new binutils
* Wed Jul 18 2018 Victor Toso <victortoso@redhat.com> - 0.3.6-1
- Update to 0.3.6
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Thu May 17 2018 Kalev Lember <klember@redhat.com> - 0.3.5-4
- Remove obsolete RHEL conditionals
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Fri Sep 08 2017 Kalev Lember <klember@redhat.com> - 0.3.5-2
- Switch to gmime 3.0
* Fri Aug 25 2017 Bastien Nocera <bnocera@redhat.com> - 0.3.5-1
+ grilo-plugins-0.3.5-1
- Update to 0.3.5
* Thu Aug 10 2017 Kalev Lember <klember@redhat.com> - 0.3.4-4
- Rebuilt for libtotem-plparser soname bump
* Mon Jul 31 2017 Kalev Lember <klember@redhat.com> - 0.3.4-3
- Rebuilt for libtotem-plparser soname bump
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Tue Feb 14 2017 Kalev Lember <klember@redhat.com> - 0.3.4-1
- Update to 0.3.4
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Tue Sep 13 2016 Kalev Lember <klember@redhat.com> - 0.3.3-1
- Update to 0.3.3
- Don't set group tags
- Use make_install macro
* Mon Jul 25 2016 Kalev Lember <klember@redhat.com> - 0.3.2-2
- Update required grilo version
* Wed Jun 22 2016 Richard Hughes <rhughes@redhat.com> - 0.3.2-1
- Update to 0.3.2
* Tue Mar 22 2016 Bastien Nocera <bnocera@redhat.com> 0.3.1-1
- Update to 0.3.1
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Fri Dec 18 2015 Kalev Lember <klember@redhat.com> - 0.3.0-1
- Update to 0.3.0
- Update project URL
* Wed Sep 23 2015 Kalev Lember <klember@redhat.com> - 0.2.16-1
- Update to 0.2.16
* Fri Sep 11 2015 Kalev Lember <klember@redhat.com> - 0.2.15-1
- Update to 0.2.15
- Tighten deps with _isa macro
- Use license macro for COPYING
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.14-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Mon Apr 27 2015 David King <amigadave@amigadave.com> - 0.2.14-3
- Rebuild for libgdata soname bump
* Fri Mar 27 2015 Ray Strode <rstrode@redhat.com> 0.2.14-2
- Conditionalize dleyna-server requirement
* Sat Feb 21 2015 Kalev Lember <kalevlember@gmail.com> - 0.2.14-1
- Update to 0.2.14
* Sun Feb 15 2015 Bastien Nocera <bnocera@redhat.com> 0.2.13-3
- Add missing dleyna-server requirement so DLNA works
* Mon Jan 26 2015 David King <amigadave@amigadave.com> - 0.2.13-2
- Port to libmediaart-2.0
* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 0.2.13-1
- Update to 0.2.13
* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 0.2.12-6
- Rebuilt with libmediaart 0.6.0
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.12-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.12-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Wed Apr 16 2014 Adam Williamson <awilliam@redhat.com> - 0.2.12-3
- rebuild for new libgdata
* Wed Apr 02 2014 Kalev Lember <kalevlember@gmail.com> - 0.2.12-2
- Build additional freebox, lua-factory and pocket plugins
* Wed Mar 19 2014 Richard Hughes <rhughes@redhat.com> - 0.2.12-1
- Update to 0.2.12
* Wed Feb 19 2014 Kalev Lember <kalevlember@gmail.com> - 0.2.11-1
- Update to 0.2.11
* Thu Dec 19 2013 Adam Williamson <awilliam@redhat.com> - 0.2.9-3
- patch to build against newer tracker, rebuild for tracker bump
* Thu Sep 19 2013 Kalev Lember <kalevlember@gmail.com> - 0.2.9-2
- Rebuilt for totem-pl-parser soname bump
* Sun Aug 25 2013 Kalev Lember <kalevlember@gmail.com> - 0.2.9-1
- Update to 0.2.9
* Sun Aug 4 2013 Peter Robinson <pbrobinson@fedoraproject.org> 0.2.8-4
- Fix FTBFS
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.8-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Thu Jun 06 2013 Kalev Lember <kalevlember@gmail.com> - 0.2.8-2
- Backport a patch to avoid DNS delays at plugin init (#969123)
* Sat May 25 2013 Kalev Lember <kalevlember@gmail.com> - 0.2.8-1
- Update to 0.2.8
* Sat May 18 2013 Kalev Lember <kalevlember@gmail.com> - 0.2.7-1
- Update to 0.2.7
* Sat May 18 2013 Kalev Lember <kalevlember@gmail.com> - 0.2.6-2
- Use the find_lang --with-gnome macro for help files
- Drop the dep on yelp (#964421)
* Wed Mar 20 2013 Kalev Lember <kalevlember@gmail.com> - 0.2.6-1
- Update to 0.2.6
* Mon Jan 28 2013 Matthias Clasen <mclasen@redhat.com> - 0.2.5-3
- Fix build against newer tracker
* Sun Jan 27 2013 Peter Robinson <pbrobinson@fedoraproject.org> 0.2.5-2
- Rebuild for tracker
* Thu Dec 20 2012 Bastien Nocera <bnocera@redhat.com> 0.2.5-1
- Update to 0.2.5
* Tue Dec 04 2012 Bastien Nocera <bnocera@redhat.com> 0.2.4-1
- Update to 0.2.4
* Tue Nov 13 2012 Kalev Lember <kalevlember@gmail.com> 0.2.3-1
- Update to 0.2.3
* Fri Oct 05 2012 Bastien Nocera <bnocera@redhat.com> 0.2.2-1
- Update to 0.2.2
* Wed Oct 03 2012 Bastien Nocera <bnocera@redhat.com> 0.2.1-1
- Update to 0.2.1
* Fri Aug 31 2012 Debarshi Ray <rishi@fedoraproject.org> 0.2.0-1
- update to 0.2.0
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.19-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Fri May 25 2012 Bastien Nocera <bnocera@redhat.com> 0.1.19-1
- Update to 0.1.19
* Fri Mar 16 2012 Adam Williamson <awilliam@redhat.com> - 0.1.18-4
- Rebuild for new tracker again
* Tue Feb 28 2012 Matthias Clasen <mclasen@redhat.com> - 0.1.18-3
- Rebuild for new tracker
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.18-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Mon Dec 12 2011 Bastien Nocera <bnocera@redhat.com> 0.1.18-1
- Update to 0.1.18
* Thu Nov 17 2011 Daniel Drake <dsd@laptop.org> 0.1.17-2
- rebuild for libquvi.so.7
* Mon Oct 17 2011 Bastien Nocera <bnocera@redhat.com> 0.1.17-1
- Update to 0.1.17
* Mon Jul 04 2011 Bastien Nocera <bnocera@redhat.com> 0.1.16-1
- Update to 0.1.16
* Fri Jun 17 2011 Peter Robinson <pbrobinson@gmail.com> 0.1.15-5
- rebuild for new gupnp/gssdp
* Fri May 20 2011 Bastien Nocera <bnocera@redhat.com> 0.1.15-4
- Update with more comments from Kalev Lember <kalev@smartlink.ee>
* Fri May 20 2011 Bastien Nocera <bnocera@redhat.com> 0.1.15-3
- Update with comments from Kalev Lember <kalev@smartlink.ee>
* Fri May 20 2011 Bastien Nocera <bnocera@redhat.com> 0.1.15-2
- Fix a few rpmlint warnings
* Thu Apr 21 2011 Bastien Nocera <bnocera@redhat.com> 0.1.15-1
- Fist package, based on upstream work by Juan A.
Suarez Romero <jasuarez@igalia.com>