Update to 0.2.14
This commit is contained in:
parent
ac415268a0
commit
bee30cd62f
1
.gitignore
vendored
1
.gitignore
vendored
@ -16,3 +16,4 @@
|
||||
/grilo-plugins-0.2.11.tar.xz
|
||||
/grilo-plugins-0.2.12.tar.xz
|
||||
/grilo-plugins-0.2.13.tar.xz
|
||||
/grilo-plugins-0.2.14.tar.xz
|
||||
|
@ -1,35 +0,0 @@
|
||||
From cf0bc157f79e058d5e307641bbf0848cd5cfda48 Mon Sep 17 00:00:00 2001
|
||||
From: Yanko Kaneti <yaneti@declera.com>
|
||||
Date: Tue, 20 Jan 2015 17:38:51 +0200
|
||||
Subject: local-metadata: Mechanically adjust for libmediaart-2.0
|
||||
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 414872c..54ef31e 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -160,7 +160,7 @@ PKG_CHECK_MODULES(GMIME, gmime-2.6,
|
||||
|
||||
PKG_CHECK_MODULES(AVAHI, [avahi-gobject avahi-glib avahi-client], HAVE_AVAHI=yes, HAVE_AVAHI=no)
|
||||
|
||||
-PKG_CHECK_MODULES(MEDIAART, [libmediaart-1.0], HAVE_MEDIAART=yes, HAVE_MEDIAART=no)
|
||||
+PKG_CHECK_MODULES(MEDIAART, [libmediaart-2.0], HAVE_MEDIAART=yes, HAVE_MEDIAART=no)
|
||||
|
||||
PKG_CHECK_MODULES(GOM, [gom-1.0 >= 0.2.1], HAVE_GOM=yes, HAVE_GOM=no)
|
||||
|
||||
diff --git a/src/local-metadata/grl-local-metadata.c b/src/local-metadata/grl-local-metadata.c
|
||||
index 2fced68..5af7eb5 100644
|
||||
--- a/src/local-metadata/grl-local-metadata.c
|
||||
+++ b/src/local-metadata/grl-local-metadata.c
|
||||
@@ -776,7 +776,7 @@ resolve_album_art (GrlSource *source,
|
||||
if (!artist || !album)
|
||||
return TRUE;
|
||||
|
||||
- media_art_get_path (artist, album, "album", NULL, &cache_uri, &thumbnail_uri);
|
||||
+ media_art_get_path (artist, album, "album", &cache_uri);
|
||||
|
||||
if (thumbnail_uri)
|
||||
grl_media_set_thumbnail (rs->media, thumbnail_uri);
|
||||
--
|
||||
cgit v0.10.1
|
||||
|
@ -1,19 +1,17 @@
|
||||
# first two digits of version
|
||||
%define release_version %(echo %{version} | awk -F. '{print $1"."$2}')
|
||||
|
||||
%global grilo_version 0.2.11
|
||||
%global grilo_version 0.2.12
|
||||
|
||||
Name: grilo-plugins
|
||||
Version: 0.2.13
|
||||
Release: 3%{?dist}
|
||||
Version: 0.2.14
|
||||
Release: 1%{?dist}
|
||||
Summary: Plugins for the Grilo framework
|
||||
|
||||
Group: Applications/Multimedia
|
||||
License: LGPLv2+
|
||||
Url: https://live.gnome.org/Grilo
|
||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/grilo-plugins/%{release_version}/grilo-plugins-%{version}.tar.xz
|
||||
# Port to libmediaart-2.0 until the next release.
|
||||
Patch0: grilo-plugins-0.2.13-libmediaart-2.0.patch
|
||||
|
||||
BuildRequires: avahi-gobject-devel
|
||||
BuildRequires: grilo-devel >= %{grilo_version}
|
||||
@ -35,8 +33,6 @@ BuildRequires: tracker-devel
|
||||
BuildRequires: gmime-devel
|
||||
BuildRequires: libdmapsharing-devel
|
||||
BuildRequires: json-glib-devel
|
||||
# Needed for autoreconf.
|
||||
BuildRequires: autoconf automake gnome-common libtool
|
||||
|
||||
Requires: grilo >= %{grilo_version}
|
||||
Requires: dleyna-server
|
||||
@ -68,8 +64,6 @@ This package contains plugins to get information from theses sources:
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
autoreconf --force --install
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -119,6 +113,9 @@ rm -f $RPM_BUILD_ROOT%{_bindir}/*
|
||||
%{_libdir}/grilo-%{release_version}/*.xml
|
||||
|
||||
%changelog
|
||||
* Sat Feb 21 2015 Kalev Lember <kalevlember@gmail.com> - 0.2.14-1
|
||||
- Update to 0.2.14
|
||||
|
||||
* Sun Feb 15 2015 Bastien Nocera <bnocera@redhat.com> 0.2.13-3
|
||||
- Add missing dleyna-server requirement so DLNA works
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user