Disabled performance related tests
(by disable-performance-related-tests patch), patch backported from upstream - Dropped disable-long-pattern-perf-test patch (not needed, covered by previous patch) Resolves: rhbz#1278428
This commit is contained in:
parent
58a4acffa4
commit
ba174f15d5
@ -1,12 +0,0 @@
|
|||||||
diff --git a/tests/long-pattern-perf b/tests/long-pattern-perf
|
|
||||||
index c222c02..17557c0 100755
|
|
||||||
--- a/tests/long-pattern-perf
|
|
||||||
+++ b/tests/long-pattern-perf
|
|
||||||
@@ -19,6 +19,7 @@
|
|
||||||
. "${srcdir=.}/init.sh"; path_prepend_ ../src
|
|
||||||
|
|
||||||
fail=0
|
|
||||||
+skip_ "not suitable for distribution buildsystem, disabled by Fedora downstream"
|
|
||||||
|
|
||||||
echo x > in || framework_failure_
|
|
||||||
# We could use seq -s '' (avoiding the tr filter), but I
|
|
54
grep-2.22-disable-performance-related-tests.patch
Normal file
54
grep-2.22-disable-performance-related-tests.patch
Normal file
@ -0,0 +1,54 @@
|
|||||||
|
From e938d22e2131972a6e9eaddbf850c6a04a4f750c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jim Meyering <meyering@fb.com>
|
||||||
|
Date: Wed, 4 Nov 2015 10:57:07 -0800
|
||||||
|
Subject: [PATCH] tests: mark performance-related tests as expensive
|
||||||
|
|
||||||
|
These performance-related tests are slightly failure prone due to
|
||||||
|
varying system load during the two runs.
|
||||||
|
Marking these tests as "expensive" makes it so they are no longer run
|
||||||
|
via "make check". You can still run them via make "check-expensive".
|
||||||
|
This makes them less likely to be run by regular users.
|
||||||
|
* tests/long-pattern-perf: Use expensive_.
|
||||||
|
* tests/mb-non-UTF8-performance: Likewise.
|
||||||
|
Reported by Jaroslav Skarvada in http://debbugs.gnu.org/21826
|
||||||
|
and by Andreas Schwab in http://debbugs.gnu.org/21812.
|
||||||
|
---
|
||||||
|
tests/long-pattern-perf | 5 +++++
|
||||||
|
tests/mb-non-UTF8-performance | 5 +++++
|
||||||
|
2 files changed, 10 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/tests/long-pattern-perf b/tests/long-pattern-perf
|
||||||
|
index c222c02..2c9d080 100755
|
||||||
|
--- a/tests/long-pattern-perf
|
||||||
|
+++ b/tests/long-pattern-perf
|
||||||
|
@@ -20,6 +20,11 @@
|
||||||
|
|
||||||
|
fail=0
|
||||||
|
|
||||||
|
+# This test is susceptible to failure due to differences in
|
||||||
|
+# system load during the two test runs, so we'll mark it as
|
||||||
|
+# "expensive", making it less likely to be run by regular users.
|
||||||
|
+expensive_
|
||||||
|
+
|
||||||
|
echo x > in || framework_failure_
|
||||||
|
# We could use seq -s '' (avoiding the tr filter), but I
|
||||||
|
# suspect some version of seq does not honor that option.
|
||||||
|
diff --git a/tests/mb-non-UTF8-performance b/tests/mb-non-UTF8-performance
|
||||||
|
index 228361d..9bd5d39 100755
|
||||||
|
--- a/tests/mb-non-UTF8-performance
|
||||||
|
+++ b/tests/mb-non-UTF8-performance
|
||||||
|
@@ -22,6 +22,11 @@
|
||||||
|
|
||||||
|
fail=0
|
||||||
|
|
||||||
|
+# This test is susceptible to failure due to differences in
|
||||||
|
+# system load during the two test runs, so we'll mark it as
|
||||||
|
+# "expensive", making it less likely to be run by regular users.
|
||||||
|
+expensive_
|
||||||
|
+
|
||||||
|
# Make this large enough so that even on high-end systems
|
||||||
|
# it incurs at least 5-10ms of user time.
|
||||||
|
yes $(printf '%078d' 0) | head -400000 > in || framework_failure_
|
||||||
|
--
|
||||||
|
2.6.0
|
||||||
|
|
17
grep.spec
17
grep.spec
@ -3,7 +3,7 @@
|
|||||||
Summary: Pattern matching utilities
|
Summary: Pattern matching utilities
|
||||||
Name: grep
|
Name: grep
|
||||||
Version: 2.22
|
Version: 2.22
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://www.gnu.org/software/grep/
|
URL: http://www.gnu.org/software/grep/
|
||||||
Group: Applications/Text
|
Group: Applications/Text
|
||||||
@ -17,7 +17,7 @@ Source4: grepconf.sh
|
|||||||
Patch0: grep-2.22-man-fix-gs.patch
|
Patch0: grep-2.22-man-fix-gs.patch
|
||||||
# upstream ticket 39445
|
# upstream ticket 39445
|
||||||
Patch1: grep-2.22-help-align.patch
|
Patch1: grep-2.22-help-align.patch
|
||||||
Patch2: grep-2.22-disable-long-pattern-perf-test.patch
|
Patch2: grep-2.22-disable-performance-related-tests.patch
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
Requires(preun): /sbin/install-info
|
Requires(preun): /sbin/install-info
|
||||||
|
|
||||||
@ -37,7 +37,11 @@ GNU grep is needed by many scripts, so it shall be installed on every system.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .man-fix-gs
|
%patch0 -p1 -b .man-fix-gs
|
||||||
%patch1 -p1 -b .help-align
|
%patch1 -p1 -b .help-align
|
||||||
%patch2 -p1 -b .disable-long-pattern-perf-test
|
# Backported from upstream, mb-non-UTF8-performance and long-pattern-perf tests
|
||||||
|
# marked as expensive and not run by default. The result is decided according
|
||||||
|
# to measured runtime, which doesn't work reliable on the builders with
|
||||||
|
# variable load.
|
||||||
|
%patch2 -p1 -b .disable-performance-related-tests
|
||||||
|
|
||||||
chmod 755 tests/kwset-abuse
|
chmod 755 tests/kwset-abuse
|
||||||
|
|
||||||
@ -90,6 +94,13 @@ fi
|
|||||||
%{_libexecdir}/grepconf.sh
|
%{_libexecdir}/grepconf.sh
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 5 2015 Jaroslav Škarvada <jskarvad@redhat.com> - 2.22-2
|
||||||
|
- Disabled performance related tests
|
||||||
|
(by disable-performance-related-tests patch), patch backported from upstream
|
||||||
|
- Dropped disable-long-pattern-perf-test patch (not needed, covered by
|
||||||
|
previous patch)
|
||||||
|
Resolves: rhbz#1278428
|
||||||
|
|
||||||
* Mon Nov 2 2015 Jaroslav Škarvada <jskarvad@redhat.com> - 2.22-1
|
* Mon Nov 2 2015 Jaroslav Škarvada <jskarvad@redhat.com> - 2.22-1
|
||||||
- New version
|
- New version
|
||||||
Resolves: rhbz#1277113
|
Resolves: rhbz#1277113
|
||||||
|
Loading…
Reference in New Issue
Block a user