New version
Resolves: rhbz#1023698 - Fixed bogus date in the changelog - Dropped gnulib-tests-rm-f patch, rejected upstream and not needed for Fedora build system - Dropped man-fix-R patch, upstreamed - De-fuzzified other patches
This commit is contained in:
parent
79ec460f74
commit
9e737f2845
@ -1,114 +0,0 @@
|
||||
diff --git a/gnulib-tests/test-update-copyright.sh b/gnulib-tests/test-update-copyright.sh
|
||||
index 80b8c5a..c746a9b 100755
|
||||
--- a/gnulib-tests/test-update-copyright.sh
|
||||
+++ b/gnulib-tests/test-update-copyright.sh
|
||||
@@ -228,7 +228,7 @@ Copyright (C) 1990-2005, 2007-2009 Acme, Inc.
|
||||
# Software Foundation, Inc.
|
||||
EOF
|
||||
|
||||
-rm $TMP*
|
||||
+rm -f $TMP*
|
||||
|
||||
## -------------- ##
|
||||
## Current year. ##
|
||||
@@ -254,7 +254,7 @@ compare /dev/null $TMP-stderr || exit 1
|
||||
compare - $TMP <<EOF || exit 1
|
||||
'\" Copyright (C) 2006, $YEAR Free Software Foundation, Inc.
|
||||
EOF
|
||||
-rm $TMP*
|
||||
+rm -f $TMP*
|
||||
|
||||
## ------------------ ##
|
||||
## Surrounding text. ##
|
||||
@@ -278,7 +278,7 @@ dnl Undisturbed text.
|
||||
dnl Copyright (C) 1989, 2010 Free Software Foundation, Inc.
|
||||
dnl Undisturbed text.
|
||||
EOF
|
||||
-rm $TMP*
|
||||
+rm -f $TMP*
|
||||
|
||||
## --------------- ##
|
||||
## Widest prefix. ##
|
||||
@@ -307,7 +307,7 @@ compare - $TMP <<EOF || exit 1
|
||||
#### Copyright (C) 1976-1988, 1999-2008, 2010-2011 Free Software
|
||||
#### Foundation, Inc.
|
||||
EOF
|
||||
-rm $TMP*
|
||||
+rm -f $TMP*
|
||||
|
||||
## ------------------- ##
|
||||
## Prefix too large. ##
|
||||
@@ -330,7 +330,7 @@ compare - $TMP <<EOF || exit 1
|
||||
#### 1986, 1987, 1988, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007,
|
||||
#### 2008 Free Software Foundation, Inc.
|
||||
EOF
|
||||
-rm $TMP*
|
||||
+rm -f $TMP*
|
||||
|
||||
## ------------- ##
|
||||
## Blank lines. ##
|
||||
@@ -365,7 +365,7 @@ Copyright (C) 1976, 1977, 1978, 1979, 1980, 1981, 1982, 1983, 1984, 1985,
|
||||
1986, 1987, 1988, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007,
|
||||
2008 Free Software Foundation, Inc.
|
||||
EOF
|
||||
-rm $TMP*
|
||||
+rm -f $TMP*
|
||||
|
||||
## -------------- ##
|
||||
## Leading tabs. ##
|
||||
@@ -394,7 +394,7 @@ compare - $TMP <<EOF || exit 1
|
||||
Copyright (C) 1987-1988, 1991-2011 Free Software Foundation,
|
||||
Inc.
|
||||
EOF
|
||||
-rm $TMP*
|
||||
+rm -f $TMP*
|
||||
|
||||
## -------------------- ##
|
||||
## Unusual whitespace. ##
|
||||
@@ -431,7 +431,7 @@ compare /dev/null $TMP-stderr || exit 1
|
||||
compare - $TMP <<EOF || exit 1
|
||||
# Copyright (C) 1987-2011 Free Software Foundation, Inc.
|
||||
EOF
|
||||
-rm $TMP*
|
||||
+rm -f $TMP*
|
||||
|
||||
## --------- ##
|
||||
## DOS EOL. ##
|
||||
@@ -453,7 +453,7 @@ Rem 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008,@
|
||||
Rem 2009, 2010 Free Software Foundation, Inc.@
|
||||
EOF
|
||||
compare $TMP-exp $TMP || exit 1
|
||||
-rm $TMP*
|
||||
+rm -f $TMP*
|
||||
|
||||
## --------------- ##
|
||||
## Omitted "(C)". ##
|
||||
@@ -474,7 +474,7 @@ compare - $TMP <<EOF || exit 1
|
||||
1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010
|
||||
Free Software Foundation, Inc.
|
||||
EOF
|
||||
-rm $TMP*
|
||||
+rm -f $TMP*
|
||||
|
||||
## ------------------ ##
|
||||
## C-style comments. ##
|
||||
@@ -536,6 +536,6 @@ compare - $TMP.extra-text-space <<EOF || exit 1
|
||||
Inc. ***
|
||||
* End of comments. */
|
||||
EOF
|
||||
-rm $TMP*
|
||||
+rm -f $TMP*
|
||||
|
||||
exit 0
|
||||
diff --git a/gnulib-tests/test-version-etc.sh b/gnulib-tests/test-version-etc.sh
|
||||
index 945383b..7c322e7 100755
|
||||
--- a/gnulib-tests/test-version-etc.sh
|
||||
+++ b/gnulib-tests/test-version-etc.sh
|
||||
@@ -38,6 +38,6 @@ EOT
|
||||
tr -d '\015' |
|
||||
diff -c $TMP - || ERR=1
|
||||
|
||||
-rm $TMP
|
||||
+rm -f $TMP
|
||||
|
||||
exit $ERR
|
@ -1,12 +0,0 @@
|
||||
diff --git a/doc/grep.in.1 b/doc/grep.in.1
|
||||
index 4bf03b4..f2d4362 100644
|
||||
--- a/doc/grep.in.1
|
||||
+++ b/doc/grep.in.1
|
||||
@@ -533,6 +533,7 @@ following symbolic links only if they are on the command line.
|
||||
This is equivalent to the
|
||||
.B "\-d recurse"
|
||||
option.
|
||||
+.TP
|
||||
.BR \-R ", " \-\^\-dereference\-recursive
|
||||
Read all files under each directory, recursively.
|
||||
Follow all symbolic links, unlike
|
@ -1,8 +1,8 @@
|
||||
diff --git a/src/main.c b/src/main.c
|
||||
index 145d6a1..c174472 100644
|
||||
index 930c429..dd46735 100644
|
||||
--- a/src/main.c
|
||||
+++ b/src/main.c
|
||||
@@ -1590,16 +1590,19 @@ Output control:\n\
|
||||
@@ -1588,16 +1588,19 @@ Output control:\n\
|
||||
-D, --devices=ACTION how to handle devices, FIFOs and sockets;\n\
|
||||
ACTION is 'read' or 'skip'\n\
|
||||
-r, --recursive like --directories=recurse\n\
|
@ -1,5 +1,5 @@
|
||||
diff --git a/doc/grep.in.1 b/doc/grep.in.1
|
||||
index f2d4362..f3e416b 100644
|
||||
index 3d65610..07e2d17 100644
|
||||
--- a/doc/grep.in.1
|
||||
+++ b/doc/grep.in.1
|
||||
@@ -377,7 +377,7 @@ Print
|
||||
@ -47,10 +47,10 @@ index f2d4362..f3e416b 100644
|
||||
.TP
|
||||
.BR \-a ", " \-\^\-text
|
||||
diff --git a/src/main.c b/src/main.c
|
||||
index e3b5186..145d6a1 100644
|
||||
index d9c7759..930c429 100644
|
||||
--- a/src/main.c
|
||||
+++ b/src/main.c
|
||||
@@ -1613,6 +1613,8 @@ Context control:\n\
|
||||
@@ -1611,6 +1611,8 @@ Context control:\n\
|
||||
"));
|
||||
printf (_("\
|
||||
-NUM same as --context=NUM\n\
|
27
grep.spec
27
grep.spec
@ -2,20 +2,18 @@
|
||||
|
||||
Summary: Pattern matching utilities
|
||||
Name: grep
|
||||
Version: 2.14
|
||||
Release: 5%{?dist}
|
||||
Version: 2.15
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/Text
|
||||
Source: ftp://ftp.gnu.org/pub/gnu/grep/grep-%{version}.tar.xz
|
||||
Source1: colorgrep.sh
|
||||
Source2: colorgrep.csh
|
||||
Source3: GREP_COLORS
|
||||
Patch1: grep-2.14-gnulib-tests-rm-f.patch
|
||||
Patch2: grep-2.14-man-fix-R.patch
|
||||
# upstream ticket 39444
|
||||
Patch3: grep-2.14-man-fix-gs.patch
|
||||
Patch0: grep-2.15-man-fix-gs.patch
|
||||
# upstream ticket 39445
|
||||
Patch4: grep-2.14-help-align.patch
|
||||
Patch1: grep-2.15-help-align.patch
|
||||
URL: http://www.gnu.org/software/grep/
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
@ -34,10 +32,8 @@ GNU grep is needed by many scripts, so it shall be installed on every system.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .gnulib-tests-rm-f
|
||||
%patch2 -p1 -b .man-fix-R
|
||||
%patch3 -p1 -b .man-fix-gs
|
||||
%patch4 -p1 -b .help-align
|
||||
%patch0 -p1 -b .man-fix-gs
|
||||
%patch1 -p1 -b .help-align
|
||||
|
||||
%build
|
||||
%global BUILD_FLAGS $RPM_OPT_FLAGS
|
||||
@ -89,6 +85,15 @@ fi
|
||||
%{_mandir}/*/*
|
||||
|
||||
%changelog
|
||||
* Tue Oct 29 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.15-1
|
||||
- New version
|
||||
Resolves: rhbz#1023698
|
||||
- Fixed bogus date in the changelog
|
||||
- Dropped gnulib-tests-rm-f patch, rejected upstream and not
|
||||
needed for Fedora build system
|
||||
- Dropped man-fix-R patch, upstreamed
|
||||
- De-fuzzified other patches
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
@ -191,7 +196,7 @@ fi
|
||||
- Added auto-color profile.d scripts (thanks to Ville Skyttä #600832)
|
||||
- Removed description macro from changelog
|
||||
|
||||
* Tue May 06 2010 Jaroslav Škarvada <jskarvad@redhat.com> - 2.6.3-2
|
||||
* Thu May 06 2010 Jaroslav Škarvada <jskarvad@redhat.com> - 2.6.3-2
|
||||
- Added dfa-optimize-period patch (speedup for . patterns in UTF-8)
|
||||
- Added glibc-matcher-fallback patch (speedup for [a-z] patterns in UTF-8)
|
||||
- Added mmap-option-fix patch
|
||||
|
Loading…
Reference in New Issue
Block a user