Fixed FTBFS with glibc-2.28
Resolves: rhbz#1604263
This commit is contained in:
parent
3ada89752b
commit
78e9cd1f16
38
grep-3.1-glibc-2.28-fix.patch
Normal file
38
grep-3.1-glibc-2.28-fix.patch
Normal file
@ -0,0 +1,38 @@
|
||||
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
||||
index 66fb461..c6e96e4 100644
|
||||
--- a/tests/Makefile.am
|
||||
+++ b/tests/Makefile.am
|
||||
@@ -55,10 +55,6 @@ XFAIL_TESTS = triple-backref
|
||||
# FIXME-2015: Remove this once the gnulib bug is fixed.
|
||||
if USE_INCLUDED_REGEX
|
||||
XFAIL_TESTS += equiv-classes
|
||||
-else
|
||||
-# The backslash-alt test fails for glibc, which needs to be fixed.
|
||||
-# FIXME-2015: Remove this once the glibc bug is fixed.
|
||||
-XFAIL_TESTS += backref-alt
|
||||
endif
|
||||
|
||||
TESTS = \
|
||||
diff --git a/tests/Makefile.in b/tests/Makefile.in
|
||||
index 55c72d0..04e64af 100644
|
||||
--- a/tests/Makefile.in
|
||||
+++ b/tests/Makefile.in
|
||||
@@ -108,9 +108,6 @@ check_PROGRAMS = get-mb-cur-max$(EXEEXT)
|
||||
# The included matcher needs to be fixed.
|
||||
# FIXME-2015: Remove this once the gnulib bug is fixed.
|
||||
@USE_INCLUDED_REGEX_TRUE@am__append_1 = equiv-classes
|
||||
-# The backslash-alt test fails for glibc, which needs to be fixed.
|
||||
-# FIXME-2015: Remove this once the glibc bug is fixed.
|
||||
-@USE_INCLUDED_REGEX_FALSE@am__append_2 = backref-alt
|
||||
subdir = tests
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||
am__aclocal_m4_deps = $(top_srcdir)/m4/00gnulib.m4 \
|
||||
@@ -1408,7 +1405,7 @@ LDADD = ../lib/libgreputils.a $(LIBINTL) ../lib/libgreputils.a
|
||||
# matcher (i.e., with glibc) and with the included matcher.
|
||||
# Both matchers need to be fixed.
|
||||
# FIXME-2015: Remove this once the glibc and gnulib bugs are fixed.
|
||||
-XFAIL_TESTS = triple-backref $(am__append_1) $(am__append_2)
|
||||
+XFAIL_TESTS = triple-backref $(am__append_1)
|
||||
TESTS = \
|
||||
backref \
|
||||
backref-alt \
|
@ -1,7 +1,7 @@
|
||||
Summary: Pattern matching utilities
|
||||
Name: grep
|
||||
Version: 3.1
|
||||
Release: 7%{?dist}
|
||||
Release: 8%{?dist}
|
||||
License: GPLv3+
|
||||
URL: http://www.gnu.org/software/grep/
|
||||
|
||||
@ -14,6 +14,7 @@ Source4: grepconf.sh
|
||||
Patch0: grep-3.31-man-fix-gs.patch
|
||||
# upstream ticket 39445
|
||||
Patch1: grep-3.31-help-align.patch
|
||||
Patch2: grep-3.1-glibc-2.28-fix.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: pcre-devel >= 3.9-10, texinfo, gettext
|
||||
@ -36,6 +37,7 @@ GNU grep is needed by many scripts, so it shall be installed on every system.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .man-fix-gs
|
||||
%patch1 -p1 -b .help-align
|
||||
%patch2 -p1 -b .glibc-2.28-fix
|
||||
|
||||
%build
|
||||
%global BUILD_FLAGS $RPM_OPT_FLAGS
|
||||
@ -78,6 +80,10 @@ make check
|
||||
%{_libexecdir}/grepconf.sh
|
||||
|
||||
%changelog
|
||||
* Thu Aug 9 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 3.1-8
|
||||
- Fixed FTBFS with glibc-2.28
|
||||
Resolves: rhbz#1604263
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user