auto-import changelog data from grep-2.5.1-28.src.rpm
Tue May 18 2004 Jeremy Katz <katzj@redhat.com> 2.5.1-28 - rebuild Tue May 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-27 - Fix dfa multibyte character class matching when -i is used (bug #123363). - Use bracket patch before i18n patch to make it clear that the bug exists upstream.
This commit is contained in:
parent
ac51d8507f
commit
51c5096257
@ -41,8 +41,8 @@
|
||||
#else
|
||||
int temp = SIGN_EXTEND_CHAR (*(source + 1));
|
||||
*dest = *source & 0377;
|
||||
--- grep-2.5.1/src/dfa.c.i18n 2001-09-26 17:57:55.000000000 +0100
|
||||
+++ grep-2.5.1/src/dfa.c 2004-02-26 13:09:54.000000000 +0000
|
||||
--- grep-2.5.1/src/dfa.c 2004-02-26 13:09:54.000000000 +0000
|
||||
+++ grep-2.5.1/src/dfa.c 2004-05-18 16:43:31.189200479 +0100
|
||||
@@ -414,7 +414,7 @@
|
||||
|
||||
/* This function fetch a wide character, and update cur_mb_len,
|
||||
@ -83,8 +83,8 @@
|
||||
work_mbc->coll_elems[work_mbc->ncoll_elems++] = elem;
|
||||
}
|
||||
}
|
||||
- wc = -1;
|
||||
+ wc = WEOF;
|
||||
- wc1 = wc = -1;
|
||||
+ wc1 = wc = WEOF;
|
||||
}
|
||||
else
|
||||
/* We treat '[' as a normal character here. */
|
||||
@ -119,6 +119,15 @@
|
||||
}
|
||||
}
|
||||
while ((wc = wc1) != L']');
|
||||
@@ -2552,6 +2552,8 @@
|
||||
}
|
||||
|
||||
/* match with a character? */
|
||||
+ if (case_fold)
|
||||
+ wc = towlower (wc);
|
||||
for (i = 0; i<work_mbc->nchars; i++)
|
||||
{
|
||||
if (wc == work_mbc->chars[i])
|
||||
--- grep-2.5.1/src/grep.c.i18n 2002-03-26 15:54:12.000000000 +0000
|
||||
+++ grep-2.5.1/src/grep.c 2004-02-26 13:09:54.000000000 +0000
|
||||
@@ -30,6 +30,12 @@
|
||||
|
@ -4,8 +4,8 @@
|
||||
work_mbc->coll_elems[work_mbc->ncoll_elems++] = elem;
|
||||
}
|
||||
}
|
||||
- wc = WEOF;
|
||||
+ wc1 = wc = WEOF;
|
||||
- wc = -1;
|
||||
+ wc1 = wc = -1;
|
||||
}
|
||||
else
|
||||
/* We treat '[' as a normal character here. */
|
||||
|
40
grep.spec
40
grep.spec
@ -1,22 +1,16 @@
|
||||
%define beta %nil
|
||||
%define rel 26
|
||||
Summary: The GNU versions of grep pattern matching utilities.
|
||||
Name: grep
|
||||
Version: 2.5.1
|
||||
%if "%{beta}" != ""
|
||||
Release: 5.%{beta}.%{rel}
|
||||
%else
|
||||
Release: %{rel}
|
||||
%endif
|
||||
Release: 28
|
||||
License: GPL
|
||||
Group: Applications/Text
|
||||
Source: ftp://ftp.gnu.org/pub/gnu/grep/grep-%{version}%{beta}.tar.bz2
|
||||
Source: ftp://ftp.gnu.org/pub/gnu/grep/grep-%{version}.tar.bz2
|
||||
Patch0: grep-2.5.1-fgrep.patch
|
||||
Patch1: grep-2.5-i18n.patch
|
||||
Patch2: grep-2.5.1-oi.patch
|
||||
Patch3: grep-2.5.1-manpage.patch
|
||||
Patch4: grep-2.5.1-gofast.patch
|
||||
Patch5: grep-2.5.1-bracket.patch
|
||||
Patch1: grep-2.5.1-bracket.patch
|
||||
Patch2: grep-2.5-i18n.patch
|
||||
Patch3: grep-2.5.1-oi.patch
|
||||
Patch4: grep-2.5.1-manpage.patch
|
||||
Patch5: grep-2.5.1-gofast.patch
|
||||
Prefix: %{_prefix}
|
||||
Prereq: /sbin/install-info
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||
@ -33,13 +27,13 @@ You should install grep on your system, because it is a very useful
|
||||
utility for searching through text.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{beta}
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p1 -b .fgrep
|
||||
%patch1 -p1 -b .i18n
|
||||
%patch2 -p1 -b .oi
|
||||
%patch3 -p1 -b .manpage
|
||||
%patch4 -p1 -b .gofast
|
||||
%patch5 -p1 -b .bracket
|
||||
%patch1 -p1 -b .bracket
|
||||
%patch2 -p1 -b .i18n
|
||||
%patch3 -p1 -b .oi
|
||||
%patch4 -p1 -b .manpage
|
||||
%patch5 -p1 -b .gofast
|
||||
|
||||
%build
|
||||
[ ! -e configure ] && ./autogen.sh
|
||||
@ -87,6 +81,14 @@ fi
|
||||
%{_mandir}/*/*
|
||||
|
||||
%changelog
|
||||
* Tue May 18 2004 Jeremy Katz <katzj@redhat.com> 2.5.1-28
|
||||
- rebuild
|
||||
|
||||
* Tue May 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-27
|
||||
- Fix dfa multibyte character class matching when -i is used (bug #123363).
|
||||
- Use bracket patch before i18n patch to make it clear that the bug exists
|
||||
upstream.
|
||||
|
||||
* Thu Feb 26 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-26
|
||||
- Fix fgrep (bug #116909).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user