New version
Related: rhbz#1421129 Updated patches
This commit is contained in:
parent
c232695f40
commit
501f9e6d87
@ -1,8 +1,8 @@
|
|||||||
diff --git a/src/grep.c b/src/grep.c
|
diff --git a/src/grep.c b/src/grep.c
|
||||||
index 8c2054b..ba67e8b 100644
|
index a2de03d..fd1b3a9 100644
|
||||||
--- a/src/grep.c
|
--- a/src/grep.c
|
||||||
+++ b/src/grep.c
|
+++ b/src/grep.c
|
||||||
@@ -1979,17 +1979,20 @@ Output control:\n\
|
@@ -1962,17 +1962,20 @@ Output control:\n\
|
||||||
-D, --devices=ACTION how to handle devices, FIFOs and sockets;\n\
|
-D, --devices=ACTION how to handle devices, FIFOs and sockets;\n\
|
||||||
ACTION is 'read' or 'skip'\n\
|
ACTION is 'read' or 'skip'\n\
|
||||||
-r, --recursive like --directories=recurse\n\
|
-r, --recursive like --directories=recurse\n\
|
||||||
@ -23,8 +23,8 @@ index 8c2054b..ba67e8b 100644
|
|||||||
+ --exclude-dir=PATTERN directories that match PATTERN will be skipped.\n\
|
+ --exclude-dir=PATTERN directories that match PATTERN will be skipped.\n\
|
||||||
"));
|
"));
|
||||||
printf (_("\
|
printf (_("\
|
||||||
- -L, --files-without-match print only names of FILEs containing no match\n\
|
- -L, --files-without-match print only names of FILEs with no selected lines\n\
|
||||||
+ -L, --files-without-match print only names of FILEs containing no match\n\
|
+ -L, --files-without-match print only names of FILEs with no selected lines\n\
|
||||||
-l, --files-with-matches print only names of FILEs containing matches\n\
|
-l, --files-with-matches print only names of FILEs with selected lines\n\
|
||||||
-c, --count print only a count of matching lines per FILE\n\
|
-c, --count print only a count of selected lines per FILE\n\
|
||||||
-T, --initial-tab make tabs line up (if needed)\n\
|
-T, --initial-tab make tabs line up (if needed)\n\
|
@ -1,8 +1,8 @@
|
|||||||
diff --git a/doc/grep.in.1 b/doc/grep.in.1
|
diff --git a/doc/grep.in.1 b/doc/grep.in.1
|
||||||
index e3472f7..28709f7 100644
|
index 40c9586..a4e89eb 100644
|
||||||
--- a/doc/grep.in.1
|
--- a/doc/grep.in.1
|
||||||
+++ b/doc/grep.in.1
|
+++ b/doc/grep.in.1
|
||||||
@@ -327,7 +327,7 @@ Print
|
@@ -335,7 +335,7 @@ Print
|
||||||
.I NUM
|
.I NUM
|
||||||
lines of trailing context after matching lines.
|
lines of trailing context after matching lines.
|
||||||
Places a line containing a group separator
|
Places a line containing a group separator
|
||||||
@ -11,7 +11,7 @@ index e3472f7..28709f7 100644
|
|||||||
between contiguous groups of matches.
|
between contiguous groups of matches.
|
||||||
With the
|
With the
|
||||||
.B \-o
|
.B \-o
|
||||||
@@ -340,7 +340,7 @@ Print
|
@@ -348,7 +348,7 @@ Print
|
||||||
.I NUM
|
.I NUM
|
||||||
lines of leading context before matching lines.
|
lines of leading context before matching lines.
|
||||||
Places a line containing a group separator
|
Places a line containing a group separator
|
||||||
@ -20,7 +20,7 @@ index e3472f7..28709f7 100644
|
|||||||
between contiguous groups of matches.
|
between contiguous groups of matches.
|
||||||
With the
|
With the
|
||||||
.B \-o
|
.B \-o
|
||||||
@@ -353,13 +353,24 @@ Print
|
@@ -361,13 +361,24 @@ Print
|
||||||
.I NUM
|
.I NUM
|
||||||
lines of output context.
|
lines of output context.
|
||||||
Places a line containing a group separator
|
Places a line containing a group separator
|
||||||
@ -47,10 +47,10 @@ index e3472f7..28709f7 100644
|
|||||||
.TP
|
.TP
|
||||||
.BR \-a ", " \-\^\-text
|
.BR \-a ", " \-\^\-text
|
||||||
diff --git a/src/grep.c b/src/grep.c
|
diff --git a/src/grep.c b/src/grep.c
|
||||||
index 81654c3..8c2054b 100644
|
index 8d22aec..a2de03d 100644
|
||||||
--- a/src/grep.c
|
--- a/src/grep.c
|
||||||
+++ b/src/grep.c
|
+++ b/src/grep.c
|
||||||
@@ -2003,6 +2003,8 @@ Context control:\n\
|
@@ -1986,6 +1986,8 @@ Context control:\n\
|
||||||
"));
|
"));
|
||||||
printf (_("\
|
printf (_("\
|
||||||
-NUM same as --context=NUM\n\
|
-NUM same as --context=NUM\n\
|
11
grep.spec
11
grep.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Summary: Pattern matching utilities
|
Summary: Pattern matching utilities
|
||||||
Name: grep
|
Name: grep
|
||||||
Version: 3.0
|
Version: 3.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://www.gnu.org/software/grep/
|
URL: http://www.gnu.org/software/grep/
|
||||||
@ -14,9 +14,9 @@ Source2: colorgrep.csh
|
|||||||
Source3: GREP_COLORS
|
Source3: GREP_COLORS
|
||||||
Source4: grepconf.sh
|
Source4: grepconf.sh
|
||||||
# upstream ticket 39444
|
# upstream ticket 39444
|
||||||
Patch0: grep-2.28-man-fix-gs.patch
|
Patch0: grep-3.31-man-fix-gs.patch
|
||||||
# upstream ticket 39445
|
# upstream ticket 39445
|
||||||
Patch1: grep-2.28-help-align.patch
|
Patch1: grep-3.31-help-align.patch
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
Requires(preun): /sbin/install-info
|
Requires(preun): /sbin/install-info
|
||||||
|
|
||||||
@ -86,6 +86,11 @@ fi
|
|||||||
%{_libexecdir}/grepconf.sh
|
%{_libexecdir}/grepconf.sh
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 3 2017 Jaroslav Škarvada <jskarvad@redhat.com> - 3.1-1
|
||||||
|
- New version
|
||||||
|
Related: rhbz#1421129
|
||||||
|
- Updated patches
|
||||||
|
|
||||||
* Fri Feb 10 2017 Jaroslav Škarvada <jskarvad@redhat.com> - 3.0-1
|
* Fri Feb 10 2017 Jaroslav Škarvada <jskarvad@redhat.com> - 3.0-1
|
||||||
- New version
|
- New version
|
||||||
Resolves: rhbz#1421129
|
Resolves: rhbz#1421129
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (grep-3.0.tar.xz) = 0e9a00df9d492f399230bae0264942edaf64bb926f93edb7922f27b075a86ba0a78698f54996cc522b6261aa01a8ecbeadeb68523d4470a9941f242c3ae24c58
|
SHA512 (grep-3.1.tar.xz) = 05494381c7dd8aad7e2ee4c17450de8d7b969a99dcfe17747db60df3475bf02d5323d091e896e8343e4f3251c29dc7f0b7a9f93c575c9d58ee2a57014c2c9d26
|
||||||
|
Loading…
Reference in New Issue
Block a user