Workaround for FTBFS with glibc-2.37.9000
Signed-off-by: Jaroslav Škarvada <jskarvad@redhat.com>
This commit is contained in:
parent
29a85be178
commit
366db98e1c
68
grep-3.11-gnulib-tests-drop.patch
Normal file
68
grep-3.11-gnulib-tests-drop.patch
Normal file
@ -0,0 +1,68 @@
|
||||
diff --git a/gnulib-tests/Makefile.in b/gnulib-tests/Makefile.in
|
||||
index 3d0ba78..cc01ad9 100644
|
||||
--- a/gnulib-tests/Makefile.in
|
||||
+++ b/gnulib-tests/Makefile.in
|
||||
@@ -188,7 +188,6 @@ TESTS = test-accept$(EXEEXT) test-alignasof$(EXEEXT) \
|
||||
test-strerror_r$(EXEEXT) test-striconv$(EXEEXT) \
|
||||
test-string$(EXEEXT) test-strnlen$(EXEEXT) \
|
||||
test-strstr$(EXEEXT) test-strtoimax$(EXEEXT) \
|
||||
- test-strtoll$(EXEEXT) test-strtoull$(EXEEXT) \
|
||||
test-strtoumax$(EXEEXT) test-symlink$(EXEEXT) \
|
||||
test-sys_ioctl$(EXEEXT) test-sys_select$(EXEEXT) \
|
||||
test-sys_socket$(EXEEXT) test-sys_stat$(EXEEXT) \
|
||||
@@ -284,7 +283,6 @@ check_PROGRAMS = test-accept$(EXEEXT) test-alignasof$(EXEEXT) \
|
||||
test-strerror_r$(EXEEXT) test-striconv$(EXEEXT) \
|
||||
test-string$(EXEEXT) test-strnlen$(EXEEXT) \
|
||||
test-strstr$(EXEEXT) test-strtoimax$(EXEEXT) \
|
||||
- test-strtoll$(EXEEXT) test-strtoull$(EXEEXT) \
|
||||
test-strtoumax$(EXEEXT) test-symlink$(EXEEXT) \
|
||||
test-sys_ioctl$(EXEEXT) test-sys_select$(EXEEXT) \
|
||||
test-sys_socket$(EXEEXT) test-sys_stat$(EXEEXT) \
|
||||
@@ -6381,20 +6379,6 @@ test-strtoimax.log: test-strtoimax$(EXEEXT)
|
||||
--log-file $$b.log --trs-file $$b.trs \
|
||||
$(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
|
||||
"$$tst" $(AM_TESTS_FD_REDIRECT)
|
||||
-test-strtoll.log: test-strtoll$(EXEEXT)
|
||||
- @p='test-strtoll$(EXEEXT)'; \
|
||||
- b='test-strtoll'; \
|
||||
- $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
|
||||
- --log-file $$b.log --trs-file $$b.trs \
|
||||
- $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
|
||||
- "$$tst" $(AM_TESTS_FD_REDIRECT)
|
||||
-test-strtoull.log: test-strtoull$(EXEEXT)
|
||||
- @p='test-strtoull$(EXEEXT)'; \
|
||||
- b='test-strtoull'; \
|
||||
- $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
|
||||
- --log-file $$b.log --trs-file $$b.trs \
|
||||
- $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
|
||||
- "$$tst" $(AM_TESTS_FD_REDIRECT)
|
||||
test-strtoumax.log: test-strtoumax$(EXEEXT)
|
||||
@p='test-strtoumax$(EXEEXT)'; \
|
||||
b='test-strtoumax'; \
|
||||
diff --git a/gnulib-tests/gnulib.mk b/gnulib-tests/gnulib.mk
|
||||
index 3556ae5..06a70c3 100644
|
||||
--- a/gnulib-tests/gnulib.mk
|
||||
+++ b/gnulib-tests/gnulib.mk
|
||||
@@ -1942,22 +1942,6 @@ EXTRA_DIST += test-strtoimax.c signature.h macros.h
|
||||
|
||||
## end gnulib module strtoimax-tests
|
||||
|
||||
-## begin gnulib module strtoll-tests
|
||||
-
|
||||
-TESTS += test-strtoll
|
||||
-check_PROGRAMS += test-strtoll
|
||||
-EXTRA_DIST += test-strtoll.c signature.h macros.h
|
||||
-
|
||||
-## end gnulib module strtoll-tests
|
||||
-
|
||||
-## begin gnulib module strtoull-tests
|
||||
-
|
||||
-TESTS += test-strtoull
|
||||
-check_PROGRAMS += test-strtoull
|
||||
-EXTRA_DIST += test-strtoull.c signature.h macros.h
|
||||
-
|
||||
-## end gnulib module strtoull-tests
|
||||
-
|
||||
## begin gnulib module strtoumax-tests
|
||||
|
||||
TESTS += test-strtoumax
|
@ -15,6 +15,8 @@ Source6: grepconf.sh
|
||||
|
||||
# upstream ticket 39445
|
||||
Patch0: grep-3.5-help-align.patch
|
||||
# upstream ticket 63965, maybe glibc bug, temporal drop of some gnulib tests shouldn't cause any harm
|
||||
Patch1: grep-3.11-gnulib-tests-drop.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: pcre2-devel
|
||||
@ -22,6 +24,10 @@ BuildRequires: texinfo
|
||||
BuildRequires: gettext
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
|
||||
# temporal for the gnulib patch
|
||||
BuildRequires: gettext-devel
|
||||
|
||||
Buildrequires: glibc-all-langpacks
|
||||
BuildRequires: perl(FileHandle)
|
||||
BuildRequires: make
|
||||
@ -58,6 +64,9 @@ GNU grep is needed by many scripts, so it shall be installed on every system.
|
||||
# Temporarily switch to the included regex until glibc bug is fixed:
|
||||
# https://sourceware.org/bugzilla/show_bug.cgi?id=11053
|
||||
#%%configure --without-included-regex --disable-silent-rules \
|
||||
|
||||
# temporal for gnulib patch, remove with the patch
|
||||
autoreconf -fi
|
||||
%configure --disable-silent-rules \
|
||||
CPPFLAGS="-I%{_includedir}/pcre" CFLAGS="%{BUILD_FLAGS}"
|
||||
%make_build
|
||||
|
Loading…
Reference in New Issue
Block a user