New version
Resolves: rhbz#1818417 Added all glibc langpacks to allow more locale sensitive tests to run Added perl-FileHandle requirement for the filename-lineno.pl test
This commit is contained in:
parent
a1aae7177d
commit
02c652ed71
@ -1,8 +1,8 @@
|
|||||||
diff --git a/src/grep.c b/src/grep.c
|
diff --git a/src/grep.c b/src/grep.c
|
||||||
index 5b05969..2384789 100644
|
index 9c0532d..caeece1 100644
|
||||||
--- a/src/grep.c
|
--- a/src/grep.c
|
||||||
+++ b/src/grep.c
|
+++ b/src/grep.c
|
||||||
@@ -1962,7 +1962,8 @@ Output control:\n\
|
@@ -1965,7 +1965,8 @@ Output control:\n\
|
||||||
-D, --devices=ACTION how to handle devices, FIFOs and sockets;\n\
|
-D, --devices=ACTION how to handle devices, FIFOs and sockets;\n\
|
||||||
ACTION is 'read' or 'skip'\n\
|
ACTION is 'read' or 'skip'\n\
|
||||||
-r, --recursive like --directories=recurse\n\
|
-r, --recursive like --directories=recurse\n\
|
||||||
@ -12,7 +12,7 @@ index 5b05969..2384789 100644
|
|||||||
"));
|
"));
|
||||||
printf (_("\
|
printf (_("\
|
||||||
--include=GLOB search only files that match GLOB (a file pattern)"
|
--include=GLOB search only files that match GLOB (a file pattern)"
|
||||||
@@ -1972,7 +1973,7 @@ Output control:\n\
|
@@ -1975,7 +1976,7 @@ Output control:\n\
|
||||||
--exclude-dir=GLOB skip directories that match GLOB\n\
|
--exclude-dir=GLOB skip directories that match GLOB\n\
|
||||||
"));
|
"));
|
||||||
printf (_("\
|
printf (_("\
|
@ -1,8 +1,8 @@
|
|||||||
diff --git a/doc/grep.in.1 b/doc/grep.in.1
|
diff --git a/doc/grep.in.1 b/doc/grep.in.1
|
||||||
index 9d0d494..735b462 100644
|
index 91c0bca..d2cf00a 100644
|
||||||
--- a/doc/grep.in.1
|
--- a/doc/grep.in.1
|
||||||
+++ b/doc/grep.in.1
|
+++ b/doc/grep.in.1
|
||||||
@@ -451,7 +451,7 @@ Print
|
@@ -464,7 +464,7 @@ Print
|
||||||
.I NUM
|
.I NUM
|
||||||
lines of trailing context after matching lines.
|
lines of trailing context after matching lines.
|
||||||
Places a line containing a group separator
|
Places a line containing a group separator
|
||||||
@ -11,7 +11,7 @@ index 9d0d494..735b462 100644
|
|||||||
between contiguous groups of matches.
|
between contiguous groups of matches.
|
||||||
With the
|
With the
|
||||||
.B \-o
|
.B \-o
|
||||||
@@ -464,7 +464,7 @@ Print
|
@@ -477,7 +477,7 @@ Print
|
||||||
.I NUM
|
.I NUM
|
||||||
lines of leading context before matching lines.
|
lines of leading context before matching lines.
|
||||||
Places a line containing a group separator
|
Places a line containing a group separator
|
||||||
@ -20,7 +20,7 @@ index 9d0d494..735b462 100644
|
|||||||
between contiguous groups of matches.
|
between contiguous groups of matches.
|
||||||
With the
|
With the
|
||||||
.B \-o
|
.B \-o
|
||||||
@@ -477,13 +477,24 @@ Print
|
@@ -490,13 +490,24 @@ Print
|
||||||
.I NUM
|
.I NUM
|
||||||
lines of output context.
|
lines of output context.
|
||||||
Places a line containing a group separator
|
Places a line containing a group separator
|
||||||
@ -47,10 +47,10 @@ index 9d0d494..735b462 100644
|
|||||||
.TP
|
.TP
|
||||||
.BR \-a ", " \-\^\-text
|
.BR \-a ", " \-\^\-text
|
||||||
diff --git a/src/grep.c b/src/grep.c
|
diff --git a/src/grep.c b/src/grep.c
|
||||||
index 9fb5e92..5b05969 100644
|
index 7ba602d..9c0532d 100644
|
||||||
--- a/src/grep.c
|
--- a/src/grep.c
|
||||||
+++ b/src/grep.c
|
+++ b/src/grep.c
|
||||||
@@ -1986,6 +1986,8 @@ Context control:\n\
|
@@ -1989,6 +1989,8 @@ Context control:\n\
|
||||||
"));
|
"));
|
||||||
printf (_("\
|
printf (_("\
|
||||||
-NUM same as --context=NUM\n\
|
-NUM same as --context=NUM\n\
|
17
grep.spec
17
grep.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Pattern matching utilities
|
Summary: Pattern matching utilities
|
||||||
Name: grep
|
Name: grep
|
||||||
Version: 3.3
|
Version: 3.4
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://www.gnu.org/software/grep/
|
URL: http://www.gnu.org/software/grep/
|
||||||
|
|
||||||
@ -11,13 +11,14 @@ Source2: colorgrep.csh
|
|||||||
Source3: GREP_COLORS
|
Source3: GREP_COLORS
|
||||||
Source4: grepconf.sh
|
Source4: grepconf.sh
|
||||||
# upstream ticket 39444
|
# upstream ticket 39444
|
||||||
Patch0: grep-3.33-man-fix-gs.patch
|
Patch0: grep-3.4-man-fix-gs.patch
|
||||||
# upstream ticket 39445
|
# upstream ticket 39445
|
||||||
Patch1: grep-3.33-help-align.patch
|
Patch1: grep-3.4-help-align.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: pcre-devel >= 3.9-10, texinfo, gettext
|
BuildRequires: pcre-devel >= 3.9-10, texinfo, gettext
|
||||||
BuildRequires: autoconf automake
|
BuildRequires: autoconf automake glibc-all-langpacks
|
||||||
|
BuildRequires: perl-FileHandle
|
||||||
# https://fedorahosted.org/fpc/ticket/174
|
# https://fedorahosted.org/fpc/ticket/174
|
||||||
Provides: bundled(gnulib)
|
Provides: bundled(gnulib)
|
||||||
# for backward compatibility (rhbz#1540485)
|
# for backward compatibility (rhbz#1540485)
|
||||||
@ -78,6 +79,12 @@ make check
|
|||||||
%{_libexecdir}/grepconf.sh
|
%{_libexecdir}/grepconf.sh
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 1 2020 Jaroslav Škarvada <jskarvad@redhat.com> - 3.4-1
|
||||||
|
- New version
|
||||||
|
Resolves: rhbz#1818417
|
||||||
|
- Added all glibc langpacks to allow more locale sensitive tests to run
|
||||||
|
- Added perl-FileHandle requirement for the filename-lineno.pl test
|
||||||
|
|
||||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.3-4
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.3-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (grep-3.3.tar.xz) = e4805dbddf7cd0f0faf412557d408509650c1ccf703bc450f10a3f727c690dbfaa1235aa81939a0e4b7ac6190f88c15ea1fcc562b343d4b4c7550f967aeb15db
|
SHA512 (grep-3.4.tar.xz) = 0f1506bd19971fbdcb47a111277ca63e8ad045456f096980852fd0a61c860f29f4b369bbaaa5cbce4b0a81718e3e3274d9a078b491f2109baa9a02ce600ee206
|
||||||
|
Loading…
Reference in New Issue
Block a user