import CS greenboot-0.15.8-3.el9

This commit is contained in:
eabdullin 2025-03-11 07:23:36 +00:00
parent 339e08b413
commit 8014d53711
4 changed files with 183 additions and 67 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/v0.15.4.tar.gz SOURCES/v0.15.8.tar.gz

View File

@ -1 +1 @@
2e9791bf98c5f1ac57c2ddf7be4dc04d59a9a6f3 SOURCES/v0.15.4.tar.gz e3baf0b7e2691ec941da8ce4cc7d274db3bcf031 SOURCES/v0.15.8.tar.gz

View File

@ -0,0 +1,59 @@
From 8c9163b8b3c68835c46420fd373f51dbf27ad1a6 Mon Sep 17 00:00:00 2001
From: Antonio Murdaca <antoniomurdaca@gmail.com>
Date: Thu, 20 Feb 2025 11:21:27 +0100
Subject: [PATCH] add RELEASING.md
Signed-off-by: Antonio Murdaca <antoniomurdaca@gmail.com>
---
RELEASING.md | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
create mode 100644 RELEASING.md
diff --git a/RELEASING.md b/RELEASING.md
new file mode 100644
index 0000000..7320b34
--- /dev/null
+++ b/RELEASING.md
@@ -0,0 +1,39 @@
+Releasing a new version
+=======================
+
+We will use the `v0.15.8` release [#202](https://github.com/fedora-iot/greenboot/pull/202) as an example of how to release a new
+greenboot version:
+
+* Fork the repo and create a new branch for the new release:
+
+ ```bash
+ gh repo fork fedora-iot/greenboot --clone --remote
+ git pull upstream main
+ git checkout -b prepare-v0.15.8
+ ```
+
+* Update the `greenboot.spec` file and set the new version: `rpmdev-bumpspec -n 0.15.8 greenboot.spec`
+* Update anything required for the new RPM
+* Update the changelog section of the spec file
+* Commit all the changes and create a PR (see #738 with all the changes described
+above):
+
+ ```bash
+ git add greenboot.spec # add anything else needed
+ git commit -s -m "chore: bump for 0.15.8 release" -m "Prepare for the 0.15.8 release."
+ gh pr create
+ ```
+
+* Once all the tests pass and the PR is merged, tag and sign the release:
+
+ ```bash
+ git tag -a -s v0.15.8
+ git push upstream v0.15.8
+ ```
+
+* Using the webui, open the [Releases](https://github.com/fedora-iot/greenboot/releases)
+page and click the "Draft a new release" button in the middle of the page. From
+there you can choose the `v0.15.8` tag you created in the previous step.
+ * Use the version as the "Release title" and keep the format i.e. "v0.15.8".
+ * In the description add in any release notes or click "Generate release notes".
+ When satisfied, click the "Save draft" or "Publish release" button at the bottom of the page.
--
2.48.1

View File

@ -1,10 +1,10 @@
%global debug_package %{nil} %global debug_package %{nil}
Name: greenboot Name: greenboot
Version: 0.15.4 Version: 0.15.8
Release: 1%{?dist} Release: 3%{?dist}
Summary: Generic Health Check Framework for systemd Summary: Generic Health Check Framework for systemd
License: LGPLv2+ License: LGPL-2.1-or-later
%global repo_owner fedora-iot %global repo_owner fedora-iot
%global repo_name %{name} %global repo_name %{name}
@ -12,16 +12,23 @@ License: LGPLv2+
URL: https://github.com/%{repo_owner}/%{repo_name} URL: https://github.com/%{repo_owner}/%{repo_name}
Source0: https://github.com/%{repo_owner}/%{repo_name}/archive/%{repo_tag}.tar.gz Source0: https://github.com/%{repo_owner}/%{repo_name}/archive/%{repo_tag}.tar.gz
# add RELEASING.md
# Author: Antonio Murdaca <antoniomurdaca@gmail.com>
Patch0001: 0001-add-RELEASING.md.patch
%if 0%{?fedora} || 0%{?rhel} >= 10
ExcludeArch: s390x %{ix86}
%else
ExcludeArch: s390x ExcludeArch: s390x
%endif
BuildRequires: systemd-rpm-macros BuildRequires: systemd-rpm-macros
%{?systemd_requires} %{?systemd_requires}
Requires: systemd Requires: systemd >= 240
Requires: grub2-tools-minimal Requires: grub2-tools-minimal
Requires: rpm-ostree Requires: rpm-ostree
# PAM is required to programatically read motd messages from /etc/motd.d/* # PAM is required to programatically read motd messages from /etc/motd.d/*
# This causes issues with RHEL-8 as the fix isn't there an el8 is on pam-1.3.x # This causes issues with RHEL-8 as the fix isn't there an el8 is on pam-1.3.x
Requires: pam Requires: pam >= 1.4.0
# While not strictly necessary to generate the motd, the main use-case of this package is to display it on SSH login # While not strictly necessary to generate the motd, the main use-case of this package is to display it on SSH login
Recommends: openssh Recommends: openssh
Provides: greenboot-auto-update-fallback Provides: greenboot-auto-update-fallback
@ -50,7 +57,7 @@ Obsoletes: greenboot-update-platforms-check <= 0.12.0
%{summary}. %{summary}.
%prep %prep
%setup -q %autosetup
%build %build
@ -77,6 +84,7 @@ install -DpZm 0644 usr/lib/tmpfiles.d/greenboot-status-motd.conf %{buildroot}%{_
install -DpZm 0755 usr/lib/greenboot/check/required.d/* %{buildroot}%{_prefix}/lib/%{name}/check/required.d install -DpZm 0755 usr/lib/greenboot/check/required.d/* %{buildroot}%{_prefix}/lib/%{name}/check/required.d
install -DpZm 0755 usr/lib/greenboot/check/wanted.d/* %{buildroot}%{_prefix}/lib/%{name}/check/wanted.d install -DpZm 0755 usr/lib/greenboot/check/wanted.d/* %{buildroot}%{_prefix}/lib/%{name}/check/wanted.d
install -DpZm 0644 etc/greenboot/greenboot.conf %{buildroot}%{_sysconfdir}/%{name}/greenboot.conf install -DpZm 0644 etc/greenboot/greenboot.conf %{buildroot}%{_sysconfdir}/%{name}/greenboot.conf
install -DpZm 0644 etc/grub.d/greenboot.cfg %{buildroot}%{_sysconfdir}/grub.d/greenboot.cfg
%post %post
%systemd_post greenboot-healthcheck.service %systemd_post greenboot-healthcheck.service
@ -89,6 +97,9 @@ install -DpZm 0644 etc/greenboot/greenboot.conf %{buildroot}%{_sysconfdir}/%{nam
%systemd_post greenboot-grub2-set-success.service %systemd_post greenboot-grub2-set-success.service
%systemd_post greenboot-rpm-ostree-grub2-check-fallback.service %systemd_post greenboot-rpm-ostree-grub2-check-fallback.service
%systemd_post redboot-auto-reboot.service %systemd_post redboot-auto-reboot.service
if [ -d /usr/lib/bootupd/grub2-static/configs.d ]; then
cp /etc/grub.d/greenboot.cfg /usr/lib/bootupd/grub2-static/configs.d
fi
%post default-health-checks %post default-health-checks
%systemd_post greenboot-loading-message.service %systemd_post greenboot-loading-message.service
@ -117,21 +128,23 @@ install -DpZm 0644 etc/greenboot/greenboot.conf %{buildroot}%{_sysconfdir}/%{nam
%systemd_postun greenboot-grub2-set-counter.service %systemd_postun greenboot-grub2-set-counter.service
%systemd_postun greenboot-grub2-set-success.service %systemd_postun greenboot-grub2-set-success.service
%systemd_postun greenboot-rpm-ostree-grub2-check-fallback.service %systemd_postun greenboot-rpm-ostree-grub2-check-fallback.service
if [ -f /usr/lib/bootupd/grub2-static/configs.d/greenboot.cfg ]; then
rm -f /usr/lib/bootupd/grub2-static/configs.d/greenboot.cfg
fi
%postun default-health-checks %postun default-health-checks
%systemd_postun greenboot-loading-message.service %systemd_postun greenboot-loading-message.service
%files %files
%doc README.md
%license LICENSE %license LICENSE
%dir %{_libexecdir}/%{name} %doc README.md
%{_libexecdir}/%{name}/%{name} %dir %{_sysconfdir}/%{name}
%{_libexecdir}/%{name}/greenboot-loading-message %dir %{_sysconfdir}/%{name}/check
%{_unitdir}/greenboot-healthcheck.service %dir %{_sysconfdir}/%{name}/check/required.d
%{_unitdir}/greenboot-loading-message.service %dir %{_sysconfdir}/%{name}/check/wanted.d
%{_unitdir}/greenboot-task-runner.service %dir %{_sysconfdir}/%{name}/green.d
%{_unitdir}/redboot-task-runner.service %dir %{_sysconfdir}/%{name}/red.d
%{_unitdir}/redboot.target %config(noreplace) %{_sysconfdir}/%{name}/greenboot.conf
%dir %{_prefix}/lib/%{name} %dir %{_prefix}/lib/%{name}
%dir %{_prefix}/lib/%{name}/check %dir %{_prefix}/lib/%{name}/check
%dir %{_prefix}/lib/%{name}/check/required.d %dir %{_prefix}/lib/%{name}/check/required.d
@ -140,24 +153,28 @@ install -DpZm 0644 etc/greenboot/greenboot.conf %{buildroot}%{_sysconfdir}/%{nam
%{_prefix}/lib/%{name}/check/wanted.d/00_wanted_scripts_start.sh %{_prefix}/lib/%{name}/check/wanted.d/00_wanted_scripts_start.sh
%dir %{_prefix}/lib/%{name}/green.d %dir %{_prefix}/lib/%{name}/green.d
%dir %{_prefix}/lib/%{name}/red.d %dir %{_prefix}/lib/%{name}/red.d
%dir %{_sysconfdir}/%{name}
%dir %{_sysconfdir}/%{name}/check
%dir %{_sysconfdir}/%{name}/check/required.d
%dir %{_sysconfdir}/%{name}/check/wanted.d
%dir %{_sysconfdir}/%{name}/green.d
%dir %{_sysconfdir}/%{name}/red.d
%{_exec_prefix}/lib/motd.d/boot-status %{_exec_prefix}/lib/motd.d/boot-status
%{_libexecdir}/%{name}/greenboot-status
%{_tmpfilesdir}/greenboot-status-motd.conf %{_tmpfilesdir}/greenboot-status-motd.conf
%{_unitdir}/greenboot-status.service %{_sysconfdir}/grub.d/*.cfg
%dir %{_libexecdir}/%{name}
%{_libexecdir}/%{name}/%{name}
%{_libexecdir}/%{name}/greenboot-grub2-set-success
%{_libexecdir}/%{name}/greenboot-boot-remount
%{_libexecdir}/%{name}/greenboot-grub2-set-counter %{_libexecdir}/%{name}/greenboot-grub2-set-counter
%{_unitdir}/greenboot-grub2-set-success.service %{_libexecdir}/%{name}/greenboot-loading-message
%{_unitdir}/greenboot-grub2-set-counter.service %{_libexecdir}/%{name}/greenboot-status
%{_libexecdir}/%{name}/greenboot-rpm-ostree-grub2-check-fallback %{_libexecdir}/%{name}/greenboot-rpm-ostree-grub2-check-fallback
%{_unitdir}/greenboot-rpm-ostree-grub2-check-fallback.service
%{_libexecdir}/%{name}/redboot-auto-reboot %{_libexecdir}/%{name}/redboot-auto-reboot
%{_unitdir}/greenboot-grub2-set-counter.service
%{_unitdir}/greenboot-grub2-set-success.service
%{_unitdir}/greenboot-healthcheck.service
%{_unitdir}/greenboot-loading-message.service
%{_unitdir}/greenboot-status.service
%{_unitdir}/greenboot-task-runner.service
%{_unitdir}/greenboot-rpm-ostree-grub2-check-fallback.service
%{_unitdir}/redboot.target
%{_unitdir}/redboot-auto-reboot.service %{_unitdir}/redboot-auto-reboot.service
%{_sysconfdir}/%{name}/greenboot.conf %{_unitdir}/redboot-task-runner.service
%files default-health-checks %files default-health-checks
%{_prefix}/lib/%{name}/check/required.d/01_repository_dns_check.sh %{_prefix}/lib/%{name}/check/required.d/01_repository_dns_check.sh
@ -166,19 +183,79 @@ install -DpZm 0644 etc/greenboot/greenboot.conf %{buildroot}%{_sysconfdir}/%{nam
%{_prefix}/lib/%{name}/check/required.d/02_watchdog.sh %{_prefix}/lib/%{name}/check/required.d/02_watchdog.sh
%changelog %changelog
* Tue Feb 21 2023 Paul Whalen <pwhalen@fedoraproject.org> - 0.15.4-1 * Fri Feb 28 2025 Antonio Murdaca <antoniomurdaca@gmail.com> - 0.15.8-3
- Update to 0.15.4 - Update to version 0.15.8
- Resolves: rhbz#2170924 - Resolves: RHEL-78244
* Tue Nov 29 2022 Paul Whalen <pwhalen@fedoraproject.org> - 0.15.3-1 * Fri Feb 28 2025 Antonio Murdaca <antoniomurdaca@gmail.com> - 0.15.8-2
- Update to version 0.15.8
- Resolves: RHEL-78244
* Wed Feb 26 2025 Antonio Murdaca <antoniomurdaca@gmail.com> - 0.15.8-1
## What's Changed
* ci: add ci test for pull request by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/164
* ci: add more wait time for fallback by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/167
* ci: fix ansible check failure by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/169
* ci: add test case of bootc anaconda iso by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/171
* test github token by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/174
* update github action by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/177
* Update greenboot-ci.yaml by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/179
* ci: fix iso case failure by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/173
* ci: add support for fedora rawhide by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/181
* ci: fix rahide failure by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/183
* ci: fix podman retry issue by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/185
* ci: add centos-stream-9 support by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/187
* ci: add rhel 9.6 support by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/190
* ci: fix rhel 9.6 anaconda case failure by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/193
* ci: fix secret error by @yih-redhat in https://github.com/fedora-iot/greenboot/pull/195
* specfile: Stop building on ix86 by @travier in https://github.com/fedora-iot/greenboot/pull/197
* rollback: if no bootc, fallback to rpm-ostree by @runcom in https://github.com/fedora-iot/greenboot/pull/199
* fix:fail early for any required script failure by @say-paul in https://github.com/fedora-iot/greenboot/pull/198
* Release 0.15.8 by @runcom in https://github.com/fedora-iot/greenboot/pull/202
## New Contributors
* @travier made their first contribution in https://github.com/fedora-iot/greenboot/pull/197
**Full Changelog**: https://github.com/fedora-iot/greenboot/compare/v0.15.7...v0.15.8
- Resolves: RHEL-78244
* Thu Oct 31 2024 Sayan Paul <paul.sayan@gmail.com> - 0.15.7-1
- Update to 0.15.7
- Reword warning message for disabled checks
- Fixed the issue that boot_counter cannot be unset and some scripts do not have executable permissions
- Packit: only use IoT relevant branches
* Tue Sep 17 2024 saypaul <paul.sayan@gmail.com> - 0.15.6-2
- Update to 0.15.6-2
* Tue Sep 10 2024 Paul Whalen <pwhalen@fedoraproject.org> - 0.15.6-1
- Update to 0.15.6
* Tue Sep 10 2024 Paul Whalen <pwhalen@fedoraproject.org> - 0.15.5-3
- Moved greenboot config to /etc/grub.d.
- %post symlink greenboot.cfg to bootupd if present
- %postun remove symlink from bootupd if present
* Thu Aug 22 2024 Peter Robinson <pbrobinson@fedoraproject.org> - 0.15.5-2
- Reorder files, don't overwrite configs on update
* Fri Aug 16 2024 saypaul <paul.sayan@gmail.com> - 0.15.5-1
- The 0.15.5 release
- Auto-detect image type and use correct rollback
- Support for read only /boot mount
- Warn users of missing disabled healthchecks
- Add feature to disable healthchecks
* Fri Feb 17 2023 Paul Whalen <pwhalen@fedoraproject.org> - 0.15.4-1
- The 0.15.4 release
- Fix update_platforms_check script
* Mon Nov 28 2022 Paul Whalen <pwhalen@fedoraproject.org> - 0.15.3-1
- The 0.15.3 release - The 0.15.3 release
- revert service-monitor - revert service-monitor
* Thu Sep 08 2022 Peter Robinson <pbrobinson@fedoraproject.org> - 0.15.1-3 * Thu Sep 08 2022 Peter Robinson <pbrobinson@fedoraproject.org> - 0.15.2-1
- Avoid running health checks if conditions aren't met - The 0.15.2 release
* Wed Aug 31 2022 Peter Robinson <pbrobinson@fedoraproject.org> - 0.15.1-2
- disable DefaultDependencies to fix cycle error
* Tue Aug 09 2022 Peter Robinson <pbrobinson@fedoraproject.org> - 0.15.1-1 * Tue Aug 09 2022 Peter Robinson <pbrobinson@fedoraproject.org> - 0.15.1-1
- Add conf during installation - Add conf during installation
@ -186,51 +263,31 @@ install -DpZm 0644 etc/greenboot/greenboot.conf %{buildroot}%{_sysconfdir}/%{nam
* Thu Jul 21 2022 Sayan Paul <saypaul@fedoraproject.org> - 0.15.0-1 * Thu Jul 21 2022 Sayan Paul <saypaul@fedoraproject.org> - 0.15.0-1
- The 0.15.0 release - The 0.15.0 release
- Add service-monitor - Add service-monitor
- Resolves: rhbz#2053469
* Tue Jan 18 2022 Peter Robinson <pbrobinson@fedoraproject.org> - 0.14.0-3 * Thu Nov 18 2021 Peter Robinson <pbrobinson@fedoraproject.org> - 0.14.0-1
- Obsolete greenboot-status - The 0.14.0 release
- Add watchdog-triggered boot check
- Ensure all required health checks are run
* Wed Dec 15 2021 Peter Robinson <pbrobinson@redhat.com> - 0.14.0-2 * Wed Nov 10 2021 Peter Robinson <pbrobinson@fedoraproject.org> - 0.13.1-1
- Fix systemd version - Update to 0.13.1
* Thu Nov 18 2021 Packit Service <user-cont-team+packit-service@redhat.com> - 0.14.0-1
- Release 0.14.0 (Peter Robinson)
- Updated testing documentation (Jose Noguera)
- README updated with TOC and improved explanations (Jose Noguera)
- Add watchdog-triggered boot check #2 (Jose Noguera)
- Update specfile and README to reflect changes in subpackage layout. (Jose Noguera)
- Ensure all required health checks are run #52 (Jose Noguera)
* Wed Nov 10 2021 Packit Service <user-cont-team+packit-service@redhat.com> - 0.13.1-1
- tag 0.31.1 (Peter Robinson)
* Mon Jul 26 2021 Jose Noguera <jnoguera@redhat.com> - 0.12.0-1 * Mon Jul 26 2021 Jose Noguera <jnoguera@redhat.com> - 0.12.0-1
- Update to 0.12.0 - Update to 0.12.0
- Add ability to configure maximum number of boot attempts via env var and config file. - Add ability to configure maximum number of boot attempts via env var and config file.
- Add How does it work section to README. - Add How does it work section to README.
- Add CI via GitHub Actions and unit testing with BATS. - Add CI via GitHub Actions and unit testing with BATS.
- Add update platforms DNS resolutiona and connection checker as health checks out of the box - Add update platforms DNS resolution and connection checker as health checks out of the box
* Sat Jan 16 2021 Peter Robinson <pbrobinson@fedoraproject.org> - 0.11.0-2 * Sat Jan 16 2021 Peter Robinson <pbrobinson@fedoraproject.org> - 0.11.0-2
- Make arch specific due to grub availability on s390x - Make arch specific due to grub availability on s390x
- Resolves: rhbz#1915241 - Resolves: rhbz#1915241
* Thu Aug 20 2020 Peter Robinson <pbrobinson@fedoraproject.org> - 0.11-1 * Thu Aug 13 2020 Christian Glombek <lorbus@fedoraproject.org> - 0.11.0-1
- Update to 0.11.0 - Update to 0.11.0
- Resolves: rhbz#1815140
* Thu Jul 23 2020 Peter Robinson <pbrobinson@fedoraproject.org> - 0.10.3-5
- Make package arch specific to work around lack of grub2 on s390x
- Resolves: rhbz#1815140
* Thu Jun 11 2020 Peter Robinson <pbrobinson@fedoraproject.org> - 0.10.3-3
- Make motd status page optional
- Resolves: rhbz#1815140
* Thu Jun 11 2020 Peter Robinson <pbrobinson@fedoraproject.org> - 0.10.3-2 * Thu Jun 11 2020 Peter Robinson <pbrobinson@fedoraproject.org> - 0.10.3-2
- Update changelog - Update changelog
- Resolves: rhbz#1815140
* Fri Jun 05 2020 Christian Glombek <lorbus@fedoraproject.org> - 0.10.3-1 * Fri Jun 05 2020 Christian Glombek <lorbus@fedoraproject.org> - 0.10.3-1
- Update to 0.10.3 - Update to 0.10.3
@ -270,4 +327,4 @@ install -DpZm 0644 etc/greenboot/greenboot.conf %{buildroot}%{_sysconfdir}/%{nam
- Spec Review - Spec Review
* Thu Jun 14 2018 Christian Glombek <lorbus@fedoraproject.org> - 0.4-1 * Thu Jun 14 2018 Christian Glombek <lorbus@fedoraproject.org> - 0.4-1
- Initial Package - Initial Package