New version
Resolves: rhbz#1406954 Dropped rtest-fix, find-fix, ocaml-fix-ints, format-string, vimdot-vi, rbconfig, gs-9.18-fix patches (all upstreamed) Defuzzified visio patch
This commit is contained in:
parent
381967c789
commit
a46ba9827c
@ -1,36 +0,0 @@
|
||||
From 2bd456d77bd035aadff61122868d02291f7898ea Mon Sep 17 00:00:00 2001
|
||||
From: Mattias Ellert <mattias.ellert@fysast.uu.se>
|
||||
Date: Wed, 28 May 2014 07:05:49 +0200
|
||||
Subject: [PATCH] Break infinite recursion that leads to segfault.
|
||||
|
||||
---
|
||||
lib/dotgen/compound.c | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/lib/dotgen/compound.c b/lib/dotgen/compound.c
|
||||
index ac78cd5..7156103 100644
|
||||
--- a/lib/dotgen/compound.c
|
||||
+++ b/lib/dotgen/compound.c
|
||||
@@ -176,6 +176,9 @@ findVertical(pointf * pts, double tmin, double tmax,
|
||||
double t;
|
||||
int no_cross = countVertCross(pts, xcoord);
|
||||
|
||||
+ if (tmin >= tmax)
|
||||
+ return -1.0;
|
||||
+
|
||||
if (no_cross == 0)
|
||||
return -1.0;
|
||||
|
||||
@@ -214,6 +217,9 @@ findHorizontal(pointf * pts, double tmin, double tmax,
|
||||
double t;
|
||||
int no_cross = countHorzCross(pts, ycoord);
|
||||
|
||||
+ if (tmin >= tmax)
|
||||
+ return -1.0;
|
||||
+
|
||||
if (no_cross == 0)
|
||||
return -1.0;
|
||||
|
||||
--
|
||||
1.9.3
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/lib/cgraph/scan.l b/lib/cgraph/scan.l
|
||||
index 87db5d4..4edda50 100644
|
||||
--- a/lib/cgraph/scan.l
|
||||
+++ b/lib/cgraph/scan.l
|
||||
@@ -225,7 +225,7 @@ void yyerror(char *str)
|
||||
agxbput (&xb, buf);
|
||||
agxbput (&xb, yytext);
|
||||
agxbput (&xb,"'\n");
|
||||
- agerr(AGERR,agxbuse(&xb));
|
||||
+ agerr(AGERR, "%s", agxbuse(&xb));
|
||||
agxbfree(&xb);
|
||||
}
|
||||
/* must be here to see flex's macro defns */
|
@ -1,19 +0,0 @@
|
||||
diff --git a/plugin/gs/gvloadimage_gs.c b/plugin/gs/gvloadimage_gs.c
|
||||
index 4ed9b71..53be600 100644
|
||||
--- a/plugin/gs/gvloadimage_gs.c
|
||||
+++ b/plugin/gs/gvloadimage_gs.c
|
||||
@@ -72,11 +72,11 @@ static void gs_error(GVJ_t * job, const char *name, const char *funstr, int err)
|
||||
|
||||
assert (err < 0);
|
||||
|
||||
- if (err >= e_VMerror)
|
||||
+ if (err >= gs_error_VMerror)
|
||||
errsrc = "PostScript Level 1";
|
||||
- else if (err >= e_unregistered)
|
||||
+ else if (err >= gs_error_unregistered)
|
||||
errsrc = "PostScript Level 2";
|
||||
- else if (err >= e_invalidid)
|
||||
+ else if (err >= gs_error_invalidid)
|
||||
errsrc = "DPS error";
|
||||
else
|
||||
errsrc = "Ghostscript internal error";
|
@ -1,11 +0,0 @@
|
||||
--- graphviz-2.38.0.old/tclpkg/gv/Makefile.am 2014-04-13 21:40:25.000000000 +0100
|
||||
+++ graphviz-2.38.0/tclpkg/gv/Makefile.am 2014-08-30 20:56:43.689541154 +0100
|
||||
@@ -115,7 +115,7 @@
|
||||
libgv_ocaml_la_SOURCES = $(BASESOURCES) gv_dummy_init.c
|
||||
libgv_ocaml_la_LIBADD = $(BASELIBS) $(OCAML_LIBS)
|
||||
libgv_ocaml_la_LDFLAGS = -module -avoid-version
|
||||
-libgv_ocaml_la_CPPFLAGS = $(BASECPPFLAGS) $(OCAML_INCLUDES)
|
||||
+libgv_ocaml_la_CPPFLAGS = $(BASECPPFLAGS) $(OCAML_INCLUDES) -Dint64=int64_t
|
||||
gv.ml gv.mli: gv_ocaml.cpp
|
||||
gv_ocaml.cpp: gv.i
|
||||
$(SWIG) -c++ -ocaml -o gv_ocaml.cpp $(srcdir)/gv.i
|
@ -1,11 +0,0 @@
|
||||
--- graphviz-2.38.0/configure.ac.rbconfig 2014-04-14 05:40:25.000000000 +0900
|
||||
+++ graphviz-2.38.0/configure.ac 2015-01-17 03:13:15.341730456 +0900
|
||||
@@ -1587,7 +1587,7 @@
|
||||
if test "x$DARWIN" = "xyes"; then
|
||||
RUBY_CFLAGS=`echo $RUBY_CFLAGS | sed 's/powerpc/universal/'`
|
||||
fi
|
||||
- RUBY_LIBS="-L`$RUBY $srcdir/config/config_ruby.rb lib` `$RUBY -rrbconfig -e \"puts Config::CONFIG[['LIBRUBYARG_SHARED']]\"`"
|
||||
+ RUBY_LIBS="-L`$RUBY $srcdir/config/config_ruby.rb lib` `$RUBY -rrbconfig -e \"puts RbConfig::CONFIG[['LIBRUBYARG_SHARED']]\"`"
|
||||
RUBY_INSTALL_DIR="`$RUBY $srcdir/config/config_ruby.rb vendorarchdir`"
|
||||
if test "x$RUBY_INSTALL_DIR" = "x"; then
|
||||
RUBY_INSTALL_DIR="`$RUBY $srcdir/config/config_ruby.rb sitearchdir`"
|
@ -1,12 +0,0 @@
|
||||
diff -up graphviz-2.38.0/rtest/rtest.sh.origy graphviz-2.38.0/rtest/rtest.sh
|
||||
--- graphviz-2.38.0/rtest/rtest.sh.origy 2014-04-13 22:40:25.000000000 +0200
|
||||
+++ graphviz-2.38.0/rtest/rtest.sh 2014-04-14 15:07:49.113994881 +0200
|
||||
@@ -311,7 +311,7 @@ function doTest
|
||||
|
||||
trap 'rm -f $TMPFILE1 $TMPFILE2 $TMPINFILE errout; exit' 0 1 2 3 15
|
||||
|
||||
-Usage=rrtest [-gvn] [TESTFILE]\n
|
||||
+Usage='rrtest [-gvn] [TESTFILE]\n
|
||||
-g : generate test data\n
|
||||
-v : verbose\n
|
||||
-n : print test'
|
@ -1,12 +0,0 @@
|
||||
diff --git a/plugin/xlib/vimdot.sh b/plugin/xlib/vimdot.sh
|
||||
index 749fe6a..a45927e 100755
|
||||
--- a/plugin/xlib/vimdot.sh
|
||||
+++ b/plugin/xlib/vimdot.sh
|
||||
@@ -4,6 +4,7 @@
|
||||
error() { echo "$0: $*" >&2; exit 1; }
|
||||
|
||||
editor="/usr/bin/vim"
|
||||
+[ -x "$editor" ] || editor="/usr/bin/vi"
|
||||
|
||||
if ! test -x "$editor"; then error "the \"$editor\" editor not found or not executable"; fi
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff --git a/plugin/visio/VisioGraphic.cpp b/plugin/visio/VisioGraphic.cpp
|
||||
index d1df091..b22ec86 100644
|
||||
index 303eac0..14e377c 100644
|
||||
--- a/plugin/visio/VisioGraphic.cpp
|
||||
+++ b/plugin/visio/VisioGraphic.cpp
|
||||
@@ -31,6 +31,8 @@
|
||||
@@ -29,6 +29,8 @@
|
||||
#define isfinite(x) finite(x)
|
||||
#endif
|
||||
|
||||
@ -12,10 +12,10 @@ index d1df091..b22ec86 100644
|
||||
|
||||
#include "gvcjob.h"
|
||||
diff --git a/plugin/visio/VisioText.cpp b/plugin/visio/VisioText.cpp
|
||||
index fad75fc..2b7db1a 100644
|
||||
index 635806c..3c6441a 100644
|
||||
--- a/plugin/visio/VisioText.cpp
|
||||
+++ b/plugin/visio/VisioText.cpp
|
||||
@@ -19,6 +19,7 @@
|
||||
@@ -17,6 +17,7 @@
|
||||
|
||||
#include "gvcjob.h"
|
||||
#include "gvio.h"
|
@ -50,24 +50,13 @@
|
||||
|
||||
Name: graphviz
|
||||
Summary: Graph Visualization Tools
|
||||
Version: 2.38.0
|
||||
Release: 40%{?dist}
|
||||
Version: 2.40.1
|
||||
Release: 1%{?dist}
|
||||
Group: Applications/Multimedia
|
||||
License: EPL
|
||||
URL: http://www.graphviz.org/
|
||||
Source0: http://www.graphviz.org/pub/graphviz/ARCHIVE/%{name}-%{version}.tar.gz
|
||||
# Fix typo in testsuite (upstream ticket #2441).
|
||||
Patch0: graphviz-2.38.0-rtest-fix.patch
|
||||
Patch1: graphviz-2.38.0-find-fix.patch
|
||||
# Not upstream patch to fix build with OCaml > 4.02.0 (upstream) and Fedora.
|
||||
Patch2: graphviz-2.38.0-ocaml-fix-ints.patch
|
||||
# Backported from upstream
|
||||
Patch3: graphviz-2.38.0-format-string.patch
|
||||
# Make vimdot to work with vi (upstream ticket #2507)
|
||||
Patch4: graphviz-2.38.0-vimdot-vi.patch
|
||||
Patch5: graphviz-2.38.0-rbconfig.patch
|
||||
Patch6: graphviz-2.38.0-visio.patch
|
||||
Patch7: graphviz-2.38.0-gs-9.18-fix.patch
|
||||
Patch0: graphviz-2.40.1-visio.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: zlib-devel, libpng-devel, libjpeg-devel, expat-devel, freetype-devel >= 2
|
||||
BuildRequires: ksh, bison, m4, flex, tk-devel, tcl-devel >= 8.3, swig
|
||||
@ -271,15 +260,7 @@ Various tcl packages (extensions) for the graphviz tools.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .rtest-fix
|
||||
%patch1 -p1 -b .find-fix
|
||||
%patch2 -p1
|
||||
%patch3 -p1 -b .format-string
|
||||
%patch4 -p1 -b .vimdot-vi
|
||||
%patch5 -p1 -b .rbconfig
|
||||
# Upstream ticket: http://www.graphviz.org/mantisbt/view.php?id=2553
|
||||
%patch6 -p1 -b .visio
|
||||
%patch7 -p1 -b .gs-9.18-fix
|
||||
%patch0 -p1 -b .visio
|
||||
|
||||
# Attempt to fix rpmlint warnings about executable sources
|
||||
find -type f -regex '.*\.\(c\|h\)$' -exec chmod a-x {} ';'
|
||||
@ -573,10 +554,15 @@ rm -rf %{buildroot}
|
||||
# hack to include gv.3tcl only if available
|
||||
# always includes tcldot.3tcl, gdtclft.3tcl
|
||||
%{_mandir}/man3/*.3tcl*
|
||||
%{_mandir}/man3/tkspline.3tk*
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 2 2017 Jaroslav Škarvada <jskarvad@redhat.com> - 2.40.1-1
|
||||
- New version
|
||||
Resolves: rhbz#1406954
|
||||
- Dropped rtest-fix, find-fix, ocaml-fix-ints, format-string,
|
||||
vimdot-vi, rbconfig, gs-9.18-fix patches (all upstreamed)
|
||||
- Defuzzified visio patch
|
||||
|
||||
* Sat Nov 05 2016 Richard W.M. Jones <rjones@redhat.com> - 2.38.0-40
|
||||
- Rebuild for OCaml 4.04.0.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user