- Patch to fix BZ#237496
- Disabling relocatability to work around BZ#237082 - Disabling -ocaml and -sharp subpackages for ppc64 to remedy BZ#239078
This commit is contained in:
parent
b2964350c8
commit
94d5cdf204
11
graphviz-libcdt.patch
Normal file
11
graphviz-libcdt.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- graphviz-2.12/lib/expr/Makefile.am.orig 2006-09-26 11:47:54.000000000 -0500
|
||||||
|
+++ graphviz-2.12/lib/expr/Makefile.am 2007-05-05 11:49:49.000000000 -0500
|
||||||
|
@@ -34,7 +34,7 @@
|
||||||
|
|
||||||
|
libexpr_la_LDFLAGS = -version-info @VERSION_INFO@
|
||||||
|
libexpr_la_SOURCES = $(libexpr_C_la_SOURCES)
|
||||||
|
-libexpr_la_LIBADD = $(libexpr_C_la_LIBADD)
|
||||||
|
+libexpr_la_LIBADD = $(libexpr_C_la_LIBADD) \
|
||||||
|
$(top_builddir)/lib/cdt/libcdt.la
|
||||||
|
|
||||||
|
$(libexpr_la_OBJECTS): exparse.h exparse.c exgram.h exop.h
|
@ -7,15 +7,17 @@
|
|||||||
#-- graphviz src.rpm --------------------------------------------------------
|
#-- graphviz src.rpm --------------------------------------------------------
|
||||||
Name: graphviz
|
Name: graphviz
|
||||||
Version: 2.12
|
Version: 2.12
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
|
|
||||||
License: CPL
|
License: CPL
|
||||||
URL: http://www.graphviz.org/
|
URL: http://www.graphviz.org/
|
||||||
Source: http://www.graphviz.org/pub/graphviz/ARCHIVE/graphviz-2.12.tar.gz
|
Source: http://www.graphviz.org/pub/graphviz/ARCHIVE/graphviz-2.12.tar.gz
|
||||||
Patch0: %{name}-php5.patch
|
Patch0: %{name}-php5.patch
|
||||||
|
Patch1: %{name}-libcdt.patch
|
||||||
|
|
||||||
# graphviz is relocatable
|
# graphviz is relocatable
|
||||||
Prefix: /usr
|
#Prefix: /usr
|
||||||
|
# not until we can figure out why relocatabilty is broken
|
||||||
|
|
||||||
#-- feature and package selection -------------------------------------------
|
#-- feature and package selection -------------------------------------------
|
||||||
# depends on %dist and %fedora (or %rhl or %rhel) which are set
|
# depends on %dist and %fedora (or %rhl or %rhel) which are set
|
||||||
@ -101,11 +103,14 @@ BuildRequires: xorg-x11-devel
|
|||||||
BuildRequires: libtool-ltdl libtool-ltdl-devel php-devel ruby ruby-devel guile-devel
|
BuildRequires: libtool-ltdl libtool-ltdl-devel php-devel ruby ruby-devel guile-devel
|
||||||
%endif
|
%endif
|
||||||
%if "%fedora" >= "5"
|
%if "%fedora" >= "5"
|
||||||
%define SHARP 1
|
|
||||||
%define JAVA 1
|
%define JAVA 1
|
||||||
%define OCAML 1
|
|
||||||
%define PYTHON 1
|
%define PYTHON 1
|
||||||
BuildRequires: libXaw-devel libSM-devel libICE-devel libXpm-devel libXt-devel libXmu-devel libXext-devel libX11-devel libgcj-devel mono-core ocaml python-devel java-devel
|
BuildRequires: libXaw-devel libSM-devel libICE-devel libXpm-devel libXt-devel libXmu-devel libXext-devel libX11-devel libgcj-devel python-devel java-devel
|
||||||
|
%ifnarch ppc64
|
||||||
|
%define SHARP 1
|
||||||
|
%define OCAML 1
|
||||||
|
BuildRequires: mono-core ocaml
|
||||||
|
%endif
|
||||||
%endif
|
%endif
|
||||||
%if "%fedora" >= "6"
|
%if "%fedora" >= "6"
|
||||||
%define LUA 1
|
%define LUA 1
|
||||||
@ -139,12 +144,12 @@ of graphs (as in nodes and edges, not as in barcharts).
|
|||||||
|
|
||||||
# run "dot -c" to generate plugin config in %{_libdir}/graphviz/config
|
# run "dot -c" to generate plugin config in %{_libdir}/graphviz/config
|
||||||
%post
|
%post
|
||||||
LD_LIBRARY_PATH=$RPM_INSTALL_PREFIX0/%{_lib} $RPM_INSTALL_PREFIX0/bin/dot -c
|
%{_bindir}/dot -c
|
||||||
/sbin/ldconfig
|
/sbin/ldconfig
|
||||||
|
|
||||||
# if there is no dot after everything else is done, the remove config
|
# if there is no dot after everything else is done, the remove config
|
||||||
%postun
|
%postun
|
||||||
if ! test -x $RPM_INSTALL_PREFIX0/bin/dot; then rm -f $RPM_INSTALL_PREFIX0/%{_lib}/graphviz/config; fi
|
if ! test -x %{_bindir}/dot; then rm -f %{_libdir}/graphviz/config; fi
|
||||||
/sbin/ldconfig
|
/sbin/ldconfig
|
||||||
|
|
||||||
#-- graphviz-gd rpm --------------------------------------------------
|
#-- graphviz-gd rpm --------------------------------------------------
|
||||||
@ -161,11 +166,11 @@ graphviz plugin for renderers based on gd
|
|||||||
|
|
||||||
# run "dot -c" to generate plugin config in %{_libdir}/graphviz/config
|
# run "dot -c" to generate plugin config in %{_libdir}/graphviz/config
|
||||||
%post gd
|
%post gd
|
||||||
LD_LIBRARY_PATH=$RPM_INSTALL_PREFIX0/%{_lib} $RPM_INSTALL_PREFIX0/bin/dot -c
|
%{_bindir}/dot -c
|
||||||
|
|
||||||
# if there is not dot after everything else is done, the remove config
|
# if there is not dot after everything else is done, the remove config
|
||||||
%postun gd
|
%postun gd
|
||||||
if ! test -x $RPM_INSTALL_PREFIX0/bin/dot; then rm -f $RPM_INSTALL_PREFIX0/%{_lib}/graphviz/config; fi
|
if ! test -x %{_bindir}/dot; then rm -f %{_libdir}/graphviz/config; fi
|
||||||
|
|
||||||
#-- graphviz-sharp rpm --------------------------------------------
|
#-- graphviz-sharp rpm --------------------------------------------
|
||||||
%if %{SHARP}
|
%if %{SHARP}
|
||||||
@ -397,6 +402,7 @@ Provides some additional PDF and HTML documentation for graphviz.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# XXX ix86 only used to have -ffast-math, let's use everywhere
|
# XXX ix86 only used to have -ffast-math, let's use everywhere
|
||||||
@ -433,6 +439,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
#-- changelog --------------------------------------------------
|
#-- changelog --------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat May 05 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.12-7
|
||||||
|
- Patch to fix BZ#237496
|
||||||
|
- Disabling relocatability to work around BZ#237082
|
||||||
|
- Disabling -ocaml and -sharp subpackages for ppc64 to remedy BZ#239078
|
||||||
|
|
||||||
* Wed Feb 14 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.12-6
|
* Wed Feb 14 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.12-6
|
||||||
- Removed patch, as tcl/tk got rolled back to 8.4
|
- Removed patch, as tcl/tk got rolled back to 8.4
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user