import graphviz-2.40.1-40.el8
This commit is contained in:
commit
83f692ae04
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/graphviz-2.40.1.tar.gz
|
1
.graphviz.metadata
Normal file
1
.graphviz.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
643843f5f48973827906f51bf6a6921701b457d2 SOURCES/graphviz-2.40.1.tar.gz
|
16
SOURCES/graphviz-2.40.1-CVE-2018-10196.patch
Normal file
16
SOURCES/graphviz-2.40.1-CVE-2018-10196.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff --git a/lib/dotgen/conc.c b/lib/dotgen/conc.c
|
||||||
|
--- a/lib/dotgen/conc.c
|
||||||
|
+++ b/lib/dotgen/conc.c
|
||||||
|
@@ -159,7 +159,11 @@ static void rebuild_vlists(graph_t * g)
|
||||||
|
|
||||||
|
for (r = GD_minrank(g); r <= GD_maxrank(g); r++) {
|
||||||
|
lead = GD_rankleader(g)[r];
|
||||||
|
- if (GD_rank(dot_root(g))[r].v[ND_order(lead)] != lead) {
|
||||||
|
+ if (lead == NULL) {
|
||||||
|
+ agerr(AGERR, "rebuiltd_vlists: lead is null for rank %d\n", r);
|
||||||
|
+ longjmp(jbuf, 1);
|
||||||
|
+ }
|
||||||
|
+ else if (GD_rank(dot_root(g))[r].v[ND_order(lead)] != lead) {
|
||||||
|
agerr(AGERR, "rebuiltd_vlists: rank lead %s not in order %d of rank %d\n",
|
||||||
|
agnameof(lead), ND_order(lead), r);
|
||||||
|
longjmp(jbuf, 1);
|
26
SOURCES/graphviz-2.40.1-coverity-scan-fixes.patch
Normal file
26
SOURCES/graphviz-2.40.1-coverity-scan-fixes.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
diff --git a/cmd/lefty/dot2l/dotlex.c b/cmd/lefty/dot2l/dotlex.c
|
||||||
|
index cf738c0..65e17e2 100644
|
||||||
|
--- a/cmd/lefty/dot2l/dotlex.c
|
||||||
|
+++ b/cmd/lefty/dot2l/dotlex.c
|
||||||
|
@@ -252,7 +252,7 @@ static char *scan_token (char *p) {
|
||||||
|
char *q;
|
||||||
|
|
||||||
|
q = lexbuf;
|
||||||
|
- if (p == '\0')
|
||||||
|
+ if (!p || *p == '\0')
|
||||||
|
return NULL;
|
||||||
|
while (isalnum (*p) || (*p == '_') || (!isascii (*p)))
|
||||||
|
*q++ = *p++;
|
||||||
|
diff --git a/cmd/tools/gvgen.c b/cmd/tools/gvgen.c
|
||||||
|
index 662343e..2925d19 100644
|
||||||
|
--- a/cmd/tools/gvgen.c
|
||||||
|
+++ b/cmd/tools/gvgen.c
|
||||||
|
@@ -458,6 +458,8 @@ closeOpen (void)
|
||||||
|
fprintf(opts.outfile, "}\ngraph {\n");
|
||||||
|
}
|
||||||
|
|
||||||
|
+extern void makeTetrix(int depth, edgefn ef);
|
||||||
|
+
|
||||||
|
int main(int argc, char *argv[])
|
||||||
|
{
|
||||||
|
GraphType graphType;
|
22
SOURCES/graphviz-2.40.1-dotty-menu-fix.patch
Normal file
22
SOURCES/graphviz-2.40.1-dotty-menu-fix.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
diff --git a/cmd/dotty/dotty_ui.lefty b/cmd/dotty/dotty_ui.lefty
|
||||||
|
index a8c9116..a708c61 100644
|
||||||
|
--- a/cmd/dotty/dotty_ui.lefty
|
||||||
|
+++ b/cmd/dotty/dotty_ui.lefty
|
||||||
|
@@ -342,7 +342,7 @@ dotty.protovt.normal.uifuncs = [
|
||||||
|
else
|
||||||
|
gt.insertedge (gt, data.pobj, null, data.obj, null, null, 1);
|
||||||
|
};
|
||||||
|
- 'rightdown' = function (data) {
|
||||||
|
+ 'rightup' = function (data) {
|
||||||
|
local vt, gt, menu, i;
|
||||||
|
|
||||||
|
vt = dotty.views[data.widget];
|
||||||
|
@@ -447,7 +447,7 @@ dotty.protovt.birdseye.uifuncs = [
|
||||||
|
'middledown' = dotty.protovt.normal.uifuncs.middledown;
|
||||||
|
'middlemove' = dotty.protovt.normal.uifuncs.middlemove;
|
||||||
|
'middleup' = dotty.protovt.normal.uifuncs.middleup;
|
||||||
|
- 'rightdown' = dotty.protovt.normal.uifuncs.rightdown;
|
||||||
|
+ 'rightup' = dotty.protovt.normal.uifuncs.rightup;
|
||||||
|
'keyup' = dotty.protovt.normal.uifuncs.keyup;
|
||||||
|
'redraw' = dotty.protovt.normal.uifuncs.redraw;
|
||||||
|
'closeview' = dotty.protovt.normal.uifuncs.closeview;
|
58
SOURCES/graphviz-2.40.1-python3.patch
Normal file
58
SOURCES/graphviz-2.40.1-python3.patch
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
diff --git a/config/config_python.py b/config/config_python.py
|
||||||
|
index b747045..2b1ac8d 100644
|
||||||
|
--- a/config/config_python.py
|
||||||
|
+++ b/config/config_python.py
|
||||||
|
@@ -1,12 +1,13 @@
|
||||||
|
+from __future__ import print_function
|
||||||
|
+
|
||||||
|
import sys
|
||||||
|
from distutils import sysconfig
|
||||||
|
|
||||||
|
if sys.argv[1] == "archlib":
|
||||||
|
- print sysconfig.get_python_lib(1,1)
|
||||||
|
+ print(sysconfig.get_python_lib(1,1))
|
||||||
|
elif sys.argv[1] == "lib":
|
||||||
|
- print sysconfig.get_python_lib(0,1)
|
||||||
|
+ print(sysconfig.get_python_lib(0,1))
|
||||||
|
elif sys.argv[1] == "archsitelib":
|
||||||
|
- print sysconfig.get_python_lib(1,0)
|
||||||
|
+ print(sysconfig.get_python_lib(1,0))
|
||||||
|
elif sys.argv[1] == "sitelib":
|
||||||
|
- print sysconfig.get_python_lib(0,0)
|
||||||
|
-
|
||||||
|
+ print(sysconfig.get_python_lib(0,0))
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 51166c3..4d8c9a0 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -1142,7 +1142,7 @@ else
|
||||||
|
if test `$SWIG -help 2>&1 | $EGREP -c '\-python *- Generate'` = 0; then
|
||||||
|
use_python="No (swig does not support -python option)"
|
||||||
|
else
|
||||||
|
- AC_CHECK_PROG(PYTHON,python,python)
|
||||||
|
+ AC_CHECK_PROGS(PYTHON,[python3 python])
|
||||||
|
if test "x$PYTHON" = "x"; then
|
||||||
|
use_python="No (python not available)"
|
||||||
|
else
|
||||||
|
@@ -1167,8 +1167,11 @@ else
|
||||||
|
if test "x$PYTHON" = "x"; then
|
||||||
|
use_python="No (python is too old)"
|
||||||
|
else
|
||||||
|
- PYTHON_PREFIX=`$PYTHON -c "import sys; print sys.prefix"`
|
||||||
|
+ PYTHON_PREFIX=`$PYTHON -c "import sys; print(sys.prefix)"`
|
||||||
|
PYTHON_INCLUDES=-I$PYTHON_PREFIX/include/python$PYTHON_VERSION_SHORT
|
||||||
|
+ if test $PYTHON_VERSION_MAJOR -gt 2; then
|
||||||
|
+ PYTHON_INCLUDES="${PYTHON_INCLUDES}m"
|
||||||
|
+ fi
|
||||||
|
# PYTHON_LIBS="-lpython$PYTHON_VERSION_SHORT"
|
||||||
|
PYTHON_LIBS="-undefined dynamic_lookup"
|
||||||
|
PYTHON_INSTALL_DIR="`$PYTHON $srcdir/config/config_python.py archsitelib`"
|
||||||
|
@@ -1548,7 +1551,7 @@ else
|
||||||
|
if test "x$PYTHON34" = "x"; then
|
||||||
|
use_python34="No (python34 is too old)"
|
||||||
|
else
|
||||||
|
- PYTHON34_PREFIX=`$PYTHON3 -c "import sys; print sys.prefix"`
|
||||||
|
+ PYTHON34_PREFIX=`$PYTHON3 -c "import sys; print(sys.prefix)"`
|
||||||
|
# PYTHON34_INCLUDES=-I$PYTHON34_PREFIX/include/python$PYTHON34_VERSION_SHORT
|
||||||
|
# FIXME - whats the stupid "m" for?
|
||||||
|
PYTHON34_INCLUDES=-I/usr/include/python3.4m
|
25
SOURCES/graphviz-2.40.1-visio.patch
Normal file
25
SOURCES/graphviz-2.40.1-visio.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
diff --git a/plugin/visio/VisioGraphic.cpp b/plugin/visio/VisioGraphic.cpp
|
||||||
|
index 303eac0..14e377c 100644
|
||||||
|
--- a/plugin/visio/VisioGraphic.cpp
|
||||||
|
+++ b/plugin/visio/VisioGraphic.cpp
|
||||||
|
@@ -29,6 +29,8 @@
|
||||||
|
#define isfinite(x) finite(x)
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include <cstdlib>
|
||||||
|
+
|
||||||
|
#include "VisioGraphic.h"
|
||||||
|
|
||||||
|
#include "gvcjob.h"
|
||||||
|
diff --git a/plugin/visio/VisioText.cpp b/plugin/visio/VisioText.cpp
|
||||||
|
index 635806c..3c6441a 100644
|
||||||
|
--- a/plugin/visio/VisioText.cpp
|
||||||
|
+++ b/plugin/visio/VisioText.cpp
|
||||||
|
@@ -17,6 +17,7 @@
|
||||||
|
|
||||||
|
#include "gvcjob.h"
|
||||||
|
#include "gvio.h"
|
||||||
|
+#include <cstdlib>
|
||||||
|
#include <string.h>
|
||||||
|
|
||||||
|
extern "C" char *xml_string(char* str);
|
1220
SPECS/graphviz.spec
Normal file
1220
SPECS/graphviz.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user