New version
Resolves: rhbz#991752 - Dropped guile2-fix, cgraph, lua-52, smyrna-doc-opt, gv2gml-options-fix, lefty-help, prune-help, man-fix patches (all upstreamed)
This commit is contained in:
parent
805d66008d
commit
80d1f22da8
@ -1,27 +0,0 @@
|
||||
diff -up graphviz-2.30.1/configure.ac.orig graphviz-2.30.1/configure.ac
|
||||
--- graphviz-2.30.1/configure.ac.orig 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/configure.ac 2013-02-15 11:43:17.794608767 +0100
|
||||
@@ -710,7 +710,7 @@ else
|
||||
GUILE_LIBS=
|
||||
# don't die if PKG_CHECK_MODULES not available - el4, el5
|
||||
PKG_CHECK_MODULES([GUILE],
|
||||
- [guile >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"],
|
||||
+ [guile-2.0 >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"],
|
||||
GUILE_INCLUDES="$GUILE_CFLAGS",
|
||||
[
|
||||
PKG_CHECK_MODULES([GUILE],
|
||||
diff -up graphviz-2.30.1/configure.orig graphviz-2.30.1/configure
|
||||
--- graphviz-2.30.1/configure.orig 2013-02-15 11:44:09.552556536 +0100
|
||||
+++ graphviz-2.30.1/configure 2013-02-14 14:30:22.000000000 +0100
|
||||
@@ -21028,9 +21028,9 @@ else
|
||||
_pkg_short_errors_supported=no
|
||||
fi
|
||||
if test $_pkg_short_errors_supported = yes; then
|
||||
- GUILE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "guile >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"" 2>&1`
|
||||
+ GUILE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "guile-2.0 >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"" 2>&1`
|
||||
else
|
||||
- GUILE_PKG_ERRORS=`$PKG_CONFIG --print-errors "guile >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"" 2>&1`
|
||||
+ GUILE_PKG_ERRORS=`$PKG_CONFIG --print-errors "guile-2.0 >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"" 2>&1`
|
||||
fi
|
||||
# Put the nasty error message in config.log where it belongs
|
||||
echo "$GUILE_PKG_ERRORS" >&5
|
@ -1,12 +0,0 @@
|
||||
diff -up graphviz-2.30.1/cmd/tools/gv2gml.c.orig5 graphviz-2.30.1/cmd/tools/gv2gml.c
|
||||
--- graphviz-2.30.1/cmd/tools/gv2gml.c.orig5 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/cmd/tools/gv2gml.c 2013-07-11 13:54:56.661096922 +0200
|
||||
@@ -712,7 +712,7 @@ static void initargs(int argc, char **ar
|
||||
|
||||
CmdName = cmdName(argv[0]);
|
||||
opterr = 0;
|
||||
- while ((c = getopt(argc, argv, ":io:")) != -1) {
|
||||
+ while ((c = getopt(argc, argv, "o:")) != -1) {
|
||||
switch (c) {
|
||||
case 'o':
|
||||
outFile = openFile(optarg, "w");
|
@ -1,11 +0,0 @@
|
||||
diff -up graphviz-2.30.1/lib/gvc/libgvc.pc.in.cgraph graphviz-2.30.1/lib/gvc/libgvc.pc.in
|
||||
--- graphviz-2.30.1/lib/gvc/libgvc.pc.in.cgraph 2013-04-23 16:13:09.034471849 -0400
|
||||
+++ graphviz-2.30.1/lib/gvc/libgvc.pc.in 2013-04-23 16:13:12.209471736 -0400
|
||||
@@ -7,6 +7,6 @@ plugins=@GVPLUGIN_VERSION@
|
||||
Name: libgvc
|
||||
Description: The GraphVizContext library
|
||||
Version: @VERSION@
|
||||
-Libs: -L${libdir} -lgvc -lgraph -lcdt
|
||||
+Libs: -L${libdir} -lgvc -lcgraph -lcdt
|
||||
Cflags: -I${includedir}
|
||||
|
@ -1,82 +0,0 @@
|
||||
diff -up graphviz-2.30.1/cmd/lefty/lefty.c.orig8 graphviz-2.30.1/cmd/lefty/lefty.c
|
||||
--- graphviz-2.30.1/cmd/lefty/lefty.c.orig8 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/cmd/lefty/lefty.c 2013-07-12 12:46:23.730664708 +0200
|
||||
@@ -86,6 +86,8 @@ static void processargs (int, char **);
|
||||
static void processstr (char *);
|
||||
static void printusage (void);
|
||||
|
||||
+static char *cmd;
|
||||
+
|
||||
#if defined(FEATURE_X11) || defined(FEATURE_NONE)
|
||||
|
||||
int main (int argc, char **argv) {
|
||||
@@ -100,6 +102,8 @@ int main (int argc, char **argv) {
|
||||
stime = time (NULL);
|
||||
#endif
|
||||
|
||||
+ cmd = argv[0];
|
||||
+
|
||||
idlerunmode = 0;
|
||||
exprstr = NULL;
|
||||
fp = NULL;
|
||||
@@ -393,6 +397,25 @@ static int processinput (int waitflag) {
|
||||
return rtn;
|
||||
}
|
||||
|
||||
+static char* usestr =
|
||||
+" acceptable options are:\n\
|
||||
+ -x - exit after processing the input file.\n\
|
||||
+ -e E - parse and execute expression E.\n\
|
||||
+ -el N - set error reporting level. (0)\n\
|
||||
+ -sd N - how much of the stack to show if error is printed. (2)\n\
|
||||
+ -sb N - how much of each function in the stack show if error is printed. (2)\n\
|
||||
+ -df S - set default font.\n\
|
||||
+ -ps F - specify a default file name for postscript files.\n\
|
||||
+ -? - show help.\n\
|
||||
+ -V - print version.\n";
|
||||
+
|
||||
+static void usage(char *cmd, int eval)
|
||||
+{
|
||||
+ fprintf (stderr, "Usage: %s [options] [file]\n", cmd);
|
||||
+ fputs (usestr, stderr);
|
||||
+ exit (eval);
|
||||
+}
|
||||
+
|
||||
static void processstr (char *buf) {
|
||||
char *words[100];
|
||||
char *s, *s1;
|
||||
@@ -441,11 +466,19 @@ static void processargs (int argc, char
|
||||
fprintf (stderr, "lefty version %s\n", LEFTYVERSION);
|
||||
fprintf (stderr, "graphviz version %s (%s)\n", VERSION, BUILDDATE);
|
||||
}
|
||||
+ else if (strcmp (argv[0], "-?") == 0)
|
||||
+ usage(cmd, 0);
|
||||
else if (strcmp (argv[0], "-") == 0)
|
||||
fp = stdin;
|
||||
+ else if (argv[0][0] == '-') {
|
||||
+ fprintf (stderr, "option %s unrecognized - ignored\n", argv[0]);
|
||||
+ usage (cmd, 1);
|
||||
+ }
|
||||
else {
|
||||
- if ((fp = fopen (argv[0], "r")) == NULL)
|
||||
- panic1 (POS, "main", "cannot open input file: %s", argv[0]);
|
||||
+ if ((fp = fopen (argv[0], "r")) == NULL) {
|
||||
+ fprintf (stderr, "cannot open input file: %s", argv[0]);
|
||||
+ exit(2);
|
||||
+ }
|
||||
}
|
||||
argv++, argc--;
|
||||
}
|
||||
diff -up graphviz-2.30.1/cmd/lefty/lefty.1.orig8 graphviz-2.30.1/cmd/lefty/lefty.1
|
||||
--- graphviz-2.30.1/cmd/lefty/lefty.1.orig8 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/cmd/lefty/lefty.1 2013-07-12 12:48:37.829553144 +0200
|
||||
@@ -115,6 +115,9 @@ call. The default file name is
|
||||
.TP
|
||||
.B -V
|
||||
Prints the version.
|
||||
+.TP
|
||||
+.B -?
|
||||
+Prints the usage and exits.
|
||||
.SH SEE ALSO
|
||||
.I lefty
|
||||
user guide.
|
@ -1,99 +0,0 @@
|
||||
diff -up graphviz-2.30.1/configure.ac.lua-52 graphviz-2.30.1/configure.ac
|
||||
--- graphviz-2.30.1/configure.ac.lua-52 2013-05-15 14:55:05.523513480 -0400
|
||||
+++ graphviz-2.30.1/configure.ac 2013-05-15 14:59:48.628517728 -0400
|
||||
@@ -874,7 +874,7 @@ else
|
||||
if test "x$PKGCONFIG" != "x"; then
|
||||
AC_MSG_CHECKING(for Lua headers and libraries with pkg-config)
|
||||
echo
|
||||
- for l in "$lua_suffix" "" "51" "5.1" "50" "5.0" ; do
|
||||
+ for l in "$lua_suffix" "" "52" "5.2" "51" "5.1" "50" "5.0" ; do
|
||||
pkgconfig_lua_found=`$PKGCONFIG --exists lua$l 2>/dev/null`
|
||||
if test "x$?" == "x0" ; then
|
||||
LUA_VERSION=`$PKGCONFIG --modversion lua$l`
|
||||
@@ -895,7 +895,7 @@ else
|
||||
|
||||
if test "x$LUA_INCLUDES" == "x" -o "x$LUA_LIBS" == "x" ; then
|
||||
LUACONFIG=""
|
||||
- AC_CHECK_PROGS(LUACONFIG, lua-config lua-config51 lua-config5.1 lua-config50 lua-config5.0)
|
||||
+ AC_CHECK_PROGS(LUACONFIG, lua-config lua-config52 lua-config5.2 lua-config51 lua-config5.1 lua-config50 lua-config5.0)
|
||||
if test "x$LUACONFIG" != "x" ; then
|
||||
AC_MSG_CHECKING(for Lua headers and libraries with lua-config)
|
||||
echo
|
||||
@@ -914,39 +914,53 @@ else
|
||||
if test "x$ac_found_lua_header" == "xyes" -a "x$ac_found_liblua_header" == "xyes"; then
|
||||
LUA_INCLUDES="$CFLAGS"
|
||||
fi
|
||||
- for l in "$lua_suffix" "" "51" "5.1" "50" "5.0" ; do
|
||||
- AC_CHECK_LIB(lua$l,lua_call,ac_found_lua_lib="yes",ac_found_lua_lib="no")
|
||||
+ for l in "$lua_suffix" "" "52" "5.2" "51" "5.1" "50" "5.0" ; do
|
||||
+ AC_CHECK_LIB(lua$l,lua_callk,ac_found_lua_lib="yes",ac_found_lua_lib="no")
|
||||
if test "x$ac_found_lua_lib" == "xyes" ; then
|
||||
- LUA_VERSION=">=5.1.0"
|
||||
-
|
||||
- LUA_LIBS="$LDFLAGS -llua$l -lm"
|
||||
-
|
||||
- ac2_save_LDFLAGS="$LDFLAGS"
|
||||
- LDFLAGS="$LDFLAGS -llua$l -lm"
|
||||
-
|
||||
- if echo "$host_os" | grep "^linux" 1>/dev/null 2>&1 ; then
|
||||
- LDFLAGS="$LDFLAGS -ldl"
|
||||
- fi
|
||||
+ LUA_VERSION=">=5.2.0"
|
||||
+
|
||||
+ LUA_LIBS="$LDFLAGS -llua$l -lm"
|
||||
+
|
||||
+ ac2_save_LDFLAGS="$LDFLAGS"
|
||||
+ LDFLAGS="$LDFLAGS -llua$l -lm"
|
||||
+
|
||||
+ if echo "$host_os" | grep "^linux" 1>/dev/null 2>&1 ; then
|
||||
+ LDFLAGS="$LDFLAGS -ldl"
|
||||
+ fi
|
||||
+
|
||||
+ AC_CHECK_LIB(lua$l,lua_call,ac_found_lua_lib="yes",ac_found_lua_lib="no")
|
||||
+ if test "x$ac_found_lua_lib" == "xyes" ; then
|
||||
+ LUA_VERSION=">=5.1.0"
|
||||
|
||||
- AC_CHECK_LIB(lualib$l,luaL_openlib,ac_found_liblua_lib="yes",ac_found_liblua_lib="no")
|
||||
- if test "x$ac_found_liblua_lib" == "xyes" ; then
|
||||
- LUA_VERSION="5.0.x"
|
||||
+ LUA_LIBS="$LDFLAGS -llua$l -lm"
|
||||
|
||||
- LUA_LIBS="$LUA_LFLAGS -llualib$l"
|
||||
+ ac2_save_LDFLAGS="$LDFLAGS"
|
||||
+ LDFLAGS="$LDFLAGS -llua$l -lm"
|
||||
|
||||
- if echo "$host_os" | grep "^linux" 1>/dev/null 2>&1 ; then
|
||||
- LUA_LIBS="$LUA_LFLAGS -ldl"
|
||||
- fi
|
||||
- fi
|
||||
+ if echo "$host_os" | grep "^linux" 1>/dev/null 2>&1 ; then
|
||||
+ LDFLAGS="$LDFLAGS -ldl"
|
||||
+ fi
|
||||
|
||||
- LDFLAGS="$ac2_save_LDFLAGS"
|
||||
- break
|
||||
- fi
|
||||
+ AC_CHECK_LIB(lualib$l,luaL_openlib,ac_found_liblua_lib="yes",ac_found_liblua_lib="no")
|
||||
+ if test "x$ac_found_liblua_lib" == "xyes" ; then
|
||||
+ LUA_VERSION="5.0.x"
|
||||
+
|
||||
+ LUA_LIBS="$LUA_LFLAGS -llualib$l"
|
||||
+
|
||||
+ if echo "$host_os" | grep "^linux" 1>/dev/null 2>&1 ; then
|
||||
+ LUA_LIBS="$LUA_LFLAGS -ldl"
|
||||
+ fi
|
||||
+ fi
|
||||
+
|
||||
+ LDFLAGS="$ac2_save_LDFLAGS"
|
||||
+ break
|
||||
+ fi
|
||||
+ fi
|
||||
done
|
||||
fi
|
||||
|
||||
AC_MSG_CHECKING(for Lua compiling and linking)
|
||||
- LUA_TEST=`LT=luatest.c ; echo "#include <lua.h>" > $LT; echo "#include <lualib.h>" >> $LT; echo "int main() { luaopen_base((lua_State *)lua_open()); return 0; }" >> $LT ; $CC -Wall $LT -o $LT.out $LUA_INCLUDES $LUA_LIBS $CFLAGS $LDFLAGS 1>/dev/null 2>&1 ; echo $?; rm -f $LT $LT.out 1>/dev/null 2>&1`
|
||||
+ LUA_TEST=`LT=luatest.c ; echo "#include <lua.h>" > $LT; echo "#include <lualib.h>" >> $LT; echo "int main() { luaopen_base((lua_State *)luaL_newstate()); return 0; }" >> $LT ; $CC -Wall $LT -o $LT.out $LUA_INCLUDES $LUA_LIBS $CFLAGS $LDFLAGS 1>/dev/null 2>&1 ; echo $?; rm -f $LT $LT.out 1>/dev/null 2>&1`
|
||||
if test "x$LUA_TEST" != "x0" ; then
|
||||
AC_MSG_RESULT(no)
|
||||
AC_MSG_WARN([
|
@ -1,172 +0,0 @@
|
||||
diff -up graphviz-2.30.1/cmd/dot/dot.1.orig2 graphviz-2.30.1/cmd/dot/dot.1
|
||||
--- graphviz-2.30.1/cmd/dot/dot.1.orig2 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/cmd/dot/dot.1 2013-07-09 14:34:22.000000000 +0200
|
||||
@@ -22,6 +22,17 @@ sfdp \- filter for drawing large undirec
|
||||
[\fB\-P\fR]
|
||||
[\fB\-v\fR]
|
||||
[\fB\-V\fR]
|
||||
+[\fB\-Lg\fR]
|
||||
+[\fB\-LO\fR]
|
||||
+[\fB\-Ln\fIiter\fR]
|
||||
+[\fB\-LU\fIfuns\fR]
|
||||
+[\fB\-LC\fIfover\fR]
|
||||
+[\fB\-LT\fR[\fB*\fR]\fIftemp\fR]
|
||||
+[\fB\-c\fR]
|
||||
+[\fB\-m\fR]
|
||||
+[\fB\-q\fIlevel\fR]
|
||||
+[\fB\-s\fIfscale\fR]
|
||||
+[\fB\-y\fR]
|
||||
[files]
|
||||
.br
|
||||
\fBneato\fR
|
||||
@@ -645,6 +656,28 @@ As usual, edge layout is guided by the \
|
||||
.PP
|
||||
\fB\-v\fP (verbose) prints various information useful for debugging.
|
||||
.PP
|
||||
+\fB\-Lg\fP do not use grid.
|
||||
+.PP
|
||||
+\fB\-LO\fP use old attractive force.
|
||||
+.PP
|
||||
+\fB\-Ln\fP\fIiter\fP set number of iterations to \fIiter\fP.
|
||||
+.PP
|
||||
+\fB\-LU\fP\fIfuns\fP set unscaled factor to \fIfuns\fP.
|
||||
+.PP
|
||||
+\fB\-LC\fP\fIfover\fP set overlap expansion factor to \fIfover\fP.
|
||||
+.PP
|
||||
+\fB\-LT\fP[\fB*\fP]\fIftemp\fP set temperature factor to \fIftemp\fP.
|
||||
+.PP
|
||||
+\fB\-c\fP configure plugins (write $prefix/lib/graphviz/config).
|
||||
+.PP
|
||||
+\fB\-m\fP memory test (observe no growth with top, kill when done).
|
||||
+.PP
|
||||
+\fB\-q\fIlevel\fP set level of message suppression, the default is 1.
|
||||
+.PP
|
||||
+\fB\-s\fIfscale\fP scale input by \fIfscale\fP, the default is 72.
|
||||
+.PP
|
||||
+\fB\-y\fR invert y coordinate in output.
|
||||
+.PP
|
||||
\fB\-V\fP (version) prints version information and exits.
|
||||
.PP
|
||||
\fB\-?\fP prints the usage and exits.
|
||||
diff -up graphviz-2.30.1/cmd/dotty/dotty.1.orig3 graphviz-2.30.1/cmd/dotty/dotty.1
|
||||
--- graphviz-2.30.1/cmd/dotty/dotty.1.orig3 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/cmd/dotty/dotty.1 2013-07-11 10:47:53.050605825 +0200
|
||||
@@ -6,6 +6,10 @@ dotty \- A Customizable Graph Editor
|
||||
[
|
||||
.B -V
|
||||
] [
|
||||
+.BI -lm mode
|
||||
+] [
|
||||
+.BI -el lev
|
||||
+] [
|
||||
.I file
|
||||
]
|
||||
.SH DESCRIPTION
|
||||
@@ -48,6 +54,12 @@ window.
|
||||
.TP
|
||||
.B -V
|
||||
Prints the version.
|
||||
+.TP
|
||||
+.BI -lm mode
|
||||
+Sets the layout mode. The \fImode\fP can be \fBsync\fP or \fBasync\fP. The default is \fBasync\fP.
|
||||
+.TP
|
||||
+.BI -el lev
|
||||
+Sets the mesage level. The \fIlev\fP can be \fB0\fP or \fB1\fP. The default is \fB0\fP.
|
||||
.SH BUGS
|
||||
The lefty parser does not accept anonymous graphs.
|
||||
.SH SEE ALSO
|
||||
diff -up graphviz-2.30.1/cmd/gvmap/cluster.1.orig2 graphviz-2.30.1/cmd/gvmap/cluster.1
|
||||
--- graphviz-2.30.1/cmd/gvmap/cluster.1.orig2 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/cmd/gvmap/cluster.1 2013-07-11 10:20:14.181466011 +0200
|
||||
@@ -13,6 +13,9 @@ cluster \- find clusters in a graph and
|
||||
.BI \-C k
|
||||
]
|
||||
[
|
||||
+.BI \-c k
|
||||
+]
|
||||
+[
|
||||
.B \-o
|
||||
.I outfile
|
||||
]
|
||||
@@ -37,6 +40,10 @@ specifies a targeted number of clusters
|
||||
The specified number \fIk\fP is only a suggestion and may not be realisable.
|
||||
If \fIk == 0\fP, the default, the number of clusters that approximately optimizes the modularity is returned.
|
||||
.TP
|
||||
+.BI \-c k
|
||||
+specifies clustering method.
|
||||
+If \fIk == 0\fP, the default, the modularity will be used. If \fIk == 1\fP modularity quality will be used.
|
||||
+.TP
|
||||
.BI \-o outfile
|
||||
Specifies that output should go into the file \fIoutfile\fP. By default,
|
||||
\fIstdout\fP is used.
|
||||
diff -up graphviz-2.30.1/cmd/tools/gc.1.orig4 graphviz-2.30.1/cmd/tools/gc.1
|
||||
--- graphviz-2.30.1/cmd/tools/gc.1.orig4 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/cmd/tools/gc.1 2013-07-11 13:36:14.847815612 +0200
|
||||
@@ -4,7 +4,7 @@ gc \- count graph components
|
||||
.SH SYNOPSIS
|
||||
.B gc
|
||||
[
|
||||
-.B \-necCaDUrs?
|
||||
+.B \-necCaDUrsv?
|
||||
]
|
||||
[
|
||||
.I files
|
||||
@@ -50,6 +50,9 @@ Only analyze directed graphs.
|
||||
.B \-U
|
||||
Only analyze undirected graphs.
|
||||
.TP
|
||||
+.B \-v
|
||||
+Verbose output.
|
||||
+.TP
|
||||
.B \-?
|
||||
Print usage information.
|
||||
.LP
|
||||
diff -up graphviz-2.30.1/cmd/tools/gvgen.1.orig6 graphviz-2.30.1/cmd/tools/gvgen.1
|
||||
--- graphviz-2.30.1/cmd/tools/gvgen.1.orig6 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/cmd/tools/gvgen.1 2013-07-11 14:58:56.599050271 +0200
|
||||
@@ -4,7 +4,7 @@ gvgen \- generate graphs
|
||||
.SH SYNOPSIS
|
||||
.B gvgen
|
||||
[
|
||||
-.B \-d?
|
||||
+.B \-dV?
|
||||
]
|
||||
[
|
||||
.BI -i n
|
||||
@@ -198,6 +198,9 @@ Otherwise, the graph is written to stand
|
||||
.B \-d
|
||||
Make the generated graph directed.
|
||||
.TP
|
||||
+.B \-V
|
||||
+Verbose output.
|
||||
+.TP
|
||||
.B \-?
|
||||
Print usage information.
|
||||
.SH "EXIT STATUS"
|
||||
diff -up graphviz-2.30.1/cmd/lneato/lneato.1.orig9 graphviz-2.30.1/cmd/lneato/lneato.1
|
||||
--- graphviz-2.30.1/cmd/lneato/lneato.1.orig9 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/cmd/lneato/lneato.1 2013-07-12 13:24:46.817426092 +0200
|
||||
@@ -6,6 +6,10 @@ lneato \- A Customizable Graph Editor
|
||||
[
|
||||
.B -V
|
||||
] [
|
||||
+.BI -lm mode
|
||||
+] [
|
||||
+.BI -el lev
|
||||
+] [
|
||||
.I file
|
||||
]
|
||||
.SH DESCRIPTION
|
||||
@@ -48,6 +52,12 @@ window.
|
||||
.TP
|
||||
.B -V
|
||||
Prints the version.
|
||||
+.TP
|
||||
+.BI -lm mode
|
||||
+Sets the layout mode. The \fImode\fP can be \fBsync\fP or \fBasync\fP. The default is \fBasync\fP.
|
||||
+.TP
|
||||
+.BI -el lev
|
||||
+Sets the mesage level. The \fIlev\fP can be \fB0\fP or \fB1\fP. The default is \fB0\fP.
|
||||
.SH SEE ALSO
|
||||
neato(1), lefty(1), dotty(1), xdot(3),
|
||||
.br
|
@ -1,45 +0,0 @@
|
||||
diff -up graphviz-2.30.1/contrib/prune/prune.c.orig10 graphviz-2.30.1/contrib/prune/prune.c
|
||||
--- graphviz-2.30.1/contrib/prune/prune.c.orig10 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/contrib/prune/prune.c 2013-07-12 13:35:44.315004975 +0200
|
||||
@@ -128,7 +128,11 @@ int main(int argc, char **argv)
|
||||
break;
|
||||
}
|
||||
case '?':
|
||||
- if (isprint(optopt)) {
|
||||
+ if (optopt == '?')
|
||||
+ {
|
||||
+ help_message(progname);
|
||||
+ exit(EXIT_SUCCESS);
|
||||
+ } else if (isprint(optopt)) {
|
||||
fprintf(stderr, "Unknown option `-%c'.\n", optopt);
|
||||
} else {
|
||||
fprintf(stderr, "Unknown option character `\\x%X'.\n",
|
||||
diff -up graphviz-2.30.1/contrib/prune/prune.1.orig10 graphviz-2.30.1/contrib/prune/prune.1
|
||||
--- graphviz-2.30.1/contrib/prune/prune.1.orig10 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/contrib/prune/prune.1 2013-07-12 13:45:30.544918729 +0200
|
||||
@@ -20,6 +20,12 @@ prune \- Prune directed graphs
|
||||
.BI \-N " attrspec"
|
||||
]
|
||||
[
|
||||
+.B \-v
|
||||
+]
|
||||
+[
|
||||
+.BR \- ( h | ? )
|
||||
+]
|
||||
+[
|
||||
.I files ...
|
||||
]
|
||||
.SH DESCRIPTION
|
||||
@@ -54,6 +60,12 @@ pruned node.
|
||||
.I attrspec
|
||||
is a string of the form
|
||||
.IR attr "=" value.
|
||||
+.TP
|
||||
+.B \-v
|
||||
+Verbose output.
|
||||
+.TP
|
||||
+.BR \-h " "\-?
|
||||
+Prints the usage and exits.
|
||||
|
||||
.SH EXAMPLES
|
||||
An input graph
|
@ -1,17 +0,0 @@
|
||||
diff -up graphviz-2.30.1/cmd/smyrna/Makefile.am.orig2 graphviz-2.30.1/cmd/smyrna/Makefile.am
|
||||
--- graphviz-2.30.1/cmd/smyrna/Makefile.am.orig2 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/cmd/smyrna/Makefile.am 2013-07-09 13:18:30.792483754 +0200
|
||||
@@ -2,10 +2,13 @@
|
||||
## Process this file with automake to produce Makefile.in
|
||||
|
||||
pdfdir = $(pkgdatadir)/doc/pdf
|
||||
+
|
||||
+if WITH_SMYRNA
|
||||
man = smyrna.1
|
||||
pdf = smyrna.1.pdf
|
||||
man_MANS = $(man)
|
||||
pdf_DATA = $(pdf)
|
||||
+endif
|
||||
|
||||
AM_CPPFLAGS = \
|
||||
-DSMYRNA_PATH=\""$(pkgdatadir)/smyrna"\" \
|
@ -1,6 +1,8 @@
|
||||
--- graphviz-2.26.0/rtest/rtest.sh.old 2009-12-06 00:27:49.000000000 +0100
|
||||
+++ graphviz-2.26.0/rtest/rtest.sh 2010-10-22 10:37:42.952893435 +0200
|
||||
@@ -279,14 +279,16 @@
|
||||
diff --git a/rtest/rtest.sh b/rtest/rtest.sh
|
||||
index ad6e14b..94bc044 100755
|
||||
--- a/rtest/rtest.sh
|
||||
+++ b/rtest/rtest.sh
|
||||
@@ -280,14 +280,16 @@ function doTest
|
||||
$testcmd 2> errout
|
||||
RVAL=$?
|
||||
|
@ -1,6 +1,8 @@
|
||||
--- graphviz-2.26.0/lib/gvc/gvconfig.c.old 2009-07-08 17:14:20.000000000 +0200
|
||||
+++ graphviz-2.26.0/lib/gvc/gvconfig.c 2010-10-20 11:51:21.238392202 +0200
|
||||
@@ -471,6 +471,7 @@
|
||||
diff --git a/lib/gvc/gvconfig.c b/lib/gvc/gvconfig.c
|
||||
index dc3d578..0562ae8 100644
|
||||
--- a/lib/gvc/gvconfig.c
|
||||
+++ b/lib/gvc/gvconfig.c
|
||||
@@ -507,6 +507,7 @@ void gvconfig(GVC_t * gvc, boolean rescan)
|
||||
libdir = gvconfig_libdir(gvc);
|
||||
rc = stat(libdir, &libdir_st);
|
||||
if (rc == -1) {
|
||||
@ -8,7 +10,7 @@
|
||||
/* if we fail to stat it then it probably doesn't exist so just fail silently */
|
||||
return;
|
||||
}
|
||||
@@ -485,6 +486,7 @@
|
||||
@@ -521,6 +522,7 @@ void gvconfig(GVC_t * gvc, boolean rescan)
|
||||
if (rescan) {
|
||||
config_rescan(gvc, gvc->config_path);
|
||||
gvc->config_found = TRUE;
|
||||
@ -16,7 +18,7 @@
|
||||
return;
|
||||
}
|
||||
|
||||
@@ -492,6 +494,7 @@
|
||||
@@ -528,6 +530,7 @@ void gvconfig(GVC_t * gvc, boolean rescan)
|
||||
|
||||
rc = stat(gvc->config_path, &config_st);
|
||||
if (rc == -1) {
|
@ -50,33 +50,18 @@
|
||||
|
||||
Name: graphviz
|
||||
Summary: Graph Visualization Tools
|
||||
Version: 2.30.1
|
||||
Release: 14%{?dist}
|
||||
Version: 2.32.0
|
||||
Release: 1%{?dist}
|
||||
Group: Applications/Multimedia
|
||||
License: EPL
|
||||
URL: http://www.graphviz.org/
|
||||
Source0: http://www.graphviz.org/pub/graphviz/ARCHIVE/%{name}-%{version}.tar.gz
|
||||
Patch2: graphviz-2.30.1-guile2-fix.patch
|
||||
# Fix SIGSEGVs on testsuite (#645703).
|
||||
Patch3: graphviz-2.26.0-testsuite-sigsegv-fix.patch
|
||||
Patch1: graphviz-2.32.0-testsuite-sigsegv-fix.patch
|
||||
# Testsuite now do diff check also in case of err output (#645703).
|
||||
Patch4: graphviz-2.26.0-rtest-errout-fix.patch
|
||||
# Now that libgraph is gone, reflect that in libgvc.pc
|
||||
Patch5: graphviz-2.30.1-gvc.pc-no-libgraph.patch
|
||||
# Lua 5.2
|
||||
Patch6: graphviz-2.30.1-lua-5.2.patch
|
||||
# Accepted upstream, ticket #2302
|
||||
Patch7: graphviz-2.30.1-smyrna-doc-opt.patch
|
||||
# Accepted upstream, ticket #2304
|
||||
Patch8: graphviz-2.30.1-gv2gml-options-fix.patch
|
||||
# Sent upstream, ticket #2305
|
||||
Patch9: graphviz-2.30.1-lefty-help.patch
|
||||
# Sent upstream, ticket #2306
|
||||
Patch10: graphviz-2.30.1-prune-help.patch
|
||||
# Sent upstream, ticket #2307
|
||||
Patch11: graphviz-2.30.1-man-fix.patch
|
||||
Patch2: graphviz-2.32.0-rtest-errout-fix.patch
|
||||
# Sent upstream, ticket #2322
|
||||
Patch12: graphviz-2.30.1-perl-fix.patch
|
||||
Patch3: graphviz-2.30.1-perl-fix.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: zlib-devel, libpng-devel, libjpeg-devel, expat-devel, freetype-devel >= 2
|
||||
BuildRequires: ksh, bison, m4, flex, tk-devel, tcl-devel >= 8.3, swig
|
||||
@ -274,17 +259,9 @@ Various tcl packages (extensions) for the graphviz tools.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch2 -p1 -b .guile2-fix
|
||||
%patch3 -p1 -b .testsuite-sigsegv-fix
|
||||
%patch4 -p1 -b .rtest-errout-fix
|
||||
%patch5 -p1 -b .cgraph
|
||||
%patch6 -p1 -b .lua-52
|
||||
%patch7 -p1 -b .smyrna-doc-opt
|
||||
%patch8 -p1 -b .gv2gml-options-fix
|
||||
%patch9 -p1 -b .lefty-help
|
||||
%patch10 -p1 -b .prune-help
|
||||
%patch11 -p1 -b .man-fix
|
||||
%patch12 -p1 -b .perl-fix
|
||||
%patch1 -p1 -b .testsuite-sigsegv-fix
|
||||
%patch2 -p1 -b .rtest-errout-fix
|
||||
%patch3 -p1 -b .perl-fix
|
||||
|
||||
# Attempt to fix rpmlint warnings about executable sources
|
||||
find -type f -regex '.*\.\(c\|h\)$' -exec chmod a-x {} ';'
|
||||
@ -561,6 +538,12 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 19 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.32.0-1
|
||||
- New version
|
||||
Resolves: rhbz#991752
|
||||
- Dropped guile2-fix, cgraph, lua-52, smyrna-doc-opt, gv2gml-options-fix,
|
||||
lefty-help, prune-help, man-fix patches (all upstreamed)
|
||||
|
||||
* Tue Aug 6 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.30.1-14
|
||||
- Used unversioned doc directory
|
||||
Resolves: rhbz#993803
|
||||
|
Loading…
Reference in New Issue
Block a user