Add workaround for some const casting badness in the OCaml bindings.
This commit is contained in:
parent
f691870b67
commit
5461340990
15
graphviz-2.42.2-ocaml-allow-const-cast.patch
Normal file
15
graphviz-2.42.2-ocaml-allow-const-cast.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
--- graphviz-stable_release_2.42.2/tclpkg/gv/Makefile.am 2019-09-12 03:11:30.000000000 +0100
|
||||||
|
+++ graphviz-stable_release_2.42.2.new/tclpkg/gv/Makefile.am 2019-12-06 13:05:44.064150008 +0000
|
||||||
|
@@ -130,7 +130,11 @@
|
||||||
|
libgv_ocaml_la_SOURCES = $(BASESOURCES) gv_dummy_init.c
|
||||||
|
libgv_ocaml_la_LIBADD = $(BASELIBS) $(OCAML_LIBS)
|
||||||
|
libgv_ocaml_la_LDFLAGS = -module -avoid-version
|
||||||
|
-libgv_ocaml_la_CPPFLAGS = $(BASECPPFLAGS) $(OCAML_INCLUDES) -Dint64=int64_t
|
||||||
|
+libgv_ocaml_la_CPPFLAGS = \
|
||||||
|
+ $(BASECPPFLAGS) \
|
||||||
|
+ $(OCAML_INCLUDES) \
|
||||||
|
+ -Dint64=int64_t \
|
||||||
|
+ -fpermissive
|
||||||
|
gv.ml gv.mli: gv_ocaml.cpp
|
||||||
|
gv_ocaml.cpp: gv.i
|
||||||
|
$(SWIG) -c++ -ocaml -o gv_ocaml.cpp $(srcdir)/gv.i
|
@ -73,6 +73,9 @@ Source0: https://gitlab.com/%{name}/%{name}/-/archive/stable_release_%{version}
|
|||||||
# rhbz#1505230
|
# rhbz#1505230
|
||||||
Patch0: graphviz-2.42.2-dotty-menu-fix.patch
|
Patch0: graphviz-2.42.2-dotty-menu-fix.patch
|
||||||
Patch1: graphviz-2.42.2-coverity-scan-fixes.patch
|
Patch1: graphviz-2.42.2-coverity-scan-fixes.patch
|
||||||
|
# Workaround for some const casting badness in the OCaml bindings.
|
||||||
|
# Real fix will need a fix to SWIG.
|
||||||
|
Patch2: graphviz-2.42.2-ocaml-allow-const-cast.patch
|
||||||
BuildRequires: zlib-devel, libpng-devel, libjpeg-devel, expat-devel, freetype-devel >= 2
|
BuildRequires: zlib-devel, libpng-devel, libjpeg-devel, expat-devel, freetype-devel >= 2
|
||||||
BuildRequires: ksh, bison, m4, flex, tk-devel, tcl-devel >= 8.3, swig, sed
|
BuildRequires: ksh, bison, m4, flex, tk-devel, tcl-devel >= 8.3, swig, sed
|
||||||
BuildRequires: fontconfig-devel, libtool-ltdl-devel, ruby-devel, ruby, guile-devel
|
BuildRequires: fontconfig-devel, libtool-ltdl-devel, ruby-devel, ruby, guile-devel
|
||||||
@ -286,6 +289,7 @@ Various tcl packages (extensions) for the graphviz tools.
|
|||||||
%setup -q -n graphviz-stable_release_%{version}
|
%setup -q -n graphviz-stable_release_%{version}
|
||||||
%patch0 -p1 -b .dotty-menu-fix
|
%patch0 -p1 -b .dotty-menu-fix
|
||||||
%patch1 -p1 -b .coverity-scan-fixes
|
%patch1 -p1 -b .coverity-scan-fixes
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
# Attempt to fix rpmlint warnings about executable sources
|
# Attempt to fix rpmlint warnings about executable sources
|
||||||
find -type f -regex '.*\.\(c\|h\)$' -exec chmod a-x {} ';'
|
find -type f -regex '.*\.\(c\|h\)$' -exec chmod a-x {} ';'
|
||||||
|
Loading…
Reference in New Issue
Block a user