import graphviz-2.40.1-44.el8

This commit is contained in:
CentOS Sources 2023-05-16 06:22:00 +00:00 committed by Stepan Oksanichenko
parent 60c18d0334
commit 334bd81414
2 changed files with 22 additions and 1 deletions

View File

@ -0,0 +1,15 @@
diff --git a/cmd/tools/Makefile.am b/cmd/tools/Makefile.am
index 3f81e73..e3a688e 100644
--- a/cmd/tools/Makefile.am
+++ b/cmd/tools/Makefile.am
@@ -157,7 +157,9 @@ gvpack_LDADD = \
$(top_builddir)/lib/ingraphs/libingraphs_C.la \
$(top_builddir)/lib/cgraph/libcgraph.la \
$(top_builddir)/lib/cdt/libcdt.la \
- $(top_builddir)/plugin/neato_layout/libgvplugin_neato_layout.la
+ $(top_builddir)/plugin/neato_layout/libgvplugin_neato_layout_C.la \
+ $(top_builddir)/lib/pathplan/libpathplan_C.la \
+ $(EXPAT_LIBS) $(Z_LIBS) $(GTS_LIBS) $(SOCKET_LIBS) $(IPSEPCOLA_LIBS) $(MATH_LIBS)
if ENABLE_STATIC
gvpack_static_SOURCES = gvpack.c

View File

@ -61,7 +61,7 @@
Name: graphviz
Summary: Graph Visualization Tools
Version: 2.40.1
Release: 43%{?dist}
Release: 44%{?dist}
License: EPL-1.0
URL: http://www.graphviz.org/
# A bit hacking needed due to: https://gitlab.com/graphviz/graphviz/issues/1371
@ -75,6 +75,7 @@ Patch3: graphviz-2.40.1-dotty-menu-fix.patch
Patch4: graphviz-2.40.1-coverity-scan-fixes.patch
Patch5: graphviz-2.40.1-CVE-2020-18032.patch
Patch6: graphviz-2.40.1-makefile-docs-fix.patch
Patch7: graphviz-2.40.1-gvpack-neato-static.patch
BuildRequires: zlib-devel, libpng-devel, libjpeg-devel, expat-devel, freetype-devel >= 2
BuildRequires: ksh, bison, m4, flex, tk-devel, tcl-devel >= 8.3, swig
BuildRequires: fontconfig-devel, libtool-ltdl-devel, ruby-devel, ruby, guile-devel
@ -293,6 +294,7 @@ Various tcl packages (extensions) for the graphviz tools.
%patch4 -p1 -b .coverity-scan-fixes
%patch5 -p1 -b .CVE-2020-18032
%patch6 -p1 -b .makefile-docs-fix
%patch7 -p1 -b .gvpack-neato-static
# Attempt to fix rpmlint warnings about executable sources
find -type f -regex '.*\.\(c\|h\)$' -exec chmod a-x {} ';'
@ -612,6 +614,10 @@ php --no-php-ini \
%{_mandir}/man3/*.3tcl*
%changelog
* Fri Feb 17 2023 Jaroslav Škarvada <jskarvad@redhat.com> - 2.40.1-44
- Fixed gvpack to run
Resolves: rhbz#2061305
* Tue Jun 8 2021 Jaroslav Škarvada <jskarvad@redhat.com> - 2.40.1-43
- Fixed races during pdf documentation build which should build docs correctly
Related: CVE-2020-18032