Added ppc64le support

Resolves: rhbz#1078464
This commit is contained in:
Jaroslav Škarvada 2014-03-19 22:19:29 +01:00
parent 8a174ca0bb
commit 18ec03b9bf
2 changed files with 55 additions and 2 deletions

View File

@ -0,0 +1,46 @@
--- graphviz-2.34.0/configure.ori
+++ graphviz-2.34.0/configure
@@ -3518,7 +3518,7 @@ if test -z "$LIBPOSTFIX"; then
case "${host_os}" in
*linux* )
case "${host_cpu}" in
- aarch64 | powerpc64 | s390x | x86_64 | sparc64 )
+ aarch64 | powerpc64 | powerpc64le | s390x | x86_64 | sparc64 )
LIBPOSTFIX="64"
;;
esac
--- graphviz-2.34.0/configure.ac.ori
+++ graphviz-2.34.0/configure.ac
@@ -102,7 +102,7 @@ if test -z "$LIBPOSTFIX"; then
case "${host_os}" in
*linux* )
case "${host_cpu}" in
- aarch64 | powerpc64 | s390x | x86_64 | sparc64 )
+ aarch64 | powerpc64 | powerpc64le | s390x | x86_64 | sparc64 )
LIBPOSTFIX="64"
;;
esac
--- graphviz-2.34.0/libltdl/config/config.guess.ori
+++ graphviz-2.34.0/libltdl/config/config.guess
@@ -972,6 +972,9 @@ EOF
ppc64:Linux:*:*)
echo powerpc64-unknown-linux-gnu
exit ;;
+ ppc64le:Linux:*:*)
+ echo powerpc64le-unknown-linux-gnu
+ exit ;;
ppc:Linux:*:*)
echo powerpc-unknown-linux-gnu
exit ;;
--- graphviz-2.34.0/config/config.guess.ori
+++ graphviz-2.34.0/config/config.guess
@@ -972,6 +972,9 @@ EOF
ppc64:Linux:*:*)
echo powerpc64-unknown-linux-gnu
exit ;;
+ ppc64le:Linux:*:*)
+ echo powerpc64le-unknown-linux-gnu
+ exit ;;
ppc:Linux:*:*)
echo powerpc-unknown-linux-gnu
exit ;;

View File

@ -1,5 +1,5 @@
# Necessary conditionals
%ifarch ppc64 s390 s390x sparc64 %{arm} alpha aarch64
%ifarch %{power64} s390 s390x sparc64 %{arm} alpha aarch64
%global SHARP 0
%else
%global SHARP 1
@ -52,7 +52,7 @@
Name: graphviz
Summary: Graph Visualization Tools
Version: 2.34.0
Release: 8%{?dist}
Release: 9%{?dist}
Group: Applications/Multimedia
License: EPL
URL: http://www.graphviz.org/
@ -67,6 +67,8 @@ Patch3: graphviz-2.34.0-lefty-getaddrinfo.patch
Patch4: graphviz-2.34.0-CVE-2014-0978-CVE-2014-1235.patch
# Fix chknum overflow (CVE-2014-1236)
Patch5: graphviz-2.34.0-CVE-2014-1236.patch
# ppc64le support
Patch6: graphviz-2.34.0-ppc64le-support.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: zlib-devel, libpng-devel, libjpeg-devel, expat-devel, freetype-devel >= 2
BuildRequires: ksh, bison, m4, flex, tk-devel, tcl-devel >= 8.3, swig
@ -274,6 +276,7 @@ Various tcl packages (extensions) for the graphviz tools.
%patch3 -p1 -b .lefty-getaddrinfo
%patch4 -p1 -b .CVE-2014-0978-CVE-2014-1235
%patch5 -p1 -b .CVE-2014-1236
%patch6 -p1 -b .ppc64le-support
# Attempt to fix rpmlint warnings about executable sources
find -type f -regex '.*\.\(c\|h\)$' -exec chmod a-x {} ';'
@ -562,6 +565,10 @@ rm -rf %{buildroot}
%changelog
* Wed Mar 19 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.34.0-9
- Added ppc64le support
Resolves: rhbz#1078464
* Thu Jan 9 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.34.0-8
- Prevent possible buffer overflow in yyerror()
Resolves: CVE-2014-1235