Update to grafana-6.2.2. Split out built-in datasources to subpackages.
Resolves: bz1685316
This commit is contained in:
parent
4fb10930a4
commit
232ba0e5a2
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,4 @@
|
|||||||
/grafana-6.2.0.tar.gz
|
/grafana-6.2.0.tar.gz
|
||||||
/grafana_webpack-6.2.0.tar.gz
|
/grafana_webpack-6.2.0.tar.gz
|
||||||
|
/grafana-6.2.2.tar.gz
|
||||||
|
/grafana_webpack-6.2.2.tar.gz
|
||||||
|
@ -839,10 +839,10 @@ index 000000000..f97c2a26b
|
|||||||
+
|
+
|
||||||
diff --git a/packaging/rpm/spec/grafana.spec b/packaging/rpm/spec/grafana.spec
|
diff --git a/packaging/rpm/spec/grafana.spec b/packaging/rpm/spec/grafana.spec
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 000000000..93c470fca
|
index 000000000..85f0dd6aa
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/packaging/rpm/spec/grafana.spec
|
+++ b/packaging/rpm/spec/grafana.spec
|
||||||
@@ -0,0 +1,554 @@
|
@@ -0,0 +1,715 @@
|
||||||
+%global grafana_arches %{lua: go_arches = {}
|
+%global grafana_arches %{lua: go_arches = {}
|
||||||
+ for arch in rpm.expand("%{go_arches}"):gmatch("%S+") do
|
+ for arch in rpm.expand("%{go_arches}"):gmatch("%S+") do
|
||||||
+ go_arches[arch] = 1
|
+ go_arches[arch] = 1
|
||||||
@ -861,7 +861,7 @@ index 000000000..93c470fca
|
|||||||
+
|
+
|
||||||
+
|
+
|
||||||
+Name: grafana
|
+Name: grafana
|
||||||
+Version: 6.2.0
|
+Version: 6.2.2
|
||||||
+Release: 1%{?dist}
|
+Release: 1%{?dist}
|
||||||
+Summary: Metrics dashboard and graph editor
|
+Summary: Metrics dashboard and graph editor
|
||||||
+License: ASL 2.0
|
+License: ASL 2.0
|
||||||
@ -897,6 +897,19 @@ index 000000000..93c470fca
|
|||||||
+
|
+
|
||||||
+BuildRequires: systemd, golang, go-srpm-macros
|
+BuildRequires: systemd, golang, go-srpm-macros
|
||||||
+
|
+
|
||||||
|
+Recommends: grafana-cloudwatch = %{version}-%{release}
|
||||||
|
+Recommends: grafana-elasticsearch = %{version}-%{release}
|
||||||
|
+Recommends: grafana-azure-monitor = %{version}-%{release}
|
||||||
|
+Recommends: grafana-graphite = %{version}-%{release}
|
||||||
|
+Recommends: grafana-influxdb = %{version}-%{release}
|
||||||
|
+Recommends: grafana-loki = %{version}-%{release}
|
||||||
|
+Recommends: grafana-mssql = %{version}-%{release}
|
||||||
|
+Recommends: grafana-mysql = %{version}-%{release}
|
||||||
|
+Recommends: grafana-opentsdb = %{version}-%{release}
|
||||||
|
+Recommends: grafana-postgres = %{version}-%{release}
|
||||||
|
+Recommends: grafana-prometheus = %{version}-%{release}
|
||||||
|
+Recommends: grafana-stackdriver = %{version}-%{release}
|
||||||
|
+
|
||||||
+%if 0%{?unbundle_vendor_sources}
|
+%if 0%{?unbundle_vendor_sources}
|
||||||
+# golang build deps. These allow us to unbundle vendor golang source.
|
+# golang build deps. These allow us to unbundle vendor golang source.
|
||||||
+BuildRequires: golang(github.com/aws/aws-sdk-go)
|
+BuildRequires: golang(github.com/aws/aws-sdk-go)
|
||||||
@ -1134,6 +1147,91 @@ index 000000000..93c470fca
|
|||||||
+Graphite, InfluxDB & OpenTSDB.
|
+Graphite, InfluxDB & OpenTSDB.
|
||||||
+
|
+
|
||||||
+
|
+
|
||||||
|
+%package cloudwatch
|
||||||
|
+Requires: %{name} = %{version}-%{release}
|
||||||
|
+Summary: Grafana cloudwatch datasource
|
||||||
|
+
|
||||||
|
+%description cloudwatch
|
||||||
|
+The Grafana cloudwatch datasource.
|
||||||
|
+
|
||||||
|
+%package elasticsearch
|
||||||
|
+Requires: %{name} = %{version}-%{release}
|
||||||
|
+Summary: Grafana elasticsearch datasource
|
||||||
|
+
|
||||||
|
+%description elasticsearch
|
||||||
|
+The Grafana elasticsearch datasource.
|
||||||
|
+
|
||||||
|
+%package azure-monitor
|
||||||
|
+Requires: %{name} = %{version}-%{release}
|
||||||
|
+Summary: Grafana azure-monitor datasource
|
||||||
|
+
|
||||||
|
+%description azure-monitor
|
||||||
|
+The Grafana azure-monitor datasource.
|
||||||
|
+
|
||||||
|
+%package graphite
|
||||||
|
+Requires: %{name} = %{version}-%{release}
|
||||||
|
+Summary: Grafana graphite datasource
|
||||||
|
+
|
||||||
|
+%description graphite
|
||||||
|
+The Grafana graphite datasource.
|
||||||
|
+
|
||||||
|
+%package influxdb
|
||||||
|
+Requires: %{name} = %{version}-%{release}
|
||||||
|
+Summary: Grafana influxdb datasource
|
||||||
|
+
|
||||||
|
+%description influxdb
|
||||||
|
+The Grafana influxdb datasource.
|
||||||
|
+
|
||||||
|
+%package loki
|
||||||
|
+Requires: %{name} = %{version}-%{release}
|
||||||
|
+Summary: Grafana loki datasource
|
||||||
|
+
|
||||||
|
+%description loki
|
||||||
|
+The Grafana loki datasource.
|
||||||
|
+
|
||||||
|
+%package mssql
|
||||||
|
+Requires: %{name} = %{version}-%{release}
|
||||||
|
+Summary: Grafana mssql datasource
|
||||||
|
+
|
||||||
|
+%description mssql
|
||||||
|
+The Grafana mssql datasource.
|
||||||
|
+
|
||||||
|
+%package mysql
|
||||||
|
+Requires: %{name} = %{version}-%{release}
|
||||||
|
+Summary: Grafana mysql datasource
|
||||||
|
+
|
||||||
|
+%description mysql
|
||||||
|
+The Grafana mysql datasource.
|
||||||
|
+
|
||||||
|
+%package opentsdb
|
||||||
|
+Requires: %{name} = %{version}-%{release}
|
||||||
|
+Summary: Grafana opentsdb datasource
|
||||||
|
+
|
||||||
|
+%description opentsdb
|
||||||
|
+The Grafana opentsdb datasource.
|
||||||
|
+
|
||||||
|
+%package postgres
|
||||||
|
+Requires: %{name} = %{version}-%{release}
|
||||||
|
+Summary: Grafana postgres datasource
|
||||||
|
+
|
||||||
|
+%description postgres
|
||||||
|
+The Grafana postgres datasource.
|
||||||
|
+
|
||||||
|
+%package prometheus
|
||||||
|
+Requires: %{name} = %{version}-%{release}
|
||||||
|
+Summary: Grafana prometheus datasource
|
||||||
|
+
|
||||||
|
+%description prometheus
|
||||||
|
+The Grafana prometheus datasource.
|
||||||
|
+
|
||||||
|
+%package stackdriver
|
||||||
|
+Requires: %{name} = %{version}-%{release}
|
||||||
|
+Summary: Grafana stackdriver datasource
|
||||||
|
+
|
||||||
|
+%description stackdriver
|
||||||
|
+The Grafana stackdriver datasource.
|
||||||
|
+
|
||||||
|
+
|
||||||
+%prep
|
+%prep
|
||||||
+%setup -q -T -D -b 0
|
+%setup -q -T -D -b 0
|
||||||
+%setup -q -T -D -b 1
|
+%setup -q -T -D -b 1
|
||||||
@ -1152,8 +1250,10 @@ index 000000000..93c470fca
|
|||||||
+%if 0%{?unbundle_vendor_sources}
|
+%if 0%{?unbundle_vendor_sources}
|
||||||
+# Unbundle all grafana vendor sources, as per BuildRequires above.
|
+# Unbundle all grafana vendor sources, as per BuildRequires above.
|
||||||
+# An exception is grafana-plugin-model, which is part of grafana.
|
+# An exception is grafana-plugin-model, which is part of grafana.
|
||||||
+# Other exceptions are golang devel packages that are not yet in Fedora.
|
+# Another exception is xerrors, which is a transition package
|
||||||
+cp --parents -a vendor/github.com/grafana vendor/github.com/robfig vendor/golang.org/x/xerrors %{_builddir}
|
+# for the new Go 1.13 error values, see https://github.com/golang/xerrors
|
||||||
|
+cp --parents -a vendor/github.com/grafana vendor/golang.org/x/xerrors \
|
||||||
|
+ vendor/github.com/robfig/cron %{_builddir}
|
||||||
+rm -r vendor # remove all vendor sources
|
+rm -r vendor # remove all vendor sources
|
||||||
+mv %{_builddir}/vendor vendor # put back what we're keeping
|
+mv %{_builddir}/vendor vendor # put back what we're keeping
|
||||||
+%endif
|
+%endif
|
||||||
@ -1174,7 +1274,7 @@ index 000000000..93c470fca
|
|||||||
+
|
+
|
||||||
+
|
+
|
||||||
+%install
|
+%install
|
||||||
+# Fix up a few things (arch bin directories, modes)
|
+# Fix up arch bin directories
|
||||||
+[ ! -d bin/x86_64 ] && ln -sf linux-amd64 bin/x86_64
|
+[ ! -d bin/x86_64 ] && ln -sf linux-amd64 bin/x86_64
|
||||||
+[ ! -d bin/i386 ] && ln -sf linux-386 bin/i386
|
+[ ! -d bin/i386 ] && ln -sf linux-386 bin/i386
|
||||||
+[ ! -d bin/ppc64le ] && ln -sf linux-ppc64le bin/ppc64le
|
+[ ! -d bin/ppc64le ] && ln -sf linux-ppc64le bin/ppc64le
|
||||||
@ -1272,9 +1372,24 @@ index 000000000..93c470fca
|
|||||||
+%attr(-, %{GRAFANA_USER}, %{GRAFANA_GROUP}) %dir %{_sharedstatedir}/%{name}
|
+%attr(-, %{GRAFANA_USER}, %{GRAFANA_GROUP}) %dir %{_sharedstatedir}/%{name}
|
||||||
+%attr(-, %{GRAFANA_USER}, %{GRAFANA_GROUP}) %dir %{_sharedstatedir}/%{name}/plugins
|
+%attr(-, %{GRAFANA_USER}, %{GRAFANA_GROUP}) %dir %{_sharedstatedir}/%{name}/plugins
|
||||||
+
|
+
|
||||||
+# shared directory and all files therein
|
+# shared directory and all files therein, except some datasources
|
||||||
+%dir %{_datadir}/%{name}
|
|
||||||
+%{_datadir}/%{name}/public
|
+%{_datadir}/%{name}/public
|
||||||
|
+
|
||||||
|
+# built-in datasources that are sub-packaged
|
||||||
|
+%global dsdir %{_datadir}/%{name}/public/app/plugins/datasource
|
||||||
|
+%exclude %{dsdir}/cloudwatch
|
||||||
|
+%exclude %{dsdir}/elasticsearch
|
||||||
|
+%exclude %{dsdir}/graphite
|
||||||
|
+%exclude %{dsdir}/grafana-azure-monitor-datasource
|
||||||
|
+%exclude %{dsdir}/influxdb
|
||||||
|
+%exclude %{dsdir}/loki
|
||||||
|
+%exclude %{dsdir}/mssql
|
||||||
|
+%exclude %{dsdir}/mysql
|
||||||
|
+%exclude %{dsdir}/opentsdb
|
||||||
|
+%exclude %{dsdir}/postgres
|
||||||
|
+%exclude %{dsdir}/prometheus
|
||||||
|
+%exclude %{dsdir}/stackdriver
|
||||||
|
+
|
||||||
+%dir %{_datadir}/%{name}/conf
|
+%dir %{_datadir}/%{name}/conf
|
||||||
+%attr(-, root, %{GRAFANA_GROUP}) %{_datadir}/%{name}/conf/*
|
+%attr(-, root, %{GRAFANA_GROUP}) %{_datadir}/%{name}/conf/*
|
||||||
+
|
+
|
||||||
@ -1293,8 +1408,54 @@ index 000000000..93c470fca
|
|||||||
+%doc CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md NOTICE.md
|
+%doc CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md NOTICE.md
|
||||||
+%doc PLUGIN_DEV.md README.md ROADMAP.md UPGRADING_DEPENDENCIES.md
|
+%doc PLUGIN_DEV.md README.md ROADMAP.md UPGRADING_DEPENDENCIES.md
|
||||||
+
|
+
|
||||||
|
+#
|
||||||
|
+# datasources split out into subpackages
|
||||||
|
+#
|
||||||
|
+%files cloudwatch
|
||||||
|
+%{_datadir}/%{name}/public/app/plugins/datasource/cloudwatch
|
||||||
|
+
|
||||||
|
+%files elasticsearch
|
||||||
|
+%{_datadir}/%{name}/public/app/plugins/datasource/elasticsearch
|
||||||
|
+
|
||||||
|
+%files azure-monitor
|
||||||
|
+%{_datadir}/%{name}/public/app/plugins/datasource/grafana-azure-monitor-datasource
|
||||||
|
+
|
||||||
|
+%files graphite
|
||||||
|
+%{_datadir}/%{name}/public/app/plugins/datasource/graphite
|
||||||
|
+
|
||||||
|
+%files influxdb
|
||||||
|
+%{_datadir}/%{name}/public/app/plugins/datasource/influxdb
|
||||||
|
+
|
||||||
|
+%files loki
|
||||||
|
+%{_datadir}/%{name}/public/app/plugins/datasource/loki
|
||||||
|
+
|
||||||
|
+%files mssql
|
||||||
|
+%{_datadir}/%{name}/public/app/plugins/datasource/mssql
|
||||||
|
+
|
||||||
|
+%files mysql
|
||||||
|
+%{_datadir}/%{name}/public/app/plugins/datasource/mysql
|
||||||
|
+
|
||||||
|
+%files opentsdb
|
||||||
|
+%{_datadir}/%{name}/public/app/plugins/datasource/opentsdb
|
||||||
|
+
|
||||||
|
+%files postgres
|
||||||
|
+%{_datadir}/%{name}/public/app/plugins/datasource/postgres
|
||||||
|
+
|
||||||
|
+%files prometheus
|
||||||
|
+%{_datadir}/%{name}/public/app/plugins/datasource/prometheus
|
||||||
|
+
|
||||||
|
+%files stackdriver
|
||||||
|
+%{_datadir}/%{name}/public/app/plugins/datasource/stackdriver
|
||||||
|
+
|
||||||
+
|
+
|
||||||
+%changelog
|
+%changelog
|
||||||
|
+* Fri Jun 07 2019 Mark Goodwin <mgoodwin@redhat.com> 6.2.2-1
|
||||||
|
+- split out some datasource plugins to sub-packages
|
||||||
|
+- update to latest upstream community sources, see CHANGELOG
|
||||||
|
+
|
||||||
|
+* Wed Jun 05 2019 Mark Goodwin <mgoodwin@redhat.com> 6.2.1-1
|
||||||
|
+- update to latest upstream community sources, see CHANGELOG
|
||||||
|
+
|
||||||
+* Fri May 24 2019 Mark Goodwin <mgoodwin@redhat.com> 6.2.0-1
|
+* Fri May 24 2019 Mark Goodwin <mgoodwin@redhat.com> 6.2.0-1
|
||||||
+- update to latest upstream community sources
|
+- update to latest upstream community sources
|
||||||
+- drop a couple of patches
|
+- drop a couple of patches
|
||||||
|
173
grafana.spec
173
grafana.spec
@ -16,7 +16,7 @@ end}
|
|||||||
|
|
||||||
|
|
||||||
Name: grafana
|
Name: grafana
|
||||||
Version: 6.2.0
|
Version: 6.2.2
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Metrics dashboard and graph editor
|
Summary: Metrics dashboard and graph editor
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
@ -52,6 +52,19 @@ Requires(pre): shadow-utils
|
|||||||
|
|
||||||
BuildRequires: systemd, golang, go-srpm-macros
|
BuildRequires: systemd, golang, go-srpm-macros
|
||||||
|
|
||||||
|
Recommends: grafana-cloudwatch = %{version}-%{release}
|
||||||
|
Recommends: grafana-elasticsearch = %{version}-%{release}
|
||||||
|
Recommends: grafana-azure-monitor = %{version}-%{release}
|
||||||
|
Recommends: grafana-graphite = %{version}-%{release}
|
||||||
|
Recommends: grafana-influxdb = %{version}-%{release}
|
||||||
|
Recommends: grafana-loki = %{version}-%{release}
|
||||||
|
Recommends: grafana-mssql = %{version}-%{release}
|
||||||
|
Recommends: grafana-mysql = %{version}-%{release}
|
||||||
|
Recommends: grafana-opentsdb = %{version}-%{release}
|
||||||
|
Recommends: grafana-postgres = %{version}-%{release}
|
||||||
|
Recommends: grafana-prometheus = %{version}-%{release}
|
||||||
|
Recommends: grafana-stackdriver = %{version}-%{release}
|
||||||
|
|
||||||
%if 0%{?unbundle_vendor_sources}
|
%if 0%{?unbundle_vendor_sources}
|
||||||
# golang build deps. These allow us to unbundle vendor golang source.
|
# golang build deps. These allow us to unbundle vendor golang source.
|
||||||
BuildRequires: golang(github.com/aws/aws-sdk-go)
|
BuildRequires: golang(github.com/aws/aws-sdk-go)
|
||||||
@ -289,6 +302,91 @@ Grafana is an open source, feature rich metrics dashboard and graph editor for
|
|||||||
Graphite, InfluxDB & OpenTSDB.
|
Graphite, InfluxDB & OpenTSDB.
|
||||||
|
|
||||||
|
|
||||||
|
%package cloudwatch
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Summary: Grafana cloudwatch datasource
|
||||||
|
|
||||||
|
%description cloudwatch
|
||||||
|
The Grafana cloudwatch datasource.
|
||||||
|
|
||||||
|
%package elasticsearch
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Summary: Grafana elasticsearch datasource
|
||||||
|
|
||||||
|
%description elasticsearch
|
||||||
|
The Grafana elasticsearch datasource.
|
||||||
|
|
||||||
|
%package azure-monitor
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Summary: Grafana azure-monitor datasource
|
||||||
|
|
||||||
|
%description azure-monitor
|
||||||
|
The Grafana azure-monitor datasource.
|
||||||
|
|
||||||
|
%package graphite
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Summary: Grafana graphite datasource
|
||||||
|
|
||||||
|
%description graphite
|
||||||
|
The Grafana graphite datasource.
|
||||||
|
|
||||||
|
%package influxdb
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Summary: Grafana influxdb datasource
|
||||||
|
|
||||||
|
%description influxdb
|
||||||
|
The Grafana influxdb datasource.
|
||||||
|
|
||||||
|
%package loki
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Summary: Grafana loki datasource
|
||||||
|
|
||||||
|
%description loki
|
||||||
|
The Grafana loki datasource.
|
||||||
|
|
||||||
|
%package mssql
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Summary: Grafana mssql datasource
|
||||||
|
|
||||||
|
%description mssql
|
||||||
|
The Grafana mssql datasource.
|
||||||
|
|
||||||
|
%package mysql
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Summary: Grafana mysql datasource
|
||||||
|
|
||||||
|
%description mysql
|
||||||
|
The Grafana mysql datasource.
|
||||||
|
|
||||||
|
%package opentsdb
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Summary: Grafana opentsdb datasource
|
||||||
|
|
||||||
|
%description opentsdb
|
||||||
|
The Grafana opentsdb datasource.
|
||||||
|
|
||||||
|
%package postgres
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Summary: Grafana postgres datasource
|
||||||
|
|
||||||
|
%description postgres
|
||||||
|
The Grafana postgres datasource.
|
||||||
|
|
||||||
|
%package prometheus
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Summary: Grafana prometheus datasource
|
||||||
|
|
||||||
|
%description prometheus
|
||||||
|
The Grafana prometheus datasource.
|
||||||
|
|
||||||
|
%package stackdriver
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Summary: Grafana stackdriver datasource
|
||||||
|
|
||||||
|
%description stackdriver
|
||||||
|
The Grafana stackdriver datasource.
|
||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -T -D -b 0
|
%setup -q -T -D -b 0
|
||||||
%setup -q -T -D -b 1
|
%setup -q -T -D -b 1
|
||||||
@ -307,8 +405,10 @@ rm -f public/sass/.sass-lint.yml public/test/.jshintrc
|
|||||||
%if 0%{?unbundle_vendor_sources}
|
%if 0%{?unbundle_vendor_sources}
|
||||||
# Unbundle all grafana vendor sources, as per BuildRequires above.
|
# Unbundle all grafana vendor sources, as per BuildRequires above.
|
||||||
# An exception is grafana-plugin-model, which is part of grafana.
|
# An exception is grafana-plugin-model, which is part of grafana.
|
||||||
# Other exceptions are golang devel packages that are not yet in Fedora.
|
# Another exception is xerrors, which is a transition package
|
||||||
cp --parents -a vendor/github.com/grafana vendor/github.com/robfig vendor/golang.org/x/xerrors %{_builddir}
|
# for the new Go 1.13 error values, see https://github.com/golang/xerrors
|
||||||
|
cp --parents -a vendor/github.com/grafana vendor/golang.org/x/xerrors \
|
||||||
|
vendor/github.com/robfig/cron %{_builddir}
|
||||||
rm -r vendor # remove all vendor sources
|
rm -r vendor # remove all vendor sources
|
||||||
mv %{_builddir}/vendor vendor # put back what we're keeping
|
mv %{_builddir}/vendor vendor # put back what we're keeping
|
||||||
%endif
|
%endif
|
||||||
@ -329,7 +429,7 @@ go run build.go build
|
|||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
# Fix up a few things (arch bin directories, modes)
|
# Fix up arch bin directories
|
||||||
[ ! -d bin/x86_64 ] && ln -sf linux-amd64 bin/x86_64
|
[ ! -d bin/x86_64 ] && ln -sf linux-amd64 bin/x86_64
|
||||||
[ ! -d bin/i386 ] && ln -sf linux-386 bin/i386
|
[ ! -d bin/i386 ] && ln -sf linux-386 bin/i386
|
||||||
[ ! -d bin/ppc64le ] && ln -sf linux-ppc64le bin/ppc64le
|
[ ! -d bin/ppc64le ] && ln -sf linux-ppc64le bin/ppc64le
|
||||||
@ -427,9 +527,24 @@ go test ./pkg/...
|
|||||||
%attr(-, %{GRAFANA_USER}, %{GRAFANA_GROUP}) %dir %{_sharedstatedir}/%{name}
|
%attr(-, %{GRAFANA_USER}, %{GRAFANA_GROUP}) %dir %{_sharedstatedir}/%{name}
|
||||||
%attr(-, %{GRAFANA_USER}, %{GRAFANA_GROUP}) %dir %{_sharedstatedir}/%{name}/plugins
|
%attr(-, %{GRAFANA_USER}, %{GRAFANA_GROUP}) %dir %{_sharedstatedir}/%{name}/plugins
|
||||||
|
|
||||||
# shared directory and all files therein
|
# shared directory and all files therein, except some datasources
|
||||||
%dir %{_datadir}/%{name}
|
|
||||||
%{_datadir}/%{name}/public
|
%{_datadir}/%{name}/public
|
||||||
|
|
||||||
|
# built-in datasources that are sub-packaged
|
||||||
|
%global dsdir %{_datadir}/%{name}/public/app/plugins/datasource
|
||||||
|
%exclude %{dsdir}/cloudwatch
|
||||||
|
%exclude %{dsdir}/elasticsearch
|
||||||
|
%exclude %{dsdir}/graphite
|
||||||
|
%exclude %{dsdir}/grafana-azure-monitor-datasource
|
||||||
|
%exclude %{dsdir}/influxdb
|
||||||
|
%exclude %{dsdir}/loki
|
||||||
|
%exclude %{dsdir}/mssql
|
||||||
|
%exclude %{dsdir}/mysql
|
||||||
|
%exclude %{dsdir}/opentsdb
|
||||||
|
%exclude %{dsdir}/postgres
|
||||||
|
%exclude %{dsdir}/prometheus
|
||||||
|
%exclude %{dsdir}/stackdriver
|
||||||
|
|
||||||
%dir %{_datadir}/%{name}/conf
|
%dir %{_datadir}/%{name}/conf
|
||||||
%attr(-, root, %{GRAFANA_GROUP}) %{_datadir}/%{name}/conf/*
|
%attr(-, root, %{GRAFANA_GROUP}) %{_datadir}/%{name}/conf/*
|
||||||
|
|
||||||
@ -448,8 +563,54 @@ go test ./pkg/...
|
|||||||
%doc CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md NOTICE.md
|
%doc CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md NOTICE.md
|
||||||
%doc PLUGIN_DEV.md README.md ROADMAP.md UPGRADING_DEPENDENCIES.md
|
%doc PLUGIN_DEV.md README.md ROADMAP.md UPGRADING_DEPENDENCIES.md
|
||||||
|
|
||||||
|
#
|
||||||
|
# datasources split out into subpackages
|
||||||
|
#
|
||||||
|
%files cloudwatch
|
||||||
|
%{_datadir}/%{name}/public/app/plugins/datasource/cloudwatch
|
||||||
|
|
||||||
|
%files elasticsearch
|
||||||
|
%{_datadir}/%{name}/public/app/plugins/datasource/elasticsearch
|
||||||
|
|
||||||
|
%files azure-monitor
|
||||||
|
%{_datadir}/%{name}/public/app/plugins/datasource/grafana-azure-monitor-datasource
|
||||||
|
|
||||||
|
%files graphite
|
||||||
|
%{_datadir}/%{name}/public/app/plugins/datasource/graphite
|
||||||
|
|
||||||
|
%files influxdb
|
||||||
|
%{_datadir}/%{name}/public/app/plugins/datasource/influxdb
|
||||||
|
|
||||||
|
%files loki
|
||||||
|
%{_datadir}/%{name}/public/app/plugins/datasource/loki
|
||||||
|
|
||||||
|
%files mssql
|
||||||
|
%{_datadir}/%{name}/public/app/plugins/datasource/mssql
|
||||||
|
|
||||||
|
%files mysql
|
||||||
|
%{_datadir}/%{name}/public/app/plugins/datasource/mysql
|
||||||
|
|
||||||
|
%files opentsdb
|
||||||
|
%{_datadir}/%{name}/public/app/plugins/datasource/opentsdb
|
||||||
|
|
||||||
|
%files postgres
|
||||||
|
%{_datadir}/%{name}/public/app/plugins/datasource/postgres
|
||||||
|
|
||||||
|
%files prometheus
|
||||||
|
%{_datadir}/%{name}/public/app/plugins/datasource/prometheus
|
||||||
|
|
||||||
|
%files stackdriver
|
||||||
|
%{_datadir}/%{name}/public/app/plugins/datasource/stackdriver
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 07 2019 Mark Goodwin <mgoodwin@redhat.com> 6.2.2-1
|
||||||
|
- split out some datasource plugins to sub-packages
|
||||||
|
- update to latest upstream community sources, see CHANGELOG
|
||||||
|
|
||||||
|
* Wed Jun 05 2019 Mark Goodwin <mgoodwin@redhat.com> 6.2.1-1
|
||||||
|
- update to latest upstream community sources, see CHANGELOG
|
||||||
|
|
||||||
* Fri May 24 2019 Mark Goodwin <mgoodwin@redhat.com> 6.2.0-1
|
* Fri May 24 2019 Mark Goodwin <mgoodwin@redhat.com> 6.2.0-1
|
||||||
- update to latest upstream community sources
|
- update to latest upstream community sources
|
||||||
- drop a couple of patches
|
- drop a couple of patches
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (grafana-6.2.0.tar.gz) = 023b5145250923452aa73493dbb1fa1e886f6cd1d2461cb88a50d6e63195f22b0cd3cc4ca438ed59aebbe439e831d43b4cd186638d5e76dbadb17ec33222eaf7
|
SHA512 (grafana-6.2.2.tar.gz) = fffa2a04c5249e6159297280313b7d6cbec2f86fc59e48200405905848dda524bb522cf34a1cf2f55855104e93c72e69284875f0dbea447cc8f551948c03e8af
|
||||||
SHA512 (grafana_webpack-6.2.0.tar.gz) = 2038f3b4842cebb10c35b796b7aac42b36760ae0d374c9d7ac98f633384ef9e879bf31c04ef258a36401bd835e457fea4070f1bea026fffe9f1ebf0a2a8706dc
|
SHA512 (grafana_webpack-6.2.2.tar.gz) = db09ff6cf5c1292bca01dfb5c0c1e615890c229c510785af11406bc945f135b19d14fcda6a483c6a438dde567f8d43d59298aec638c6780a788b60bb9b734d64
|
||||||
|
Loading…
Reference in New Issue
Block a user