Resolves: RHEL-62307
This commit is contained in:
parent
a34da3b735
commit
0c88038638
58
0014-resolve-dompurify-CVE.patch
Normal file
58
0014-resolve-dompurify-CVE.patch
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
diff --git a/package.json b/package.json
|
||||||
|
index e26f95d855a..14b3826a64d 100644
|
||||||
|
--- a/package.json
|
||||||
|
+++ b/package.json
|
||||||
|
@@ -316,7 +316,7 @@
|
||||||
|
"dangerously-set-html-content": "1.0.9",
|
||||||
|
"date-fns": "2.29.1",
|
||||||
|
"debounce-promise": "3.1.2",
|
||||||
|
- "dompurify": "^2.4.1",
|
||||||
|
+ "dompurify": "^2.5.0",
|
||||||
|
"emotion": "11.0.0",
|
||||||
|
"eventemitter3": "4.0.7",
|
||||||
|
"fast-deep-equal": "^3.1.3",
|
||||||
|
@@ -422,7 +422,8 @@
|
||||||
|
"@storybook/react/webpack": "5.74.0",
|
||||||
|
"ngtemplate-loader/loader-utils": "^2.0.0",
|
||||||
|
"node-fetch": "2.6.7",
|
||||||
|
- "slate-dev-environment@^0.2.2": "patch:slate-dev-environment@npm:0.2.5#.yarn/patches/slate-dev-environment-npm-0.2.5-9aeb7da7b5.patch"
|
||||||
|
+ "slate-dev-environment@^0.2.2": "patch:slate-dev-environment@npm:0.2.5#.yarn/patches/slate-dev-environment-npm-0.2.5-9aeb7da7b5.patch",
|
||||||
|
+ "dompurify": "^2.5.0"
|
||||||
|
},
|
||||||
|
"workspaces": {
|
||||||
|
"packages": [
|
||||||
|
diff --git a/yarn.lock b/yarn.lock
|
||||||
|
index f374e10e333..834cfee2642 100644
|
||||||
|
--- a/yarn.lock
|
||||||
|
+++ b/yarn.lock
|
||||||
|
@@ -18739,17 +18739,10 @@ __metadata:
|
||||||
|
languageName: node
|
||||||
|
linkType: hard
|
||||||
|
|
||||||
|
-"dompurify@npm:^2.2.0":
|
||||||
|
- version: 2.3.8
|
||||||
|
- resolution: "dompurify@npm:2.3.8"
|
||||||
|
- checksum: dc7b32ee57a03fe5166a850071200897cc13fa069287a709e3b2138052d73ec09a87026b9e28c8d2f254a74eaa52ef30644e98e54294c30acbca2a53f1bbc5f4
|
||||||
|
- languageName: node
|
||||||
|
- linkType: hard
|
||||||
|
-
|
||||||
|
-"dompurify@npm:^2.4.1":
|
||||||
|
- version: 2.4.1
|
||||||
|
- resolution: "dompurify@npm:2.4.1"
|
||||||
|
- checksum: 1169177465b3cbb25a44322937fba549f6c4e1a91b83245d144471be26619c835cccf0f8e20aa78c25ac11a06efd17cc1b9db9cacadceb78a4c08a1029eafee5
|
||||||
|
+"dompurify@npm:^2.5.0":
|
||||||
|
+ version: 2.5.7
|
||||||
|
+ resolution: "dompurify@npm:2.5.7"
|
||||||
|
+ checksum: 9652139743130b5ebaf5278fadec06d9b3920019b80c205565b9b8d52cd0cea90ff690c1994c5c0da5bc9d57a94dc19236cdf1ccabdc1c6cff7c255e1e597031
|
||||||
|
languageName: node
|
||||||
|
linkType: hard
|
||||||
|
|
||||||
|
@@ -21953,7 +21946,7 @@ __metadata:
|
||||||
|
dangerously-set-html-content: 1.0.9
|
||||||
|
date-fns: 2.29.1
|
||||||
|
debounce-promise: 3.1.2
|
||||||
|
- dompurify: ^2.4.1
|
||||||
|
+ dompurify: ^2.5.0
|
||||||
|
emotion: 11.0.0
|
||||||
|
enzyme: 3.11.0
|
||||||
|
enzyme-to-json: 3.6.2
|
@ -40,6 +40,7 @@ awk '$2 ~ /^v/ && $4 != "indirect" {print "Provides: bundled(golang(" $1 ")) = "
|
|||||||
|
|
||||||
# Vendor Node.js dependencies
|
# Vendor Node.js dependencies
|
||||||
patch -p1 --fuzz=0 < ../0005-remove-unused-frontend-crypto.patch
|
patch -p1 --fuzz=0 < ../0005-remove-unused-frontend-crypto.patch
|
||||||
|
patch -p1 --fuzz=0 < ../0014-resolve-dompurify-CVE.patch
|
||||||
export HUSKY=0
|
export HUSKY=0
|
||||||
yarn install --frozen-lockfile
|
yarn install --frozen-lockfile
|
||||||
|
|
||||||
|
@ -6,7 +6,7 @@
|
|||||||
#
|
#
|
||||||
|
|
||||||
cat <<EOF | podman build -t grafana-build -f - .
|
cat <<EOF | podman build -t grafana-build -f - .
|
||||||
FROM fedora:35
|
FROM fedora:36
|
||||||
|
|
||||||
RUN dnf upgrade -y && \
|
RUN dnf upgrade -y && \
|
||||||
dnf install -y rpmdevtools python3-packaging python3-pyyaml make golang nodejs yarnpkg
|
dnf install -y rpmdevtools python3-packaging python3-pyyaml make golang nodejs yarnpkg
|
||||||
|
13
grafana.spec
13
grafana.spec
@ -35,7 +35,7 @@ end}
|
|||||||
|
|
||||||
Name: grafana
|
Name: grafana
|
||||||
Version: 9.2.10
|
Version: 9.2.10
|
||||||
Release: 19%{?dist}
|
Release: 20%{?dist}
|
||||||
Summary: Metrics dashboard and graph editor
|
Summary: Metrics dashboard and graph editor
|
||||||
License: AGPLv3
|
License: AGPLv3
|
||||||
URL: https://grafana.org
|
URL: https://grafana.org
|
||||||
@ -46,13 +46,13 @@ Source0: https://github.com/grafana/grafana/archive/v%{version}/%{name}
|
|||||||
# Source1 contains the bundled Go and Node.js dependencies
|
# Source1 contains the bundled Go and Node.js dependencies
|
||||||
# Note: In case there were no changes to this tarball, the NVR of this tarball
|
# Note: In case there were no changes to this tarball, the NVR of this tarball
|
||||||
# lags behind the NVR of this package.
|
# lags behind the NVR of this package.
|
||||||
Source1: grafana-vendor-%{version}-2.tar.xz
|
Source1: grafana-vendor-%{version}-20.tar.xz
|
||||||
|
|
||||||
%if %{compile_frontend} == 0
|
%if %{compile_frontend} == 0
|
||||||
# Source2 contains the precompiled frontend
|
# Source2 contains the precompiled frontend
|
||||||
# Note: In case there were no changes to this tarball, the NVR of this tarball
|
# Note: In case there were no changes to this tarball, the NVR of this tarball
|
||||||
# lags behind the NVR of this package.
|
# lags behind the NVR of this package.
|
||||||
Source2: grafana-webpack-%{version}-2.tar.gz
|
Source2: grafana-webpack-%{version}-20.tar.gz
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Source3 contains the systemd-sysusers configuration
|
# Source3 contains the systemd-sysusers configuration
|
||||||
@ -88,6 +88,7 @@ Patch10: 0010-skip-tests.patch
|
|||||||
Patch11: 0011-remove-email-lookup.patch
|
Patch11: 0011-remove-email-lookup.patch
|
||||||
Patch12: 0012-coredump-selinux-error.patch
|
Patch12: 0012-coredump-selinux-error.patch
|
||||||
Patch13: 0013-snapshot-delete-check-org.patch
|
Patch13: 0013-snapshot-delete-check-org.patch
|
||||||
|
Patch14: 0014-resolve-dompurify-CVE.patch
|
||||||
|
|
||||||
# Patches affecting the vendor tarball
|
# Patches affecting the vendor tarball
|
||||||
Patch1001: 1001-vendor-patch-removed-backend-crypto.patch
|
Patch1001: 1001-vendor-patch-removed-backend-crypto.patch
|
||||||
@ -531,7 +532,7 @@ Provides: bundled(npm(date-fns)) = 2.25.0
|
|||||||
Provides: bundled(npm(debounce-promise)) = 3.1.2
|
Provides: bundled(npm(debounce-promise)) = 3.1.2
|
||||||
Provides: bundled(npm(deep-freeze)) = 0.0.1
|
Provides: bundled(npm(deep-freeze)) = 0.0.1
|
||||||
Provides: bundled(npm(devtools-protocol)) = 0.0.927104
|
Provides: bundled(npm(devtools-protocol)) = 0.0.927104
|
||||||
Provides: bundled(npm(dompurify)) = 2.3.8
|
Provides: bundled(npm(dompurify)) = 2.5.7
|
||||||
Provides: bundled(npm(emotion)) = 10.0.27
|
Provides: bundled(npm(emotion)) = 10.0.27
|
||||||
Provides: bundled(npm(enzyme)) = 3.11.0
|
Provides: bundled(npm(enzyme)) = 3.11.0
|
||||||
Provides: bundled(npm(enzyme-to-json)) = 3.6.2
|
Provides: bundled(npm(enzyme-to-json)) = 3.6.2
|
||||||
@ -775,6 +776,7 @@ cp -p %{SOURCE8} %{SOURCE9} %{SOURCE10} SELinux
|
|||||||
%patch -P 11 -p1
|
%patch -P 11 -p1
|
||||||
%patch -P 12 -p1
|
%patch -P 12 -p1
|
||||||
%patch -P 13 -p1
|
%patch -P 13 -p1
|
||||||
|
%patch -P 14 -p1
|
||||||
|
|
||||||
%patch -P 1001 -p1
|
%patch -P 1001 -p1
|
||||||
%if %{enable_fips_mode}
|
%if %{enable_fips_mode}
|
||||||
@ -1021,6 +1023,9 @@ fi
|
|||||||
%{_datadir}/selinux/*/grafana.pp
|
%{_datadir}/selinux/*/grafana.pp
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 17 2024 Sam Feifer <sfeifer@redhat.com> 9.2.10-20
|
||||||
|
- Resolves RHEL-62307: CVE-2024-47875
|
||||||
|
|
||||||
* Thu Oct 10 2024 Sam Feifer <sfeifer@redhat.com> 9.2.10-19
|
* Thu Oct 10 2024 Sam Feifer <sfeifer@redhat.com> 9.2.10-19
|
||||||
- Resolves RHEL-61779: CVE-2024-9355
|
- Resolves RHEL-61779: CVE-2024-9355
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (grafana-9.2.10.tar.gz) = 5eadfcd8ed8822c4a05b4b486baa50402d989049071256d933fe7a7249a22b68e039ad6445a8a6d4a9f0754661882ab8ece1af308aad9c148f31d2cdb320c8c0
|
SHA512 (grafana-9.2.10.tar.gz) = 5eadfcd8ed8822c4a05b4b486baa50402d989049071256d933fe7a7249a22b68e039ad6445a8a6d4a9f0754661882ab8ece1af308aad9c148f31d2cdb320c8c0
|
||||||
SHA512 (grafana-webpack-9.2.10-2.tar.gz) = 4ca5c3ce0ca695ad4e5cd8c5d9f130cf5b0f47e75e224237955212557db572891c8b8a48a303892ef7c04859047229956ece63015c7704f2730b9d7fd43e09ea
|
SHA512 (grafana-webpack-9.2.10-20.tar.gz) = 5469b2fe57a4a3f6987f9eab621782d4acda385dbbb0784a5fa9ffe57111c2d31a3ffed7993732a90c29fe230eec831515543d8489e6ae6942970d54625ada2a
|
||||||
SHA512 (grafana-vendor-9.2.10-2.tar.xz) = 70967b7e8ace2146f0abf6aab03e9533d3653f567f737874377d5bfb48c572859e7776d547a8faf8d38ccf07eb5f54ee84d138c8f7b5e82144d8edc6f3f9e5c0
|
SHA512 (grafana-vendor-9.2.10-20.tar.xz) = be2b54eba969983780eaa6b2e8759dd434db11c14dfadef27b44d6fe2a38e672e733783bd08922a8218b5d008895ecf924391c21545950128e06e1297f0cd56f
|
||||||
|
Loading…
Reference in New Issue
Block a user