gpsd/python-pyexecdir-install-gpsd-2.38.patch
Douglas E. Warner 532b77d09c - updating to 2.38
- creating init script and sysconfig files
- migrating hotplug rules to udev + hotplug wrapper script from svn r5147
- updating pyexecdir patch
- fixing udev rule subsystem match
- Regression test load for RoyalTek RGM3800 and Blumax GPS-009 added
- Scaling on E error-estimate fields fixed to match O
- Listen on localhost only by default to avoid security problems; this can
    be overridden with the -G command-line option
- The packet-state machine can now recognize RTCM3 packets, though support
    is not yet complete
- Added support for ublox5 and mkt-3301 devices
- Add a wrapper around gpsd_hexdump to save CPU
- Lots of little fixes to various packet parsers
- Always keep the device open: "-n" is not optional any more
- xgpsspeed no longer depends on Motif
- gpsctl can now ship arbitrary payloads to a device; It's possible to send
    binary through the control channel with the new "&" command
- Experimental new driver for Novatel SuperStarII
- The 'g' mode switch command now requires, and returns, 'rtcm104v2' rather
    than 'rtcm104'; this is design forward for when RTCM104v2 is fully
    working
2009-03-16 13:54:41 +00:00

98 lines
4.6 KiB
Diff

diff -ruN gpsd-2.38-orig/Makefile.in gpsd-2.38/Makefile.in
--- gpsd-2.38-orig/Makefile.in 2009-02-10 15:44:43.000000000 -0500
+++ gpsd-2.38/Makefile.in 2009-02-12 11:04:18.000000000 -0500
@@ -75,7 +75,7 @@
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" \
"$(DESTDIR)$(sbindir)" "$(DESTDIR)$(bindir)" \
- "$(DESTDIR)$(pythondir)" "$(DESTDIR)$(pythondir)" \
+ "$(DESTDIR)$(pyexecdir)" "$(DESTDIR)$(pyexecdir)" \
"$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man3dir)" \
"$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)" \
"$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(includedir)" \
@@ -1005,21 +1005,21 @@
-rm -f libtool
install-nodist_pythonPYTHON: $(nodist_python_PYTHON)
@$(NORMAL_INSTALL)
- test -z "$(pythondir)" || $(MKDIR_P) "$(DESTDIR)$(pythondir)"
+ test -z "$(pyexecdir)" || $(MKDIR_P) "$(DESTDIR)$(pyexecdir)"
@list='$(nodist_python_PYTHON)'; dlist=''; for p in $$list; do\
if test -f "$$p"; then b=; else b="$(srcdir)/"; fi; \
if test -f $$b$$p; then \
f=$(am__strip_dir) \
dlist="$$dlist $$f"; \
- echo " $(nodist_pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pythondir)/$$f'"; \
- $(nodist_pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pythondir)/$$f"; \
+ echo " $(nodist_pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pyexecdir)/$$f'"; \
+ $(nodist_pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pyexecdir)/$$f"; \
else :; fi; \
done; \
if test -n "$$dlist"; then \
if test -z "$(DESTDIR)"; then \
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(pythondir)" $$dlist; \
+ PYTHON=$(PYTHON) $(py_compile) --basedir "$(pyexecdir)" $$dlist; \
else \
- PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pythondir)" $$dlist; \
+ PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pyexecdir)" $$dlist; \
fi; \
else :; fi
@@ -1027,27 +1027,27 @@
@$(NORMAL_UNINSTALL)
@list='$(nodist_python_PYTHON)'; dlist=''; for p in $$list; do\
f=$(am__strip_dir) \
- rm -f "$(DESTDIR)$(pythondir)/$$f"; \
- rm -f "$(DESTDIR)$(pythondir)/$${f}c"; \
- rm -f "$(DESTDIR)$(pythondir)/$${f}o"; \
+ rm -f "$(DESTDIR)$(pyexecdir)/$$f"; \
+ rm -f "$(DESTDIR)$(pyexecdir)/$${f}c"; \
+ rm -f "$(DESTDIR)$(pyexecdir)/$${f}o"; \
done
install-pythonPYTHON: $(python_PYTHON)
@$(NORMAL_INSTALL)
- test -z "$(pythondir)" || $(MKDIR_P) "$(DESTDIR)$(pythondir)"
+ test -z "$(pyexecdir)" || $(MKDIR_P) "$(DESTDIR)$(pyexecdir)"
@list='$(python_PYTHON)'; dlist=''; for p in $$list; do\
if test -f "$$p"; then b=; else b="$(srcdir)/"; fi; \
if test -f $$b$$p; then \
f=$(am__strip_dir) \
dlist="$$dlist $$f"; \
- echo " $(pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pythondir)/$$f'"; \
- $(pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pythondir)/$$f"; \
+ echo " $(pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pyexecdir)/$$f'"; \
+ $(pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pyexecdir)/$$f"; \
else :; fi; \
done; \
if test -n "$$dlist"; then \
if test -z "$(DESTDIR)"; then \
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(pythondir)" $$dlist; \
+ PYTHON=$(PYTHON) $(py_compile) --basedir "$(pyexecdir)" $$dlist; \
else \
- PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pythondir)" $$dlist; \
+ PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pyexecdir)" $$dlist; \
fi; \
else :; fi
@@ -1055,9 +1055,9 @@
@$(NORMAL_UNINSTALL)
@list='$(python_PYTHON)'; dlist=''; for p in $$list; do\
f=$(am__strip_dir) \
- rm -f "$(DESTDIR)$(pythondir)/$$f"; \
- rm -f "$(DESTDIR)$(pythondir)/$${f}c"; \
- rm -f "$(DESTDIR)$(pythondir)/$${f}o"; \
+ rm -f "$(DESTDIR)$(pyexecdir)/$$f"; \
+ rm -f "$(DESTDIR)$(pyexecdir)/$${f}c"; \
+ rm -f "$(DESTDIR)$(pyexecdir)/$${f}o"; \
done
install-man1: $(man1_MANS) $(man_MANS)
@$(NORMAL_INSTALL)
@@ -1478,7 +1478,7 @@
install-binPROGRAMS: install-libLTLIBRARIES
installdirs:
- for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pythondir)" "$(DESTDIR)$(pythondir)" "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man3dir)" "$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)" "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)"; do \
+ for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pyexecdir)" "$(DESTDIR)$(pyexecdir)" "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man3dir)" "$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)" "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)"; do \
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done
install: $(BUILT_SOURCES)