- update to 2.95
- add /usr/sbin to PATH in gpsd.hotplug.wrapper - pass sysconfig variables to gpsd started from udev - enable libusb support
This commit is contained in:
parent
861f81b1f3
commit
f58bfef12f
@ -1 +1 @@
|
|||||||
gpsd-2.94.tar.gz
|
gpsd-2.95.tar.gz
|
||||||
|
32
gpsd-2.95-hotplugvars.patch
Normal file
32
gpsd-2.95-hotplugvars.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
diff -up gpsd-2.95/gpsd.hotplug.wrapper.hotplugvars gpsd-2.95/gpsd.hotplug.wrapper
|
||||||
|
--- gpsd-2.95/gpsd.hotplug.wrapper.hotplugvars 2010-07-12 02:40:22.000000000 +0200
|
||||||
|
+++ gpsd-2.95/gpsd.hotplug.wrapper 2010-07-15 16:48:08.000000000 +0200
|
||||||
|
@@ -3,20 +3,25 @@
|
||||||
|
# This file is Copyright (c) 2010 by the GPSD project
|
||||||
|
# BSD terms apply: see the file COPYING in the distribution root for details.
|
||||||
|
|
||||||
|
+PATH=/usr/sbin:$PATH
|
||||||
|
+export PATH
|
||||||
|
+
|
||||||
|
if [ -r /etc/default/gpsd ]; then
|
||||||
|
. /etc/default/gpsd
|
||||||
|
elif [ -r /etc/sysconfig/gpsd ]; then
|
||||||
|
. /etc/sysconfig/gpsd
|
||||||
|
+ GPSD_OPTIONS=$OPTIONS
|
||||||
|
+ GPSD_SOCKET=$CONTROL_SOCKET
|
||||||
|
fi
|
||||||
|
|
||||||
|
-if [ -n $GPSD_OPTIONS ]; then
|
||||||
|
+if [ -n "$GPSD_OPTIONS" ]; then
|
||||||
|
export GPSD_OPTIONS
|
||||||
|
fi
|
||||||
|
-if [ -n $GPSD_SOCKET ]; then
|
||||||
|
+if [ -n "$GPSD_SOCKET" ]; then
|
||||||
|
export GPSD_SOCKET
|
||||||
|
fi
|
||||||
|
|
||||||
|
-if [ -n $USBAUTO ]; then
|
||||||
|
+if [ -n "$USBAUTO" ]; then
|
||||||
|
[ "$USBAUTO" = "true" ] || exit 0
|
||||||
|
fi
|
||||||
|
|
12
gpsd-2.95-silentmake.patch
Normal file
12
gpsd-2.95-silentmake.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up gpsd-2.95/setup.py.silentmake gpsd-2.95/setup.py
|
||||||
|
--- gpsd-2.95/setup.py.silentmake 2010-06-11 10:38:24.000000000 +0200
|
||||||
|
+++ gpsd-2.95/setup.py 2010-07-14 17:23:12.000000000 +0200
|
||||||
|
@@ -57,7 +57,7 @@ if not 'clean' in sys.argv:
|
||||||
|
gpspacket_sources = ["gpspacket.c", "packet.c", "isgps.c",
|
||||||
|
"driver_rtcm2.c", "strl.c", "hex.c", "crc24q.c"]
|
||||||
|
include_dirs = [ os.path.realpath(os.path.dirname(__file__)) ]
|
||||||
|
-version_out = os.popen(MAKE + " -s version")
|
||||||
|
+version_out = os.popen(MAKE + " --no-print-directory version")
|
||||||
|
version = version_out.read()
|
||||||
|
print(version)
|
||||||
|
if version_out.close():
|
BIN
gpsd-logo.png
BIN
gpsd-logo.png
Binary file not shown.
Before Width: | Height: | Size: 16 KiB |
@ -1,28 +0,0 @@
|
|||||||
#! /bin/bash
|
|
||||||
# $Id$
|
|
||||||
|
|
||||||
if [ "$ACTION" == "remove" ] ; then
|
|
||||||
if [ $(echo $DEVLINKS | grep -q /dev/gps) ] ; then
|
|
||||||
exec /lib/udev/gpsd.hotplug "$ACTION" "$DEVNAME"
|
|
||||||
fi
|
|
||||||
exit 0
|
|
||||||
fi
|
|
||||||
|
|
||||||
# This was formerly in /lib/udev/hotplug.functions
|
|
||||||
wait_for_file() {
|
|
||||||
[ -e "$1" ] && return 0
|
|
||||||
local count=0
|
|
||||||
while sleep 1; do
|
|
||||||
let count=count+1
|
|
||||||
[ -e "$1" ] && return 0
|
|
||||||
if [ $count -gt 60 ]; then
|
|
||||||
return 1
|
|
||||||
fi
|
|
||||||
done
|
|
||||||
}
|
|
||||||
|
|
||||||
# wait for /usr & /var to be mounted
|
|
||||||
wait_for_file /usr/bin/python && \
|
|
||||||
wait_for_file /var/run && \
|
|
||||||
exec /lib/udev/gpsd.hotplug "$ACTION" "$DEVNAME"
|
|
||||||
|
|
34
gpsd.spec
34
gpsd.spec
@ -1,7 +1,7 @@
|
|||||||
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||||
|
|
||||||
Name: gpsd
|
Name: gpsd
|
||||||
Version: 2.94
|
Version: 2.95
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Service daemon for mediating access to a GPS
|
Summary: Service daemon for mediating access to a GPS
|
||||||
|
|
||||||
@ -9,17 +9,14 @@ Group: System Environment/Daemons
|
|||||||
License: BSD
|
License: BSD
|
||||||
URL: http://developer.berlios.de/projects/gpsd/
|
URL: http://developer.berlios.de/projects/gpsd/
|
||||||
Source0: http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
|
Source0: http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
|
||||||
Source1: xgps.desktop
|
|
||||||
Source2: xgpsspeed.desktop
|
|
||||||
Source3: gpsd-logo.png
|
|
||||||
Source10: gpsd.init
|
Source10: gpsd.init
|
||||||
Source11: gpsd.sysconfig
|
Source11: gpsd.sysconfig
|
||||||
Source21: gpsd.hotplug.wrapper
|
Patch0: gpsd-2.95-silentmake.patch
|
||||||
Patch0: gpsd-2.94-silentmake.patch
|
Patch1: gpsd-2.95-hotplugvars.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
|
BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
|
||||||
BuildRequires: libXaw-devel desktop-file-utils
|
BuildRequires: libusb1-devel desktop-file-utils
|
||||||
|
|
||||||
Requires: udev
|
Requires: udev
|
||||||
Requires(post): /sbin/ldconfig
|
Requires(post): /sbin/ldconfig
|
||||||
@ -69,10 +66,12 @@ can run on a serial terminal or terminal emulator.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .silentmake
|
%patch0 -p1 -b .silentmake
|
||||||
|
%patch1 -p1 -b .hotplugvars
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
--enable-dbus \
|
--enable-dbus \
|
||||||
|
--disable-libQgpsmm \
|
||||||
--disable-static
|
--disable-static
|
||||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||||
@ -84,11 +83,6 @@ make %{?_smp_mflags}
|
|||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
make DESTDIR=%{buildroot} pythondir=%{python_sitearch} install
|
make DESTDIR=%{buildroot} pythondir=%{python_sitearch} install
|
||||||
|
|
||||||
# X11 defaults
|
|
||||||
%{__install} -d -m 0755 %{buildroot}%{_datadir}/X11/app-defaults/
|
|
||||||
%{__install} -p -m 0644 xgpsspeed.ad \
|
|
||||||
%{buildroot}%{_datadir}/X11/app-defaults/xgpsspeed
|
|
||||||
|
|
||||||
# init scripts
|
# init scripts
|
||||||
%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/init.d
|
%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/init.d
|
||||||
%{__install} -p -m 0755 %{SOURCE10} \
|
%{__install} -p -m 0755 %{SOURCE10} \
|
||||||
@ -105,8 +99,7 @@ make DESTDIR=%{buildroot} pythondir=%{python_sitearch} install
|
|||||||
|
|
||||||
# hotplug script
|
# hotplug script
|
||||||
%{__install} -d -m 0755 %{buildroot}/lib/udev
|
%{__install} -d -m 0755 %{buildroot}/lib/udev
|
||||||
%{__install} -p -m 0755 gpsd.hotplug %{SOURCE21} \
|
%{__install} -p -m 0755 gpsd.hotplug gpsd.hotplug.wrapper %{buildroot}/lib/udev
|
||||||
%{buildroot}/lib/udev
|
|
||||||
|
|
||||||
# remove .la files
|
# remove .la files
|
||||||
rm -f %{buildroot}%{_libdir}/libgps*.la
|
rm -f %{buildroot}%{_libdir}/libgps*.la
|
||||||
@ -118,15 +111,15 @@ rm -f %{buildroot}%{_libdir}/libgps*.la
|
|||||||
desktop-file-install --vendor fedora \
|
desktop-file-install --vendor fedora \
|
||||||
--dir %{buildroot}%{_datadir}/applications \
|
--dir %{buildroot}%{_datadir}/applications \
|
||||||
--add-category X-Fedora \
|
--add-category X-Fedora \
|
||||||
%{SOURCE1}
|
packaging/X11/xgps.desktop
|
||||||
desktop-file-install --vendor fedora \
|
desktop-file-install --vendor fedora \
|
||||||
--dir %{buildroot}%{_datadir}/applications \
|
--dir %{buildroot}%{_datadir}/applications \
|
||||||
--add-category X-Fedora \
|
--add-category X-Fedora \
|
||||||
%{SOURCE2}
|
packaging/X11/xgpsspeed.desktop
|
||||||
|
|
||||||
# Install logo icon for .desktop files
|
# Install logo icon for .desktop files
|
||||||
%{__install} -d -m 0755 %{buildroot}%{_datadir}/gpsd
|
%{__install} -d -m 0755 %{buildroot}%{_datadir}/gpsd
|
||||||
%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{_datadir}/gpsd/gpsd-logo.png
|
%{__install} -p -m 0644 packaging/X11/gpsd-logo.png %{buildroot}%{_datadir}/gpsd/gpsd-logo.png
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -200,13 +193,18 @@ fi
|
|||||||
%{_mandir}/man1/xgpsspeed.1*
|
%{_mandir}/man1/xgpsspeed.1*
|
||||||
%{_mandir}/man1/cgps.1*
|
%{_mandir}/man1/cgps.1*
|
||||||
%{_mandir}/man1/gpscat.1*
|
%{_mandir}/man1/gpscat.1*
|
||||||
%{_datadir}/X11/app-defaults/xgpsspeed
|
|
||||||
%{_datadir}/applications/*.desktop
|
%{_datadir}/applications/*.desktop
|
||||||
%dir %{_datadir}/gpsd
|
%dir %{_datadir}/gpsd
|
||||||
%{_datadir}/gpsd/gpsd-logo.png
|
%{_datadir}/gpsd/gpsd-logo.png
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 15 2010 Miroslav Lichvar <mlichvar@redhat.com> - 2.95-1
|
||||||
|
- update to 2.95
|
||||||
|
- add /usr/sbin to PATH in gpsd.hotplug.wrapper
|
||||||
|
- pass sysconfig variables to gpsd started from udev
|
||||||
|
- enable libusb support
|
||||||
|
|
||||||
* Thu May 06 2010 Miroslav Lichvar <mlichvar@redhat.com> - 2.94-1
|
* Thu May 06 2010 Miroslav Lichvar <mlichvar@redhat.com> - 2.94-1
|
||||||
- update to 2.94 (#556642)
|
- update to 2.94 (#556642)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
ce70bcd707ac1df861d4c72f503c09d1 gpsd-2.94.tar.gz
|
12535a9ed9fecf9ea2c5bdc9840da5ae gpsd-2.95.tar.gz
|
||||||
|
10
xgps.desktop
10
xgps.desktop
@ -1,10 +0,0 @@
|
|||||||
[Desktop Entry]
|
|
||||||
Encoding=UTF-8
|
|
||||||
Name=xgps
|
|
||||||
GenericName=GPS information
|
|
||||||
Comment=Display GPS information from a gpsd daemon
|
|
||||||
Exec=xgps
|
|
||||||
Icon=/usr/share/gpsd/gpsd-logo.png
|
|
||||||
Terminal=false
|
|
||||||
Type=Application
|
|
||||||
Categories=Application;Graphics;
|
|
@ -1,10 +0,0 @@
|
|||||||
[Desktop Entry]
|
|
||||||
Encoding=UTF-8
|
|
||||||
Name=xgpsspeed
|
|
||||||
GenericName=GPS speedometer
|
|
||||||
Comment=Display GPS speed from a gpsd daemon
|
|
||||||
Exec=xgpsspeed
|
|
||||||
Icon=/usr/share/gpsd/gpsd-logo.png
|
|
||||||
Terminal=false
|
|
||||||
Type=Application
|
|
||||||
Categories=Application;Graphics;
|
|
Loading…
Reference in New Issue
Block a user