- moving gpspacket.so python lib to main package
- adding zero.patch to make ZEROIZE error go away on fedora 7
This commit is contained in:
parent
d26a0c919e
commit
e7eb63db94
11
gpsd.spec
11
gpsd.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: gpsd
|
Name: gpsd
|
||||||
Version: 2.37
|
Version: 2.37
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Service daemon for mediating access to a GPS
|
Summary: Service daemon for mediating access to a GPS
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -13,10 +13,12 @@ Source1: xgps.desktop
|
|||||||
Source2: xgpsspeed.desktop
|
Source2: xgpsspeed.desktop
|
||||||
Source3: gpsd-logo.png
|
Source3: gpsd-logo.png
|
||||||
Patch0: python-pyexecdir-install-gpsd-2.37.patch
|
Patch0: python-pyexecdir-install-gpsd-2.37.patch
|
||||||
|
Patch1: zero.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
|
BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
|
||||||
BuildRequires: lesstif-devel libXaw-devel desktop-file-utils
|
BuildRequires: lesstif-devel libXaw-devel desktop-file-utils
|
||||||
|
BuildRequires: python
|
||||||
|
|
||||||
Requires(post): /sbin/ldconfig
|
Requires(post): /sbin/ldconfig
|
||||||
Requires(postun): /sbin/ldconfig
|
Requires(postun): /sbin/ldconfig
|
||||||
@ -62,6 +64,7 @@ can run on a serial terminal or terminal emulator.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p0
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -129,6 +132,7 @@ rm -rf %{buildroot}
|
|||||||
%{_bindir}/gpsctl
|
%{_bindir}/gpsctl
|
||||||
%{_libdir}/libgps.so.*
|
%{_libdir}/libgps.so.*
|
||||||
%{python_sitearch}/gps.py*
|
%{python_sitearch}/gps.py*
|
||||||
|
%{python_sitearch}/gpspacket.so
|
||||||
%{_mandir}/man8/gpsd.8*
|
%{_mandir}/man8/gpsd.8*
|
||||||
%{_mandir}/man1/gpsprof.1*
|
%{_mandir}/man1/gpsprof.1*
|
||||||
%{_mandir}/man1/sirfmon.1*
|
%{_mandir}/man1/sirfmon.1*
|
||||||
@ -145,7 +149,6 @@ rm -rf %{buildroot}
|
|||||||
%{_libdir}/libgps.so
|
%{_libdir}/libgps.so
|
||||||
%{_libdir}/pkgconfig/*.pc
|
%{_libdir}/pkgconfig/*.pc
|
||||||
%{python_sitearch}/gpsfake*
|
%{python_sitearch}/gpsfake*
|
||||||
%{python_sitearch}/gpspacket.so
|
|
||||||
%{_includedir}/gps.h
|
%{_includedir}/gps.h
|
||||||
%{_includedir}/libgpsmm.h
|
%{_includedir}/libgpsmm.h
|
||||||
%{_includedir}/gpsd.h
|
%{_includedir}/gpsd.h
|
||||||
@ -182,6 +185,10 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 19 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-2
|
||||||
|
- moving gpspacket.so python lib to main package
|
||||||
|
- adding zero.patch to make ZEROIZE error go away on fedora 7
|
||||||
|
|
||||||
* Wed Feb 27 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-1
|
* Wed Feb 27 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-1
|
||||||
- update to 2.37
|
- update to 2.37
|
||||||
- removed install-gpsd_config.h.patch
|
- removed install-gpsd_config.h.patch
|
||||||
|
26
zero.patch
Normal file
26
zero.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
--- libgpsd_core.c.orig 2008-03-19 12:11:55.000000000 -0700
|
||||||
|
+++ libgpsd_core.c 2008-03-19 12:14:28.000000000 -0700
|
||||||
|
@@ -415,6 +415,7 @@
|
||||||
|
tm.tm_mon++;
|
||||||
|
tm.tm_year %= 100;
|
||||||
|
}
|
||||||
|
+#define ZEROIZE(x) (isnan(x)!=0 ? 0.0 : x)
|
||||||
|
/*@ -usedef @*/
|
||||||
|
(void)snprintf(bufp, len,
|
||||||
|
"$GPRMC,%02d%02d%02d,%c,%09.4f,%c,%010.4f,%c,%.4f,%.3f,%02d%02d%02d,,",
|
||||||
|
@@ -426,14 +427,13 @@
|
||||||
|
((session->gpsdata.fix.latitude > 0) ? 'N' : 'S'),
|
||||||
|
degtodm(fabs(session->gpsdata.fix.longitude)),
|
||||||
|
((session->gpsdata.fix.longitude > 0) ? 'E' : 'W'),
|
||||||
|
-#define ZEROIZE(x) (isnan(x)!=0 ? 0.0 : x)
|
||||||
|
ZEROIZE(session->gpsdata.fix.speed * MPS_TO_KNOTS),
|
||||||
|
ZEROIZE(session->gpsdata.fix.track),
|
||||||
|
-#undef ZEROIZE
|
||||||
|
tm.tm_mday,
|
||||||
|
tm.tm_mon,
|
||||||
|
tm.tm_year);
|
||||||
|
/*@ +usedef @*/
|
||||||
|
+#undef ZEROIZE
|
||||||
|
nmea_add_checksum(bufp);
|
||||||
|
}
|
||||||
|
|
Loading…
Reference in New Issue
Block a user