- update to 2.37

- removed install-gpsd_config.h.patch
- installed pkgconfig files in devel package
- added patch to install python modules in sitearch
- removing rpath from inclucded libtool
- moving X11 app-defaults to datadir
- using macros for commands in install; using install instead of cp and
    mkdir
- cleaning up spaces/tabs for rpmlint
This commit is contained in:
Douglas E. Warner 2008-02-28 18:51:06 +00:00
parent 1e75d4c55a
commit d26a0c919e
5 changed files with 183 additions and 80 deletions

View File

@ -1,3 +1,2 @@
gpsd-2.34.tar.gz
gspd-logo.png
gpsd-2.37.tar.gz
gpsd-logo.png

View File

@ -1,6 +1,8 @@
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
Name: gpsd
Version: 2.34
Release: 9%{?dist}
Version: 2.37
Release: 1%{?dist}
Summary: Service daemon for mediating access to a GPS
Group: System Environment/Daemons
@ -10,7 +12,7 @@ Source0: http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
Source1: xgps.desktop
Source2: xgpsspeed.desktop
Source3: gpsd-logo.png
Patch: install-gpsd_config.h.patch
Patch0: python-pyexecdir-install-gpsd-2.37.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
@ -33,10 +35,11 @@ parse than NMEA 0183.
Summary: Client libraries in C and Python for talking to a running gpsd or GPS
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: pkgconfig
%description devel
This package provides C header files for the gpsd shared libraries
that manage access to a GPS for applications; also Python modules.
This package provides C header files and python modules for the gpsd shared
libraries that manage access to a GPS for applications
%package clients
Summary: Clients for gpsd
@ -55,32 +58,45 @@ to dump the package version and exit. Additionally, it accepts -rv
cgps resembles xgps, but without the pictorial satellite display. It
can run on a serial terminal or terminal emulator.
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%prep
%setup -q
%patch -p1
%patch0 -p1
%build
%configure --enable-dbus --disable-static
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
make %{?_smp_mflags}
%install
rm -rf %{buildroot}
mkdir -p %{buildroot}
make DESTDIR=%{buildroot} install
make install DESTDIR=%{buildroot}
# additional gpsd files
mkdir -p %{buildroot}%{_libdir}/X11/app-defaults/
cp -p xgps.ad %{buildroot}%{_libdir}/X11/app-defaults/xgps
cp -p xgpsspeed.ad %{buildroot}%{_libdir}/X11/app-defaults/xgpsspeed
mkdir -p %{buildroot}%{_sysconfdir}/hotplug.d/usb
cp -p gpsd.hotplug gpsd.usermap %{buildroot}%{_sysconfdir}/hotplug.d/usb/
# X11 defaults
%{__install} -d -m 0755 %{buildroot}%{_datadir}/X11/app-defaults/
%{__install} -p -m 0644 xgps.ad %{buildroot}%{_datadir}/X11/app-defaults/xgps
%{__install} -p -m 0644 xgpsspeed.ad \
%{buildroot}%{_datadir}/X11/app-defaults/xgpsspeed
#remove nasty little .la files
# hotplug script
%{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/hotplug.d/usb
%{__install} -p -m 0644 gpsd.hotplug gpsd.usermap \
%{buildroot}%{_sysconfdir}/hotplug.d/usb/
# remove .la files
rm -f %{buildroot}%{_libdir}/libgps.la
#Install the .desktop files
# fix non-executable libraries
%{__chmod} +x %{buildroot}%{_libdir}/libgps.so.17.0.0
%{__chmod} +x %{buildroot}%{python_sitearch}/gpspacket.so
# fix non-executable python script
%{__chmod} +x %{buildroot}%{python_sitearch}/gps.py
# Install the .desktop files
desktop-file-install --vendor fedora \
--dir %{buildroot}%{_datadir}/applications \
--add-category X-Fedora \
@ -90,17 +106,20 @@ desktop-file-install --vendor fedora \
--add-category X-Fedora \
%{SOURCE2}
#Install logo icon for .desktop files
mkdir -p %{buildroot}%{_datadir}/gpsd
cp -p %{SOURCE3} %{buildroot}%{_datadir}/gpsd/gpsd-logo.png
# Install logo icon for .desktop files
%{__install} -d -m 0755 %{buildroot}%{_datadir}/gpsd
%{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{_datadir}/gpsd/gpsd-logo.png
%clean
rm -rf %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%doc README INSTALL COPYING
@ -109,13 +128,13 @@ rm -rf %{buildroot}
%{_bindir}/sirfmon
%{_bindir}/gpsctl
%{_libdir}/libgps.so.*
%{python_sitearch}/gps.py*
%{_mandir}/man8/gpsd.8*
%{_mandir}/man1/gpsprof.1*
%{_mandir}/man1/sirfmon.1*
%{_mandir}/man1/gpsctl.1*
%{_sysconfdir}/hotplug.d/usb/gpsd.hotplug
%{_sysconfdir}/hotplug.d/usb/gpsd.usermap
%{python_sitelib}/gps.py*
%files devel
%defattr(-,root,root,-)
@ -123,13 +142,13 @@ rm -rf %{buildroot}
%{_bindir}/gpsfake
%{_bindir}/rtcmdecode
%{_bindir}/gpsflash
%{python_sitelib}/gpsfake*
%{python_sitelib}/gpspacket.so
%{_libdir}/libgps.so
%{_libdir}/pkgconfig/*.pc
%{python_sitearch}/gpsfake*
%{python_sitearch}/gpspacket.so
%{_includedir}/gps.h
%{_includedir}/libgpsmm.h
%{_includedir}/gpsd.h
%{_includedir}/gpsd_config.h
%{_mandir}/man1/gpsfake.1*
%{_mandir}/man1/rtcmdecode.1*
%{_mandir}/man1/gpsflash.1*
@ -155,13 +174,24 @@ rm -rf %{buildroot}
%{_mandir}/man1/cgps.1*
%{_mandir}/man1/gpscat.1*
%{_mandir}/man1/cgpxlogger.1*
%{_libdir}/X11/app-defaults/xgps
%{_libdir}/X11/app-defaults/xgpsspeed
%{_datadir}/X11/app-defaults/xgps
%{_datadir}/X11/app-defaults/xgpsspeed
%{_datadir}/applications/*.desktop
%dir %{_datadir}/gpsd
%{_datadir}/gpsd/gpsd-logo.png
%changelog
* Wed Feb 27 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-1
- update to 2.37
- removed install-gpsd_config.h.patch
- installed pkgconfig files in devel package
- added patch to install python modules in sitearch
- removing rpath from inclucded libtool
- moving X11 app-defaults to datadir
- using macros for commands in install; using install instead of cp and mkdir
- cleaning up spaces/tabs for rpmlint
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.34-9
- Autorebuild for GCC 4.3

View File

@ -1,24 +0,0 @@
diff -u gpsd-2.34/Makefile.am gpsd-2.34-fixed-install/Makefile.am
--- gpsd-2.34/Makefile.am 2006-12-14 18:43:39.000000000 -0500
+++ gpsd-2.34-fixed-install/Makefile.am 2007-08-19 09:11:14.000000000 -0400
@@ -242,7 +242,7 @@
endif
-include_HEADERS = gps.h gpsd.h libgpsmm.h
+include_HEADERS = gps.h gpsd.h gpsd_config.h libgpsmm.h
EXTRA_DIST = \
autogen.sh \
diff -u gpsd-2.34/Makefile.in gpsd-2.34-fixed-install/Makefile.in
--- gpsd-2.34/Makefile.in 2006-12-14 19:13:13.000000000 -0500
+++ gpsd-2.34-fixed-install/Makefile.in 2007-08-19 09:15:10.000000000 -0400
@@ -541,7 +541,7 @@
@HAVE_XSLT_PROCESSOR_TRUE@ rtcm-104.5 \
@HAVE_XSLT_PROCESSOR_TRUE@ srec.5
-include_HEADERS = gps.h gpsd.h libgpsmm.h
+include_HEADERS = gps.h gpsd.h gpsd_config.h libgpsmm.h
EXTRA_DIST = \
autogen.sh \
README \

View File

@ -0,0 +1,97 @@
diff -ruN gpsd-2.37/Makefile.in gpsd-2.37-new/Makefile.in
--- gpsd-2.37/Makefile.in 2008-02-17 12:41:06.000000000 -0500
+++ gpsd-2.37-new/Makefile.in 2008-02-28 11:45:00.000000000 -0500
@@ -77,7 +77,7 @@
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" \
"$(DESTDIR)$(sbindir)" "$(DESTDIR)$(bindir)" \
- "$(DESTDIR)$(pythondir)" "$(DESTDIR)$(pythondir)" \
+ "$(DESTDIR)$(pyexecdir)" "$(DESTDIR)$(pyexecdir)" \
"$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man3dir)" \
"$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)" \
"$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(includedir)" \
@@ -966,21 +966,21 @@
uninstall-info-am:
install-nodist_pythonPYTHON: $(nodist_python_PYTHON)
@$(NORMAL_INSTALL)
- test -z "$(pythondir)" || $(mkdir_p) "$(DESTDIR)$(pythondir)"
+ test -z "$(pyexecdir)" || $(mkdir_p) "$(DESTDIR)$(pyexecdir)"
@list='$(nodist_python_PYTHON)'; dlist=''; for p in $$list; do\
if test -f "$$p"; then b=; else b="$(srcdir)/"; fi; \
if test -f $$b$$p; then \
f=$(am__strip_dir) \
dlist="$$dlist $$f"; \
- echo " $(nodist_pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pythondir)/$$f'"; \
- $(nodist_pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pythondir)/$$f"; \
+ echo " $(nodist_pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pyexecdir)/$$f'"; \
+ $(nodist_pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pyexecdir)/$$f"; \
else :; fi; \
done; \
if test -n "$$dlist"; then \
if test -z "$(DESTDIR)"; then \
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(pythondir)" $$dlist; \
+ PYTHON=$(PYTHON) $(py_compile) --basedir "$(pyexecdir)" $$dlist; \
else \
- PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pythondir)" $$dlist; \
+ PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pyexecdir)" $$dlist; \
fi; \
else :; fi
@@ -988,27 +988,27 @@
@$(NORMAL_UNINSTALL)
@list='$(nodist_python_PYTHON)'; dlist=''; for p in $$list; do\
f=$(am__strip_dir) \
- rm -f "$(DESTDIR)$(pythondir)/$$f"; \
- rm -f "$(DESTDIR)$(pythondir)/$${f}c"; \
- rm -f "$(DESTDIR)$(pythondir)/$${f}o"; \
+ rm -f "$(DESTDIR)$(pyexecdir)/$$f"; \
+ rm -f "$(DESTDIR)$(pyexecdir)/$${f}c"; \
+ rm -f "$(DESTDIR)$(pyexecdir)/$${f}o"; \
done
install-pythonPYTHON: $(python_PYTHON)
@$(NORMAL_INSTALL)
- test -z "$(pythondir)" || $(mkdir_p) "$(DESTDIR)$(pythondir)"
+ test -z "$(pyexecdir)" || $(mkdir_p) "$(DESTDIR)$(pyexecdir)"
@list='$(python_PYTHON)'; dlist=''; for p in $$list; do\
if test -f "$$p"; then b=; else b="$(srcdir)/"; fi; \
if test -f $$b$$p; then \
f=$(am__strip_dir) \
dlist="$$dlist $$f"; \
- echo " $(pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pythondir)/$$f'"; \
- $(pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pythondir)/$$f"; \
+ echo " $(pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pyexecdir)/$$f'"; \
+ $(pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pyexecdir)/$$f"; \
else :; fi; \
done; \
if test -n "$$dlist"; then \
if test -z "$(DESTDIR)"; then \
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(pythondir)" $$dlist; \
+ PYTHON=$(PYTHON) $(py_compile) --basedir "$(pyexecdir)" $$dlist; \
else \
- PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pythondir)" $$dlist; \
+ PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pyexecdir)" $$dlist; \
fi; \
else :; fi
@@ -1016,9 +1016,9 @@
@$(NORMAL_UNINSTALL)
@list='$(python_PYTHON)'; dlist=''; for p in $$list; do\
f=$(am__strip_dir) \
- rm -f "$(DESTDIR)$(pythondir)/$$f"; \
- rm -f "$(DESTDIR)$(pythondir)/$${f}c"; \
- rm -f "$(DESTDIR)$(pythondir)/$${f}o"; \
+ rm -f "$(DESTDIR)$(pyexecdir)/$$f"; \
+ rm -f "$(DESTDIR)$(pyexecdir)/$${f}c"; \
+ rm -f "$(DESTDIR)$(pyexecdir)/$${f}o"; \
done
install-man1: $(man1_MANS) $(man_MANS)
@$(NORMAL_INSTALL)
@@ -1436,7 +1436,7 @@
install-binPROGRAMS: install-libLTLIBRARIES
installdirs:
- for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pythondir)" "$(DESTDIR)$(pythondir)" "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man3dir)" "$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)" "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)"; do \
+ for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pyexecdir)" "$(DESTDIR)$(pyexecdir)" "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man3dir)" "$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)" "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)"; do \
test -z "$$dir" || $(mkdir_p) "$$dir"; \
done
install: $(BUILT_SOURCES)

View File

@ -1,2 +1,3 @@
1ad07e10f34e46ffdaf10688743f2f43 gpsd-2.34.tar.gz
6c96cc0b2df0279cb7baac1ebc5881d3 gpsd-2.37.tar.gz
f742145dff43d607f7014aa387835738 gpsd-logo.png