- update to 2.94 (#556642)
This commit is contained in:
parent
0e1ecc8b46
commit
861f81b1f3
@ -1 +1 @@
|
|||||||
gpsd-2.39.tar.gz
|
gpsd-2.94.tar.gz
|
||||||
|
@ -1,21 +0,0 @@
|
|||||||
diff -up gpsd-2.39/Makefile.in.implicitlibdeps gpsd-2.39/Makefile.in
|
|
||||||
--- gpsd-2.39/Makefile.in.implicitlibdeps 2010-02-15 12:51:28.000000000 +0100
|
|
||||||
+++ gpsd-2.39/Makefile.in 2010-02-15 12:56:31.000000000 +0100
|
|
||||||
@@ -331,7 +331,7 @@ XP_LIBS = @XP_LIBS@
|
|
||||||
XT_LIBS = @XT_LIBS@
|
|
||||||
X_CFLAGS = @X_CFLAGS@
|
|
||||||
X_EXTRA_LIBS = @X_EXTRA_LIBS@
|
|
||||||
-X_LIBS = @X_LIBS@
|
|
||||||
+X_LIBS = @X_LIBS@ -lX11
|
|
||||||
X_PRE_LIBS = @X_PRE_LIBS@
|
|
||||||
abs_builddir = @abs_builddir@
|
|
||||||
abs_srcdir = @abs_srcdir@
|
|
||||||
@@ -446,7 +446,7 @@ xgpsspeed_SOURCES = \
|
|
||||||
$(xgpsspeed_c_sources) \
|
|
||||||
xgpsspeed.icon
|
|
||||||
|
|
||||||
-xgpsspeed_LDADD = $(LIBM) $(LIBC) $(LIBNSL) $(LIBSOCKET) $(XAW_LIBS) $(X_LIBS) $(X_PRE_LIBS) libgps.la -lm $(LIBPTHREAD)
|
|
||||||
+xgpsspeed_LDADD = $(LIBM) $(LIBC) $(LIBNSL) $(LIBSOCKET) $(XAW_LIBS) $(XT_LIBS) $(X_LIBS) $(X_PRE_LIBS) libgps.la -lm $(LIBPTHREAD)
|
|
||||||
|
|
||||||
#
|
|
||||||
# Build cgps
|
|
@ -1,32 +0,0 @@
|
|||||||
diff -up gpsd-2.39/Makefile.am.BAD gpsd-2.39/Makefile.am
|
|
||||||
--- gpsd-2.39/Makefile.am.BAD 2009-03-31 11:34:18.000000000 -0400
|
|
||||||
+++ gpsd-2.39/Makefile.am 2009-03-31 11:34:30.000000000 -0400
|
|
||||||
@@ -318,10 +318,10 @@ CLEANFILES += stamp-gps-manpages stamp-g
|
|
||||||
endif
|
|
||||||
|
|
||||||
noinst_HEADERS = driver_italk.h driver_rtcm2.h driver_superstar2.h \
|
|
||||||
- driver_ubx.h gpsmon.h gpsdclient.h
|
|
||||||
+ driver_ubx.h gpsmon.h
|
|
||||||
|
|
||||||
nodist_include_HEADERS = gpsd.h
|
|
||||||
-include_HEADERS = gps.h libgpsmm.h
|
|
||||||
+include_HEADERS = gps.h gpsdclient.h libgpsmm.h
|
|
||||||
|
|
||||||
EXTRA_DIST = \
|
|
||||||
autogen.sh \
|
|
||||||
diff -up gpsd-2.39/Makefile.in.BAD gpsd-2.39/Makefile.in
|
|
||||||
--- gpsd-2.39/Makefile.in.BAD 2009-03-31 11:34:40.000000000 -0400
|
|
||||||
+++ gpsd-2.39/Makefile.in 2009-03-31 11:34:51.000000000 -0400
|
|
||||||
@@ -632,10 +632,10 @@ man_MANS = \
|
|
||||||
#
|
|
||||||
@HAVE_XSLT_PROCESSOR_TRUE@BUILT_MANPAGES = $(MANPAGES_DIST)
|
|
||||||
noinst_HEADERS = driver_italk.h driver_rtcm2.h driver_superstar2.h \
|
|
||||||
- driver_ubx.h gpsmon.h gpsdclient.h
|
|
||||||
+ driver_ubx.h gpsmon.h
|
|
||||||
|
|
||||||
nodist_include_HEADERS = gpsd.h
|
|
||||||
-include_HEADERS = gps.h libgpsmm.h
|
|
||||||
+include_HEADERS = gps.h gpsdclient.h libgpsmm.h
|
|
||||||
EXTRA_DIST = \
|
|
||||||
autogen.sh \
|
|
||||||
README \
|
|
12
gpsd-2.94-silentmake.patch
Normal file
12
gpsd-2.94-silentmake.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up gpsd-2.94/setup.py.silentmake gpsd-2.94/setup.py
|
||||||
|
--- gpsd-2.94/setup.py.silentmake 2010-04-20 11:37:21.000000000 +0200
|
||||||
|
+++ gpsd-2.94/setup.py 2010-04-30 14:48:19.000000000 +0200
|
||||||
|
@@ -56,7 +56,7 @@ if not 'clean' in sys.argv:
|
||||||
|
gpspacket_sources = ["gpspacket.c", "packet.c", "isgps.c",
|
||||||
|
"driver_rtcm2.c", "strl.c", "hex.c", "crc24q.c"]
|
||||||
|
include_dirs = [ os.path.realpath(os.path.dirname(__file__)) ]
|
||||||
|
-version_out = os.popen(MAKE + " version")
|
||||||
|
+version_out = os.popen(MAKE + " --no-print-directory version")
|
||||||
|
version = version_out.read()
|
||||||
|
print(version)
|
||||||
|
if version_out.close():
|
61
gpsd.spec
61
gpsd.spec
@ -1,8 +1,8 @@
|
|||||||
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||||
|
|
||||||
Name: gpsd
|
Name: gpsd
|
||||||
Version: 2.39
|
Version: 2.94
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Service daemon for mediating access to a GPS
|
Summary: Service daemon for mediating access to a GPS
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -15,16 +15,11 @@ Source3: gpsd-logo.png
|
|||||||
Source10: gpsd.init
|
Source10: gpsd.init
|
||||||
Source11: gpsd.sysconfig
|
Source11: gpsd.sysconfig
|
||||||
Source21: gpsd.hotplug.wrapper
|
Source21: gpsd.hotplug.wrapper
|
||||||
Patch0: python-pyexecdir-install-gpsd-2.38.patch
|
Patch0: gpsd-2.94-silentmake.patch
|
||||||
Patch1: parallel-make-dependencies.patch
|
|
||||||
# Viking needs this header file to be able to build
|
|
||||||
Patch2: gpsd-2.39-install-gpsdclient-header.patch
|
|
||||||
Patch3: gpsd-2.39-implicitlibdeps.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
|
BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
|
||||||
BuildRequires: lesstif-devel libXaw-devel desktop-file-utils
|
BuildRequires: libXaw-devel desktop-file-utils
|
||||||
BuildRequires: python
|
|
||||||
|
|
||||||
Requires: udev
|
Requires: udev
|
||||||
Requires(post): /sbin/ldconfig
|
Requires(post): /sbin/ldconfig
|
||||||
@ -73,30 +68,24 @@ can run on a serial terminal or terminal emulator.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1 -b .silentmake
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
|
||||||
%patch3 -p1
|
|
||||||
|
|
||||||
sed -i 's/SYSFS/ATTRS/g' gpsd.rules
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
--disable-rpath \
|
|
||||||
--enable-dbus \
|
--enable-dbus \
|
||||||
--disable-static
|
--disable-static
|
||||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ltmain.sh
|
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ltmain.sh
|
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
make DESTDIR=%{buildroot} install
|
make DESTDIR=%{buildroot} pythondir=%{python_sitearch} install
|
||||||
|
|
||||||
# X11 defaults
|
# X11 defaults
|
||||||
%{__install} -d -m 0755 %{buildroot}%{_datadir}/X11/app-defaults/
|
%{__install} -d -m 0755 %{buildroot}%{_datadir}/X11/app-defaults/
|
||||||
%{__install} -p -m 0644 xgps.ad %{buildroot}%{_datadir}/X11/app-defaults/xgps
|
|
||||||
%{__install} -p -m 0644 xgpsspeed.ad \
|
%{__install} -p -m 0644 xgpsspeed.ad \
|
||||||
%{buildroot}%{_datadir}/X11/app-defaults/xgpsspeed
|
%{buildroot}%{_datadir}/X11/app-defaults/xgpsspeed
|
||||||
|
|
||||||
@ -119,18 +108,11 @@ make DESTDIR=%{buildroot} install
|
|||||||
%{__install} -p -m 0755 gpsd.hotplug %{SOURCE21} \
|
%{__install} -p -m 0755 gpsd.hotplug %{SOURCE21} \
|
||||||
%{buildroot}/lib/udev
|
%{buildroot}/lib/udev
|
||||||
|
|
||||||
# create new gpxlogger man page
|
|
||||||
%{__cp} -p %{buildroot}%{_mandir}/man1/cgpxlogger.1 \
|
|
||||||
%{buildroot}%{_mandir}/man1/gpxlogger.1
|
|
||||||
|
|
||||||
# remove .la files
|
# remove .la files
|
||||||
rm -f %{buildroot}%{_libdir}/libgps.la
|
rm -f %{buildroot}%{_libdir}/libgps*.la
|
||||||
|
|
||||||
# fix non-executable libraries
|
|
||||||
%{__chmod} +x %{buildroot}%{python_sitearch}/gpspacket.so
|
|
||||||
|
|
||||||
# fix non-executable python script
|
# fix non-executable python script
|
||||||
%{__chmod} +x %{buildroot}%{python_sitearch}/gps.py
|
%{__chmod} +x %{buildroot}%{python_sitearch}/gps/gps.py
|
||||||
|
|
||||||
# Install the .desktop files
|
# Install the .desktop files
|
||||||
desktop-file-install --vendor fedora \
|
desktop-file-install --vendor fedora \
|
||||||
@ -174,12 +156,10 @@ fi
|
|||||||
%{_bindir}/gpsprof
|
%{_bindir}/gpsprof
|
||||||
%{_bindir}/gpsmon
|
%{_bindir}/gpsmon
|
||||||
%{_bindir}/gpsctl
|
%{_bindir}/gpsctl
|
||||||
%{_libdir}/libgps.so.*
|
%{_libdir}/libgps*.so.*
|
||||||
/lib/udev/gpsd*
|
/lib/udev/gpsd*
|
||||||
%{python_sitearch}/gps.py*
|
%{python_sitearch}/gps*
|
||||||
%{python_sitearch}/gpscap.py*
|
%exclude %{python_sitearch}/gps/fake*
|
||||||
%{python_sitearch}/gpslib.so
|
|
||||||
%{python_sitearch}/gpspacket.so
|
|
||||||
%{_mandir}/man8/gpsd.8*
|
%{_mandir}/man8/gpsd.8*
|
||||||
%{_mandir}/man1/gpsprof.1*
|
%{_mandir}/man1/gpsprof.1*
|
||||||
%{_mandir}/man1/gpsmon.1*
|
%{_mandir}/man1/gpsmon.1*
|
||||||
@ -189,16 +169,13 @@ fi
|
|||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc TODO
|
%doc TODO
|
||||||
%{_bindir}/gpsfake
|
%{_bindir}/gpsfake
|
||||||
%{_bindir}/gpsflash
|
%{_libdir}/libgps*.so
|
||||||
%{_libdir}/libgps.so
|
|
||||||
%{_libdir}/pkgconfig/*.pc
|
%{_libdir}/pkgconfig/*.pc
|
||||||
%{python_sitearch}/gpsfake*
|
%{python_sitearch}/gps/fake*
|
||||||
%{_includedir}/gps.h
|
%{_includedir}/gps.h
|
||||||
%{_includedir}/libgpsmm.h
|
%{_includedir}/libgpsmm.h
|
||||||
%{_includedir}/gpsd.h
|
%{_includedir}/gpsd.h
|
||||||
%{_includedir}/gpsdclient.h
|
|
||||||
%{_mandir}/man1/gpsfake.1*
|
%{_mandir}/man1/gpsfake.1*
|
||||||
%{_mandir}/man1/gpsflash.1*
|
|
||||||
%{_mandir}/man3/libgps.3*
|
%{_mandir}/man3/libgps.3*
|
||||||
%{_mandir}/man3/libgpsmm.3*
|
%{_mandir}/man3/libgpsmm.3*
|
||||||
%{_mandir}/man3/libgpsd.3*
|
%{_mandir}/man3/libgpsd.3*
|
||||||
@ -215,17 +192,14 @@ fi
|
|||||||
%{_bindir}/lcdgps
|
%{_bindir}/lcdgps
|
||||||
%{_bindir}/xgps
|
%{_bindir}/xgps
|
||||||
%{_bindir}/xgpsspeed
|
%{_bindir}/xgpsspeed
|
||||||
%{_mandir}/man1/cgpxlogger.1*
|
|
||||||
%{_mandir}/man1/gps.1*
|
%{_mandir}/man1/gps.1*
|
||||||
%{_mandir}/man1/gpsdecode.1*
|
%{_mandir}/man1/gpsdecode.1*
|
||||||
%{_mandir}/man1/gpspipe.1*
|
%{_mandir}/man1/gpspipe.1*
|
||||||
%{_mandir}/man1/gpxlogger.1*
|
|
||||||
%{_mandir}/man1/lcdgps.1*
|
%{_mandir}/man1/lcdgps.1*
|
||||||
%{_mandir}/man1/xgps.1*
|
%{_mandir}/man1/xgps.1*
|
||||||
%{_mandir}/man1/xgpsspeed.1*
|
%{_mandir}/man1/xgpsspeed.1*
|
||||||
%{_mandir}/man1/cgps.1*
|
%{_mandir}/man1/cgps.1*
|
||||||
%{_mandir}/man1/gpscat.1*
|
%{_mandir}/man1/gpscat.1*
|
||||||
%{_datadir}/X11/app-defaults/xgps
|
|
||||||
%{_datadir}/X11/app-defaults/xgpsspeed
|
%{_datadir}/X11/app-defaults/xgpsspeed
|
||||||
%{_datadir}/applications/*.desktop
|
%{_datadir}/applications/*.desktop
|
||||||
%dir %{_datadir}/gpsd
|
%dir %{_datadir}/gpsd
|
||||||
@ -233,6 +207,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 06 2010 Miroslav Lichvar <mlichvar@redhat.com> - 2.94-1
|
||||||
|
- update to 2.94 (#556642)
|
||||||
|
|
||||||
* Tue Mar 02 2010 Miroslav Lichvar <mlichvar@redhat.com> - 2.39-7
|
* Tue Mar 02 2010 Miroslav Lichvar <mlichvar@redhat.com> - 2.39-7
|
||||||
- don't use deprecated SYSFS{} in udev rules (#569089)
|
- don't use deprecated SYSFS{} in udev rules (#569089)
|
||||||
- fix init script LSB compliance
|
- fix init script LSB compliance
|
||||||
|
File diff suppressed because it is too large
Load Diff
@ -1,97 +0,0 @@
|
|||||||
diff -ruN gpsd-2.38-orig/Makefile.in gpsd-2.38/Makefile.in
|
|
||||||
--- gpsd-2.38-orig/Makefile.in 2009-02-10 15:44:43.000000000 -0500
|
|
||||||
+++ gpsd-2.38/Makefile.in 2009-02-12 11:04:18.000000000 -0500
|
|
||||||
@@ -75,7 +75,7 @@
|
|
||||||
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
|
|
||||||
am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" \
|
|
||||||
"$(DESTDIR)$(sbindir)" "$(DESTDIR)$(bindir)" \
|
|
||||||
- "$(DESTDIR)$(pythondir)" "$(DESTDIR)$(pythondir)" \
|
|
||||||
+ "$(DESTDIR)$(pyexecdir)" "$(DESTDIR)$(pyexecdir)" \
|
|
||||||
"$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man3dir)" \
|
|
||||||
"$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)" \
|
|
||||||
"$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(includedir)" \
|
|
||||||
@@ -1005,21 +1005,21 @@
|
|
||||||
-rm -f libtool
|
|
||||||
install-nodist_pythonPYTHON: $(nodist_python_PYTHON)
|
|
||||||
@$(NORMAL_INSTALL)
|
|
||||||
- test -z "$(pythondir)" || $(MKDIR_P) "$(DESTDIR)$(pythondir)"
|
|
||||||
+ test -z "$(pyexecdir)" || $(MKDIR_P) "$(DESTDIR)$(pyexecdir)"
|
|
||||||
@list='$(nodist_python_PYTHON)'; dlist=''; for p in $$list; do\
|
|
||||||
if test -f "$$p"; then b=; else b="$(srcdir)/"; fi; \
|
|
||||||
if test -f $$b$$p; then \
|
|
||||||
f=$(am__strip_dir) \
|
|
||||||
dlist="$$dlist $$f"; \
|
|
||||||
- echo " $(nodist_pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pythondir)/$$f'"; \
|
|
||||||
- $(nodist_pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pythondir)/$$f"; \
|
|
||||||
+ echo " $(nodist_pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pyexecdir)/$$f'"; \
|
|
||||||
+ $(nodist_pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pyexecdir)/$$f"; \
|
|
||||||
else :; fi; \
|
|
||||||
done; \
|
|
||||||
if test -n "$$dlist"; then \
|
|
||||||
if test -z "$(DESTDIR)"; then \
|
|
||||||
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(pythondir)" $$dlist; \
|
|
||||||
+ PYTHON=$(PYTHON) $(py_compile) --basedir "$(pyexecdir)" $$dlist; \
|
|
||||||
else \
|
|
||||||
- PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pythondir)" $$dlist; \
|
|
||||||
+ PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pyexecdir)" $$dlist; \
|
|
||||||
fi; \
|
|
||||||
else :; fi
|
|
||||||
|
|
||||||
@@ -1027,27 +1027,27 @@
|
|
||||||
@$(NORMAL_UNINSTALL)
|
|
||||||
@list='$(nodist_python_PYTHON)'; dlist=''; for p in $$list; do\
|
|
||||||
f=$(am__strip_dir) \
|
|
||||||
- rm -f "$(DESTDIR)$(pythondir)/$$f"; \
|
|
||||||
- rm -f "$(DESTDIR)$(pythondir)/$${f}c"; \
|
|
||||||
- rm -f "$(DESTDIR)$(pythondir)/$${f}o"; \
|
|
||||||
+ rm -f "$(DESTDIR)$(pyexecdir)/$$f"; \
|
|
||||||
+ rm -f "$(DESTDIR)$(pyexecdir)/$${f}c"; \
|
|
||||||
+ rm -f "$(DESTDIR)$(pyexecdir)/$${f}o"; \
|
|
||||||
done
|
|
||||||
install-pythonPYTHON: $(python_PYTHON)
|
|
||||||
@$(NORMAL_INSTALL)
|
|
||||||
- test -z "$(pythondir)" || $(MKDIR_P) "$(DESTDIR)$(pythondir)"
|
|
||||||
+ test -z "$(pyexecdir)" || $(MKDIR_P) "$(DESTDIR)$(pyexecdir)"
|
|
||||||
@list='$(python_PYTHON)'; dlist=''; for p in $$list; do\
|
|
||||||
if test -f "$$p"; then b=; else b="$(srcdir)/"; fi; \
|
|
||||||
if test -f $$b$$p; then \
|
|
||||||
f=$(am__strip_dir) \
|
|
||||||
dlist="$$dlist $$f"; \
|
|
||||||
- echo " $(pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pythondir)/$$f'"; \
|
|
||||||
- $(pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pythondir)/$$f"; \
|
|
||||||
+ echo " $(pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pyexecdir)/$$f'"; \
|
|
||||||
+ $(pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pyexecdir)/$$f"; \
|
|
||||||
else :; fi; \
|
|
||||||
done; \
|
|
||||||
if test -n "$$dlist"; then \
|
|
||||||
if test -z "$(DESTDIR)"; then \
|
|
||||||
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(pythondir)" $$dlist; \
|
|
||||||
+ PYTHON=$(PYTHON) $(py_compile) --basedir "$(pyexecdir)" $$dlist; \
|
|
||||||
else \
|
|
||||||
- PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pythondir)" $$dlist; \
|
|
||||||
+ PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pyexecdir)" $$dlist; \
|
|
||||||
fi; \
|
|
||||||
else :; fi
|
|
||||||
|
|
||||||
@@ -1055,9 +1055,9 @@
|
|
||||||
@$(NORMAL_UNINSTALL)
|
|
||||||
@list='$(python_PYTHON)'; dlist=''; for p in $$list; do\
|
|
||||||
f=$(am__strip_dir) \
|
|
||||||
- rm -f "$(DESTDIR)$(pythondir)/$$f"; \
|
|
||||||
- rm -f "$(DESTDIR)$(pythondir)/$${f}c"; \
|
|
||||||
- rm -f "$(DESTDIR)$(pythondir)/$${f}o"; \
|
|
||||||
+ rm -f "$(DESTDIR)$(pyexecdir)/$$f"; \
|
|
||||||
+ rm -f "$(DESTDIR)$(pyexecdir)/$${f}c"; \
|
|
||||||
+ rm -f "$(DESTDIR)$(pyexecdir)/$${f}o"; \
|
|
||||||
done
|
|
||||||
install-man1: $(man1_MANS) $(man_MANS)
|
|
||||||
@$(NORMAL_INSTALL)
|
|
||||||
@@ -1478,7 +1478,7 @@
|
|
||||||
install-binPROGRAMS: install-libLTLIBRARIES
|
|
||||||
|
|
||||||
installdirs:
|
|
||||||
- for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pythondir)" "$(DESTDIR)$(pythondir)" "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man3dir)" "$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)" "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)"; do \
|
|
||||||
+ for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pyexecdir)" "$(DESTDIR)$(pyexecdir)" "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man3dir)" "$(DESTDIR)$(man5dir)" "$(DESTDIR)$(man8dir)" "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)"; do \
|
|
||||||
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
|
|
||||||
done
|
|
||||||
install: $(BUILT_SOURCES)
|
|
Loading…
Reference in New Issue
Block a user