update to 3.4
This commit is contained in:
parent
f86fae8404
commit
41cc0ddce1
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
/gpsd-3.0.tar.gz
|
/gpsd-3.0.tar.gz
|
||||||
/gpsd-3.1.tar.gz
|
/gpsd-3.1.tar.gz
|
||||||
/gpsd-3.3.tar.gz
|
/gpsd-3.3.tar.gz
|
||||||
|
/gpsd-3.4.tar.gz
|
||||||
|
@ -1,43 +0,0 @@
|
|||||||
diff -up gpsd-3.3/SConstruct.scons gpsd-3.3/SConstruct
|
|
||||||
--- gpsd-3.3/SConstruct.scons 2011-10-29 13:48:53.000000000 +0200
|
|
||||||
+++ gpsd-3.3/SConstruct 2011-10-31 15:42:33.616170514 +0100
|
|
||||||
@@ -255,7 +255,6 @@ def installdir(dir):
|
|
||||||
|
|
||||||
# Honor the specified installation prefix in link paths.
|
|
||||||
env.Prepend(LIBPATH=[installdir('libdir')])
|
|
||||||
-env.Prepend(RPATH=[installdir('libdir')])
|
|
||||||
|
|
||||||
# Give deheader a way to set compiler flags
|
|
||||||
if 'MORECFLAGS' in os.environ:
|
|
||||||
@@ -380,11 +379,8 @@ if config.CheckExecutable('$CHRPATH -v',
|
|
||||||
# handled sanely by scons on all systems. Not good to use '.' or
|
|
||||||
# a relative path here; it's a security risk. At install time we
|
|
||||||
# use chrpath to edit this out of RPATH.
|
|
||||||
- env.Prepend(LIBPATH=[os.path.realpath(os.curdir)])
|
|
||||||
- env.Prepend(RPATH=[os.path.realpath(os.curdir)])
|
|
||||||
-else:
|
|
||||||
- print "The chrpath utility is required for GPSD to build."
|
|
||||||
- quit()
|
|
||||||
+ pass
|
|
||||||
+env.Prepend(LIBPATH=[os.path.realpath(os.curdir)])
|
|
||||||
|
|
||||||
confdefs = ["/* gpsd_config.h. Generated by scons, do not hand-hack. */\n"]
|
|
||||||
|
|
||||||
@@ -962,7 +958,7 @@ if st != 0:
|
|
||||||
from datetime import datetime
|
|
||||||
rev = datetime.now().isoformat()[:-4]
|
|
||||||
revision='#define REVISION "%s"\n' %(rev.strip(),)
|
|
||||||
-env.NoClean(env.Textfile(target="revision.h", source=[revision]))
|
|
||||||
+#env.NoClean(env.Textfile(target="revision.h", source=[revision]))
|
|
||||||
|
|
||||||
# generate pps_pin.h
|
|
||||||
pps_pin = env['pps_pin']
|
|
||||||
@@ -1102,8 +1098,6 @@ binaryinstall.append(LibraryInstall(env,
|
|
||||||
if qt_env:
|
|
||||||
binaryinstall.append(LibraryInstall(qt_env, installdir('libdir'), compiled_qgpsmmlib))
|
|
||||||
|
|
||||||
-env.AddPostAction(binaryinstall, '$CHRPATH -r "%s" "$TARGET"' % installdir('libdir'))
|
|
||||||
-
|
|
||||||
if not env['debug'] and not env['profiling'] and env['strip']:
|
|
||||||
env.AddPostAction(binaryinstall, '$STRIP $TARGET')
|
|
||||||
|
|
19
gpsd.spec
19
gpsd.spec
@ -1,6 +1,6 @@
|
|||||||
Name: gpsd
|
Name: gpsd
|
||||||
Version: 3.3
|
Version: 3.4
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Service daemon for mediating access to a GPS
|
Summary: Service daemon for mediating access to a GPS
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -10,11 +10,10 @@ Source0: http://download.savannah.gnu.org/releases/gpsd/%{name}-%{version}.tar.g
|
|||||||
Source10: gpsd.service
|
Source10: gpsd.service
|
||||||
Source11: gpsd.sysconfig
|
Source11: gpsd.sysconfig
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
# fix RPATH and revision.h
|
|
||||||
Patch0: gpsd-scons.patch
|
|
||||||
|
|
||||||
BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
|
BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
|
||||||
BuildRequires: scons desktop-file-utils bluez-libs-devel pps-tools-devel
|
BuildRequires: scons desktop-file-utils bluez-libs-devel pps-tools-devel
|
||||||
|
BuildRequires: chrpath
|
||||||
%ifnarch s390 s390x
|
%ifnarch s390 s390x
|
||||||
BuildRequires: libusb1-devel
|
BuildRequires: libusb1-devel
|
||||||
%endif
|
%endif
|
||||||
@ -72,9 +71,6 @@ can run on a serial terminal or terminal emulator.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .scons
|
|
||||||
|
|
||||||
echo '#define REVISION "release-%{version}-%{release}"' > revision.h
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CCFLAGS="%{optflags}"
|
export CCFLAGS="%{optflags}"
|
||||||
@ -137,6 +133,12 @@ desktop-file-install --vendor fedora \
|
|||||||
# Not needed since gpsd.h is not installed
|
# Not needed since gpsd.h is not installed
|
||||||
rm %{buildroot}%{_libdir}/{libgpsd.so,pkgconfig/libgpsd.pc}
|
rm %{buildroot}%{_libdir}/{libgpsd.so,pkgconfig/libgpsd.pc}
|
||||||
|
|
||||||
|
# Remove RPATH (even the actual string)
|
||||||
|
for i in %{buildroot}%{python_sitearch}/gps/*.so; do
|
||||||
|
chrpath -r "" $i
|
||||||
|
chrpath -d $i
|
||||||
|
done
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
@ -228,6 +230,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 26 2012 Miroslav Lichvar <mlichvar@redhat.com> - 3.4-1
|
||||||
|
- update to 3.4
|
||||||
|
|
||||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3-2
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user