update to 3.23
This commit is contained in:
parent
6657e60ea9
commit
231de1a53e
1
.gitignore
vendored
1
.gitignore
vendored
@ -19,3 +19,4 @@
|
|||||||
/gpsd-3.19.tar.gz
|
/gpsd-3.19.tar.gz
|
||||||
/gpsd-3.20.tar.gz
|
/gpsd-3.20.tar.gz
|
||||||
/gpsd-3.22.tar.gz
|
/gpsd-3.22.tar.gz
|
||||||
|
/gpsd-3.23.tar.gz
|
||||||
|
@ -1,44 +0,0 @@
|
|||||||
Hunk cherry-picked from the following commit. It doesn't add the command to set
|
|
||||||
the date in tests, i.e. they are broken now.
|
|
||||||
|
|
||||||
commit 7f30d88d04dc62b8bd6265ad1d09d72d220f97f6
|
|
||||||
Author: Gary E. Miller <gem@rellim.com>
|
|
||||||
Date: Sat Jul 24 20:22:15 2021 -0700
|
|
||||||
|
|
||||||
gpsd/timebase.c" Don't compute wrong GPS rollover after 2020-10-23.
|
|
||||||
|
|
||||||
gpsfake uses "# Date: yyyy-mm-dd" to set initial time.
|
|
||||||
|
|
||||||
Some regressions needed proper dates.
|
|
||||||
Some regressions now compute proper dates.
|
|
||||||
|
|
||||||
diff --git a/gpsd/timebase.c b/gpsd/timebase.c
|
|
||||||
index 31ac5fab4..513499021 100644
|
|
||||||
--- a/gpsd/timebase.c
|
|
||||||
+++ b/gpsd/timebase.c
|
|
||||||
@@ -388,19 +402,12 @@ timespec_t gpsd_gpstime_resolv(struct gps_device_t *session,
|
|
||||||
if (week < 1024)
|
|
||||||
week += session->context->rollovers * 1024;
|
|
||||||
|
|
||||||
- /* sanity check week number, GPS epoch, against leap seconds
|
|
||||||
- * Does not work well with regressions because the leap_sconds
|
|
||||||
- * could be from the receiver, or from BUILD_LEAPSECONDS. */
|
|
||||||
- if (0 < session->context->leap_seconds &&
|
|
||||||
- 19 > session->context->leap_seconds &&
|
|
||||||
- 2180 < week) {
|
|
||||||
- /* assume leap second = 19 by 31 Dec 2022
|
|
||||||
- * so week > 2180 is way in the future, do not allow it */
|
|
||||||
- week -= 1024;
|
|
||||||
- GPSD_LOG(LOG_WARN, &session->context->errout,
|
|
||||||
- "GPS week confusion. Adjusted week %u for leap %d\n",
|
|
||||||
- week, session->context->leap_seconds);
|
|
||||||
- }
|
|
||||||
+ /* This used to sanity check week number, GPS epoch, against leap
|
|
||||||
+ * seconds. Did not work well with regressions because the leap_sconds
|
|
||||||
+ * could be from the receiver, or from BUILD_LEAPSECONDS.
|
|
||||||
+ * Maybe if the regressions files provided BUILD_LEAPSECONDS this
|
|
||||||
+ * could be tried again.
|
|
||||||
+ */
|
|
||||||
|
|
||||||
// gcc needs the (time_t)week to not overflow. clang got it right.
|
|
||||||
// if time_t is 32-bits, then still 2038 issues
|
|
14
gpsd.spec
14
gpsd.spec
@ -3,7 +3,7 @@
|
|||||||
%global with_qt 1
|
%global with_qt 1
|
||||||
|
|
||||||
Name: gpsd
|
Name: gpsd
|
||||||
Version: 3.22
|
Version: 3.23
|
||||||
Release: 5%{?dist}
|
Release: 5%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Summary: Service daemon for mediating access to a GPS
|
Summary: Service daemon for mediating access to a GPS
|
||||||
@ -13,9 +13,6 @@ URL: http://catb.org/gpsd/
|
|||||||
Source0: https://download-mirror.savannah.gnu.org/releases/gpsd/%{name}-%{version}.tar.gz
|
Source0: https://download-mirror.savannah.gnu.org/releases/gpsd/%{name}-%{version}.tar.gz
|
||||||
Source11: gpsd.sysconfig
|
Source11: gpsd.sysconfig
|
||||||
|
|
||||||
# Fix handling of GPS weeks after 2180
|
|
||||||
Patch1: gpsd-week2180.patch
|
|
||||||
|
|
||||||
BuildRequires: dbus-devel
|
BuildRequires: dbus-devel
|
||||||
BuildRequires: dbus-glib-devel
|
BuildRequires: dbus-glib-devel
|
||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
@ -107,7 +104,6 @@ This package contains various clients using gpsd.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .week2180
|
|
||||||
|
|
||||||
# don't try reloading systemd when installing in the build root
|
# don't try reloading systemd when installing in the build root
|
||||||
sed -i 's|systemctl daemon-reload|true|' SConscript
|
sed -i 's|systemctl daemon-reload|true|' SConscript
|
||||||
@ -224,7 +220,7 @@ rm -rf %{buildroot}%{_docdir}/gpsd
|
|||||||
%{_mandir}/man1/ntpshmmon.1*
|
%{_mandir}/man1/ntpshmmon.1*
|
||||||
|
|
||||||
%files libs
|
%files libs
|
||||||
%{_libdir}/libgps.so.28*
|
%{_libdir}/libgps.so.29*
|
||||||
|
|
||||||
%files -n python3-%{name}
|
%files -n python3-%{name}
|
||||||
%{_libdir}/libgpsdpacket.so*
|
%{_libdir}/libgpsdpacket.so*
|
||||||
@ -242,7 +238,7 @@ rm -rf %{buildroot}%{_docdir}/gpsd
|
|||||||
|
|
||||||
%if %{with_qt}
|
%if %{with_qt}
|
||||||
%files qt
|
%files qt
|
||||||
%{_libdir}/libQgpsmm.so.28*
|
%{_libdir}/libQgpsmm.so.29*
|
||||||
|
|
||||||
%files qt-devel
|
%files qt-devel
|
||||||
%{_libdir}/libQgpsmm.so
|
%{_libdir}/libQgpsmm.so
|
||||||
@ -257,11 +253,13 @@ rm -rf %{buildroot}%{_docdir}/gpsd
|
|||||||
%{_bindir}/gps2udp
|
%{_bindir}/gps2udp
|
||||||
%{_bindir}/gpscat
|
%{_bindir}/gpscat
|
||||||
%{_bindir}/gpscsv
|
%{_bindir}/gpscsv
|
||||||
|
%{_bindir}/gpsdebuginfo
|
||||||
%{_bindir}/gpsdecode
|
%{_bindir}/gpsdecode
|
||||||
%{_bindir}/gpspipe
|
%{_bindir}/gpspipe
|
||||||
%{_bindir}/gpsplot
|
%{_bindir}/gpsplot
|
||||||
%{_bindir}/gpsprof
|
%{_bindir}/gpsprof
|
||||||
%{_bindir}/gpsrinex
|
%{_bindir}/gpsrinex
|
||||||
|
%{_bindir}/gpssnmp
|
||||||
%{_bindir}/gpssubframe
|
%{_bindir}/gpssubframe
|
||||||
%{_bindir}/gpxlogger
|
%{_bindir}/gpxlogger
|
||||||
%{_bindir}/lcdgps
|
%{_bindir}/lcdgps
|
||||||
@ -274,11 +272,13 @@ rm -rf %{buildroot}%{_docdir}/gpsd
|
|||||||
%{_mandir}/man1/gps.1*
|
%{_mandir}/man1/gps.1*
|
||||||
%{_mandir}/man1/gps2udp.1*
|
%{_mandir}/man1/gps2udp.1*
|
||||||
%{_mandir}/man1/gpscsv.1*
|
%{_mandir}/man1/gpscsv.1*
|
||||||
|
%{_mandir}/man1/gpsdebuginfo.1*
|
||||||
%{_mandir}/man1/gpsdecode.1*
|
%{_mandir}/man1/gpsdecode.1*
|
||||||
%{_mandir}/man1/gpspipe.1*
|
%{_mandir}/man1/gpspipe.1*
|
||||||
%{_mandir}/man1/gpsplot.1*
|
%{_mandir}/man1/gpsplot.1*
|
||||||
%{_mandir}/man1/gpsprof.1*
|
%{_mandir}/man1/gpsprof.1*
|
||||||
%{_mandir}/man1/gpsrinex.1*
|
%{_mandir}/man1/gpsrinex.1*
|
||||||
|
%{_mandir}/man1/gpssnmp.1*
|
||||||
%{_mandir}/man1/gpssubframe.1*
|
%{_mandir}/man1/gpssubframe.1*
|
||||||
%{_mandir}/man1/gpxlogger.1*
|
%{_mandir}/man1/gpxlogger.1*
|
||||||
%{_mandir}/man1/lcdgps.1*
|
%{_mandir}/man1/lcdgps.1*
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gpsd-3.22.tar.gz) = 4ed08e92b17f8f1bcef6be66f7bb232994d419d1638af0d435a5b03800dcde070accdecb707ea27cceebd333ab597fd0b3a77f405542b488626cb4f1efbe856b
|
SHA512 (gpsd-3.23.tar.gz) = 967cc9801271418023630df02b457b76108968992151f6e80b569e99b856bd79cc3d0369d2088f3bc609b2ab22b29dba87639bf466bf262ab80b2b3f04055f8b
|
||||||
|
Loading…
Reference in New Issue
Block a user