update to 3.3
This commit is contained in:
parent
c1bdb5e1ba
commit
1f146dd202
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/gpsd-3.0.tar.gz
|
||||
/gpsd-3.1.tar.gz
|
||||
/gpsd-3.3.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up gpsd-2.94/setup.py.silentmake gpsd-2.94/setup.py
|
||||
--- gpsd-2.94/setup.py.silentmake 2010-04-20 11:37:21.000000000 +0200
|
||||
+++ gpsd-2.94/setup.py 2010-04-30 14:48:19.000000000 +0200
|
||||
@@ -56,7 +56,7 @@ if not 'clean' in sys.argv:
|
||||
gpspacket_sources = ["gpspacket.c", "packet.c", "isgps.c",
|
||||
"driver_rtcm2.c", "strl.c", "hex.c", "crc24q.c"]
|
||||
include_dirs = [ os.path.realpath(os.path.dirname(__file__)) ]
|
||||
-version_out = os.popen(MAKE + " version")
|
||||
+version_out = os.popen(MAKE + " --no-print-directory version")
|
||||
version = version_out.read()
|
||||
print(version)
|
||||
if version_out.close():
|
@ -1,44 +1,43 @@
|
||||
diff -up gpsd-3.1/SConstruct.scons gpsd-3.1/SConstruct
|
||||
--- gpsd-3.1/SConstruct.scons 2011-08-28 13:14:24.000000000 +0200
|
||||
+++ gpsd-3.1/SConstruct 2011-08-29 16:18:11.701614604 +0200
|
||||
@@ -208,14 +208,12 @@ def installdir(dir):
|
||||
diff -up gpsd-3.3/SConstruct.scons gpsd-3.3/SConstruct
|
||||
--- gpsd-3.3/SConstruct.scons 2011-10-29 13:48:53.000000000 +0200
|
||||
+++ gpsd-3.3/SConstruct 2011-10-31 15:42:33.616170514 +0100
|
||||
@@ -255,7 +255,6 @@ def installdir(dir):
|
||||
|
||||
# Honor the specified installation prefix in link paths.
|
||||
env.Prepend(LIBPATH=[os.path.join(env['prefix'], installdir('libdir'))])
|
||||
-env.Prepend(RPATH=[os.path.join(env['prefix'], installdir('libdir'))])
|
||||
|
||||
# Tell generated binaries to look in the current directory for
|
||||
# shared libraries. Should be handled sanely by scons on all systems.
|
||||
# Not good to use '.' or a relative path here; it's a security risk.
|
||||
# At install time we should use chrpath to edit this out of RPATH.
|
||||
env.Prepend(LIBPATH=[os.path.realpath(os.curdir)])
|
||||
-env.Prepend(RPATH=[os.path.realpath(os.curdir)])
|
||||
env.Prepend(LIBPATH=[installdir('libdir')])
|
||||
-env.Prepend(RPATH=[installdir('libdir')])
|
||||
|
||||
# Give deheader a way to set compiler flags
|
||||
if 'MORECFLAGS' in os.environ:
|
||||
@@ -409,6 +407,7 @@ if config.CheckExecutable('$CHRPATH -v',
|
||||
have_chrpath = True
|
||||
else:
|
||||
have_chrpath = False
|
||||
+have_chrpath = False
|
||||
@@ -380,11 +379,8 @@ if config.CheckExecutable('$CHRPATH -v',
|
||||
# handled sanely by scons on all systems. Not good to use '.' or
|
||||
# a relative path here; it's a security risk. At install time we
|
||||
# use chrpath to edit this out of RPATH.
|
||||
- env.Prepend(LIBPATH=[os.path.realpath(os.curdir)])
|
||||
- env.Prepend(RPATH=[os.path.realpath(os.curdir)])
|
||||
-else:
|
||||
- print "The chrpath utility is required for GPSD to build."
|
||||
- quit()
|
||||
+ pass
|
||||
+env.Prepend(LIBPATH=[os.path.realpath(os.curdir)])
|
||||
|
||||
# Map options to libraries required to support them that might be absent.
|
||||
optionrequires = {
|
||||
@@ -686,7 +685,7 @@ compiled_gpslib = Library(env=env,
|
||||
compiled_gpsdlib = Library(env=env,
|
||||
target="gpsd",
|
||||
sources=libgpsd_sources,
|
||||
- version=libversion, parse_flags=usblibs + rtlibs + bluezlibs)
|
||||
+ version=libversion, parse_flags=usblibs + bluezlibs + [ "-lm", "-lgps"])
|
||||
confdefs = ["/* gpsd_config.h. Generated by scons, do not hand-hack. */\n"]
|
||||
|
||||
libraries = [compiled_gpslib, compiled_gpsdlib]
|
||||
|
||||
@@ -896,7 +895,7 @@ if st != 0:
|
||||
@@ -962,7 +958,7 @@ if st != 0:
|
||||
from datetime import datetime
|
||||
rev = datetime.now().isoformat()[:-4]
|
||||
revision='#define REVISION "%s"\n' %(rev.strip(),)
|
||||
-env.NoClean(env.Textfile(target="revision.h", source=[revision]))
|
||||
+#env.NoClean(env.Textfile(target="revision.h", source=[revision]))
|
||||
|
||||
generated_sources = ['packet_names.h', 'timebase.h', 'gpsd.h', "ais_json.i",
|
||||
'gps_maskdump.c', 'ais_json.c', 'revision.h']
|
||||
# generate pps_pin.h
|
||||
pps_pin = env['pps_pin']
|
||||
@@ -1102,8 +1098,6 @@ binaryinstall.append(LibraryInstall(env,
|
||||
if qt_env:
|
||||
binaryinstall.append(LibraryInstall(qt_env, installdir('libdir'), compiled_qgpsmmlib))
|
||||
|
||||
-env.AddPostAction(binaryinstall, '$CHRPATH -r "%s" "$TARGET"' % installdir('libdir'))
|
||||
-
|
||||
if not env['debug'] and not env['profiling'] and env['strip']:
|
||||
env.AddPostAction(binaryinstall, '$STRIP $TARGET')
|
||||
|
||||
|
13
gpsd.spec
13
gpsd.spec
@ -1,16 +1,16 @@
|
||||
Name: gpsd
|
||||
Version: 3.1
|
||||
Version: 3.3
|
||||
Release: 1%{?dist}
|
||||
Summary: Service daemon for mediating access to a GPS
|
||||
|
||||
Group: System Environment/Daemons
|
||||
License: BSD
|
||||
URL: http://developer.berlios.de/projects/gpsd/
|
||||
Source0: http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
|
||||
URL: http://catb.org/gpsd/
|
||||
Source0: http://download.savannah.gnu.org/releases/gpsd/%{name}-%{version}.tar.gz
|
||||
Source10: gpsd.service
|
||||
Source11: gpsd.sysconfig
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
# fix RPATH, libs and revision.h
|
||||
# fix RPATH and revision.h
|
||||
Patch0: gpsd-scons.patch
|
||||
|
||||
BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
|
||||
@ -187,7 +187,7 @@ fi
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%doc TODO www/client-howto.txt
|
||||
%doc TODO
|
||||
%{_bindir}/gpsfake
|
||||
%{_libdir}/libgps*.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
@ -228,6 +228,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Oct 31 2011 Miroslav Lichvar <mlichvar@redhat.com> - 3.3-1
|
||||
- update to 3.3
|
||||
|
||||
* Mon Aug 29 2011 Miroslav Lichvar <mlichvar@redhat.com> - 3.1-1
|
||||
- update to 3.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user