a3cc5c089f
Tue May 04 2004 Adrian Havill <havill@redhat.com> 1.20.1-49 - remove superfluous "i die" msg (#121845) Tue May 04 2004 Adrian Havill <havill@redhat.com> 1.20.1-48 - restore gpmopen() NULL check that was removed with the evdev superpatch (#118554) Fri Apr 16 2004 Adrian Havill <havill@redhat.com> 1.20.1-47 - make presence of t-mouse.el flexible (#120958) Wed Mar 31 2004 Adrian Havill <havill@redhat.com> 1.20.1-46 - revise nodebug patch as liblow reporting the VC to the console through stderr has re-appeared (#117676) Mon Mar 22 2004 Adrian Havill <havill@redhat.com> 1.20.1-45 - remove circular ncurses dep for prelink by restoring wgetch patch (#117150)
39 lines
1.1 KiB
Diff
39 lines
1.1 KiB
Diff
--- gpm-1.20.1/src/lib/libcurses.c.weak-wgetch 2002-12-24 17:57:16.000000000 -0500
|
|
+++ gpm-1.20.1/src/lib/libcurses.c 2004-03-22 15:51:24.000000000 -0500
|
|
@@ -41,7 +41,12 @@
|
|
#endif /* HAVE_NCURSES_CURSES_H */
|
|
#endif /* HAVE_NCURSES_H */
|
|
|
|
-#define GET(win) ((win) ? wgetch(win) : getch())
|
|
+/* If win != NULL, it must have been created by ncurses anyway.
|
|
+ Avoid circular library dependencies. */
|
|
+#pragma weak wgetch
|
|
+#pragma weak stdscr
|
|
+
|
|
+#define GET(win) ((win && wgetch) ? wgetch(win) : getch())
|
|
|
|
int Gpm_Wgetch(WINDOW *win)
|
|
{
|
|
--- gpm-1.20.1/configure.in.weak-wgetch 2004-03-22 15:49:51.000000000 -0500
|
|
+++ gpm-1.20.1/configure.in 2004-03-22 15:51:24.000000000 -0500
|
|
@@ -115,7 +115,7 @@
|
|
AC_CHECK_LIB($i, wgetch,,,$TERMLIBS)
|
|
else :; fi
|
|
done
|
|
- SHARED_LIBS="$LIBS $TERMLIBS -lc"
|
|
+ SHARED_LIBS="-lc"
|
|
LIBS=$SAVELIBS ;;
|
|
esac
|
|
|
|
--- gpm-1.20.1/configure.weak-wgetch 2004-03-22 15:49:55.000000000 -0500
|
|
+++ gpm-1.20.1/configure 2004-03-22 15:51:24.000000000 -0500
|
|
@@ -4295,7 +4295,7 @@
|
|
|
|
else :; fi
|
|
done
|
|
- SHARED_LIBS="$LIBS $TERMLIBS -lc"
|
|
+ SHARED_LIBS="-lc"
|
|
LIBS=$SAVELIBS ;;
|
|
esac
|
|
|