Updated to 1.20.5. Removed doc patch. Removed lisp stuff, it is part of
emacs-common now. Spec clean up.
This commit is contained in:
parent
c19a4ca89d
commit
e6e7901b95
@ -1 +1 @@
|
|||||||
gpm-1.20.3.tar.gz
|
gpm-1.20.5.tar.gz
|
||||||
|
@ -48,5 +48,5 @@
|
|||||||
$(CP) -r $(srcdir) $(top_builddir)/gpm-$(release)/
|
$(CP) -r $(srcdir) $(top_builddir)/gpm-$(release)/
|
||||||
|
|
||||||
clean distclean:
|
clean distclean:
|
||||||
- $(RM) -f $(srcdir)/emacs/*.elc
|
- $(RM) -f $(srcdir)/emacs/*.elc Makefile
|
||||||
+ $(RM) $(srcdir)/emacs/*.elc
|
+ $(RM) $(srcdir)/emacs/*.elc Makefile
|
||||||
|
@ -14,8 +14,8 @@
|
|||||||
|
|
||||||
int Gpm_Wgetch(WINDOW *win)
|
int Gpm_Wgetch(WINDOW *win)
|
||||||
{
|
{
|
||||||
--- gpm-1.20.1/configure.in.weak-wgetch 2004-03-22 15:49:51.000000000 -0500
|
--- gpm-1.20.1/configure.ac.weak-wgetch 2004-03-22 15:49:51.000000000 -0500
|
||||||
+++ gpm-1.20.1/configure.in 2004-03-22 15:51:24.000000000 -0500
|
+++ gpm-1.20.1/configure.ac 2004-03-22 15:51:24.000000000 -0500
|
||||||
@@ -115,7 +115,7 @@
|
@@ -115,7 +115,7 @@
|
||||||
AC_CHECK_LIB($i, wgetch,,,$TERMLIBS)
|
AC_CHECK_LIB($i, wgetch,,,$TERMLIBS)
|
||||||
else :; fi
|
else :; fi
|
||||||
@ -24,15 +24,3 @@
|
|||||||
+ SHARED_LIBS="-lc"
|
+ SHARED_LIBS="-lc"
|
||||||
LIBS=$SAVELIBS ;;
|
LIBS=$SAVELIBS ;;
|
||||||
esac
|
esac
|
||||||
|
|
||||||
--- gpm-1.20.1/configure.weak-wgetch 2004-03-22 15:49:55.000000000 -0500
|
|
||||||
+++ gpm-1.20.1/configure 2004-03-22 15:51:24.000000000 -0500
|
|
||||||
@@ -4295,7 +4295,7 @@
|
|
||||||
|
|
||||||
else :; fi
|
|
||||||
done
|
|
||||||
- SHARED_LIBS="$LIBS $TERMLIBS -lc"
|
|
||||||
+ SHARED_LIBS="-lc"
|
|
||||||
LIBS=$SAVELIBS ;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
|
127
gpm.spec
127
gpm.spec
@ -1,25 +1,24 @@
|
|||||||
Summary: A mouse server for the Linux console.
|
Summary: A mouse server for the Linux console.
|
||||||
Name: gpm
|
Name: gpm
|
||||||
Version: 1.20.3
|
Version: 1.20.5
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: http://ftp.linux.it/pub/People/rubini/gpm/%{name}-%{version}.tar.gz
|
URL: http://unix.schottelius.org/gpm/
|
||||||
|
Source: http://unix.schottelius.org/gpm/archives/%{name}-%{version}.tar.gz
|
||||||
Source1: gpm.init
|
Source1: gpm.init
|
||||||
Source2: inputattach.c
|
Source2: inputattach.c
|
||||||
Patch1: gpm-1.20.1-multilib.patch
|
Patch1: gpm-1.20.1-multilib.patch
|
||||||
Patch2: gpm-1.20.1-lib-silent.patch
|
Patch2: gpm-1.20.1-lib-silent.patch
|
||||||
Patch3: gpm-1.20.3-gcc4.3.patch
|
Patch3: gpm-1.20.3-gcc4.3.patch
|
||||||
Patch4: gpm-1.20.3-close-fds.patch
|
Patch4: gpm-1.20.3-close-fds.patch
|
||||||
Patch5: gpm-1.20.1-doc.patch
|
Patch5: gpm-1.20.1-weak-wgetch.patch
|
||||||
Patch6: gpm-1.20.1-weak-wgetch.patch
|
|
||||||
|
|
||||||
Prereq: /sbin/chkconfig /sbin/ldconfig /sbin/install-info
|
Prereq: /sbin/chkconfig /sbin/ldconfig /sbin/install-info
|
||||||
Requires: bash >= 2.0
|
Requires: bash >= 2.0
|
||||||
# this defines the library version that this package builds.
|
# this defines the library version that this package builds.
|
||||||
%define LIBVER 1.20.0
|
%define LIBVER 2.1.0
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
BuildPrereq: sed gawk texinfo bison ncurses-devel autoconf
|
BuildRequires: sed gawk texinfo bison ncurses-devel autoconf
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Gpm provides mouse support to text-based Linux applications like the
|
Gpm provides mouse support to text-based Linux applications like the
|
||||||
@ -47,16 +46,13 @@ mouse button.
|
|||||||
%patch2 -p1 -b .lib-silent
|
%patch2 -p1 -b .lib-silent
|
||||||
%patch3 -p1 -b .gcc4.3
|
%patch3 -p1 -b .gcc4.3
|
||||||
%patch4 -p1 -b .close-fds
|
%patch4 -p1 -b .close-fds
|
||||||
%patch5 -p1 -b .doc
|
%patch5 -p1 -b .weak-wgetch
|
||||||
%patch6 -p1 -b .weak-wgetch
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
rm -f configure
|
rm -f configure
|
||||||
rm -f src/prog/open_console.o
|
rm -f src/prog/open_console.o
|
||||||
autoconf
|
autoconf
|
||||||
CFLAGS="-D_GNU_SOURCE $RPM_OPT_FLAGS" \
|
CFLAGS="-D_GNU_SOURCE $RPM_OPT_FLAGS" \
|
||||||
lispdir=%{buildroot}%{_datadir}/emacs/site-lisp \
|
|
||||||
%configure
|
%configure
|
||||||
make
|
make
|
||||||
gcc $RPM_OPT_FLAGS -o inputattach %{SOURCE2}
|
gcc $RPM_OPT_FLAGS -o inputattach %{SOURCE2}
|
||||||
@ -64,57 +60,23 @@ gcc $RPM_OPT_FLAGS -o inputattach %{SOURCE2}
|
|||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
ln -sf libgpm.so.%{LIBVER} $RPM_BUILD_ROOT/%{_libdir}/libgpm.so
|
||||||
|
|
||||||
|
%ifnarch s390 s390x
|
||||||
mkdir -p %{buildroot}%{_sysconfdir}
|
mkdir -p %{buildroot}%{_sysconfdir}
|
||||||
|
|
||||||
PATH=/sbin:$PATH:/usr/sbin:$PATH
|
|
||||||
|
|
||||||
mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp
|
|
||||||
%makeinstall lispdir=%{buildroot}%{_datadir}/emacs/site-lisp
|
|
||||||
install -m 755 inputattach %{buildroot}/%{_sbindir}
|
|
||||||
|
|
||||||
%ifnarch s390 s390x
|
|
||||||
install -m644 doc/gpm-root.1 %{buildroot}%{_mandir}/man1
|
|
||||||
install -m644 conf/gpm-root.conf %{buildroot}%{_sysconfdir}
|
|
||||||
install -s -m755 src/prog/hltest %{buildroot}%{_bindir}
|
|
||||||
%else
|
|
||||||
rm -f $RPM_BUILD_ROOT%{_bindir}/{mev,gpm-root}
|
|
||||||
%endif
|
|
||||||
|
|
||||||
# The emacs-common package contains a newer version of this.
|
|
||||||
#cp contrib/emacs/t-mouse.el* %{buildroot}%{_datadir}/emacs/site-lisp
|
|
||||||
|
|
||||||
{
|
|
||||||
pushd %{buildroot}
|
|
||||||
chmod +x .%{_libdir}/libgpm.so.%{LIBVER}
|
|
||||||
ln -sf libgpm.so.%{LIBVER} .%{_libdir}/libgpm.so
|
|
||||||
/sbin/ldconfig -n .%{_libdir}
|
|
||||||
popd
|
|
||||||
}
|
|
||||||
|
|
||||||
%ifnarch s390 s390x
|
|
||||||
mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
|
mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
|
||||||
|
install -m 755 inputattach %{buildroot}%{_sbindir}
|
||||||
|
install -m 644 conf/gpm-* %{buildroot}%{_sysconfdir}
|
||||||
install -m 755 %{SOURCE1} %{buildroot}%{_sysconfdir}/rc.d/init.d/gpm
|
install -m 755 %{SOURCE1} %{buildroot}%{_sysconfdir}/rc.d/init.d/gpm
|
||||||
%endif
|
%else
|
||||||
|
# we're shipping only libraries in s390[x], so
|
||||||
mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
|
|
||||||
#cat >$RPM_BUILD_ROOT/etc/sysconfig/gpm <<EOF
|
|
||||||
## Additional options for gpm (e.g. acceleration), device
|
|
||||||
#OPTIONS=""
|
|
||||||
#DEVICE="/dev/input/mice"
|
|
||||||
#MOUSETYPE="exps2"
|
|
||||||
#EOF
|
|
||||||
|
|
||||||
# remove stuff from the buildroot that we aren't shipping
|
# remove stuff from the buildroot that we aren't shipping
|
||||||
rm -f $RPM_BUILD_ROOT%{_bindir}/disable-paste
|
rm -rf %{buildroot}%{_sbindir}
|
||||||
rm -f $RPM_BUILD_ROOT%{_mandir}/man1/mouse-test.1*
|
rm -rf %{buildroot}%{_bindir}
|
||||||
%ifarch s390 s390x
|
rm -rf %{buildroot}%{_mandir}
|
||||||
rm -f $RPM_BUILD_ROOT/usr/sbin/gpm
|
|
||||||
rm -f $RPM_BUILD_ROOT/usr/bin/hltest
|
|
||||||
rm -f $RPM_BUILD_ROOT/usr/bin/mouse-test
|
|
||||||
rm -rf $RPM_BUILD_ROOT/%{_mandir}
|
|
||||||
rm -f $RPM_BUILD_ROOT/usr/sbin/inputattach
|
|
||||||
rm -f $RPM_BUILD_ROOT/usr/bin/display-buttons
|
|
||||||
rm -f $RPM_BUILD_ROOT/usr/bin/display-coords
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -124,48 +86,39 @@ rm -rf %{buildroot}
|
|||||||
%ifnarch s390 s390x
|
%ifnarch s390 s390x
|
||||||
/sbin/chkconfig --add gpm
|
/sbin/chkconfig --add gpm
|
||||||
%endif
|
%endif
|
||||||
/sbin/ldconfig
|
|
||||||
/sbin/install-info %{_infodir}/gpm.info.gz %{_infodir}/dir
|
/sbin/install-info %{_infodir}/gpm.info.gz %{_infodir}/dir
|
||||||
exit 0
|
/sbin/ldconfig
|
||||||
|
|
||||||
%preun
|
%preun
|
||||||
if [ $1 = 0 ]; then
|
|
||||||
/sbin/install-info %{_infodir}/gpm.info.gz --delete %{_infodir}/dir
|
|
||||||
%ifnarch s390 s390x
|
%ifnarch s390 s390x
|
||||||
service gpm stop >/dev/null 2>&1
|
if [ "$1" = "0" ]; then
|
||||||
|
/sbin/service gpm stop >/dev/null 2>&1
|
||||||
/sbin/chkconfig --del gpm
|
/sbin/chkconfig --del gpm
|
||||||
%endif
|
|
||||||
fi
|
fi
|
||||||
|
%endif
|
||||||
|
/sbin/install-info %{_infodir}/gpm.info.gz --delete %{_infodir}/dir
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
%ifnarch s390 s390x
|
%ifnarch s390 s390x
|
||||||
if [ "$1" -ge "1" ]; then
|
if [ "$1" -ge "1" ]; then
|
||||||
service gpm condrestart >/dev/null 2>&1
|
/sbin/service gpm condrestart >/dev/null 2>&1
|
||||||
fi
|
fi
|
||||||
%endif
|
%endif
|
||||||
/sbin/ldconfig
|
/sbin/ldconfig
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%ifnarch s390 s390x
|
%doc BUGS COPYING README TODO
|
||||||
%config %{_sysconfdir}/gpm-root.conf
|
%doc doc/README* doc/FAQ doc/Announce doc/changes/*
|
||||||
%config %{_sysconfdir}/rc.d/init.d/gpm
|
%{_infodir}/*
|
||||||
%{_bindir}/mev
|
|
||||||
%{_bindir}/gpm-root
|
|
||||||
%{_bindir}/hltest
|
|
||||||
%{_bindir}/mouse-test
|
|
||||||
%{_bindir}/display-coords
|
|
||||||
%{_bindir}/display-buttons
|
|
||||||
%{_mandir}/man1/mev.1*
|
|
||||||
%{_mandir}/man1/gpm-root*
|
|
||||||
%{_mandir}/man7/gpm-types*
|
|
||||||
%{_mandir}/man8/gpm*
|
|
||||||
/usr/sbin/gpm
|
|
||||||
/usr/sbin/inputattach
|
|
||||||
%endif
|
|
||||||
#%{_datadir}/emacs/site-lisp/t-mouse.el*
|
|
||||||
%{_infodir}/gpm.info*
|
|
||||||
%{_libdir}/libgpm.so.*
|
%{_libdir}/libgpm.so.*
|
||||||
|
%ifnarch s390 s390x
|
||||||
|
%config(noreplace) %{_sysconfdir}/gpm-*
|
||||||
|
%attr(0755,root,root) %{_sysconfdir}/rc.d/init.d/gpm
|
||||||
|
%{_sbindir}/*
|
||||||
|
%{_bindir}/*
|
||||||
|
%{_mandir}/*/*
|
||||||
|
%endif
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -174,6 +127,12 @@ fi
|
|||||||
%{_libdir}/libgpm.so
|
%{_libdir}/libgpm.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 17 2008 Zdenek Prikryl <zprikryl@redhat.com> - 1.20.5-1
|
||||||
|
- Updated to 1.20.5
|
||||||
|
- Removed doc patch
|
||||||
|
- Removed lisp stuff, it is part of emacs-common now
|
||||||
|
- Spec clean up
|
||||||
|
|
||||||
* Thu Jun 04 2008 Zdenek Prikryl <zprikryl@redhat.com> - 1.20.3-2
|
* Thu Jun 04 2008 Zdenek Prikryl <zprikryl@redhat.com> - 1.20.3-2
|
||||||
- Enable gpm in runlevel 5
|
- Enable gpm in runlevel 5
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user