Two patches have been upstreamed
This commit is contained in:
parent
62aa471614
commit
e56bc421e6
@ -122,7 +122,7 @@ index afd5a29..795b958 100644
|
||||
Many many contributors, to both selection and gpm.
|
||||
.fi
|
||||
diff --git a/src/Makefile.in b/src/Makefile.in
|
||||
index d3b1dcd..7e9e2ef 100644
|
||||
index d3b1dcd..2f92989 100644
|
||||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -79,7 +79,7 @@ prog/%: prog/%.o
|
||||
@ -134,6 +134,15 @@ index d3b1dcd..7e9e2ef 100644
|
||||
|
||||
gpm: $(GOBJ)
|
||||
$(CC) @LDFLAGS@ $(LDFLAGS) -o $@ $(GOBJ) @LIBS@ $(LIBS) -lm
|
||||
@@ -96,7 +96,7 @@ $(DEPFILE) dep: prog/gpm-root.c
|
||||
|
||||
# create dependencies
|
||||
for DEPS in `echo *.c */*.c`; do \
|
||||
- $(CC) -I. -I $(srcdir) -M @CPPFLAGS@ $(CPPFLAGS) $$DEPS | \
|
||||
+ $(CC) -I. -I $(srcdir) -I $(srcdir)/headers -M @CPPFLAGS@ $(CPPFLAGS) $$DEPS | \
|
||||
$(SED) 's/^\(.*\)\.o\([ :]+\)/\1.o \1.lo\2/g' >> $(DEPFILE) ; done
|
||||
|
||||
### INSTALL
|
||||
@@ -113,7 +113,7 @@ install: check
|
||||
# 2.x goes along; unfortunately that means an additional
|
||||
# headache in cases like this
|
||||
@ -228,6 +237,19 @@ index a5839a3..e92fa63 100644
|
||||
gpm_report(GPM_PR_DEBUG, GPM_MESS_REQUEST_ON, vc, MAX_VC);
|
||||
free(info);
|
||||
close(newfd);
|
||||
diff --git a/src/headers/daemon.h b/src/headers/daemon.h
|
||||
index a8936ad..24a1a97 100644
|
||||
--- a/src/headers/daemon.h
|
||||
+++ b/src/headers/daemon.h
|
||||
@@ -180,7 +180,7 @@ extern struct mouse_features mouse_table[3],
|
||||
extern Gpm_Type mice[];
|
||||
extern Gpm_Type *repeated_type;
|
||||
|
||||
-time_t last_selection_time;
|
||||
+extern time_t last_selection_time;
|
||||
|
||||
|
||||
|
||||
diff --git a/src/headers/gpm.h b/src/headers/gpm.h
|
||||
index 57dc618..fe52e53 100644
|
||||
--- a/src/headers/gpm.h
|
@ -1,39 +0,0 @@
|
||||
From f04f24dd5ca5c1c13608b144ab66e2ccd47f106a Mon Sep 17 00:00:00 2001
|
||||
From: Sergei Trofimovich <slyfox@gentoo.org>
|
||||
Date: Sun, 19 Jan 2020 19:53:41 +0000
|
||||
Subject: [PATCH] src/headers/daemon.h: avoid redefinition of
|
||||
'last_selection_time'
|
||||
|
||||
Noticed build failure on gcc-10 as:
|
||||
|
||||
```
|
||||
gcc -L/home/slyfox/dev/git/gpm/src -o gpm mice.o ... report.o tools.o -lm
|
||||
ld: twiddler.o:gpm/src/headers/daemon.h:183:
|
||||
multiple definition of `last_selection_time'; mice.o:gpm/src/headers/daemon.h:183: first defined here
|
||||
ld: synaptics.o:git/gpm/src/headers/daemon.h:183:
|
||||
multiple definition of `last_selection_time'; mice.o:git/gpm/src/headers/daemon.h:183: first defined here
|
||||
```
|
||||
|
||||
gcc-10 will change the default from -fcommon to fno-common:
|
||||
https://gcc.gnu.org/PR85678.
|
||||
|
||||
The error also happens if CFLAGS=-fno-common passed explicitly.
|
||||
|
||||
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
|
||||
---
|
||||
src/headers/daemon.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/headers/daemon.h b/src/headers/daemon.h
|
||||
index a8936ad..24a1a97 100644
|
||||
--- a/src/headers/daemon.h
|
||||
+++ b/src/headers/daemon.h
|
||||
@@ -180,7 +180,7 @@ extern struct mouse_features mouse_table[3],
|
||||
extern Gpm_Type mice[];
|
||||
extern Gpm_Type *repeated_type;
|
||||
|
||||
-time_t last_selection_time;
|
||||
+extern time_t last_selection_time;
|
||||
|
||||
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -Naur gpm-1.20.6.orig/src/Makefile.in gpm-1.20.6/src/Makefile.in
|
||||
--- gpm-1.20.6.orig/src/Makefile.in 2009-02-09 10:58:53.000000000 +0100
|
||||
+++ gpm-1.20.6/src/Makefile.in 2013-03-19 14:33:58.092659991 +0100
|
||||
@@ -96,7 +96,7 @@
|
||||
|
||||
# create dependencies
|
||||
for DEPS in `echo *.c */*.c`; do \
|
||||
- $(CC) -I. -I $(srcdir) -M @CPPFLAGS@ $(CPPFLAGS) $$DEPS | \
|
||||
+ $(CC) -I. -Iheaders -I $(srcdir) -M @CPPFLAGS@ $(CPPFLAGS) $$DEPS | \
|
||||
$(SED) 's/^\(.*\)\.o\([ :]+\)/\1.o \1.lo\2/g' >> $(DEPFILE) ; done
|
||||
|
||||
### INSTALL
|
22
gpm.spec
22
gpm.spec
@ -1,7 +1,7 @@
|
||||
Summary: A mouse server for the Linux console
|
||||
Name: gpm
|
||||
Version: 1.20.7
|
||||
Release: 21%{?dist}
|
||||
Release: 22%{?dist}
|
||||
License: GPLv2 and GPLv2+ with exceptions and GPLv3+ and Verbatim and Copyright only
|
||||
URL: http://www.nico.schottelius.org/software/gpm/
|
||||
#URL2 : http://freecode.com/projects/gpm
|
||||
@ -10,16 +10,14 @@ URL: http://www.nico.schottelius.org/software/gpm/
|
||||
# and that's why we need to remove them and recreate the tarball
|
||||
#
|
||||
# 1.] mkdir docs-removal && cd docs-removal
|
||||
# 2.] wget http://www.nico.schottelius.org/software/gpm/archives/%{name}-%{version}.tar.lzma
|
||||
# 3.] tar xf %{name}-%{version}.tar.lzma
|
||||
# 4.] rm -rf %{name}-%{version}/doc/specs
|
||||
# 5.] tar cJf %{name}-%{version}.tar.xz %{name}-%{version}
|
||||
# 2.] wget http://www.nico.schottelius.org/software/gpm/archives/%%{name}-%%{version}.tar.lzma
|
||||
# 3.] tar xf %%{name}-%%{version}.tar.lzma
|
||||
# 4.] rm -rf %%{name}-%%{version}/doc/specs
|
||||
# 5.] tar cJf %%{name}-%%{version}.tar.xz %%{name}-%%{version}
|
||||
|
||||
Source: %{name}-%{version}.tar.xz
|
||||
Source1: gpm.service
|
||||
Patch0: https://github.com/telmich/gpm/compare/1.20.7...4a938233fbe6de7af05aabc74891b68d4bae40f8.diff
|
||||
# https://github.com/telmich/gpm/pull/37/
|
||||
Patch3: f04f24dd5ca5c1c13608b144ab66e2ccd47f106a.patch
|
||||
Patch0: https://github.com/telmich/gpm/compare/1.20.7...e82d1a653ca94aa4ed12441424da6ce780b1e530.diff
|
||||
Patch1: gpm-1.20.6-multilib.patch
|
||||
Patch2: gpm-1.20.1-lib-silent.patch
|
||||
Patch4: gpm-1.20.5-close-fds.patch
|
||||
@ -27,7 +25,6 @@ Patch5: gpm-1.20.1-weak-wgetch.patch
|
||||
Patch7: gpm-1.20.7-rhbz-668480-gpm-types-7-manpage-fixes.patch
|
||||
|
||||
# Disabled, need to be reviewed
|
||||
Patch8: gpm-1.20.6-missing-header-dir-in-make-depend.patch
|
||||
Patch9: gpm-1.20.6-capability.patch
|
||||
|
||||
Requires(post): systemd info
|
||||
@ -77,15 +74,11 @@ mouse support to text-based Linux applications.
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1 -b .master
|
||||
%patch3 -p1 -b .gcc10
|
||||
%patch1 -p1 -b .multilib
|
||||
%patch2 -p1 -b .lib-silent
|
||||
%patch4 -p1 -b .close-fds
|
||||
%patch5 -p1 -b .weak-wgetch
|
||||
%patch7 -p1
|
||||
# not sure if this is really needed
|
||||
#patch8 -p1
|
||||
|
||||
#patch9 -p1 -b .capability
|
||||
|
||||
%build
|
||||
@ -157,6 +150,9 @@ rm -rf %{buildroot}%{_mandir}
|
||||
%{_libdir}/libgpm.a
|
||||
|
||||
%changelog
|
||||
* Thu Jun 18 2020 Sérgio Basto <sergio@serjux.com> - 1.20.7-22
|
||||
- Two patches have been upstreamed
|
||||
|
||||
* Sat Feb 22 2020 Sérgio Basto <sergio@serjux.com> - 1.20.7-21
|
||||
- Better comments in spec file
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user