Include upstream pull request patches to fix FTBFS (BZ#1500092)
This commit is contained in:
parent
df916d6570
commit
dbf661f05d
16
gpm-1.20.7-sigemptyset.patch
Normal file
16
gpm-1.20.7-sigemptyset.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -r -u gpm-1.20.7-orig/src/prog/gpm-root.y gpm-1.20.7/src/prog/gpm-root.y
|
||||
--- gpm-1.20.7-orig/src/prog/gpm-root.y 2012-10-26 16:21:38.000000000 -0500
|
||||
+++ gpm-1.20.7/src/prog/gpm-root.y 2017-10-10 13:50:02.115721252 -0500
|
||||
@@ -1196,11 +1196,7 @@
|
||||
LOG_DAEMON : LOG_USER);
|
||||
/* reap your zombies */
|
||||
childaction.sa_handler=reap_children;
|
||||
-#if defined(__GLIBC__)
|
||||
- __sigemptyset(&childaction.sa_mask);
|
||||
-#else /* __GLIBC__ */
|
||||
- childaction.sa_mask=0;
|
||||
-#endif /* __GLIBC__ */
|
||||
+ sigemptyset(&childaction.sa_mask);
|
||||
childaction.sa_flags=SA_INTERRUPT; /* need to break the select() call */
|
||||
sigaction(SIGCHLD,&childaction,NULL);
|
||||
|
14
gpm-1.20.7-sysmacros.patch
Normal file
14
gpm-1.20.7-sysmacros.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -r -u gpm-1.20.7-orig/src/daemon/open_console.c gpm-1.20.7/src/daemon/open_console.c
|
||||
--- gpm-1.20.7-orig/src/daemon/open_console.c 2012-10-26 16:21:38.000000000 -0500
|
||||
+++ gpm-1.20.7/src/daemon/open_console.c 2017-10-10 13:40:39.896316258 -0500
|
||||
@@ -23,6 +23,10 @@
|
||||
#include <sys/stat.h> /* stat() */
|
||||
#include <sys/ioctl.h> /* ioctl */
|
||||
|
||||
+#ifdef HAVE_SYS_SYSMACROS_H
|
||||
+#include <sys/sysmacros.h> /* major() w/newer glibc */
|
||||
+#endif
|
||||
+
|
||||
/* Linux specific (to be outsourced in gpm2 */
|
||||
#include <linux/serial.h> /* for serial console check */
|
||||
#include <asm/ioctls.h> /* for serial console check */
|
11
gpm.spec
11
gpm.spec
@ -1,7 +1,7 @@
|
||||
Summary: A mouse server for the Linux console
|
||||
Name: gpm
|
||||
Version: 1.20.7
|
||||
Release: 12%{?dist}
|
||||
Release: 13%{?dist}
|
||||
License: GPLv2 and GPLv2+ with exceptions and GPLv3+ and Verbatim and Copyright only
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.nico.schottelius.org/software/gpm/
|
||||
@ -25,6 +25,10 @@ Patch5: gpm-1.20.1-weak-wgetch.patch
|
||||
Patch7: gpm-1.20.7-rhbz-668480-gpm-types-7-manpage-fixes.patch
|
||||
Patch8: gpm-1.20.6-missing-header-dir-in-make-depend.patch
|
||||
Patch9: gpm-format-security.patch
|
||||
# Include patch from upstream pull request: https://github.com/telmich/gpm/pull/12
|
||||
Patch10: gpm-1.20.7-sysmacros.patch
|
||||
# Include patch from upstream pull request: https://github.com/telmich/gpm/pull/20
|
||||
Patch11: gpm-1.20.7-sigemptyset.patch
|
||||
#Patch7: gpm-1.20.6-capability.patch
|
||||
Requires(post): systemd systemd-sysv info
|
||||
Requires(preun): systemd info
|
||||
@ -85,6 +89,8 @@ mouse support to text-based Linux applications.
|
||||
# not sure if this is really needed
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
|
||||
#%patch7 -p1 -b .capability
|
||||
|
||||
@ -169,6 +175,9 @@ fi
|
||||
%{_libdir}/libgpm.a
|
||||
|
||||
%changelog
|
||||
* Tue Oct 10 2017 Merlin Mathesius <mmathesi@redhat.com> - 1.20.7-13
|
||||
- Include upstream pull request patches to fix FTBFS (BZ#1500092)
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.20.7-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user