Fixed debug mode (#473422)
This commit is contained in:
parent
dee7eed2f6
commit
cf3c1369e6
@ -1,13 +1,16 @@
|
||||
--- gpm-1.20.5/src/daemon/startup.c.close-fds 2008-07-17 11:39:55.000000000 +0200
|
||||
+++ gpm-1.20.5/src/daemon/startup.c 2008-07-17 11:40:20.000000000 +0200
|
||||
@@ -135,6 +135,11 @@ void startup(int argc, char **argv)
|
||||
diff -up gpm-1.20.5/src/daemon/startup.c.close-fds gpm-1.20.5/src/daemon/startup.c
|
||||
--- gpm-1.20.5/src/daemon/startup.c.close-fds 2008-06-13 10:08:19.000000000 +0200
|
||||
+++ gpm-1.20.5/src/daemon/startup.c 2008-12-02 10:11:12.000000000 +0100
|
||||
@@ -135,6 +135,13 @@ void startup(int argc, char **argv)
|
||||
check_uniqueness();
|
||||
gpm_report(GPM_PR_INFO,GPM_MESS_STARTED);
|
||||
|
||||
+ // close extra fds
|
||||
+ close(0);
|
||||
+ close(1);
|
||||
+ close(2);
|
||||
+ if (option.run_status == GPM_RUN_STARTUP ) {
|
||||
+ close(0);
|
||||
+ close(1);
|
||||
+ close(2);
|
||||
+ }
|
||||
+
|
||||
//return mouse_table[1].fd; /* the second is handled in the main() */
|
||||
|
||||
|
5
gpm.spec
5
gpm.spec
@ -1,7 +1,7 @@
|
||||
Summary: A mouse server for the Linux console.
|
||||
Name: gpm
|
||||
Version: 1.20.5
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Daemons
|
||||
URL: http://unix.schottelius.org/gpm/
|
||||
@ -129,6 +129,9 @@ fi
|
||||
%{_libdir}/libgpm.so
|
||||
|
||||
%changelog
|
||||
* Wed Dec 02 2008 Zdenek Prikryl <zprikryl@redhat.com> - 1.20.5-2
|
||||
- Fixed debug mode (#473422)
|
||||
|
||||
* Thu Jul 17 2008 Zdenek Prikryl <zprikryl@redhat.com> - 1.20.5-1
|
||||
- Updated to 1.20.5
|
||||
- Removed doc patch
|
||||
|
Loading…
Reference in New Issue
Block a user