auto-import changelog data from gpm-1.20.1-38.src.rpm
Thu Aug 07 2003 Adrian Havill <havill@redhat.com> 1.20.1-38 - Gpm_Open() NULL deref revisited (#101104). Patch by <leonardjo@hetnet.nl> Wed Jul 30 2003 Adrian Havill <havill@redhat.com> 1.20.1-37 - removed auto-add of repeat with -M (#84310) Tue Jul 29 2003 Adrian Havill <havill@redhat.com> 1.20.1-36 - fixed grammar typos in the init script (#89109) - don't deref NULL string in Gpm_Open (#101104) Wed Jul 02 2003 Adrian Havill <havill@redhat.com> 1.20.1-35 - remove debug output from gpm_report() to prevent spurious debugging msgs even when not in debug mode (#98210) Thu Jun 26 2003 Adrian Havill <havill@redhat.com> 1.20.1-33 - reversed -t and -m params in init script, removed $OPTION - add doc blurb regarding no auto-repeat with multiple mice Tue Jun 24 2003 Adrian Havill <havill@redhat.com> 1.20.1-32 - update version - add -lm for ceil() - add hltest, mouse-test for all but zSeries Mon Jun 16 2003 Jakub Jelinek <jakub@redhat.com> - don't link against -lncurses, instead make wgetch and stdscr weak undefined symbols to break library dependency cycle Thu Jun 12 2003 Elliot Lee <sopwith@redhat.com> - Remove pam requirement Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> - rebuilt
This commit is contained in:
parent
a19f9c16c9
commit
c78d0885e9
@ -1 +1 @@
|
|||||||
gpm-1.19.3.tar.gz
|
gpm-1.20.1.tar.gz
|
||||||
|
23
gpm-1.20.1-gpmopen.patch
Normal file
23
gpm-1.20.1-gpmopen.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff -pruN gpm-1.20.1/src/lib/liblow.c.orig gpm-1.20.1/src/lib/liblow.c
|
||||||
|
--- gpm-1.20.1/src/lib/liblow.c.orig 2003-08-03 17:55:00.000000000 +0200
|
||||||
|
+++ gpm-1.20.1/src/lib/liblow.c 2003-08-03 17:59:49.000000000 +0200
|
||||||
|
@@ -199,8 +199,6 @@ int Gpm_Open(Gpm_Connect *conn, int flag
|
||||||
|
Gpm_Stst *new = NULL;
|
||||||
|
char* sock_name = 0;
|
||||||
|
|
||||||
|
- option.consolename = NULL;
|
||||||
|
-
|
||||||
|
#if 0
|
||||||
|
gpm_report(GPM_PR_DEBUG,"VC: %d",flag);
|
||||||
|
#endif
|
||||||
|
@@ -259,6 +257,10 @@ int Gpm_Open(Gpm_Connect *conn, int flag
|
||||||
|
gpm_report(GPM_PR_ERR,"checking tty name failed");
|
||||||
|
goto err;
|
||||||
|
}
|
||||||
|
+ if (option.consolename == NULL) {
|
||||||
|
+ gpm_report(GPM_PR_ERR,"option.consolename not set");
|
||||||
|
+ goto err;
|
||||||
|
+ }
|
||||||
|
/* do we really need this check ? */
|
||||||
|
if(strncmp(tty,option.consolename,strlen(option.consolename)-1)
|
||||||
|
|| !isdigit(tty[strlen(option.consolename)-1])) {
|
11
gpm-1.20.1-math.patch
Normal file
11
gpm-1.20.1-math.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- gpm-1.20.1/configure.in.math Tue Jun 24 10:52:44 2003
|
||||||
|
+++ gpm-1.20.1/configure.in Tue Jun 24 10:53:54 2003
|
||||||
|
@@ -128,7 +128,7 @@
|
||||||
|
AC_SUBST(lispdir)
|
||||||
|
|
||||||
|
CPPFLAGS='-I$(srcdir) $(DEFS) -include headers/config.h -Wall -DSYSCONFDIR="\"$(sysconfdir)\"" -DSBINDIR="\"$(sbindir)\""'
|
||||||
|
-LDFLAGS='-L$(srcdir)'
|
||||||
|
+LDFLAGS='-lm -L$(srcdir)'
|
||||||
|
|
||||||
|
dnl AC_DEFINE_UNQUOTED(SYSCONFDIR,"$sysconfdir")
|
||||||
|
dnl AC_DEFINE_UNQUOTED(SBINDIR,"$sbindir")
|
56
gpm-1.20.1-nodebug.patch
Normal file
56
gpm-1.20.1-nodebug.patch
Normal file
@ -0,0 +1,56 @@
|
|||||||
|
--- gpm-1.20.1/src/report.c.nodebug 2002-12-24 17:57:16.000000000 -0500
|
||||||
|
+++ gpm-1.20.1/src/report.c 2003-07-02 15:07:19.000000000 -0400
|
||||||
|
@@ -126,6 +126,7 @@
|
||||||
|
/******************** RUNNING *****************/
|
||||||
|
case GPM_RUN_DAEMON:
|
||||||
|
switch(stat) {
|
||||||
|
+#if 0
|
||||||
|
case GPM_STAT_INFO:
|
||||||
|
#ifdef HAVE_VSYSLOG
|
||||||
|
syslog(LOG_INFO | LOG_USER, GPM_STRING_INFO);
|
||||||
|
@@ -165,6 +166,7 @@
|
||||||
|
fclose(console);
|
||||||
|
}
|
||||||
|
break;
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
case GPM_STAT_OOPS:
|
||||||
|
#ifdef HAVE_VSYSLOG
|
||||||
|
@@ -183,6 +185,7 @@
|
||||||
|
/******************** DEBUGGING and CLIENT *****************/
|
||||||
|
case GPM_RUN_DEBUG:
|
||||||
|
switch(stat) {
|
||||||
|
+#if 0
|
||||||
|
case GPM_STAT_INFO:
|
||||||
|
console = stdout;
|
||||||
|
fprintf(console,GPM_STRING_INFO); break;
|
||||||
|
@@ -195,13 +198,15 @@
|
||||||
|
case GPM_STAT_DEBUG:
|
||||||
|
console = stderr;
|
||||||
|
fprintf(console,GPM_STRING_DEBUG); break;
|
||||||
|
+#endif
|
||||||
|
case GPM_STAT_OOPS:
|
||||||
|
console = stderr;
|
||||||
|
fprintf(console,GPM_STRING_OOPS); break;
|
||||||
|
+ vfprintf(console,text,ap);
|
||||||
|
+ fprintf(console,"\n");
|
||||||
|
+ break;
|
||||||
|
}
|
||||||
|
|
||||||
|
- vfprintf(console,text,ap);
|
||||||
|
- fprintf(console,"\n");
|
||||||
|
|
||||||
|
if(stat == GPM_STAT_OOPS) exit(1);
|
||||||
|
|
||||||
|
--- gpm-1.20.1/src/lib/liblow.c.orig 2003-07-02 15:24:40.000000000 -0400
|
||||||
|
+++ gpm-1.20.1/src/lib/liblow.c 2003-07-02 15:24:44.000000000 -0400
|
||||||
|
@@ -201,7 +201,9 @@
|
||||||
|
|
||||||
|
option.consolename = NULL;
|
||||||
|
|
||||||
|
+#if 0
|
||||||
|
gpm_report(GPM_PR_DEBUG,"VC: %d",flag);
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/*....................................... First of all, check xterm */
|
||||||
|
|
46
gpm-1.20.1-weak-wgetch.patch
Normal file
46
gpm-1.20.1-weak-wgetch.patch
Normal file
@ -0,0 +1,46 @@
|
|||||||
|
When libncurses is configured with gpm support and gpm with ncurses support,
|
||||||
|
libncurses.so depends on libgpm.so and libgpm.so depends on libncurses.so.
|
||||||
|
Such loops should never happen.
|
||||||
|
If Gpm_Wgetch is passed non-NULL win argument, it must have been created by
|
||||||
|
ncurses anyway and so it should be already loaded.
|
||||||
|
On the other side, if Gpm_Wgetch is never used or used just with
|
||||||
|
NULL argument, libncurses is never needed.
|
||||||
|
|
||||||
|
--- gpm-1.20.1/configure.in.jj Tue Jul 18 09:17:32 2000
|
||||||
|
+++ gpm-1.20.1/configure.in Mon Jun 16 10:51:16 2003
|
||||||
|
@@ -98,7 +98,7 @@ No|no|N|n) SHARED_LIBS=-lc ;;
|
||||||
|
AC_CHECK_LIB($i, wgetch,,,$TERMLIBS)
|
||||||
|
else :; fi
|
||||||
|
done
|
||||||
|
- SHARED_LIBS="$LIBS $TERMLIBS -lc"
|
||||||
|
+ SHARED_LIBS="-lc"
|
||||||
|
LIBS=$SAVELIBS ;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
--- gpm-1.20.1/configure.jj Tue Jul 18 09:18:10 2000
|
||||||
|
+++ gpm-1.20.1/configure Mon Jun 16 10:51:32 2003
|
||||||
|
@@ -1582,7 +1582,7 @@ fi
|
||||||
|
|
||||||
|
else :; fi
|
||||||
|
done
|
||||||
|
- SHARED_LIBS="$LIBS $TERMLIBS -lc"
|
||||||
|
+ SHARED_LIBS="-lc"
|
||||||
|
LIBS=$SAVELIBS ;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
--- gpm-1.20.1/src/lib/libcurses.c.jj Mon Jan 17 16:34:00 2000
|
||||||
|
+++ gpm-1.20.1/src/lib/libcurses.c Mon Jun 16 10:55:52 2003
|
||||||
|
@@ -40,7 +40,12 @@
|
||||||
|
#endif /* HAVE_NCURSES_CURSES_H */
|
||||||
|
#endif /* HAVE_NCURSES_H */
|
||||||
|
|
||||||
|
-#define GET(win) ((win) ? wgetch(win) : getch())
|
||||||
|
+/* If win != NULL, it must have been created by ncurses anyway.
|
||||||
|
+ Avoid circular library dependencies. */
|
||||||
|
+#pragma weak wgetch
|
||||||
|
+#pragma weak stdscr
|
||||||
|
+
|
||||||
|
+#define GET(win) ((win && wgetch) ? wgetch(win) : getch())
|
||||||
|
|
||||||
|
int Gpm_Wgetch(WINDOW *win)
|
||||||
|
{
|
6
gpm.init
6
gpm.init
@ -2,7 +2,7 @@
|
|||||||
#
|
#
|
||||||
# chkconfig: 2345 85 15
|
# chkconfig: 2345 85 15
|
||||||
# description: GPM adds mouse support to text-based Linux applications such \
|
# description: GPM adds mouse support to text-based Linux applications such \
|
||||||
# the Midnight Commander. Is also allows mouse-based console \
|
# as the Midnight Commander. It also allows mouse-based console \
|
||||||
# cut-and-paste operations, and includes support for pop-up \
|
# cut-and-paste operations, and includes support for pop-up \
|
||||||
# menus on the console.
|
# menus on the console.
|
||||||
# processname: gpm
|
# processname: gpm
|
||||||
@ -41,9 +41,9 @@ start() {
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
if [ -n "$MOUSETYPE" ]; then
|
if [ -n "$MOUSETYPE" ]; then
|
||||||
daemon gpm $OPTIONS -t $MOUSETYPE -m $DEVICE
|
daemon gpm -m $DEVICE -t $MOUSETYPE
|
||||||
else
|
else
|
||||||
daemon gpm $OPTIONS -m $DEVICE
|
daemon gpm -m $DEVICE
|
||||||
fi
|
fi
|
||||||
RETVAL=$?
|
RETVAL=$?
|
||||||
echo
|
echo
|
||||||
|
90
gpm.spec
90
gpm.spec
@ -1,26 +1,25 @@
|
|||||||
Summary: A mouse server for the Linux console.
|
Summary: A mouse server for the Linux console.
|
||||||
Name: gpm
|
Name: gpm
|
||||||
Version: 1.19.3
|
Version: 1.20.1
|
||||||
Release: 27
|
Release: 38
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: ftp://ftp.systemy.it/pub/develop/%{name}-%{version}.tar.gz
|
Source: http://ftp.linux.it/pub/People/rubini/gpm/%{name}-%{version}.tar.gz
|
||||||
Source1: gpm.init
|
Source1: gpm.init
|
||||||
Patch0: gpm-nops.patch
|
Patch5: gpm-1.20.1-secenhance.patch
|
||||||
Patch2: gpm-1.19.3-docfix.patch
|
Patch6: gpm-1.20.1-limits.patch
|
||||||
Patch3: gpm-1.19.3-root.patch
|
Patch7: gpm-1.20.1-serialconsole.patch
|
||||||
Patch4: gpm-root.patch
|
Patch10: gpm-1.20.1-norepeater.patch
|
||||||
Patch5: gpm-1.19.1-secenhance.patch
|
Patch11: gpm-1.20.1-weak-wgetch.patch
|
||||||
Patch6: gpm-1.19.2-limits.patch
|
Patch12: gpm-1.20.1-math.patch
|
||||||
Patch7: gpm-1.19.3-serialconsole.patch
|
Patch13: gpm-1.20.1-nodebug.patch
|
||||||
Patch8: gpm-1.19.3-devfs.patch
|
Patch14: gpm-1.20.1-deref-null.patch
|
||||||
Patch9: gpm-1.19.3-noworldwrite.patch
|
Patch15: gpm-1.20.1-gpmopen.patch
|
||||||
Patch10: gpm-1.19.3-norepeater.patch
|
|
||||||
|
|
||||||
Prereq: /sbin/chkconfig /sbin/ldconfig /sbin/install-info
|
Prereq: /sbin/chkconfig /sbin/ldconfig /sbin/install-info
|
||||||
Requires: pam >= 0.72-22 bash >= 2.0
|
Requires: bash >= 2.0
|
||||||
# this defines the library version that this package builds.
|
# this defines the library version that this package builds.
|
||||||
%define LIBVER 1.18.0
|
%define LIBVER 1.19.0
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
BuildPrereq: sed gawk texinfo
|
BuildPrereq: sed gawk texinfo
|
||||||
|
|
||||||
@ -47,16 +46,14 @@ mouse button.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .nops
|
|
||||||
%patch2 -p1 -b .docfix
|
|
||||||
%patch3 -p1 -b .nonroot
|
|
||||||
%patch4 -p1 -b .root
|
|
||||||
%patch5 -p1 -b .secenhance
|
%patch5 -p1 -b .secenhance
|
||||||
%patch6 -p1 -b .limits
|
%patch6 -p1 -b .limits
|
||||||
%patch7 -p1 -b .serialconsole
|
#%patch7 -p1 -b .serialconsole
|
||||||
%patch8 -p1 -b .devfs
|
#%patch10 -p1 -b .repeater
|
||||||
%patch9 -p1 -b .noworldwrite
|
%patch11 -p1 -b .weak-wgetch
|
||||||
%patch10 -p1 -b .repeater
|
%patch12 -p1 -b .math
|
||||||
|
%patch13 -p1 -b .nodebug
|
||||||
|
%patch15 -p1 -b .gpmopen
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoconf
|
autoconf
|
||||||
@ -76,12 +73,13 @@ mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp
|
|||||||
|
|
||||||
%ifnarch s390 s390x
|
%ifnarch s390 s390x
|
||||||
install -m644 doc/gpm-root.1 %{buildroot}%{_mandir}/man1
|
install -m644 doc/gpm-root.1 %{buildroot}%{_mandir}/man1
|
||||||
install -m644 gpm-root.conf %{buildroot}%{_sysconfdir}
|
install -m644 conf/gpm-root.conf %{buildroot}%{_sysconfdir}
|
||||||
install -s -m755 hltest %{buildroot}%{_bindir}
|
install -s -m755 src/prog/hltest %{buildroot}%{_bindir}
|
||||||
|
%else
|
||||||
|
rm -f $RPM_BUILD_ROOT%{_bindir}/{mev,gpm-root}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
make t-mouse.el t-mouse.elc
|
cp contrib/emacs/t-mouse.el* %{buildroot}%{_datadir}/emacs/site-lisp
|
||||||
cp t-mouse.el* %{buildroot}%{_datadir}/emacs/site-lisp
|
|
||||||
|
|
||||||
{
|
{
|
||||||
pushd %{buildroot}
|
pushd %{buildroot}
|
||||||
@ -107,7 +105,9 @@ EOF
|
|||||||
rm -f $RPM_BUILD_ROOT%{_bindir}/disable-paste
|
rm -f $RPM_BUILD_ROOT%{_bindir}/disable-paste
|
||||||
rm -f $RPM_BUILD_ROOT%{_mandir}/man1/mouse-test.1*
|
rm -f $RPM_BUILD_ROOT%{_mandir}/man1/mouse-test.1*
|
||||||
%ifarch s390 s390x
|
%ifarch s390 s390x
|
||||||
rm -f $RPM_BUILD_ROOT/usr/sbin/gpm $RPM_BUILD_ROOT/%{_bindir}/*
|
rm -f $RPM_BUILD_ROOT/usr/sbin/gpm
|
||||||
|
rm -f $RPM_BUILD_ROOT/usr/bin/hltest
|
||||||
|
rm -f $RPM_BUILD_ROOT/usr/bin/mouse-test
|
||||||
rm -rf $RPM_BUILD_ROOT/%{_mandir}
|
rm -rf $RPM_BUILD_ROOT/%{_mandir}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -146,6 +146,7 @@ fi
|
|||||||
%{_bindir}/mev
|
%{_bindir}/mev
|
||||||
%{_bindir}/gpm-root
|
%{_bindir}/gpm-root
|
||||||
%{_bindir}/hltest
|
%{_bindir}/hltest
|
||||||
|
%{_bindir}/mouse-test
|
||||||
%{_mandir}/man1/mev.1*
|
%{_mandir}/man1/mev.1*
|
||||||
%{_mandir}/man1/gpm-root*
|
%{_mandir}/man1/gpm-root*
|
||||||
%{_mandir}/man7/gpm-types*
|
%{_mandir}/man7/gpm-types*
|
||||||
@ -165,6 +166,39 @@ fi
|
|||||||
%{_libdir}/libgpm.so
|
%{_libdir}/libgpm.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 07 2003 Adrian Havill <havill@redhat.com> 1.20.1-38
|
||||||
|
- Gpm_Open() NULL deref revisited (#101104). Patch by
|
||||||
|
<leonardjo@hetnet.nl>
|
||||||
|
* Wed Jul 30 2003 Adrian Havill <havill@redhat.com> 1.20.1-37
|
||||||
|
- removed auto-add of repeat with -M (#84310)
|
||||||
|
|
||||||
|
* Tue Jul 29 2003 Adrian Havill <havill@redhat.com> 1.20.1-36
|
||||||
|
- fixed grammar typos in the init script (#89109)
|
||||||
|
- don't deref NULL string in Gpm_Open (#101104)
|
||||||
|
|
||||||
|
* Wed Jul 02 2003 Adrian Havill <havill@redhat.com> 1.20.1-35
|
||||||
|
- remove debug output from gpm_report() to prevent spurious
|
||||||
|
debugging msgs even when not in debug mode (#98210)
|
||||||
|
|
||||||
|
* Thu Jun 26 2003 Adrian Havill <havill@redhat.com> 1.20.1-33
|
||||||
|
- reversed -t and -m params in init script, removed $OPTION
|
||||||
|
- add doc blurb regarding no auto-repeat with multiple mice
|
||||||
|
|
||||||
|
* Tue Jun 24 2003 Adrian Havill <havill@redhat.com> 1.20.1-32
|
||||||
|
- update version
|
||||||
|
- add -lm for ceil()
|
||||||
|
- add hltest, mouse-test for all but zSeries
|
||||||
|
|
||||||
|
* Mon Jun 16 2003 Jakub Jelinek <jakub@redhat.com>
|
||||||
|
- don't link against -lncurses, instead make wgetch and stdscr weak
|
||||||
|
undefined symbols to break library dependency cycle
|
||||||
|
|
||||||
|
* Thu Jun 12 2003 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- Remove pam requirement
|
||||||
|
|
||||||
|
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
* Wed Jan 29 2003 Bill Nottingham <notting@redhat.com> 1.19.13-27
|
* Wed Jan 29 2003 Bill Nottingham <notting@redhat.com> 1.19.13-27
|
||||||
- ship libraries on s390/s390x
|
- ship libraries on s390/s390x
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user