auto-import changelog data from gpm-1.20.1-49.src.rpm

Tue May 04 2004 Adrian Havill <havill@redhat.com> 1.20.1-49
- remove superfluous "i die" msg (#121845)
Tue May 04 2004 Adrian Havill <havill@redhat.com> 1.20.1-48
- restore gpmopen() NULL check that was removed with the evdev superpatch
    (#118554)
Fri Apr 16 2004 Adrian Havill <havill@redhat.com> 1.20.1-47
- make presence of t-mouse.el flexible (#120958)
Wed Mar 31 2004 Adrian Havill <havill@redhat.com> 1.20.1-46
- revise nodebug patch as liblow reporting the VC to the console through
    stderr has re-appeared (#117676)
Mon Mar 22 2004 Adrian Havill <havill@redhat.com> 1.20.1-45
- remove circular ncurses dep for prelink by restoring wgetch patch
    (#117150)
This commit is contained in:
cvsdist 2004-09-09 05:52:50 +00:00
parent f476c1f288
commit a3cc5c089f
5 changed files with 112 additions and 3 deletions

22
gpm-1.20.1-gpmopen.patch Normal file
View File

@ -0,0 +1,22 @@
--- gpm-1.20.1/src/lib/liblow.c.gpmopen 2004-05-04 17:36:09.000000000 -0400
+++ gpm-1.20.1/src/lib/liblow.c 2004-05-04 17:42:51.000000000 -0400
@@ -200,8 +200,6 @@
Gpm_Stst *new = NULL;
char* sock_name = 0;
- consolename = NULL;
-
#if 0
gpm_report(GPM_PR_DEBUG,"VC: %d",flag);
#endif
@@ -260,6 +258,10 @@
gpm_report(GPM_PR_ERR,"checking tty name failed");
goto err;
}
+ if (consolename == NULL) {
+ gpm_report(GPM_PR_ERR,"consolename not set");
+ goto err;
+ }
/* do we really need this check ? */
if(strncmp(tty,consolename,strlen(consolename)-1)
|| !isdigit(tty[strlen(consolename)-1])) {

12
gpm-1.20.1-idie.patch Normal file
View File

@ -0,0 +1,12 @@
--- gpm-1.20.1/src/lib/liblow.c.orig 2004-05-06 14:14:03.000000000 -0400
+++ gpm-1.20.1/src/lib/liblow.c 2004-05-06 14:18:05.000000000 -0400
@@ -376,7 +376,9 @@
/*....................................... Error: free all memory */
err:
+#if 0
gpm_report(GPM_PR_ERR,"Oh, oh, it's an error! possibly I die! ");
+#endif
do {
new=gpm_stack->next;
free(gpm_stack);

12
gpm-1.20.1-nodebug.patch Normal file
View File

@ -0,0 +1,12 @@
--- gpm-1.20.1/src/lib/liblow.c.orig 2004-03-31 15:06:45.000000000 -0500
+++ gpm-1.20.1/src/lib/liblow.c 2004-03-31 15:09:32.000000000 -0500
@@ -202,7 +202,9 @@
consolename = NULL;
+#if 0
gpm_report(GPM_PR_DEBUG,"VC: %d",flag);
+#endif
/*....................................... First of all, check xterm */

View File

@ -0,0 +1,38 @@
--- gpm-1.20.1/src/lib/libcurses.c.weak-wgetch 2002-12-24 17:57:16.000000000 -0500
+++ gpm-1.20.1/src/lib/libcurses.c 2004-03-22 15:51:24.000000000 -0500
@@ -41,7 +41,12 @@
#endif /* HAVE_NCURSES_CURSES_H */
#endif /* HAVE_NCURSES_H */
-#define GET(win) ((win) ? wgetch(win) : getch())
+/* If win != NULL, it must have been created by ncurses anyway.
+ Avoid circular library dependencies. */
+#pragma weak wgetch
+#pragma weak stdscr
+
+#define GET(win) ((win && wgetch) ? wgetch(win) : getch())
int Gpm_Wgetch(WINDOW *win)
{
--- gpm-1.20.1/configure.in.weak-wgetch 2004-03-22 15:49:51.000000000 -0500
+++ gpm-1.20.1/configure.in 2004-03-22 15:51:24.000000000 -0500
@@ -115,7 +115,7 @@
AC_CHECK_LIB($i, wgetch,,,$TERMLIBS)
else :; fi
done
- SHARED_LIBS="$LIBS $TERMLIBS -lc"
+ SHARED_LIBS="-lc"
LIBS=$SAVELIBS ;;
esac
--- gpm-1.20.1/configure.weak-wgetch 2004-03-22 15:49:55.000000000 -0500
+++ gpm-1.20.1/configure 2004-03-22 15:51:24.000000000 -0500
@@ -4295,7 +4295,7 @@
else :; fi
done
- SHARED_LIBS="$LIBS $TERMLIBS -lc"
+ SHARED_LIBS="-lc"
LIBS=$SAVELIBS ;;
esac

View File

@ -1,7 +1,7 @@
Summary: A mouse server for the Linux console.
Name: gpm
Version: 1.20.1
Release: 44
Release: 49
License: GPL
Group: System Environment/Daemons
Source: http://ftp.linux.it/pub/People/rubini/gpm/%{name}-%{version}.tar.gz
@ -9,6 +9,10 @@ Source1: gpm.init
Source2: inputattach.c
Patch1: gpm-evdev-cumulative.patch
Patch2: gpm-1.20.1-math.patch
Patch3: gpm-1.20.1-weak-wgetch.patch
Patch4: gpm-1.20.1-nodebug.patch
Patch5: gpm-1.20.1-gpmopen.patch
Patch6: gpm-1.20.1-idie.patch
Patch16: gpm-1.20.1-subscript.patch
Prereq: /sbin/chkconfig /sbin/ldconfig /sbin/install-info
@ -43,6 +47,10 @@ mouse button.
%setup -q
%patch1 -p1 -b .evdev
%patch2 -p1 -b .math
%patch3 -p1 -b .weak-wgetch
%patch4 -p1 -b .nodebug
%patch5 -p1 -b .gpmopen
%patch6 -p1 -b .idie
%patch16 -p1 -b .subscript
%build
@ -150,8 +158,7 @@ fi
/usr/sbin/gpm
/usr/sbin/inputattach
%endif
%{_datadir}/emacs/site-lisp/t-mouse.el
%{_datadir}/emacs/site-lisp/t-mouse.elc
%{_datadir}/emacs/site-lisp/t-mouse.el*
%{_infodir}/gpm.info*
%{_libdir}/libgpm.so.*
%config %{_sysconfdir}/sysconfig/gpm
@ -163,6 +170,24 @@ fi
%{_libdir}/libgpm.so
%changelog
* Tue May 04 2004 Adrian Havill <havill@redhat.com> 1.20.1-49
- remove superfluous "i die" msg (#121845)
* Tue May 04 2004 Adrian Havill <havill@redhat.com> 1.20.1-48
- restore gpmopen() NULL check that was removed with the
evdev superpatch (#118554)
* Fri Apr 16 2004 Adrian Havill <havill@redhat.com> 1.20.1-47
- make presence of t-mouse.el flexible (#120958)
* Wed Mar 31 2004 Adrian Havill <havill@redhat.com> 1.20.1-46
- revise nodebug patch as liblow reporting the VC to the console through
stderr has re-appeared (#117676)
* Mon Mar 22 2004 Adrian Havill <havill@redhat.com> 1.20.1-45
- remove circular ncurses dep for prelink by restoring wgetch
patch (#117150)
* Wed Mar 17 2004 Bill Nottingham <notting@redhat.com> 1.20.1-44
- include inputattach
- if configured mouse has IMOUSETYPE, use inputattach