Fixed gpm.info.gz building
This commit is contained in:
parent
2854bd569c
commit
a090bb4853
@ -1,28 +1,7 @@
|
||||
--- gpm-1.20.1/doc/Makefile.in.multilib 2002-12-24 17:57:16.000000000 -0500
|
||||
+++ gpm-1.20.1/doc/Makefile.in 2004-10-20 17:25:11.000000000 -0400
|
||||
@@ -97,7 +97,7 @@
|
||||
|
||||
# Main portion
|
||||
|
||||
-all: $(srcdir)/gpm.info $(MANPAGES)
|
||||
+all: gpm.info $(MANPAGES)
|
||||
|
||||
# why gpmdoc.ps and gpm.ps??
|
||||
# there is no gpm.ps in my tree and no rule to generate gpm.ps.
|
||||
@@ -131,8 +131,8 @@
|
||||
#i keep all my infopages compressed and i'm tired to do it by
|
||||
#hand, so check if there are any compressed pages and do this
|
||||
#one too
|
||||
- -ls $(infodir)/*[-.]info.gz >/dev/null 2>&1 \
|
||||
- && gzip -f $(infodir)/gpm.info
|
||||
+ #-ls $(infodir)/*[-.]info.gz >/dev/null 2>&1 \
|
||||
+ # && gzip -f $(infodir)/gpm.info
|
||||
# Hmm.... shouldn't man pages be compressed too?
|
||||
# maybe they should, but at least at my system they are not.
|
||||
|
||||
--- gpm-1.20.1/contrib/Makefile.in.multilib 2002-12-24 17:57:16.000000000 -0500
|
||||
+++ gpm-1.20.1/contrib/Makefile.in 2004-10-20 17:11:38.000000000 -0400
|
||||
@@ -9,10 +9,10 @@
|
||||
diff -up gpm-1.20.6/contrib/Makefile.in.multilib gpm-1.20.6/contrib/Makefile.in
|
||||
--- gpm-1.20.6/contrib/Makefile.in.multilib 2008-06-19 07:48:48.000000000 +0200
|
||||
+++ gpm-1.20.6/contrib/Makefile.in 2009-02-24 10:36:09.000000000 +0100
|
||||
@@ -9,10 +9,10 @@ top_builddir = ..
|
||||
|
||||
include $(top_builddir)/Makefile.include
|
||||
|
||||
@ -35,7 +14,7 @@
|
||||
$(INSTALL_DATA) $(srcdir)/$$i $(lispdir)/`basename $$i` ;\
|
||||
done; fi
|
||||
|
||||
@@ -20,7 +20,7 @@
|
||||
@@ -20,7 +20,7 @@ install: all
|
||||
$(EMACS) -batch -l $(srcdir)/emacs/exec.el -exec '(byte-compile-file "$<")'
|
||||
|
||||
uninstall:
|
||||
@ -44,9 +23,23 @@
|
||||
rm -f $(lispdir)/$$i ;\
|
||||
done; fi
|
||||
|
||||
@@ -28,4 +28,4 @@
|
||||
@@ -28,4 +28,4 @@ dist:
|
||||
$(CP) -r $(srcdir) $(top_builddir)/gpm-$(release)/
|
||||
|
||||
clean distclean:
|
||||
- $(RM) -f $(srcdir)/emacs/*.elc Makefile
|
||||
+ $(RM) $(srcdir)/emacs/*.elc Makefile
|
||||
diff -up gpm-1.20.6/doc/Makefile.in.multilib gpm-1.20.6/doc/Makefile.in
|
||||
--- gpm-1.20.6/doc/Makefile.in.multilib 2009-02-09 10:58:53.000000000 +0100
|
||||
+++ gpm-1.20.6/doc/Makefile.in 2009-02-24 10:36:09.000000000 +0100
|
||||
@@ -130,8 +130,8 @@ install: all installdirs
|
||||
#i keep all my infopages compressed and i'm tired to do it by
|
||||
#hand, so check if there are any compressed pages and do this
|
||||
#one too
|
||||
- -ls $(infodir)/*[-.]info.gz >/dev/null 2>&1 \
|
||||
- && gzip -f $(infodir)/gpm.info
|
||||
+ #-ls $(infodir)/*[-.]info.gz >/dev/null 2>&1 \
|
||||
+ # && gzip -f $(infodir)/gpm.info
|
||||
# Hmm.... shouldn't man pages be compressed too?
|
||||
# maybe they should, but at least at my system they are not.
|
||||
|
8
gpm.spec
8
gpm.spec
@ -1,14 +1,14 @@
|
||||
Summary: A mouse server for the Linux console
|
||||
Name: gpm
|
||||
Version: 1.20.6
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Daemons
|
||||
URL: http://unix.schottelius.org/gpm/
|
||||
Source: http://unix.schottelius.org/gpm/archives/%{name}-%{version}.tar.gz
|
||||
Source1: gpm.init
|
||||
Source2: inputattach.c
|
||||
Patch1: gpm-1.20.1-multilib.patch
|
||||
Patch1: gpm-1.20.6-multilib.patch
|
||||
Patch2: gpm-1.20.1-lib-silent.patch
|
||||
Patch3: gpm-1.20.3-gcc4.3.patch
|
||||
Patch4: gpm-1.20.5-close-fds.patch
|
||||
@ -62,7 +62,6 @@ iconv -f iso-8859-1 -t utf-8 -o TODO.utf8 TODO
|
||||
touch -c -r TODO TODO.utf8
|
||||
mv -f TODO.utf8 TODO
|
||||
|
||||
rm -f configure
|
||||
autoreconf
|
||||
|
||||
%build
|
||||
@ -144,6 +143,9 @@ fi
|
||||
%{_libdir}/libgpm.a
|
||||
|
||||
%changelog
|
||||
* Tue Feb 24 2009 Zdenek Prikryl <zprikryl@redhat.com> - 1.20.6-2
|
||||
- Fixed gpm.info.gz building
|
||||
|
||||
* Tue Feb 03 2009 Zdenek Prikryl <zprikryl@redhat.com> - 1.20.6-1
|
||||
- Spec review (#225856)
|
||||
- Updated to 1.20.6
|
||||
|
Loading…
Reference in New Issue
Block a user