- remove unnecessary diagnostic and check of the consolename (#129962)
This commit is contained in:
parent
08dcf69661
commit
9e3544ebdb
@ -10,3 +10,21 @@
|
|||||||
|
|
||||||
/*....................................... First of all, check xterm */
|
/*....................................... First of all, check xterm */
|
||||||
|
|
||||||
|
--- gpm-1.20.1/src/lib/liblow.c.orig 2004-10-13 15:46:57.892406044 -0400
|
||||||
|
+++ gpm-1.20.1/src/lib/liblow.c 2004-10-13 15:56:10.922975340 -0400
|
||||||
|
@@ -262,13 +262,14 @@
|
||||||
|
gpm_report(GPM_PR_ERR,"consolename not set");
|
||||||
|
goto err;
|
||||||
|
}
|
||||||
|
+#if 0
|
||||||
|
/* do we really need this check ? */
|
||||||
|
if(strncmp(tty,consolename,strlen(consolename)-1)
|
||||||
|
|| !isdigit(tty[strlen(consolename)-1])) {
|
||||||
|
gpm_report(GPM_PR_ERR,"strncmp/isdigit/consolename failed");
|
||||||
|
goto err;
|
||||||
|
}
|
||||||
|
-
|
||||||
|
+#endif
|
||||||
|
conn->vc=atoi(&tty[strlen(consolename)-1]);
|
||||||
|
}
|
||||||
|
|
||||||
|
5
gpm.spec
5
gpm.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A mouse server for the Linux console.
|
Summary: A mouse server for the Linux console.
|
||||||
Name: gpm
|
Name: gpm
|
||||||
Version: 1.20.1
|
Version: 1.20.1
|
||||||
Release: 58
|
Release: 59
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: http://ftp.linux.it/pub/People/rubini/gpm/%{name}-%{version}.tar.gz
|
Source: http://ftp.linux.it/pub/People/rubini/gpm/%{name}-%{version}.tar.gz
|
||||||
@ -171,6 +171,9 @@ fi
|
|||||||
%{_libdir}/libgpm.so
|
%{_libdir}/libgpm.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 13 2004 Adrian Havill <havill@redhat.com> 1.20.1-59
|
||||||
|
- remove unnecessary diagnostic and check of the consolename (#129962)
|
||||||
|
|
||||||
* Wed Oct 13 2004 Florian La Roche <laroche@redhat.com>
|
* Wed Oct 13 2004 Florian La Roche <laroche@redhat.com>
|
||||||
- sysconfig/gpm should probably go away, that is more confusing than
|
- sysconfig/gpm should probably go away, that is more confusing than
|
||||||
helping anyone
|
helping anyone
|
||||||
|
Loading…
Reference in New Issue
Block a user