Rediff
This commit is contained in:
parent
0f53aba88a
commit
809b8e48c3
@ -1,13 +0,0 @@
|
||||
--- gpm-1.20.3/src/daemon/startup.c.close-fds 2008-05-28 13:18:59.000000000 +0200
|
||||
+++ gpm-1.20.3/src/daemon/startup.c 2008-05-28 13:20:13.000000000 +0200
|
||||
@@ -143,6 +143,10 @@ void startup(int argc, char **argv)
|
||||
* remove and ignore it ?? FIXME */
|
||||
if (chdir("/") < 0) gpm_report(GPM_PR_OOPS,GPM_MESS_CHDIR_FAILED);
|
||||
|
||||
+ // close extra fds
|
||||
+ close(0);
|
||||
+ close(1);
|
||||
+ close(2);
|
||||
|
||||
//return mouse_table[1].fd; /* the second is handled in the main() */
|
||||
|
14
gpm-1.20.5-close-fds.patch
Normal file
14
gpm-1.20.5-close-fds.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- gpm-1.20.5/src/daemon/startup.c.close-fds 2008-07-17 11:39:55.000000000 +0200
|
||||
+++ gpm-1.20.5/src/daemon/startup.c 2008-07-17 11:40:20.000000000 +0200
|
||||
@@ -135,6 +135,11 @@ void startup(int argc, char **argv)
|
||||
check_uniqueness();
|
||||
gpm_report(GPM_PR_INFO,GPM_MESS_STARTED);
|
||||
|
||||
+ // close extra fds
|
||||
+ close(0);
|
||||
+ close(1);
|
||||
+ close(2);
|
||||
+
|
||||
//return mouse_table[1].fd; /* the second is handled in the main() */
|
||||
|
||||
/****************** OLD CODE from gpn.c END ***********************/
|
2
gpm.spec
2
gpm.spec
@ -11,7 +11,7 @@ Source2: inputattach.c
|
||||
Patch1: gpm-1.20.1-multilib.patch
|
||||
Patch2: gpm-1.20.1-lib-silent.patch
|
||||
Patch3: gpm-1.20.3-gcc4.3.patch
|
||||
Patch4: gpm-1.20.3-close-fds.patch
|
||||
Patch4: gpm-1.20.5-close-fds.patch
|
||||
Patch5: gpm-1.20.1-weak-wgetch.patch
|
||||
Prereq: /sbin/chkconfig /sbin/ldconfig /sbin/install-info
|
||||
Requires: bash >= 2.0
|
||||
|
Loading…
Reference in New Issue
Block a user