- Removing OPTFLAGS

- Introducing full RELRO
- Missing header dir in Makefile.in / depend
- Fixing UsrMove for i686 (mv -f says 'directory not empty')
This commit is contained in:
Jaromir Capik 2013-03-19 15:34:01 +01:00
parent a67b04b296
commit 4047b890ae
2 changed files with 26 additions and 9 deletions

View File

@ -0,0 +1,12 @@
diff -Naur gpm-1.20.6.orig/src/Makefile.in gpm-1.20.6/src/Makefile.in
--- gpm-1.20.6.orig/src/Makefile.in 2009-02-09 10:58:53.000000000 +0100
+++ gpm-1.20.6/src/Makefile.in 2013-03-19 14:33:58.092659991 +0100
@@ -96,7 +96,7 @@
# create dependencies
for DEPS in `echo *.c */*.c`; do \
- $(CC) -I. -I $(srcdir) -M @CPPFLAGS@ $(CPPFLAGS) $$DEPS | \
+ $(CC) -I. -Iheaders -I $(srcdir) -M @CPPFLAGS@ $(CPPFLAGS) $$DEPS | \
$(SED) 's/^\(.*\)\.o\([ :]+\)/\1.o \1.lo\2/g' >> $(DEPFILE) ; done
### INSTALL

View File

@ -1,7 +1,7 @@
Summary: A mouse server for the Linux console Summary: A mouse server for the Linux console
Name: gpm Name: gpm
Version: 1.20.6 Version: 1.20.6
Release: 28%{?dist} Release: 29%{?dist}
License: GPLv2+ License: GPLv2+
Group: System Environment/Daemons Group: System Environment/Daemons
URL: http://www.nico.schottelius.org/software/gpm/ URL: http://www.nico.schottelius.org/software/gpm/
@ -15,6 +15,7 @@ Patch4: gpm-1.20.5-close-fds.patch
Patch5: gpm-1.20.1-weak-wgetch.patch Patch5: gpm-1.20.1-weak-wgetch.patch
Patch6: gpm-1.20.6-libtool.patch Patch6: gpm-1.20.6-libtool.patch
Patch7: 0001-rhbz-668480-gpm-types-7-manpage-fixes.patch Patch7: 0001-rhbz-668480-gpm-types-7-manpage-fixes.patch
Patch8: gpm-1.20.6-missing-header-dir-in-make-depend.patch
#Patch7: gpm-1.20.6-capability.patch #Patch7: gpm-1.20.6-capability.patch
Requires(post): systemd-units systemd-sysv info Requires(post): systemd-units systemd-sysv info
Requires(preun): systemd-units info Requires(preun): systemd-units info
@ -70,6 +71,7 @@ mouse support to text-based Linux applications.
%patch5 -p1 -b .weak-wgetch %patch5 -p1 -b .weak-wgetch
%patch6 -p1 -b .libtool %patch6 -p1 -b .libtool
%patch7 -p1 %patch7 -p1
%patch8 -p1
#%patch7 -p1 -b .capability #%patch7 -p1 -b .capability
iconv -f iso-8859-1 -t utf-8 -o TODO.utf8 TODO iconv -f iso-8859-1 -t utf-8 -o TODO.utf8 TODO
@ -79,9 +81,9 @@ mv -f TODO.utf8 TODO
autoreconf autoreconf
%build %build
LDFLAGS='-Wl,-z,relro -Wl,-z,bind_now'
%configure %configure
make CFLAGS="%{optflags}" %{?_smp_mflags} make %{?_smp_mflags}
%install %install
%makeinstall %makeinstall
@ -93,11 +95,11 @@ rm -f %{buildroot}%{_datadir}/emacs/site-lisp/t-mouse.el
%ifnarch s390 s390x %ifnarch s390 s390x
mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
mkdir -p %{buildroot}/lib/systemd/system/ mkdir -p %{buildroot}/usr/lib/systemd/system/
install -m 644 conf/gpm-* %{buildroot}%{_sysconfdir} install -m 644 conf/gpm-* %{buildroot}%{_sysconfdir}
# Systemd # Systemd
mkdir -p %{buildroot}/lib/systemd/system mkdir -p %{buildroot}/usr/lib/systemd/system
install -m644 %{SOURCE1} %{buildroot}/lib/systemd/system install -m644 %{SOURCE1} %{buildroot}/usr/lib/systemd/system
rm -rf %{buildroot}%{_initrddir} rm -rf %{buildroot}%{_initrddir}
%else %else
# we're shipping only libraries in s390[x], so # we're shipping only libraries in s390[x], so
@ -107,9 +109,6 @@ rm -rf %{buildroot}%{_bindir}
rm -rf %{buildroot}%{_mandir} rm -rf %{buildroot}%{_mandir}
%endif %endif
# UsrMove
mv -f %{buildroot}/lib %{buildroot}/usr/
%post %post
%ifnarch s390 s390x %ifnarch s390 s390x
%systemd_post gpm.service %systemd_post gpm.service
@ -168,6 +167,12 @@ fi
%{_libdir}/libgpm.a %{_libdir}/libgpm.a
%changelog %changelog
* Wed Mar 06 2013 Jaromir Capik <jcapik@redhat.com> - 1.20.6-29
- Removing OPTFLAGS
- Introducing full RELRO
- Missing header dir in Makefile.in / depend
- Fixing UsrMove for i686 (mv -f says 'directory not empty')
* Wed Mar 06 2013 Jaromir Capik <jcapik@redhat.com> - 1.20.6-28 * Wed Mar 06 2013 Jaromir Capik <jcapik@redhat.com> - 1.20.6-28
- Adding missing requires - Adding missing requires
- Passing OPTFLAGS to make - Passing OPTFLAGS to make