fix patch
This commit is contained in:
parent
ef4815e190
commit
2b9583dacf
@ -0,0 +1,18 @@
|
|||||||
|
--- gpm-1.20.1/src/lib/liblow.c.orig 2004-10-13 16:34:15.181502369 -0400
|
||||||
|
+++ gpm-1.20.1/src/lib/liblow.c 2004-10-13 16:34:20.491778415 -0400
|
||||||
|
@@ -262,13 +262,14 @@
|
||||||
|
gpm_report(GPM_PR_ERR,"consolename not set");
|
||||||
|
goto err;
|
||||||
|
}
|
||||||
|
+#if 0
|
||||||
|
/* do we really need this check ? */
|
||||||
|
if(strncmp(tty,consolename,strlen(consolename)-1)
|
||||||
|
|| !isdigit(tty[strlen(consolename)-1])) {
|
||||||
|
gpm_report(GPM_PR_ERR,"strncmp/isdigit/consolename failed");
|
||||||
|
goto err;
|
||||||
|
}
|
||||||
|
-
|
||||||
|
+#endif
|
||||||
|
conn->vc=atoi(&tty[strlen(consolename)-1]);
|
||||||
|
}
|
||||||
|
|
4
gpm.spec
4
gpm.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A mouse server for the Linux console.
|
Summary: A mouse server for the Linux console.
|
||||||
Name: gpm
|
Name: gpm
|
||||||
Version: 1.20.1
|
Version: 1.20.1
|
||||||
Release: 60
|
Release: 61
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: http://ftp.linux.it/pub/People/rubini/gpm/%{name}-%{version}.tar.gz
|
Source: http://ftp.linux.it/pub/People/rubini/gpm/%{name}-%{version}.tar.gz
|
||||||
@ -172,7 +172,7 @@ fi
|
|||||||
%{_libdir}/libgpm.so
|
%{_libdir}/libgpm.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Oct 13 2004 Adrian Havill <havill@redhat.com> 1.20.1-60
|
* Wed Oct 13 2004 Adrian Havill <havill@redhat.com> 1.20.1-61
|
||||||
- remove unnecessary diagnostic and check of the consolename (#129962)
|
- remove unnecessary diagnostic and check of the consolename (#129962)
|
||||||
- remove /etc/sysconfig/gpm; set unset defaults in the init script instead
|
- remove /etc/sysconfig/gpm; set unset defaults in the init script instead
|
||||||
after mousecfg is (or is not) read
|
after mousecfg is (or is not) read
|
||||||
|
Loading…
Reference in New Issue
Block a user